News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread: http://www.celephais.net/board/view_thread.php?id=60097
First | Previous | Next | Last
 
I can't tell exactly what's what in the picture, but I would make sure the down push ends above the horizontal push by at least 64 units.

The horizontal push doesn't need to be real tall. 32 units is probably enough and place it a bit above the floor, 16 - 32 units should be fine. 
Crazy Idea But 
Is the push angle at 0? If it is, set it to 1 or -359 instead. 
Went To The Quake Wiki 
And apparently putting 0 at the angle key doesn't work, somehow.
Anyway, I put it at 360 and now it works. Odd. 
Black Spots On The Skybox + Unfixable Grey World 
I was just a centimeter finished for doing this map when I have this stuff pop up on Quakespasm.

First off, at the start map I have a sky cieling where some parts are grey: http://image.noelshack.com/fichiers/2016/16/1461362247-spasm0002.png
At first I thought this was related to that "inside out grey world" bug where a map goes out of the game's boundaries, so I tried to put the whole map down to some units, but try as I might, the error's still there (Same thing happened even if I put -bsp2 in the compiler).
Same thing happened with the first actual map: on top of having parts of the sky greyed-out, in the final room, on its front side when you enter, and you get close to it, the inside out grey world bug happens, but usually when it happened in my maps it showed the world at its place, like if you were inside a brush, but here I have the duplicate of the map in front of me, like a pattern you'd see on a wallpaper, because it's the exact same axis: http://image.noelshack.com/fichiers/2016/16/1461362301-spasm0001.png
And still in there, as much as I try moving the map around, nothing changes. 
 
I've never seen patches of the skybox not drawing like that. Is there possibly a skip brush clipping away the sky there or something?
Check in other engines, and maybe try a different compiler.

It shouldn't be related to exceeding the +- 4096 bounds.

inside out grey world bug
For this, keep the player and all entities within +- 4096. It should be ok for inaccessible areas of the map (like the cliffs + skybox in your shot)

Enter 'viewpos' in the console to print your current position, or in quakespasm you can do "r_pos 1" to enable a continuous printout of the player's position. 
Edit: 
Does "r_novis 1" do anything to make the grey patches go away? (make sure to set it back to 0 afterwards.) 
Daya - Wild Guess 
Are your sky brushes textured sky on all sides? Those brushes can hickup when a normal texture is on one side. 
Fixed 
The grey patches was indeed because the sky brushes were clipping through other brushes. Fixing that also fixed the grey world bug, somehow. 
Good 
 
Backing 
Hello, Im back here to know if exist mapping guides talking about entities and keys, if be so much thanks. 
Spec And Bible 
WARNING: Reached Occupant At (592 96 -96) 
I know this is supposed to indicate a leak, but at specifically this error in the map is just a light. If I remove this light, the error will change to the next light. And if I remove all the lights it will go to a different entity like for example, a spawn point. But the weird part is, these entities all worked fine at one point. A .prt file could be created for it, everything worked, vis ran perfectly fine and I had a working map. I wasn't satisfied with the lighting and as soon as I changed even one light, it would all give me errors. I can go back of course, but I have made a lot of changes since then and don't want to lose everything so does anyone have an idea of what could be wrong? I have already tried several other QBSP versions and they all give me the same shit so I assume its possibly Trenchbroom. 
It's Not TrenchBroom. 
There is a leak in your map. Afaik, the point file trace always starts and / or ends in entities. The algorithm uses entities to determine what the inside of the map is. 
SleepwalkR 
Thanks for the hint, this may also be why some vanilla GPL maps gives the same error. I'll look into this. 
 
Load the map and enter the pointfile command in the console. Turn on noclip and go find the dashed line. The line will lead you through wherever the leak is on its way to whichever entity it reached first. 
Or 
Load the point file in TrenchBroom. Note that the file must be in the same directory as the map file and that the base name of both files must be identical. The next beta will allow you to load point files from any location. 
 
That was really fast, I fixed my problem immediately after you pointed that out, thank you a lot 
 
I've realized Jackhammer loads point files automatically, as rainbow-colored lines.

Also, after spending hours trying to understand how to fix the leak, I've figured out that the pointfile ends exactly where there's an empty BSP node that must be filled. Problem solved. 
Func_group 
Is there a way to use func_group in Trenchbroom? The option is there, but it doesn't seem to work. I tried it with two brushes, and all it did was group the brush's bounding boxes together, but I was still able to manipulate both brushes independently. 
Ruin 
To select the group you double click 
In TB2 That Is 
You can get the latest beta from http://kristianduske.com/trenchbroom under downloads. 
Thank You Both. 
 
 
Noob question. I'm having trouble getting the Zerstorer entities into Quakespasm. I can load the mod in the Mod tab but the entities don't populate. Looking at the documentation (I'm using TB 2.0.0) it seems like I need a DEF or FGD file, but I don't see one in the zer folder. I do see a list of "entity definitions" in the dev readme but I'm not sure what to do with it.

If anyone can help, or hell, better yet, post a DEF or FGD file with the models already set up to display in TrenchBroom, that would be very helpful! 
Def Files 
I'd try pasting those entity definitions into a text file, and saving it with the filename "zer.def". You won't get the models, because that's a 2015 feature in a 1997 defintion file, but it should be usable. 
 
Never mind, I actually found an FGD file put together by CZG in the Zerstorer Mapjam thread. Thanks anyway.

Ok, so now for my real question. I started putting together a map for Quoth using Trenchbroom 2 (not Quakespasm as I said above, lol), but my ultimate goal is to make a map using Quoth entities BUT ALSO the riot controller (SSG replacement) from Zerstorer--but nothing else from zer. Trenchbroom allows me to load multiple mods into my map, and I also copied everything relevant to the riot controller from the zer FGD file to a copy of the Quoth FGD that came with Trenchbroom. This seems to do what I want, since I can see everything Quoth in the entity panel, plus the riot controller.

So is it that simple or am I opening the door to all kinds of horrible conflicts between the two? (I'm not close to a point where I can compile it and test it out.) Also, how does using multiple mods for Trenchbroom actually work in terms of running the map? I've noticed that I can only select one set of entity definitions at a time, making me wonder how multiple mods fit in. This doesn't really seem to be detailed in the TB documentation. 
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2017 John Fitzgibbons. All posts are copyright their respective authors.