News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread:
First | Previous | Next | Last
One of the quirks of the mdl format is that the model keeps the bottom left corner fixed when you rescale it, rather than the centre. If you add a line like

mymdl.mdl.origin = (-64 -64 -64)

after the mymdl.mdl.boundingradius line in the script from the previous point, you can specify the coordinates you'd like the bottom-left point to be at. Play around with the values! 
I figured it would be something like that. Thanks a heap for going through the trouble of helping me out! :) 
No Worries 
It's cool to see someone using it, I worried that it being a python module was a bit off-putting 
Func_train Question 
How to make train move through four path_corners? I named each correspondingly and gave paths corresponding direction. 
I made a sample map linked below. It's pretty easy to do as you'll see.

I made 4 path_corners. t1 - t4 make sure the target/targetnames are correct and that they close a "loop" - that's the part that people mess up on the most.

I don't think you need to specify a direction. I didn't in this case. Sorry for the weird name. Also you can use Quake101.wad or q.wad for the textures in this map. 
Thank you for your help! watched your tutorial on tuesday so thaks for that as well! 
You're very welcome. LMK if you have any requests for tutorials. :) 
Texture Wads 
New to mapping (thanks @dumptruck_ds) and wondering where everyone gets their textures?

For the moment I'm just looking for the default Q1 textures, but it'd be good to know where to get custom textures come from too. 
Here's A Start. 
Texmex will let you open a map/bsp and save as a wad 
Tex Mex 
Does TexMex have a homepage somewhere? Or is it just floating around, no longer developed. 
Looks Like Floating Out There 
Looks Like Floating Out There 
Guessing this one is the one people are using texmex_34 
This is more of an engine question but does quakespasm or vkquake support increasing the playback speed for animated textures using the +0, +1, +2 naming convention?

DP lets you circumvent this with Q3 shaders but i'm just curious if there's a more universal option for having an animated waterfall look smoother 
Not that I know of, but there's a tutorial on Preach's site about using func_wall's on-trigger function (switching texture between two sets) to double the framerate from 5FPS to 10 using two sets of premade textures. 
I Should Add.. 
That the method in the tutorial is a bit convoluted, because it describes how to get the effect in unmodified Quake. It would be much better to achieve the same effect with a simple mod that added QuakeC code to perform the switching between the textures. 
I'm Using Func_illusionaries 
So i guess i'll just deal with the low framerate.

I have another question/problem - I made a huge lift in my map that goes up slowly, it's a door -

It has items on it, but seemingly at random while the player is riding it he will get snagged on it and take damage, and send the lift back down.

Is there any reason for this/workaround? I know i could make it so you ride it down slowly instead of up, but I have to redesign it if i do that. I wanted to avoid using a func_train but if it's some sort of engine problem I'll switch.

I'm using quakespasm btw 
Wait What? 
I switched to a train and the collision does not match up with the position of the train - i tested in quakespasm and vkquake and it's broken in both, but oddly enough in darkplaces the collision of the train is correct

I have no idea what's going on 
Check for an "angle" or "angles" key on the func_train and delete it if there is one. 
I feel like a dope, that was it. Leftover from converting door > train

Check Your Server Fps Too 
Another thing that can cause weird physics glitches, like the one you had with your elevator, is setting the server fps too high in the config (default 72, if I recall correctly). When I use Quakespasm, setting it to 150 still seems to allow everything to work correctly. 
I Actually Kept Quakespasm Running At 72 Fps 
It still would happen. Sometimes the train gets caught too and does a point or 2 of damage but it's alright since it doesn't break the whole sequence 
I had the same stubborn func_plat that caused me headaches to solve.
Glad finding the solution here.

(for the the func_plat head) P: 
Lava Alpha 1 
It's been asked many times, but here I go. There is a worldspawn key to set the lava alpha for that particular level, right? Which one is that, again? 
Meet The "alpha's", Hehe (Hope This Is Correct) 

----- Alpha Options -----

water_alpha(string) : "Water Alpha" : : "Set the transparency of water (ex .70), which are brushes textured with a water(ex *04water) texture. This setting tranfers directly to the other 'liquid' types and teleporters, UNLESS you are using an engine that supports individual 'alpha's' for each(see below). NOTE - Defaults to the players own 'r_wateralpha' settings if no value is assigned."

lavaalpha(string) : "Lava Alpha" : : "Set the individual transparency of Lava, brush solids textured with a lava(ex *lava1) texture. Default inherits the 'water_alpha' setting. If 'water_alpha' is not set then it defaults to the players own 'r_wateralpha' setting."

slimealpha(string) : "Slime Alpha" : : "Transparency of Slime, works the same as 'lavaalpha' except for solids textured with a slime(ex *slime0) texture."

telealpha(string) : "Teleporter Alpha" : : "Transparency of Teleporters, works the same as 'lavaalpha' except for solids textured with a teleporter(ex *teleport) texture."

This works for me and I believe it to be accurate but if it is not, please let me know otherwise. 
I Forgot To Bold This... 
... and it threw me when I was testing:

IF 'water_alpha' is NOT set, then it defaults to the players own 'r_wateralpha' setting."

That means, that to set lavaalpha, it IS necessary to set a starting water_alpha to get the results you desire! 
Sorry For The Empty Post Above 
Is this Quakespasm? Do these work in other engines? 
Yes, Quakespasm. I just assumed it was a QS related question since it was a specific lava alpha question, maybe that was wrong?

I tested with DP, FTE, AD-MOD/QSS etc... I only remember I had mixed results, not the specifics to what each one did upon map load. 
Thanks, But 
I hope I can still set water_alpha 0.5 and lavaalpha 1, transparent water and opaque lava. Will try later. 
Water_alpha Is An AD Feature 
It works on any engine, but only with the AD mod.

Quakespasm and MarkV both support "_lavaalpha" and "_wateralpha" worldspawn keys. These work on any mod includong id1. This is relatively new (last 2 years ish) and not sure if any other engines recognize these keys. 
Really Wish I Could Edit My Post, Grrrr 
I should have used my modified version of Daz's FGD for reference, doh. I forgot the subtle differences.

Which has the correct entry for wateralpha, which is:

wateralpha(string) : "Water Alpha" : : "Set the overall transparency of liquids, default = (1.00)"

This I just tested with stock id1. No underscore needed at all?

Apologies for the confusion. 
Just checked MarkV and QS source, they will both accept underscore or no underscore. 
What About Telealpha For Mark V? 
In my map it's not recognizing it? 
MarkV Doesn't Seem To Support A Telealpha Key 
I think were technical reasons for not doing it.

Mark V has automatic underwater transparency detection (which isn't hard to implement, btw --- I told qbism how to do it and he added it qbism super8).

But the underwater transparency test cannot be applied to all teleporters because a small teleporter might not even materially affect vis.

Recommendation: Add automatic underwater transparency to Quakespasm (you'll like it) and then also remove support for tele-alpha.

Qbism added automatic underwater transparency to super8 because if a map isn't water-vised, honoring the user's r_wateralpha value (unless r_novis 1) is just silly looks horrible.

If you add automatic underwater transparency, you'll never see that ugliness ever again! 
1 post not shown on this page because it was spam
First | Previous | Next | Last
Post A Reply:
Website copyright © 2002-2017 John Fitzgibbons. All posts are copyright their respective authors.