News | Forum | People | FAQ | Links | Search | Register | Log in
Quake Injector Alpha1
megaman and Spirit present: A first alpha version of the Quake Injector.

The Quake Injector is a tool to download, install and play Quake singleplayer maps from the Quaddicted.com archive. Ever been annoyed by an excruciating installation process? Could not figure out how to install a certain map? Well, this tool makes it a piece of cake. Simply pick the map and click Install.

Features

All Quake singleplayer maps ever made (900+ in the database)

Simply pick a map, click install and play

Filter, sort, browse to find your favourite map

Automatically installs dependencies (e.g. Quoth)

Cross-Platform

Free, Open Source Software, released under the GPL.



Screenshot: http://www.quaddicted.com/wp-content/uploads/quakeinjector_20090528.png
Check it out: http://haukerehfeld.de/projects/quakeinjector/
First | Previous | Next | Last
 
works great! very good thing. 
 
HAWT! Will check this out tonight... 
OSX Error Message 
"Java JAR could not be launched".

I don't know if I have Java 6 on my Mac, maybe Willem or someone can try this out. 
Hm 
We haven't tested on macs (none available) but in theory it SHOULD work. I guess you don't have java 6.

If you can, try to start with "java -jar quakeinjector.jar" and pastebin the output for me, that would probably help. 
Wow 
..can't check yet, but does it locate directories? 
FAQ Says It Doesn't 
^
Ok 
Can't check yet because I'm in three projects today. 
Amazing 
But I'm a bit afraid to check it out, my quake dir is already a mess! 
"C:\Users\alex\desktop\quake" Cannot Be Written To! 
but "C:\Users\alex" can, :S? is this something im doing wrong, other than having the quake folder on my desktop for ease of access? 
Edit 
that's "C:\Users\alex\desktop\quake" there only 
 
OK, I get the same error on my Mac. This is the spew in the console:

Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:675)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:316)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:280)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:374) 
Looks 
like you guys don't have java6? I remember the mac version for 6 being delayed some time.

You can check your java version with java -version
Metch 
is that from the engine config dialog? what's the full, exact path you put? is that & a mistake in markup/ a typo? are you sure the path is writeable? which one of the fields?

I'm using the java lib functions for those checks, so i'm pretty sure they should work well with all paths, unless there's some fuckup on my part that makes it check the wrong paths in the first place. 
Ci475 
just copy the engine and id1/pak0.pak and id1/pak1.pak to some new directory and start from a clean install ;-) 
Megaman, 
the "&..." stuff gets added her for some reason when i type out the full dir, it ends at the folder "quake". it is the "engine configuration" dialog, under the type box [the place where you type stuff of course] labeled "quake directory"; i put in the path and the comment next to it says "cannot be written to!" 
Metch ... Using Vista? 
Vista can be cruel.

/a guess ... even possibly a wrong guess 
Java 6 
There is a Java 6 VM for themac, and it should be installed on every Mac running Leoopard. But you have to specifiy which Java version you want to use as the default for running programs. Go to /Applications/Utilities/Java and launch Java Settings (don't know the exact english name). There, change the order of priority of the VMs so that Java 6 64bit is on top. Now it should work. 
.app 
It doesn't recognize application bundles as executable on OS X. If I type the path to the actual executable inside the bundle, it works. But it would be better if it could just handle .app bundles. 
Also 
Fitz SDL 0.8 seems to hang (after I leave the game) until I quit your app on OS X. It closes the window alright, goes back to desktop, but the icon keeps sitting in the dock until I force quit it or leave your program. That seems odd, how do you start the process? 
Hmmm 
1) I check with File.canExecute() -- if the .app thing doesn't have the proper rights, there's not much I can do. Or is that .app just a folder? But then the message would be different, iirc.

2) i'm using processbuilder to start the engine. The code is in de.haukerehfeld.quakeinjector. EngineStarter.start() 
Source Code For Starting 
Hmm 
.app bundles are just directories with special treatment by the Mac OS. It's possible that File.canExecute() doesn't work for app bundles. The permissions are not a problem I think.

About Fitzquake not quitting, that seems to be a bug with Fitz or could be related to the way it works. I just tested it with a different engine and it worked fine. So nevermind.

Here are a few minor observations:
- The app could look better. With a few tweaks here and there it would look less amateurish (sorry about that).
- It should remember the sort column and direction as well as window size and layout (esp. column layout - I always have to resize the release date column manually).
- Make the progress bar disappear when installing a map is done. It's just confusing when it remains down there because on OS X, it animates. Make it disappear maybe after 3 seconds or so.
- Double clicking on a map in the table should install and play it.
- If you press play, the launch dialog of the engine (Fitz has one on mac, as well as the Fruitz of Dojo engines) stays behind your app. That's very annoying. It should be in front of your app.
- Make the rating column show stars or dots or whatever - the vertical bars are hard to read. Or even better, show numbers, because who can tell the difference between 8 and 9 vertical bars? Just show the rating as a number.

Okay, that's it with the negativity ;-). Apart from those minor flaws, I really like the app very much! It's very useful and easy to use, so thanks for all the effort you put into it. It's well appreciated (even though it might not seem that way after all the nitpicking above)! 
 
Wpw, yeah, my Java looks to be ancient old:

java version "1.5.0_16"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b06-284)
Java HotSpot(TM) Client VM (build 1.5.0_16-133, mixed mode, sharing) 
 
SleepWalker

Thanks for the "Java Preferences" tip! Works great now. Woot! 
Baker 
...yesi am using vista :S 
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2017 John Fitzgibbons. All posts are copyright their respective authors.