News | Forum | People | FAQ | Links | Search | Register | Log in
Quakespasm Engine
This engine needs its own thread.

Feedback: I like the OS X version, but I have to start it from the terminal for it to work and can't just double-click it like a traditional OS X app. I'm sure you guys already know this, either way great engine.

http://quakespasm.sourceforge.net/
First | Previous | Next | Last
Hud Keys/powerups Unused Frames 
I made a quick patch to QS to make it use the unused flashing frames for the keys and powerups when you pick them up. I also added a flash for when powerups expire, which is hardcoded at 29 seconds. TODO: I should really consider that as a cvar or read it from the quakec field for mod purposes.

https://youtu.be/e661Xsy934o

Modified sbar.c is available at https://pastebin.com/Ev0eNp21, very few changes are marked with // c0burn 
@c0burn 
2nd link is busted 
@dumptruck 
Take the comma off. 
 
that looks cool, though it might be nice if the icon flashes were synced to the screen flashes when power-ups expire. 
Exit Flashes 
Two thoughts on getting the exit flashes to work:

In terms of how to automatically trigger the hud flashes on existing mods, could you expand on metlslime's suggestion, and make the trigger for a hud flash become "a screenflash occurs 27, 28 or 29 seconds after the icon was last turned on"? Don't know how tight you could afford to make the timing for it to work over the network. Maybe you just let the feature fail sometimes in that scenario because it's cosmetic.

Triggering the icons to flash on *any* screenflash would be too permissive, because all the icons would end up flashing when any powerup expires, even if some have a while still to go. That would be less useful than just not flashing the icons at all.

It does mean that mods can't vary powerup length and just expect the icon to flash when they flash the screen. So my second thought was how mods might request the feature - is it easy for QC to resend the message to turn on the icon? Turning the flag on and off again in the same frame won't work. If there's a reasonable way to repeat the message, flashing the icon each time that happens might work. If so, a cvar to opt out of the automatic flashes would be a good idea. 
 
can't vary powerup length
This includes picking up two of the same powerup within 30 secs.
It constantly flashing for up to 30 seconds would be really annoying. 
Quakespasm On *buntu 18.04 
[Cross-posting from the general thread ; might have a better better chance of getting a response here:]

Anyone else using Ubuntu 18.04 or one of its derivatives (e.g. Mint 19.1) and getting bad performance and/or weird issues when running Quakespasm -- as in brush faces flickering in and out of existence, the game freezing for several seconds, or outright crashing with an error message that says "i965: Failed to submit batchbuffer: Input/output error"? I've tried three different distros now, all based on Ubuntu 18.04 and all with the same problem. This is on a machine with Intel integrated graphics, for what it's worth.

I've tried googling and searching around on Linux forums, with little success (perhaps because I know too little to even know what to search for). Thought maybe someone here might have run into the same issues and/or know what the solution is and/or be able to point me in the right direction...


PS: By posting this here, I don't mean to suggest that the problem is with Quakespasm. It's clearly something connected with my system; I just don't know what & was hoping someone here might know. The problems started with a recent OS upgrade. On the exact same computer running Linux Mint 17.1 (based on Ubuntu 14.04) I never had these problems (or any problems, as far as I can remember) when running Quakespasm. 
 
I run Quakespasm on elementary OS 5 which is based on Ubuntu 18.04. No issues here. But, I have an NVidia graphics card, so I expect that your problems are with the Intel graphics hardware and/or drivers. If you search back up the thread a bit you'll find other Intel-related issues. 
 
This looks like a driver issue. Quake code isn't very good at checking GPU capabilities so it's likely that you're hitting a hardware limit. Does this happen on every map or just some? 
Thanks For Responding! 
If you search back up the thread a bit you'll find other Intel-related issues.

Thanks for the tip. I just did that, but couldn't find anything resembling the issues I'm having. :(

Does this happen on every map or just some?

Well, it sometimes happens and sometimes doesn't, but does not seem dependent on which maps I'm playing. Sometimes the weirdness is there from the start; other times things start off ok, but then the flickering I described above starts. And once it starts, it keeps happening across any and all maps I try to load, including the original id1 maps. Then it seems to be just a matter of time before the game freezes and/or crashes.

Before upgrading my OS I had no trouble playing anything apart from one or two of the maps in Ter Shibboleth -- and even then, it's just that the framerate was low; the game never crashed or behaved weirdly. 
 
Two ideas, see if you can run vkquake, it's a Vulkan port of Quakespasm. I was able to install it on ubuntu 18.10 with "snap install --edge vkquake" but my drivers didn't support it.

Another option, if you launch quakespasm with the "-noglsl" command line option it reverts to fixed-function OpenGL 1.x. This will be slower but may be less likely to trigger driver bugs. 
Thank You Very Much, Ericw 
I'll look into both of those options as a possible interim solution. However, I would love to solve the underlying issue, if at all possible. Is it safe to assume that it's an Intel graphics driver problem?

I've also experienced seemingly random freezes when not playing Quake, but just e.g. reading something online, looking through pictures on my machine or working on a document in LibreOffice. And on one of the previous Ubuntu 18.04-based distros I tried out (as I wrote, I went through three of those in an attempt to solve -- or sidestep -- the issue), ioquake3 would also randomly crash. I haven't tested ioquake3 on this latest OS yet.

But the most consistent problems have been with Quakespasm. Just to be clear again, I'm not blaming the programme (as I said, it worked perfectly on my old OS), but I thought the particular issues I'm having might be something that you or someone else here would recognise and be able to say "ah, yes, that's because of an issue with X; you need to do Y". 
I Don't Know Why My Post Has That Red Symbol/emoticon 
I guess I clicked it by accident. 
 
If this happens outside of QS it's definitely either driver or HW problem. Intel drivers are typically pretty solid so if updating[1] to latest doesn't help, start saving for a new machine (if this is a laptop).

[1] Pretty good guide:

https://ubuntuforums.org/showthread.php?t=2072420

Also install mesa-utils (sudo apt install mesa-utils) if your GPU/driver doesn't report its name properly 
Re: Thulsa; Ericw 
Also install mesa-utils (sudo apt install mesa-utils) if your GPU/driver doesn't report its name properly

I already have mesa-utils 8.4.0-1, and as far as I can tell, the system recognises the GPU correctly -- e.g. when I run sysinfo.

Thank you for the link; I might try and update to the latest driver if I can summon the courage (I'm scared of breaking things even more).

Another option, if you launch quakespasm with the "-noglsl" command line option it reverts to fixed-function OpenGL 1.x. This will be slower but may be less likely to trigger driver bugs.

Thanks. I've tried this a few times now and so far, so good -- except that the audio kind of ... I don't know if "stutters" is the right word. Every now and again it sort of misses a beat, as if the system is under strain. I think this happened before too, but the visual glitches were much more obvious, so I didn't really focus on the audio. So far the game hasn't frozen or crashed ... yet.

start saving for a new machine

I hope it doesn't come to this.:( 
Spoke Too Soon... 
It finally started happening when running QS with "-noglsl". Now once the weird visual glitches start appearing again, they show up every time I restart QS until I reboot my computer. Rebooting makes it go away for a while. This what it looks like, by the way.

Another weird thing I've noticed is that quite often when I've pressed down the run key (mapped to "w") for a while, I suddenly stop moving, and have to release and re-press the key. Don't know if it's related, but it never happened on my old OS.

The audio thing is most noticeable when using weapons with rapid fire (i.e. the nailgun or SNG). It's as if the firing sound doesn't loop smoothly, but rather stops briefly and then restarts.


PS: Sorry for spamming this thread with my problem. Hopefully it doesn't annoy anyone. 
 
Is there a way to create a dedicated server on Linux with QS? Preferably without the host acting as a client as well. I'm interested in spinning up something for co-op and ideally I'd like to be capable of hosting multiple mods like AD and Quoth. I see that FTE has a binary for servers but I'd first like to see if I could get something going without QuakeWorld physics i.e. ludicrously fast bunny hopping.

I know that QSS works well for co-op but I don't want to host from my computer and I also can't host without acting as a client myself. 
About FTE Physics 
You can switch to Netquake physics in FTE with the console command sv_nqplayerphysics 1. 
Still Getting Weird Audio On Quakespasm 
I've switched to a new computer since posts #3601 and #3602, but I still get that weird stuttering audio thing that had never happened before.

The same thing happens on a third, much older computer too.

Each of these computers is running some version or derivative of Ubuntu 18.04 and has Intel integrated graphics, in case that's relevant.

You can actually already hear it the moment you start a new game in Quakespasm: the ambient sound that plays right at the beginning in the start map doesn't loop seamlessly as it should (and always used to), but instead clearly stops and then starts again. With louder sounds, e.g. during combat, it's much more noticeable. 
 
Tough to diagnose. I've got a few debugging things you can try:
- Try with a clean config. Make a copy of your quake directory, and delete everything except id1/pak0.pak and pak1.pak. You can launch in this gamedir with "quakespasm -basedir {directory here}"
- try the Linux binary from http://quakespasm.sourceforge.net/download.htm as well as the Ubuntu one you can install with apt. Does the issue happen on both?
- Type "condump" and upload the resulting file
- Do you get a reasonably good framerate? What does "host_maxfps 1000" then "scr_showfps 1" show? Make sure to reset "host_maxfps 72" afterwards. 
Thanks For The Response, Ericw 
<quote>Does the issue happen on both?</quote>

This is with the Linux binary downloaded from http://quakespasm.sourceforge.net/download.htm (which is what I've also done in the past when things worked properly; I don't think I've ever installed Quakespasm with apt).

I'll definitely try the things you listed and then post the results. My apologies in advance if it takes a while. 
 
Does the issue happen on both?

^Obviously that's what I meant to do. How embarrassing. 
3 posts not shown on this page because they were spam
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2019 John Fitzgibbons. All posts are copyright their respective authors.