News | Forum | People | FAQ | Links | Search | Register | Log in
Quakespasm Engine
This engine needs its own thread.

Feedback: I like the OS X version, but I have to start it from the terminal for it to work and can't just double-click it like a traditional OS X app. I'm sure you guys already know this, either way great engine.
First | Previous | Next | Last
I run Quakespasm on elementary OS 5 which is based on Ubuntu 18.04. No issues here. But, I have an NVidia graphics card, so I expect that your problems are with the Intel graphics hardware and/or drivers. If you search back up the thread a bit you'll find other Intel-related issues. 
This looks like a driver issue. Quake code isn't very good at checking GPU capabilities so it's likely that you're hitting a hardware limit. Does this happen on every map or just some? 
Thanks For Responding! 
If you search back up the thread a bit you'll find other Intel-related issues.

Thanks for the tip. I just did that, but couldn't find anything resembling the issues I'm having. :(

Does this happen on every map or just some?

Well, it sometimes happens and sometimes doesn't, but does not seem dependent on which maps I'm playing. Sometimes the weirdness is there from the start; other times things start off ok, but then the flickering I described above starts. And once it starts, it keeps happening across any and all maps I try to load, including the original id1 maps. Then it seems to be just a matter of time before the game freezes and/or crashes.

Before upgrading my OS I had no trouble playing anything apart from one or two of the maps in Ter Shibboleth -- and even then, it's just that the framerate was low; the game never crashed or behaved weirdly. 
Two ideas, see if you can run vkquake, it's a Vulkan port of Quakespasm. I was able to install it on ubuntu 18.10 with "snap install --edge vkquake" but my drivers didn't support it.

Another option, if you launch quakespasm with the "-noglsl" command line option it reverts to fixed-function OpenGL 1.x. This will be slower but may be less likely to trigger driver bugs. 
Thank You Very Much, Ericw 
I'll look into both of those options as a possible interim solution. However, I would love to solve the underlying issue, if at all possible. Is it safe to assume that it's an Intel graphics driver problem?

I've also experienced seemingly random freezes when not playing Quake, but just e.g. reading something online, looking through pictures on my machine or working on a document in LibreOffice. And on one of the previous Ubuntu 18.04-based distros I tried out (as I wrote, I went through three of those in an attempt to solve -- or sidestep -- the issue), ioquake3 would also randomly crash. I haven't tested ioquake3 on this latest OS yet.

But the most consistent problems have been with Quakespasm. Just to be clear again, I'm not blaming the programme (as I said, it worked perfectly on my old OS), but I thought the particular issues I'm having might be something that you or someone else here would recognise and be able to say "ah, yes, that's because of an issue with X; you need to do Y". 
I Don't Know Why My Post Has That Red Symbol/emoticon 
I guess I clicked it by accident. 
If this happens outside of QS it's definitely either driver or HW problem. Intel drivers are typically pretty solid so if updating[1] to latest doesn't help, start saving for a new machine (if this is a laptop).

[1] Pretty good guide:

Also install mesa-utils (sudo apt install mesa-utils) if your GPU/driver doesn't report its name properly 
Re: Thulsa; Ericw 
Also install mesa-utils (sudo apt install mesa-utils) if your GPU/driver doesn't report its name properly

I already have mesa-utils 8.4.0-1, and as far as I can tell, the system recognises the GPU correctly -- e.g. when I run sysinfo.

Thank you for the link; I might try and update to the latest driver if I can summon the courage (I'm scared of breaking things even more).

Another option, if you launch quakespasm with the "-noglsl" command line option it reverts to fixed-function OpenGL 1.x. This will be slower but may be less likely to trigger driver bugs.

Thanks. I've tried this a few times now and so far, so good -- except that the audio kind of ... I don't know if "stutters" is the right word. Every now and again it sort of misses a beat, as if the system is under strain. I think this happened before too, but the visual glitches were much more obvious, so I didn't really focus on the audio. So far the game hasn't frozen or crashed ... yet.

start saving for a new machine

I hope it doesn't come to this.:( 
Spoke Too Soon... 
It finally started happening when running QS with "-noglsl". Now once the weird visual glitches start appearing again, they show up every time I restart QS until I reboot my computer. Rebooting makes it go away for a while. This what it looks like, by the way.

Another weird thing I've noticed is that quite often when I've pressed down the run key (mapped to "w") for a while, I suddenly stop moving, and have to release and re-press the key. Don't know if it's related, but it never happened on my old OS.

The audio thing is most noticeable when using weapons with rapid fire (i.e. the nailgun or SNG). It's as if the firing sound doesn't loop smoothly, but rather stops briefly and then restarts.

PS: Sorry for spamming this thread with my problem. Hopefully it doesn't annoy anyone. 
Is there a way to create a dedicated server on Linux with QS? Preferably without the host acting as a client as well. I'm interested in spinning up something for co-op and ideally I'd like to be capable of hosting multiple mods like AD and Quoth. I see that FTE has a binary for servers but I'd first like to see if I could get something going without QuakeWorld physics i.e. ludicrously fast bunny hopping.

I know that QSS works well for co-op but I don't want to host from my computer and I also can't host without acting as a client myself. 
About FTE Physics 
You can switch to Netquake physics in FTE with the console command sv_nqplayerphysics 1. 
Still Getting Weird Audio On Quakespasm 
I've switched to a new computer since posts #3601 and #3602, but I still get that weird stuttering audio thing that had never happened before.

The same thing happens on a third, much older computer too.

Each of these computers is running some version or derivative of Ubuntu 18.04 and has Intel integrated graphics, in case that's relevant.

You can actually already hear it the moment you start a new game in Quakespasm: the ambient sound that plays right at the beginning in the start map doesn't loop seamlessly as it should (and always used to), but instead clearly stops and then starts again. With louder sounds, e.g. during combat, it's much more noticeable. 
Tough to diagnose. I've got a few debugging things you can try:
- Try with a clean config. Make a copy of your quake directory, and delete everything except id1/pak0.pak and pak1.pak. You can launch in this gamedir with "quakespasm -basedir {directory here}"
- try the Linux binary from as well as the Ubuntu one you can install with apt. Does the issue happen on both?
- Type "condump" and upload the resulting file
- Do you get a reasonably good framerate? What does "host_maxfps 1000" then "scr_showfps 1" show? Make sure to reset "host_maxfps 72" afterwards. 
Thanks For The Response, Ericw 
<quote>Does the issue happen on both?</quote>

This is with the Linux binary downloaded from (which is what I've also done in the past when things worked properly; I don't think I've ever installed Quakespasm with apt).

I'll definitely try the things you listed and then post the results. My apologies in advance if it takes a while. 
Does the issue happen on both?

^Obviously that's what I meant to do. How embarrassing. 
Help With Improved Collision Detection For Quakespasm 
So I've added per triangle collision detection for entities (vs. bounding boxes) to my quakespasm project at home but I'm running into a peculiar collision detection issue.

My code works fine when the entity's baseline angles/origins remain 0, but not otherwise. I'm using the entities's v.origin and v.angles to construct an inverse transformation matrix. I perform my per-triangle traceline collision detection, find my hit point, and then transforming the hit point back into world space.

As stated, this works fine when the baseline is zero. If i need to do some more voodoo in my math to account for baseline angles/origins please let me know? 
That is odd. Assuming your collision detection is being done in server code, the baseline shouldn’t matter at all since that is merely used as part of the network protocol and client code. What types of collisions are you testing with this? Bullets against enemy models? 
RE: Collision Detection For Quakespasm 
Thank you for responding metlslime. I am testing bullets against enemy models. I have a modified traceline routine that iterates through all of the model's triangles looking for ray triangle intersection (terribly unoptimized, I know).

What you have helped me understand is that i don't need to worry about the baseline information. Is using the AngleVectors on the entity's v.angles call to extract the forward, right and up vectors, plus using the v.origin sufficient to build my world-to-model space matrix? Is there a better way?

The only time it does work correctly is when the model's angles are <0,0,0>, and i invert the y axis (right vector * -1) when projecting from world to model space. I don't know if this behavior pops any ideas into your head, but i thought id share.

Thanks for your help!

FYI: the collision data is built in model space during the the Mod_LoadAliasModel process. In pr_cmds.c I invoke my modified traceline routine to translate my ray origin & endpoint from world space into model space, perform my hit detection, and then transform it back from model space to world space. 
I'm really sorry it took me this long to respond.

- Try with a clean config.

With the binary downloaded from it happens with a clean config too.

- try the Linux binary from as well as the Ubuntu one you can install with apt. Does the issue happen on both?

Ok, I've installed Quakespasm via the Software Centre or whatever it's called nowadays (which I guess is the same as installing via the terminal with apt. It's called "quakespasm-beidl", though. Is that right, or did I accidentally install the wrong thing?). As far as I can tell, the problem doesn't happen with this version of Quakespasm, or at least it hasn't yet.

- Type "condump" and upload the resulting file

Should I do this for both versions of Quakespasm I now have on my computer? And where do I upload it?

- Do you get a reasonably good framerate? What does "host_maxfps 1000" then "scr_showfps 1" show?

Under both versions of Quakespasm, my framerate is initially just under 200 on the start map and then rises a little, while hovering between 200 and 300 on e1m1. Is that good? The version downloaded from seems to have a slightly higher framerate, though, for what it's worth. 
Alternate Menu Navigation Keys 
It would be nice to be able to bind my own menu navigation keys in QS. My keyboard doesn't have regular arrow keys but can send the numpad direction keys. Is this feature already present and I just don't see it? It's not super annoying to have a second keyboard shoved in the back of my desk to do Quake menu nav, but it would be nice to use my aircraft carrier Model F for everything. 
Oooh, Model F, you say? o: Gotta love dem clicky keys! ;) I'd wager some hardcore typists would pay a hefty penny for one of those keyboards. :D 
I love my Model M keyboards. 
But Yeah 
Condolences to anyone else in the same building as you when you're typing on that thing. 
where does one buy these? 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.