News | Forum | People | FAQ | Links | Search | Register | Log in
Quakespasm Engine
This engine needs its own thread.

Feedback: I like the OS X version, but I have to start it from the terminal for it to work and can't just double-click it like a traditional OS X app. I'm sure you guys already know this, either way great engine.

http://quakespasm.sourceforge.net/
First | Previous | Next | Last
 
I had an config file which works good with many engines. At some point though I only got this grey screen in quakespasm. After finding the solution I wanted to post here to help anyone experiencing the same problems. 
 
Yes, "cl_bob 0" is obviously the intended way to disable bobbing in the engine, but unfortunately "set cl_bobcycle to 0" is one of those items of "Quake lore" that gets passed around, which accidentally works some of the time, but which is actually wrong.

Fortunately it's an easy fix in the code: just check if it's 0 and set cycle to 0 if so: https://github.com/id-Software/Quake/blob/master/WinQuake/view.c#L117 
Dynamic Shadows 
So, I woke up at 3am, bored, and well here's this..

https://youtu.be/2SABwkUnqRE

in r_alias.c

i just added the shade variable in GL_DrawAliasShadow
after..

R_LightPoint (e->origin);

shade = (((lightcolor[1] + lightcolor[2] + lightcolor[3]) / 3)/128);//R00k

//then

glColor4f(0,0,0, shade * (entalpha));//R00k: fade light based on ambientlight

//before

GL_DrawAliasFrame (paliashdr, lerpdata); 
 
un-private the video fella 
Doh! 
Needed Features 
Hello. There are any chances to see WinQuake's software render with oldschool look/atmosphere and QuakeWorld servers support? 
 
Quake Qbism. 
 
qengine
engoo 
 
"QuakeWorld servers"
Zquake 
 
There is no Vanilla based engines with those features, so I want to see it in QuakeSpasm. 
 
tyrquake 
 
Its exactly the same as WinQuake even with no proper widescreen resolutions support and this port has its own bugs, so it has no sense. 
 
tyrquake, compared to WinQuake, can render more complex maps (BSP2 support) and has model interpolation. It also has alpha support for models and liquids, including the software renderer.

I'd say it's otherwise close to WinQuake, but it certainly has improvements. It certainly is not on the feature-level of quakespasm.


Talking of which: I noticed vkquake included QSS' support for decoupled render/physics framerates: https://github.com/Novum/vkQuake/commit/ffc9adf2ec52d3b786f6e80c61f3eabea697eacf

Looks surprisingly non-intrusive and should not alter behaviour for framerate caps up to 72. Is this something that can be considered for upstream inclusion? 
 
iirc the 'decoupled render/physics' is from quakespasm-spiked. And it does have limitations.
if you are on a huge map and your frames drop below 72 it starts to produce a slow-motion effect the further away from 72 you go. And on the opposite end, the higher you go over 500fps, it gets faster.
but, for the 72-500 range it works fine. And it's not the logic of the code, it also happens on othe independent physics code i have tested. 
 
Yeah, that's code from quakespasm-spiked.

As for problems above 500 fps - well, capping it at (pulling a number out of thing air) 300 fps would still enable a match for all modern display devices, so that's the easy case.

Slowmo below 72 fps, of course, is a problem. I wonder if the engine could detect that and switch dynamically as per situation. 
 
Basically, grab the current fps value, if its < 72 then turn off the independent physics code, and let the engine run like normal. 
 
same for > 500 too. 
 
You could also run multiple physics frames of the renderer is running slow. 
Setting Server Ip On Linux 
is anybody able to use the -ip flag on linux? it works fine on windows, but it seems to be useless on linux. other flags like -game or -dedicated work fine, so i don't think it's an issue with flags in general. it defaults to 127.0.0.1 no matter what ip is specified, which does not seem to be a problem as long as you have a linux client and server, but windows clients can't connect to a linux server in this configuration. i've tried it with regular qs and qss 0.93.2, both have the same problem. using qss the problem can be avoided by launching an automatically configured server from the menu, but running it as dedicated still gets you stuck at 127.0.0.1. 
Can't Play Quake Via QuakeSpasm Engine 
I bought first Quake and its mission packs in Steam. As many people recommend, I installed QuakeSpasm, and even installed soundtrack for all three games, and got Steam Overlay work with QuakeSpasm.
QuakeSpasm menu works OK - options and everything. But I pushed to start a new singleplayer game. Spasm crashes. Then I looked up, that I downloaded x64 version cause i'm using Win10x64. I reinstalled to x32(86) - the same problem.
Also, I tried to enter the game through console - "map e1m1" - the same problem - crash.

Sorry for my bad english, I tried to be correct as possible as it can be for me. 
#3653 
Are you on a laptop? What video card are you using? Can you play with a software rendered engine like Super8? http://super8.qbism.com/

How about a WinQuake?

You can also try Mark V's version of WinQuake: http://quakeone.com/markv/builds/1099_mark_v_windows_revision_4.zip 
#3653 - QuakeSpasm Crashes 
I've been able to reproduce this and fix it (or work around it) on a test machine by running with -noglsl.

The symptoms were broadly the same as you - the engine starts up OK, I can navigate the console and the menus, but as soon as I start a map (in any way) it exits silently and nothing is logged.

That seems to suggest that something's going wrong in the VBO loading code, and I hope to get a debug build going on this device soon-ish. 
#3653 - QuakeSpasm Crashes 
Bit of an overdue update.

It doesn't crash in a debug build, only with the released binary. I guess you need to run with -noglsl then. 
Down With "file Merging"; Up With "basegame" 
I did a quick hack of my own build of Quakespasm so that it supports "-ad" and "-copper" arguments in a similar way to the existing "-quoth" argument. It has made playing AD or Copper map releases so much nicer; just bang them into their own gamedir and away you go. No manual file merging, no mixing of savegames, easy cleanup/uninstall.

I realize this is probably not the right way to do it as a general feature for public consumption. FTE for example has a generalized "-basegame" feature that seems to work for this purpose.

I don't want to relitigate "well then just use FTE" here -- often I do, there are reasons why sometimes I (or others) don't -- that's old ground and in any case Quakespasm will continue to be popular for a long time. I'm posting here just from general curiosity about whether there's a gotcha that has prevented this sort of feature from showing up in Quakespasm. I dimly remember some past arguments/discussions about why or why not to implement this. (Although I don't know why "-quoth" got a free pass.)

Also I'm kind of generally curious about the state of QS development and whether there's a process for contributing to it. I took a look at the Quakespasm repo on Sourceforge and there's activity, but it seems to be pretty buttoned-down as to who can open a ticket or otherwise contribute.

Anyway... if I had to enumerate the stumbling blocks that I see folks running into on reddit or Steam forums or GOG or wherever, the lack of a Mods menu would probably be #1, but this thing about needing to do file-merges to play AD or Copper maps would be somewhere in top 5. 
 
Here's an example of the (clean but hacky) approach of just adding "-ad" and "-copper" support:
https://github.com/neogeographica/Quakespasm/commit/d38492f24deffd765792d117292ddde6c54cc5a4

And here's an example of a feature supporting a generalized "basegame". Gets quite a bit messier because of maintaining backwards compat for other existing messy behaviors, so I'm not sure if this is actually the desirable solution, but it works for me. Described more in the commit comments:

https://github.com/neogeographica/Quakespasm/commit/5b849b3abe32809f7047b24b790b177a0a8dc60c 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.