News | Forum | People | FAQ | Links | Search | Register | Log in
Fitzquake Mark V
I wasn't planning on doing this mini-project, it started as an effort to address some Fitzquake issues, fix them the right way up to Fitzquake standards (i.e. do it right, once and properly versus continual releases) and donate it back.

FitzQuake Mark V Download:

http://quake-1.com/docs/utils/fitzquake_mark_v.zip

Short version: Eliminated most issues in FitzQuake thread, most issues I can even remember hearing of ever and marked every single one clearly with a very minimal implementation.

It may be the case that only metlslime and Quakespasm and engine coders may find this engine upgrade of interest.

Features: 5 button mouse support, single pass video mode, external mdl textures, alpha textures (like RMQ), record demo at any time, rotation support, video capture (bind "capturevideo toggle"), console to clipboard, screenshot to clipboard, entities to clipboard, tool_texturepointer, tool_inspector (change weapons to see different info), clock fix, contrast support, fov does not affect gun, gun displays onscreen, Quakespasm wrong content protection, external ent support, session-to-session history and .. (see readme).
First | Previous | Next | Last
Episode Finale Text Length 
Other thing:

Unfortunately, the fix for finale text length from build 15 still isn't enough for some addons.

I picked Rapture for testing since it has extremely long texts, and there the text is still cut off as you can see here. On this screenshot, 5 lines are not shown. I dunno if you can push this fix any further, but maybe if it doesn't fit on the screen you could try shrinking the font size automatically or something.

Other than that, I checked Malice map d13 once more and the crash with respawning Vasquez sisters is definitely gone. Thumbs up! 
Good Catch On Rapture 
The text is cut off in fitz085. This is rainend.bsp.
winquake is OK: http://imgur.com/DaISTRW

I don't know the code that draws these but my suggestion is:
- check the buffer size winquake uses
- calculate the actual height of the full message, so it can be centered on screen properly. 
 
It is far better to find out about all these edge cases now so they can be addressed while the iron is hot. 
RRP 
Something else to think about in the meantime: Checking RRP, I get a crash to console in "Telefragged".

It happens like this:
After picking up the yellow keycard, I go around the corner and approach the yellow keycard door. Game crashes to console with a message like:

call0 2303(multi_trigger)multi_trigger()
... <-- couple of lines with subs.qc/triggers.qc etc here
(no function)
stack overflow
host_error: program error


Try if you can reproduce it with these savegames and autodemo (1.07 MB). Quicksave gets you right after picking up the keycard. Go around the corner and watch the game crash (probably). Autodemo shows the whole procedure. 
Afailk 
that is a known bug in telefragged.bsp on easy skill, not an engine issue 
Text 
I did a rough calculation of the text length and it comes out at ~900 chars. Now, Quake copies the centerprint text to a 1024 char buffer (in SCR_CenterPrint), so it's possible that this particular text is exceeding the buffer size and being chopped. That's possibility one.

Quake also counts the lines of text (stored to scr_center_lines) and I make it 29 lines, or 232 pixels high. Now, FitzQuake implements a GL_SetCanvas mechanism for laying out the 2D GUI elements, and centerprints use CANVAS_MENU, which is constrained to a 320x200 viewport (via a glViewport call), so anything outside of that viewport gets discarded by the driver. Add in the "Congratulations" banner and you can easily see why the text gets chopped. That's possibility two.

Possibility one is unlikely but it is nonetheless something that you should try to fix.

Possibility two is definitely what's going on here; the text is just too large for a 320x200 viewport.

Unfortunately this is a case where the mod author was careless: the same problem would occur on any engine running at a sufficiently low resolution. It doesn't occur on non-Fitz-based engines at higher resolutions simply because they don't use the same constrained viewport.

I'd chalk this one down to "bad content", of a similar class to textures containing fullbright texels, but it's up to you whether or not you think engines should support bad content like this. 
 
Windows GL | WinQuake - Probably fixes the Rapture end text for Open GL by expanding the canvas height to 480 or the largest it can do for the screen resolution being used while keeping the completion plaque or congratulations plaque in the same place.

@mh - Well, I'm sort of the mindset that 320x200 should be supported but also if original Quake does it then it can't really be a bug.

I am particularly interested in coop and I'm hoping to acquire ZQuake into the engine this week. In previous times, I wouldn't have had the right kind of knowledge to make this happen. It is possible I may discover I still don't. Finding out is half the fun. 
End Text With Latest Build 
With the new build, now the "Congratulations" panel shows in 5:4 modes, but text remains cut off. In 16:9 however, the panel isn't visible while the text is displayed completely.

I was trying this with scr_menuscale 1 and higher, wouldn't make any difference. 
Malice Boss Fight 
So I played the last two levels of Malice. While I didn't expect anything to go wrong there any more, it unfortunately did.

In d15 (boss map), the game seems to change your FOV, I guess as a side effect of the boss attack when he pulls you towards him or something. This effect should only be temporary and restore your original FOV afterwards, of course. However, sooner or later this causes a crash to console with this message:

host_error: bad fov: 180.000000

I had my FOV set to 105 in config.cfg before this happened, and when I checked after the crash, it was 170. it also happened when setting my initial FOV to 90, so this doesn't seem to be causing it.

Check autodemo and savegames here (136 KB)
(Last savegame and quicksave are relevant - I recommend activating godmode immediately.)

This should be the last issue with Malice.

At least, it seems pushing small crates works after all. No idea if it was something with latest builds that fixed it or I just didn't try pushing at the right angle. Main thing is you can push these crates, so I believe there is no need to look into it after all. 
RRP 
Yeah sorry about that, complete oversight on my part - nobody tested in easy :[ 
RRP Telefragged 
Is there a fix anywhere for this map? Or would it be possible to make one? It's not the first time it has been requested. :P 
 
Ok ... I'm glad you can push the Malice crates --- that was #1 on my least favorite thing to examine because it shouldn't be related to the engine and would involve QuakeC.

Not that I wouldn't have been able to figure out a game plan, but that it would be very time consuming, especially because I'm sure Malice's QuakeC isn't open source.

Text-cutoff: Thanks for info. 
I'll Try And Make Some Time For It 
If I can't then I'll let you know. 
RRP 
It's still possible to complete the map even with the bug. I just opened the yellow key door by walking backwards into it. And afterwards you have to be careful when returning to that room, ofc.
(As a general advice: Don't include stuff like resolution settings in quake.rc - folks don't like when their default config gets changed.)

Other than that, Mk V doesn't seem to have any issues with RRP. Plays smoothly. Still need to get through Mfx's map to complete the pack, though. 
Level Ending Screen 
Something else I noticed with level completion screens: It always displays "current music track" in the upper left corner when starting to play the level stats music. I think that can vanish. 
 
bad quake.rc files are nothing new.

I don't know that anyone, even with the best of intentions is qualified to make a quake.rc file, most of them are toxic to some extent.

Which is why I've always preferred to type -game <gamedir> in the console.

The mods that really need a quake.rc file are the highly exotic ones and it is not very helpful since you usually do not know that "R" has the reload gun bind key or "K" is use items.

quake.rc files are just basically entirely useless unless they indicate something like the preferred r_wateralpha value. 
 
Other than that, Mk V doesn't seem to have any issues with RRP. Plays smoothly. Still need to get through Mfx's map to complete the pack, though.

Mark V doesn't say anything 'cause there's lots of builds that may work different if you don't update every time. I still haven't played RRP 'cause it crashes on the build of mark V I tried it back then. I need to check if new version works fine with it. 
 
I know Baker just added the ability to load RRP maps in the last few weeks, so only the bleeding edge builds in the last few pages of this thread would support it 
RRP 
RRP definitely works fine with latest Mk V snapshots. Just be careful about Telefragged on easy. 
Telefragged Patch 
I'll see if I can do this on the weekend, as well as fix a few other problems with the level, like the long drop secret and make that retarded pipe progression easier to spot. 
Experimental Features 
Windows GL | WinQuake | Source

Improved ability to handle very large finale text ("Congratulations! ...") like the Rapture.

Experimental feature for use at your own risk --- and this means if you aren't interested in beta testing and not very Quake savvy this one isn't for you. That zlib1.dll file is required because libcurl needs it and I don't have anything checking to make sure it is there.

* Ability to install mods (or uninstall) via console.

Example:
install travail (will try Quaddicted)
install http://celephais.net/levels/files/rubicon2.zip (direct from any web address provided it is a standard .zip file)
uninstall travail (removes quake/travail but keeps the travail.zip)
uninstall travail full (removes quake/travail and removes the travail.zip)

The downloaded .zip files live in quake/id1/_library

This is a beta and it prints a bit more than it should when installing and so far handles things rather intelligently and in a user-friendly manner.

But I have more to do like don't be playing travail and type "uninstall travail". I also want to require the .zip file to uninstall a mod and use the .zip file to only remove files that came with the .zip. 
Neat 
Just installed it... it crashes to desktop when attempting the install command 
Also New Thing 
Playing with the music a bit -

If you do cd play 2 it will play track002, you can keep doing this and it will play the tracks but without stopping the previous one. The funny thing is that cd stop only works once so you can only disable one of the tracks, the others keep playing. 
Awesome! Someone Please Port It To Linux 
someone please port it to linux
someone please port it to linux
someone please port it to linux
someone please port it to linux

Default directory for downloads is qdir/Downloads/ in the Injector I think, would be great if we synchronise.

I'd suggest "purge" instead of "uninstall NAME full" or maybe at least the other order "uninstall full NAME" or "uninstall purge NAME". That would be more normal. 
@spirit 
Some notes:

And I know this would be rather difficult for the Quake Injector to do but here goes:

1) I have all installed files as lower case no matter what.
2) Take an archive like warpspasm.zip. It should install to warpspasm not warp. You shouldn't have zip files that need a gamedir other than the archive name. And this unarchives that way instead of honoring the \warp directory in the .zip.
3) I agree with synchronization, but I don't want the Downloads folder obviously exposed to the user.
4) I plan that in coop, a server can just transmit over the archive to the client and live install. Mark V as a server already stuffs in a hint to the client that tells another Mark V client to change to directory like -game warpspasm -quoth.
5) I also plan to try to disallow any external archive having the same name as a Quaddicted known archive and refusing to install it.

I have plenty more hammering to do.

@fifth --- at the moment, I don't have another computer available so this really hasn't been run on anything except my hard drive. Thanks for the heads up on the cd play command. 
First | Previous | Next | Last
This thread has been closed by a moderator.
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.