News | Forum | People | FAQ | Links | Search | Register | Log in
Spiked Quakespasm Modding/Coding Help Thread
Thread for figuring out all the new particle and modding features in the "Spiked" version of Quakespasm.

Actual QSS engine download:


Tutorial on how to enable rain and snow on the Quake start map:

1. Video of snow:
2. Video of rain:


1. Put this start.ent download in c:/Quake/id1/maps folder. Tells it what textures emit snow and rain.

2. Put this weather.cfg download in c:/Quake/id1/particles folder. Indicates spawn information on particles and how they behave.

3. Enter r_particledesc "weather classic"; map start in the console. I assume "weather" is the name of cfg. Also seems to work with just r_particledesc "weather".


Q: How do you find out the name of textures?

With Quakespasm I don't know that you can, but in Mark V just type "tool_texturepointer 1" in the console and look at a surface and it displays the name of any texture you look at on-screen. screenshot

Q: How is the external ent file made and what does it need?

Open up Mark V and type "map start". Now just type "copy ents" and the entities for the entire map is on the clipboard. Open a text editor and paste. Save it as c:/Quake/id1/maps/start.ent

The first few lines of the file look like this, add the 2 bolded lines that tell the particle system that the texture names are "sky1" for snow and "wizwood1_8" for rain.

"sounds" "4"
"classname" "worldspawn"
"wad" "gfx/start.wad"
"_texpart_sky1" "weather.tex_skysnow"
"_texpart_wizwood1_8" "weather.tex_skyrain
"message" "Introduction"
"worldtype" "0"

A devkit is also available HERE with source code examples of how to create your own custom HUD using CSQC. The examples show CSQC recreations of the classic HUD as well as variations for the missionpacks and should serve as a good starting point for your own creations. There's a few other goodies in there too (e.g. particle stuff), so check the readme inside the devkit.
First | Previous | Next | Last
You Might Need... 
Extras_r4 has some fancy particle effects, in particular it turns nails and rockets into 'particle' objects that react to forces. That mod has a cool gravity well thing that pulls nails and rockets away. Could be used to do the reverse. 
Thanks for saying that, makes my day!

There's a newer version of extras now that Khreathor fixed up. I'd suggest that. The source is included in uwjam. See here: 
just curious why on the first post it is raining inside?

2. Video of rain: 
maybe baker was curious as to whether the floor entity thing would cause the splash effect too (not my video, and I don't remember what state I left my examples in). 
Traceline And Texture Questions 
I'm trying to check what texture is below the player when he walks, then I'll change the sound of his steps depending on the texture.
I found this function in fteextensions:

string(entity e, float s) getsurfacetexture

So I thought that I should use traceline to get an entity below the player to get its texture:

traceline (self.origin, self.origin + '0 0 -40', 0, self);

But trace_ent always returns world.
I'm almost positive I'm doing everything wrong here, that traceline only interacts with entities and not the map itself.
Any ideas? 
Yeah, I was completely wrong.
Just do this:

local float surfnum = getsurfacenearpoint(world, self.origin + '0 0 -40');
local string s = getsurfacetexture(world, surfnum);
sprint(self, s); 
Missing Textures On Models 
Textures for models used with DP do not affected in QSS. Models still grey.
How to solve an issue? 
Spiked Particle Effects 
i was playing through lost sepulcher months back, and i was using the ad spiked mod, and i had the particle effects working.

i downloaded the most recent version of spiked, extracted the contents to the root quake folder, ran the exe, tried out vanilaa quake, but i cannot see the partical effects.

i must admit, i'm out of the loop here, so any advice would be appreciated! 
Qss Effects 
the particle stuff in qss were added for use by mods or maps, rather than forcing it on all users (retaining the quakespasm feel by default).
ad uses them, vanilla does not.

if you want to use custom effects, either use the r_particledesc cvar to tell the engine where to load the particle effects from, or do the equivalent via the particleeffectnum/pointparticles/trailparticles qc builtins, or use worldspawn keys of the form "_texpart_TEXTURENAME" "CONFIG.EFFECT" in your own map creations.
Without one of those, you'll get the same results as you would with unmodified quakespasm. 
Are you saying that the version of spiked released for AD has particles forced ON in the engine, and all other versions of spiked don't? 
Kinn (you Forgot To Log Out) 
No, they are opt-in only, and AD has opted in basically, it calls the various particles effects in the qc etc.
As far as I know there is no version of QSS specific for AD anyways? But AD is probably one of the only mods that uses these features? 
Learning Curve 
ah, i'm not really at the level where i can grasp a lot of this.

i was talking to rob martens, and he mentioned what i think you mentioned first (i quote):

1.) From a copy of Arcane Dimensions, copy the particles directory and the effectinfo.txt file over to your ID1 directory.

2.) In the QSS console, enter r_particledesc "effectinfo" to enable the use of the effectinfo file instead of the classic particles.

i'll give that a go.

cheers spike. 
Ah I'm confused because i thought the question sounded like "AD run with the spiked exe released for AD has particles, but if you replace with newer version of spiked exe no particles appear".

That's how I took the original situation, but if I'm totally wrong then disregard. Probably my crap reading comprehension. 
oh LMAO, sorry just read the original post #196 and he's talking about them not appearing in vanilla.

So yeah ignore me. 
I'm playing the Xmas Jam 2018 with Quakespasm-Spiked-ADMod.exe and i'm getting this error with both Scampie's and Strideh's maps:

Host_Error: Illegible Server Message 119, previous was svc_serverinfo

Anyone knows what's happening? :/ 
Spile will know better what that is but try updating to the latest build:

The qss-admod was a one-off build I made with a few patches to Spike's engine when AD came out but it hasn't been bug fixed since. 
Thank you very much, sir!! Now it's working =D

I didn't knew that you guys have been updating Quakespasm-Spiked =D 
It's me again. Sorry for the double post...

One thing that i noticed when i was testing xmas jam with another source-ports is that the start map have snow falling from the sky in quakespasm and markV, but not in quakespasm-spiked...

i opened the file in trenchbroom, and it seems the snow is made by something called "misc_particletemplate"... quakespasm-spiked doesn't understand this feature? 
set pr_checkextension 0 if you want mods (like AD) to treat qss like they would quakespasm. 

But when i do this i don't have those cools effects (smoke, sparks, somke, etc) from quakespasm-spiked anymore :P

i was also trying to make a *.ent file for QMaster's map "Gift of the Boxlord" (to make snow in the map) but i noticed that the *.bsp already had a line where it says:
"_texpart_sky_xsnow" "fte_weather.tex_skysnow"
but there is no snow falling, even when i write r_particledesc fte_weather or r_particledesc weather on the console :( 
How to disable the custom particle effects? I've tried all cvars I could think of, and nothing. Specifically, I'd like to disable the custom TE_GUNSHOT particles, because lots of 8-bit alpha overdraw makes the engine too slow when up close.

Also, I wonder if Spike could fix the crash when FSAA is enabled on Intel HD Graphics 3000 IGPs. 
Ok, I've just re-read the thread and will try a couple ways to disable the custom particles. 
I cannot fix your intel drivers for you.
that said, I do wonder if its caused by the use of glCopyTexSubImage. Either way its not something I can test/debug/fix for you.

particle configs can get loaded a few ways:
non-default r_particledesc cvar setting
worldspawn _texpart_* keys
qc particleeffectnum() calls that include a full-stop separator.

chances are the mod is doing it explicitly, which implies you need to mod your mod to disable it.

(assuming this is AD you're using, you'd need to open effectinfo.txt and strip out the TE_ effects that are generally at the start of the file - sock used a different prefix for extended effects, and if you strip his new effects then there's no fallback and you'll see less particles there. Or you can just set pr_checkextension 0 to prevent the mod from realising that it can use those particle effects thus preventing it from forcing them to load.). 
Haze.cfg Crash 
When I set r_particledesc to "haze.cfg" on a map with torches it hardlocks on r10. I've booted up into start and e1m1 with this active and it has froze every time. 
QSS Bug? 
Many maps have different textures with same names. To load correct HD texture for current map it placed into textures\map_name subfolder. QSS even in this case loads both textures: from each textures\map_name\ and textures\ folders. And if texture in textures\ folder has _luma. file it looks especially bright.
It looks like this (on Forgotten Sepulcher):
I found elegant decision - just put in textures\map_name\ subfolder entirely black _luma. file for current texture. It solve problem.
It is a bug or its a feature? 
That's definitely a bug. If loading from textures/mapname/texturename, the engine should ignore textures/texturename_luma.

Now I don't remember if that bug also happens in my own engine... 
RMQ Winter 2011 
If anyone remembers the old RMQ project,the e2m1rq map in the Winter 2011 release is a bit crazy wit hthat opening cutscene.

In Mark V that cutscene plays at normal speed,showing the grunts and marine fight and enforcers teleoprting at normal (and intended) speed.

QSS plays the cutscene at hyper-speed.

The second cutscene plays after maybe 5 seconds in Mark V
(the one with they shall not contain thee)
and QSS plays the cutscene a little later (8 secs?) but at the right speed. 
RMQ Winter 2011 
will not fix - its a bug in the rmq qc, not qss (or fte for that matter).

you can work around it by setting pr_checkextensions to 0, giving you the same result as (unmodified)qs or markv.

specifically, the qc has different behaviour between:
a) no extensions (read: qs expected)
b) extensions+DP_SV_CLIENTCAMERA (read: dp expected)
c) extensions without DP_SV_CLIENTCAMERA (read: they didn't bother to test that pathway properly, and its bugged).

The DP_SV_CLIENTCAMERA extension is designed as a simple wrapper around svc_setview (except that it also switches the pvs too). rmq doesn't even use it, so I don't know why its bothering to check for it. 
How to use external replacement conback, gfx.wad and menu images?

The source seems to support it, at least for menus, but I'm having no luck. 
I don't know where else to report this but there's a bug with one of the xmasjam2018 maps. In spipper's map "A Christmas Romp," entering the map and saving causes QSS to crash immediately. I don't have the same problem in regular QS. 
This a patched in one of the last commits in QS (it's a buffer overflow with keyvalue length) 
Performance Problems 
Does QSS have particle limits or any sort of limits when it comes to fancy effects? For mods that take advantage of it like AD, it's my preferred port of choice but there are moments when it slows down to under 1 FPS. Granted my computer has some pretty old parts in it but I feel like the Quake engine shouldn't be that difficult to run even with some fancy effects.

I had performance problems in Leptis Magna and also in ad_azad during the final boss fight. During the final boss's death animation, I was worried that the game might crash. Usual when I get to this point in a map, I have to save and reload in regular QS. 
you mean like the r_part_maxparticles or r_particle_tracelimit cvars?
if its the rain/snow/etc effects, you can just set r_part_rain_quantity 0 (or really any value lower than its default). 
I don't know what's actually causing the slowdown and why it's so drastic but I'll try changing those cvars. None of the maps in which I'm having performance problems have any weather effects so it's something else causing issues. 
Try hiding the world with r_drawworld 0 and see what is rendering and what the fps is. IIRC all torches in the map render in AD+QSS 
You're right in that all the torches get rendered in AD. I think everything with a particle effect on it essentially gets rendered from torches to armor.

Using the boss fight in ad_azad as a benchmark, QSS grinds to a freeze with the default settings. With r_part_maxparticles set at 16384 down from the default 65536, the fight is actually pretty playable. It still drops well below 60fps though. I wonder if it's just my CPU - using a first generation i7 at 2.67 GHz. 
I tried ad_azad in FTE with the Quakespasm preset and the game doesn't slow down at all for me in ad_azad (general FTE slowdown issues aside). I get a consistently smooth frame rate all throughout the boss fight whereas it freezes for me at certain parts in QSS. I don't get it. 
Entities Are Stuck In Ceiling And Walls 
I very like QSS engine for all that can QS classic plus all, that can’t QS classic, but QSS do, especially for .pk3 and skin replacement for .mdl support. (I don’t really understand, why it two simply things still not realized in Quakespasm.)
1. I want report/get help to fix one sadly bug in QSS:
On some maps models (monsters, ammo boxes, other entities) are stuck in ceiling and walls, or simply in air. Like this laser fences out of place on rub2m2 map:
Similar bug there is in Quakespasm on Scourge Of Armagon (hipnotic) MP, where silver key drops down thru floor. It fix with
sv_gameplayfix_droptofloorstartsolid "1"
QSS reports about it as “unknown command”
How to fix it?
2. Why QSS developer don’t announce about new releases? 
Entities No More Stuck In Ceiling And Walls 
Unexpected for myself, I found decision to solve it!
I just run QSS with sv_protocol 999

Tested on Rubicon 2 and RRP and bug not happened. 
This trick still does not work on
coe1.bsp of Coven of Ebony
some others. 
From It's Own Thread..... 
Two of the three maps of this classical mod doesn't load in QSS:

It loads well with the latest version available of QS. But what's wrong with this mod under QSS?

On OSX, QS cannot load mods from within the game, and cannot quit using the usual command-Q, while QSS can do all these. WTF? 
How To Disable The Added Effects In Arcane Dimensions? 
I love this port apart from that feature. I tried pr_checkextensions 0 but nothing happened. More than anything else I just want to disable the glow effect that happens when your bullets hit a wall. Thanks, hope you can help! 
Ignore #230 
Sorry, I was using pr_checkextensions 0 in console. Once I put it in config and then loaded the game it worked fine. Thanks for the fantastic port. 
Put this start.ent in your Id folder.
Link is down. 
Referring to Poorchop: I ran into the framedrops with Quakespasm while playing Ad. I made it about half way through the maps then my frames tanked. At first I thought it was my pc, but then I experimented with Spiked and still got the crap framerates. Same with another port I can't remember. I put Fritz into the directory and suddenly my config was reset and the framerate was normal. I just made a fresh Quakespasm folder and put my save in there and all is well. No idea what the cause was or how to replicate it but both Spiked and regular QS were both affected. 
woah wtf... how did i not see this before.

huh... with this, i wouldn't need to have my mod spawn rain drops and create 2gb demo files.

there's a lot to look at here, i hope i have the time to work through this. 
I think there's something wrong with the last quakespasm-spiked release :/

I was playing ww's map for sm107, and there's a rocket launcher that is supposed to fall after you kill some vores (look in this video at 02:41 )

With the new version of quakespasm-spiked the rocket-launcher doesn't fall, but with an older version that i have on my PC it works perfectly.

Also, if you play the map "ad_beep1m2" (The Lima Project by Comrade Beep) with the new quakespasm-spiked, the player cant' move at all when you load the map. This issue don't exist if you play with an older version of the engine :P

what's going on? :P 
Previous Version 0.93.2 X_win64 22.11.19 Works Fine 
It would be nice to publish few latest builds of QSS for example, as it is for DP and QS classic. 
Try pr_checkextransion 0 
... pr_checkextension 0 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.