News | Forum | People | FAQ | Links | Search | Register | Log in
FTE Engine
This engine needs its own thread... also!

FTE's homepage:

This thread is for the discussion of using FTE's enhanced features, and/or drawbacks, for Quake level design/modding and/or gaming in general.

First | Previous | Next | Last
I was having issues with singleplayer in the latest build of FTE. Often freezing on level load/change, and sometimes nothing happening on selecting new singleplayer game.

On a suggestion from Spike in the discord I set sv_nqplayerphysics 1 before trying to load a singleplayer map. That fixed the map load freeze. I haven't tried the "new game" selection yet to see whether that is still flaky.

You might or might not already have sv_nqplayerphysics set to 1. I think it is by default, but in the setup you get from the AfterQuake package it appears to be 0. Anyway, if it's 0 for you currently, try setting it to 1. 
Thanks for the responses. Neither command fixed the issue with selecting single player. I added -nohome in a bat file and I also entered the sv_nqplayerphysics 1 in the console. Nothing. What's funny is that in 5399 everything worked fine. The last two updates broke the new game selection for single player. :/ Oh well hopefully the fte qw team is aware of the issue. 
It's A Single Executable 
Why not just go back to 5399? 
Because I deleted it. Can't find it anywhere and the fte qw site doesn't keep old versions on their page. 
BTW, sv_nqplayerphysics doesn't seem to be the panacea for me after all. Weird edge friction going on. If my player model is overhanging a ledge and I tap the walk button once in a direction pointing along the edge, often the player will "grind the rail" all the way along the edge. 
hopefully some of these things are fixed in revision 5424 
Single player fixed with 5424. :) Thanks. Tilding then tapping map e1m1 (or whatever start map) was a little annoying. 
Yah all issues I mentioned above are gone in 5424. :thumbsup: 
RT Lights Are Point Entity Only Yes? 
Without resorting to Q3BSP+Q3map2, is it possible to have in Q1, a texture emit RT Lighting? Using scripts/shaders? 
Quake Injector 
Quake Injector not showing in menu anymore with latest build. 
for the quake injector option to be displayed, you must have the qi plugin loaded, and is normally obtained+enabled in the updates menu.
(you can also 'plug_load qi; qi' to load it without using the menu, assuming you manually downloaded the extra dll) 
Stuttering Frame Rate 
After playing in FTE for a little while, the game starts to get jittery. The frame rate is smooth for a while after launching but maybe 5 to 10 minutes later, there's a bit of stuttering that really messes with my eyes. Any idea what's up?

Also what's the cvar for square particles? 
R_particles 2 
works for most engines 
I have downloaded all plugins and enabled them and none show. 
r_particles isn't recognized as a command in FTE. Only way I can get square particles is to use the vanilla video mode but I still can't find the cvar for square particles alone.

Also after playing around in FTE a bunch, it seems like the stuttering frame rate starts pretty consistently at the same time every time. Doing a vid_restart smooths out the game again but then 5 minutes later, it's back to stuttering. It seems to get jittery even sooner when I alt+tab out and then back in. 
r_part_classic_square 1 ??? 
#157 P2 
btw, I had the graphics preset on "spasm". 
That works, thanks. 
it does support webrtc, but only between itself, and it requires a broker to do so.
web server: sv_port_rtc rtc://BROKERADDRESS/GAMENAME
web client: connect rtc://BROKERADDRESS/GAMENAME
non-emscripten server: net_enable_webrtcbroker 1; sv_port_tcp BROKERPORT
(it is possible to omit the BROKERADDRESS args by including a usable value inside your site's fmf file, but you'll need a reliable broker for that.)

Unfortunately this does not work for me.
I've started server like this:
| ./fteqw-sv64 +sv_port_tcp 27500 +net_enable_webrtcbroker 1 +map frenzy

Then on web-server I've entered:
| sv_port_rtc rtc://<serverip>:27500/magic
and got following output:
| Listening on ws://<serverip>:27500/magic

At the same time on dedicated server a message appeared:
| Websocket request for /magic from ws://<clientip>:64509 (rtc_host)

Then using another instance of web-client I tried to connect like:
| connect rtc://<serverip>:27500/magic
and got following output:
| Connecting to rtc://<serverip>:27500/magic...
| No route to host, giving up

Could you, please, help me with this? 
What would you guys say it's the most stable build of FTE? 
Clean Win64 install from fresh download today, plugins such as the Quake Injector one don't want to load, "plug_load qi" returns "Couldn't load plugin qi". Something I'm missing? 
Aha. Plugin items reappear in menu with 5529 update. Quit the game, reload FTE, they're gone. Disable/reenable in updates+packages brings them back and seems to be only way to do it ("plug_load" doesn't work). Quit, gone again. 
Stuttering Sound 
I'm having a problem with a level that I'm creating, and I'm not sure whether it is the level, or FTE. Note that I don't have this issue with Darkplaces or Quakespasm.

The problem is that at some places (often the same places), the sound starts to stutter. More specifically, some of the sound effects have the last one second repeated a few times. While the sound is repeating, the game keeps running and the other sounds are occurring normally.

The framerate is at its lowest 30FPS. I've tried more complex levels, and not been able to replicate this problem. Even in a large level, like those in Ter Shibboleth, which brings FTE to a crawl, the sound doesn't repeat. The level I am is using progs_dump, if that makes any difference.

Any ideas on how I might be able to troubleshoot? 
Sound Follow Up 
A clarification. What is occuring, is the entire sound effect is being repeated. I put snd_show to 1, and it appears that as the sound is being repeated, is is registering as an additional sound being played. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.