News | Forum | People | FAQ | Links | Search | Register | Log in
FTE Engine
This engine needs its own thread... also!

FTE's homepage: http://fte.triptohell.info/

This thread is for the discussion of using FTE's enhanced features, and/or drawbacks, for Quake level design/modding and/or gaming in general.

Discuss...
First | Previous | Next | Last
Spike 
I'm not sure what that command has to do with what I described, considering its always on 0 by default. 
-lux Light Question 
Ok, I've been testing with this since I started this thread. Here's something I'm curious about.

I have a completely stock install of FTE making sure that these are set in my autoexec.cfg, and are working as intended:

gl_load24bit 1
gl_specular 1
r_glsl_offsetmapping 1
r_deluxemapping 1

Compiling, Light gets this:

-lux -extra4 "$bspdir/$file"

Nothing else, as far as the engine and the mapping, is changed for this test.

I am of course using some replacement textures each with normal maps and one including a specular map(floor).

My issue is, you know how we use "muzzle flash" from the weapons to light up dark areas? Or even just general rocket/grenade usage that lights up areas as well...

That doesn't seem to work for me mapping like this. Or it's inconsistent.

The dark areas most of the time just stay really dark(black/unlit) or... for no reason will light up occasionally and then stop again.

This of course looks strange.

Any thoughts on what I can do to correct this? 
I Tried To Screenshot It... 
... but no matter what window mode I select, FTE writes only a transparent image and my Windows "Print Screen" button seems disabled(?) as well!

Hope the info I provided is enough. 
Screenshotted 
I used OBS to record and grabbed images from video:

https://i.imgur.com/mIOxyaA.jpg 
How Deep The Rabbit Hole Goes ... 
rabbit holes, explore 2 or 3 with an advanced engine ... eventually ... you don't return at all.

Quake is successful because of the limitations (256 colors, etc.) and the many things you cannot do force an author to limit the scope of their project.

With an advanced engine, what starts as a project morphs into exploration drift -- then you find bugs or limitations.

I mention this because it is very uncommon to find a completed project that targeted DarkPlaces or FTE.

The specs of the project increase and increase, exponentially growing the labor hours required for the result --- until the number of labor hours passes the event horizon ... never to return.

A paradox ensues --- offering more capabilities dramatically increases the possibilities but decreases the probabilities.

So planned projects that plan to target the engine capabilities increase, but completed projects that actually do target the engine decrease --- usually to a specific number --> zero.

/Thought of the day 
Yes And No 
Having an engine with more advanced capabilities seems a dubious problem. Evidently there are projects built on UE4, CryEngine, Source, etc that do get completed.

Having the capability to mod the engine is IMO more of a problem. But blaming the engine is only half the story. Mod teams need to exercise discipline and restraint too. 
Limits Didn't Define Quake 
quake defined the limits higher.

dork. 
#29 
This is accurate, in my limited experience. I have since imposed a set of limits on my project so that it will be coherent and actually make it to completion. IMO, setting limits was a great move both logistically and creatively. 
Weapon Bob In FTEQW 
Is it possible to change the weapon bob in FTEQW? Quake's default bob is annoying, the weapon just goes up and down, but it looks like it's stretching or some crap. Is it possible to change it to something like Doom, left and right?

I've noticed that DP has something similar:

cl_bobmodel
cl_bobmodel_up
cl_bobmodel_side
cl_bobmodel_speed 
 
FTE has cl_bob, cl_bobcycle, and cl_bobup. 
Fancy Weapon Movements 
If you're willing to write some CSQC code, you can just set cl_bob 0 and then implement whatever crazy viewmodel movements you want.

All you really need to do is avoid the MASK_VIEWMODELS flag in addentities and to then add an entity yourself using something like:

{
static entity ent;
if (!ent) ent = spawn();
ent.origin=[sin(time)*5,0,0];
setmodelindex(ent,getstatf(STAT_WEAPONMODEL));
ent.frame=getstatf(STAT_WEAPONFRAME);
ent.renderflags=RF_VIEWMODEL|RF_DEPTHHACK;
addentity(ent);
}

The maths your mod uses are then entirely up to you.
(RF_VIEWMODEL is responsible for sticking the ent to the view, which avoids the need for matrix stuff, RF_DEPTHHACK messes around with the ent's projection to prevent it from poking through walls.)
(note that the above code lacks interpolation, its .frame2+.lerpfrac for that, but it makes examples messy. use .frame1time and frame2time if you want control over framegroups.)

Shpuld's TurboQuake mod is a good example of the value of csqc controlling viewmodels:
https://www.youtube.com/watch?v=oCqhxekWn5M
That said, its worth noting that using the vanilla content for it is more painful than it otherwise should be - like spinning the SNG barrel (read: spinning the entire model around a point which is not its origin). 
 
Where's FTE irc located at now?
The quakenet one listed at the site is empty, not even a bot in there.
I needed some assistance with FTE cvars and can't reach out it's chat hangout place, bummer. 
 
“also make sure you don't have both vid_conwidth+vid_conheight lingering from other engines - those other engines tend to have screwed aspect ratios. As a general rule you should only use ONE of them, with the other set to 0. “
true if the engine does console sizing correctly it will
autoadjust the height based on the proper
aspect ratio 
@spike 
What's best place to find you for questions or documentation for FTE? Here? The Wiki seems pretty out of date. Is Sourceforge still the best place to report bugs?

5121 Win64 Dell Win10 laptop. I'm having keyboard input issues similar to buttons being held down. I confirmed the physical keys are fine and this behavior doesn't happen in other ports. I had changed some video settings prior to the issue. Restarting app had no effect. 
 
Is there any sane way to animate weapons and models from QC? Without having to tie frames and game logic and without having to declare each and every frame as a var and then as a function? 
 
@dumptruck
Best way to poke me is generally via #qc, if I'm on. Or if you're on discord I got harassed into joining the Quakeworld one.

I don't know what would be up with the keyboard input. you could try toggling in_rawinput (followed by in_restart) which may or may not help, but I've not seen similar issues in the windows builds. I also don't use win10, but hey.

@dfut
framegroups would be the obvious answer there.
however, animating with framegroups from ssqc is kinda messy as there's no way for the server to force a framegroup restart, which makes firing animations de-sync.
csqc has full control over the time into framegroups though, and because that's the answer to everything, you can use it to detect toggles of some bitflag and convert them into restarting whatever framegroup.
and if you're using csqc, you could also use it to position the various bones of eg an iqm via the skeletal objects extension, which allows things to spin independently of whatever animation they're otherwise meant to be playing, for smooth chainguns or whatever. 
 
Where i can find any examples of CSQC framegroups? Do they work normally with MDL and MD2? 
 
md2+md3 do not natively support framegroups, while mdl+iqm do.
csqc is quite explicit when it comes to animation, so there's about 5 fields that need to be updated each frame.
.frame+.frame2 define the two framegroups/animations to lerp between, eg when the animation changes.
.lerpfrac says how much of .frame2 to use (and thus how little of .frame to use). 0 uses excusively .frame, 1 uses exlusively .frame2, other values linearly interpolate.
.frame1time+.frame2time define the time into the two animations.

So, to switch from one animation to a new one, you copy .frame to .frame2 (and .frame1time to .frame2time), set .frame to the new animation (and .frame1time to 0), set .lerpfrac to 1, and then slowly decrement it over time (depending on how smooth you want the animation switch to be, probably lerpfrac=max(0,lerpfrac-frametime*10);
additionally, you need to increment both .frame1time and .frame2time by frametime. You can scale it or whatever if desired.

note that if you want to restart an animation, you will likely want to do it with lerpfrac (and .frame1==.frame2) instead of trivially resetting .frameNtime to 0, as this avoids sudden snaps.

when it comes to viewmodels, they're not really any different from any other entity. Just make sure MASK_VIEWMODELS isn't used, spawn a private entity with renderflags|=RF_VIEWMODEL|RF_DEPTHHACK, setmodelindex it to getstatf(STAT_WEAPONMODEL), and update its frame to getstat(STAT_WEAPONFRAME) as appropriate.
use some bit in the frame stat to signify animation restarts, and have the csqc restart the animation when its toggled by the ssqc or so.

So yeah, quite a bit of code that really needs some proper example code to fully understand. I don't really have easy-to-read code to link though, so I'm sorry about that. 
 
Thanks a lot for the information! I'll try to figure it out. Sounds very complex :D 
 
Does FTE support AD? The site says it doesn't, but I keep seeing people suggesting it... 
Mostly 
Should work for most AD maps. Might not work on sepulchre, swampy, or other megamaps. Spike can correct me, but I don't believe FTE has support for sv_protocol 999 even though it does support bsp2.

Spike could have done some updating though. I highly recommend he does since "can it play AD" seems to be the new standard for whether a Quake engine is "worthy" (initial AD release only specified Quakespasm as supported, leading to a lot of questions on other engines). Orl maps are a concern too since they are very very large as well. 
@idiot And @Qmaster 
use sv_bigcoords 1 for 999 maps (per Spike in a prior post in this thread) 
 
ad_sepulcher: worked okay last time I tried it.
ad_swampy: I really have no idea why anyone would think this map would have a problem.
999: sv_bigcoords 1; if its need isn't autodetected (if for some reason you want 999 specifically, also set cl_loopbackprotocol fitz;cl_nopext 1).

I'm not aware of any limits that are lower in FTE than QS, while I am aware of the reverse (even vs QSS).
That's not to say that there are no issues whatsoever, just that any issues are more likely to be due to qw-by-default player physics, or other such 'minor' incompatibilities that could affect ANY map...
And this is why you never fix what are obviously bugs. :(

But yeah, if I was aware of any issues with any of those maps that were mentioned, then I've either fixed them or just forgotten about them... Feel free to try them and shout at me should they somehow crash and burn. This is not a warranty - if it causes your computer to explode and destroy your entire city, then you probably shouldn't have been playing quake inside a nuclear reactor. or whatever. 
Spike 
Any advancement on the control pad issue that myself and Kinn were experiencing? 
@FifthElephant 
As I said in the other thread, I got PrimalLove to give me a list of changes on that front, which are now implemented in the latest build.
Most of it was just cvar changes, so you'll need to do 'cvarreset joy*' or to wipe that part of your config some other way. 
 
So... this is news for me... i've been playing quake with FTE for 6 months now and never experienced crackling sound :/ but when i play sm181_coce1 and sm181_coce2 i can hear some annoying cracklings... and if i go to "menu/audio options/restart sound" the cracklings stops, but if i load the map again, or just press F9, the crackling returns :(

Why is this happening? And why only in these two maps? :/ 
 
snd_restart doesn't restart static sounds.
there's a crackly static sound played near all wall torches.
I've no idea how you wouldn't have noticed that on other maps too though, maybe you've just been playing maps that use regular lights. 
I Suppose 
that in the first one the crackling comes from the torches, and in the second from light_fluoro or light_fluorospark (i don't remember which right now). But torches do a very different sound from the fluoro ... so maybe its another thing.

There is no logic gates or other sounds that repeat save the idle sounds from the enemies so it isn't from that, it can't be from performance as one is very open and the other took visibility seriously ... so I have no idea. 
 
Ok, i've made a video showing what i'm talking about =D

https://www.youtube.com/watch?v=0yJ5DR2eutY

I choose "coce2" because it doesnt have torches, so there will be no mistake here ;)

After 00:27 you can hear the crackling sound. At 00:50 i restart the sound, and the crackling is gone, but the "wind" sound is gone too... So, at 01:30 i've loaded the map again to show that if you reload the map the crackling is back, and this time i fought some death-knights to prove that the crackling has nothing to do with the "wind" sound, since you can hear it when i'm fighting...

And at 02:15 i loaded the same map with quakespasm to show that there's no crackling sound in this engine.

But, as i said before, coce1 and coce2 are the only maps that i heard this annoying crackling ;) 
No Idea 
but it is not from my maps, as it isn't any of the sounds Quake does. I also used a completely clean install (just FTE.exe and the two .paks) of the game to check and heard none of that in any of the two maps so maybe it comes from your configuration.

What i noticed and will be interesting for the developer is something on coloured lighting: i have coloured lights everywhere on the map, but there is only one not coloured. It's values are 1 1 1 to make a very dark light, so i suppose that FTE misunderstood it as a light with values between 0-1 instead of 0-255 and made it pure white. Look back on the spawning point on skill 1 and you'll see it.

I also noticed that on default config hell_knight projectiles don't leave a trail. Rechecked it with E2M5 and the same happens so its not from my map. Gotta check which option puts that well. 
 
sound:
try using directsound instead of openal.
snd_device dsound
(or pick an explicit outpur driver+device via the menus)
or wasapi or sdl2 or alsa... etc...

lights:
this is the problem when there's a complete lack of standards.
you may wish to provide an .rtlights file with your map, so that the engine doesn't have to guess at all.

missing trail particles:
QS rounds up - particles get thicker at high framerates, making it harder to see enemies.
FTE rounds down - particles get thinner. This is consistent with other QW engines. Unfortunately they can get so thin that they become invisible...
I need to do something about this, I'm just not entirely sure what. The scripted particles do not have this issue (they have working distance tracking).
In the meantime, cl_maxfps 150 (or vsync), or 'r_particledesc high' will 'fix' it, assuming a lax definition of fix. 
 
Thank you!! Changing to directsound did the trick! =D 
Noclip 
what's the command to get q2-style noclip movement? (fly in direction you are looking). For some reason this keeps going away and I end up back with sucky vanilla noclip style 
#57, Kinn 
that's nq player physics for you. oh, so NOW you don't want it faithful! pah! :P
sv_nqplayerphysics 0 will give qw physics, which don't have that annoyance (yes, there are a few mods that depend on the vanilla behaviour, which just makes things messy). its default varies by preset, which is awkward. 
 
Hehe, well I don't consider noclip as "part of the game", so how that works can be as unfaithful as I like :}

Is there anywhere I can read about the differences in player physics between qw and nq, because it sounds pretty interesting, and is something that I've never really come across before, having been a single player all my life, and never actually played qw. 
 
Stunting the player experience is faithful!

Fucking hell. 
 
missing trail particles:
QS rounds up - particles get thicker at high framerates, making it harder to see enemies.
FTE rounds down - particles get thinner. This is consistent with other QW engines.


It's a little more complex than this.

If you run your favourite Quake engine at 20-30 fps - which is the best that most people would have been getting in 1996 - you'll see that the intended behaviour of particle trails is not a straight, continuous trail of particles, but actually a trail that drops "clumps" of particles at discrete intervals.

There was a .plan or something from Romero back in the day that exactly describes this effect, but I don't have a link to it handy.

So both NQ and QW are actually behaving incorrectly at higher framerates.

The correct way to "fix" particle trails is to track an "ent->oldtrailorigin"; if a certain timespan has passed (something between 1/20 and 1/36 seconds works good) drop a clump (using standard R_RocketTrail from ent->oldtrailorigin to ent->origin) and update oldtrailorigin from origin. Add in some reset behaviour for when a new ent is spawned or an existing one is culled, and you're done.

This way works consistently at any high framerate and doesn't excessively spam particles in timedemos either. 
Crunchy Piskels 
Ok, so I can set 3d filter mode to "nearest" and 2d filter mode to "nearest" to make the world and the HUD cruncky pixels, but is there a way to make the console / text pixelly? Currently it's blurry and the text has some line artifacts around it, which seem to be a result of the filtering.... 
Kinn: QW Physics Vs NQ Physics: Everything You Ever Wanted To Know 
Freewill 
Noice, cheers. 
Spike, Controller Question 
It's working much better now but I want to be able to rebind the controller, seems you can't do this in the quake menu?
Also look up/down on the right analog is inverted! How do I undo this? 
#65 
controller 'keys' are prefixed with GP_, you should be able to use argument autocompletion on the bind command for the full names.
their default actions are not listed in the menus on account of how I set up their defaults, but if you actually bind them (either via menu or console) then they'll appear in the menus. Note that fte only shows two keys per binding, rather than 3 or whatever.

to invert pitch, either set joypitchsensitivity -1 or so, or set 'joyadvaxisu lookdown' instead of lookup.
I don't recall if m_pitch affects it too. 
Cheers Spike. 
Will check this out at home 
Gp_ 
doesnt show anything in the console for me.

setting joypitchsensitivity to a minus figure does correct the invert look though. 
 
Played a bit of deathmatch with my girlfriend. It works well, but rebinding is a huge faff. Would love to be able to do it easily in the menu (would also like to bind direct weapon impulses like in Quake 3) 
 
So... there's this game breaker bug with FTE when you can not get out of water sometimes... you can see in this video at 02:20 https://www.youtube.com/watch?v=E5BMeiBAPoI

This happended to me a couple of times with other maps, but it never bothered me, because i can just start the map and play it again in quakespasm or markV... BUT, today i was thinking: what if this happen when i'm playing an episode with a lot of maps? I would have to go back all the way to the first map and play all the maps again :P

Surely i'm not the first one to notice this... is there something i can do to avoid this? some console command like "fix the get-out-of-water physics please"? XD 
Set Sv_nqplayerphysics To 1. 
Technical mumbojumbo gibberish:
NQ's waterjump distance is framerate dependant (due to a frame's delay - waterlevel is set from the frame before so is set despite the player being out of water that frame).
QuakeWorld's physics does not have this issue, thus there is no extra 'slop'.

sv_nqplayerphysics 1; can be used to switch to NQ physics for players.
(you can change it mid-game without any real issues, though it probably only matters for coop).
This also disables prediction (hence why its not enabled by default).
And remember that waterjump heights are still framerate dependant - you can increase waterjump heights by decreasing the framerate by increasing sv_mintic, but you should only need that in extreme cases.

Obviously this will affect other bits of player physics too, making all the various fancy jumps more like other nq engines too. 
 
Thank you very much, Spike =D

You're awesome =D 
 
What is the easiest way to implement blood splat in FTE? I mean, like these awesome dark red decals here:

http://images.akamai.steamusercontent.com/ugc/704037719774586031/FE956021E201FFFBF3B9708D066733F126DB4B1C/

http://images.akamai.steamusercontent.com/ugc/704037719774585892/A54C896DF6196FE8C76C81677DD16E36984ADAF6/

These images are from a modification that Bloodshot12 made in particlefont.tga for Quake 1.5... Unfortunatly it is a darkplaces mod.

I know there's a way to do this changing the progs.dat, but i don't want to mess with progs.dat because i want the blood splat working with other mods, like DMSP2 and the official mission-packs =D

So, is there a easy way for me to do this or is too complicate? :P 
WebAssembly + WebRTC? 
Does the Emscripten build of FTEQW support WebAssembly and WebRTC for multiplayer? 
 
@Tribal
r_particledesc effectinfo is the lazy way.
you can also use r_converteffectinfo (iirc) to see what it would look like in fte's native particle syntax.
you can use r_part_redirect to rename a single existing effect to some other name, although this is usually only useful for weird people who want to mix multiple different effects without editing the particle configs.
FTE's embedded particle configs don't contain any decal effects on account of decals generally needing much high res artwork in order to look good. That said, if you use 'type cdecal' then you will get an effect that spawns as clipped decals, but you'll want to provide your own textures.

@bubbag
no, it doesn't use webassembly yet, though I imagine it wouldn't be too hard to update emscripten and tweak the compile flags in the makefile.

it does support webrtc, but only between itself, and it requires a broker to do so.
web server: sv_port_rtc rtc://BROKERADDRESS/GAMENAME
web client: connect rtc://BROKERADDRESS/GAMENAME
non-emscripten server: net_enable_webrtcbroker 1; sv_port_tcp BROKERPORT
(it is possible to omit the BROKERADDRESS args by including a usable value inside your site's fmf file, but you'll need a reliable broker for that.)

Otherwise you'd need to use websockets to connect to an existing server, eg 'connect ws://server:tcpport', but this only works for fte servers with both a tcp port open (controlled eg via sv_port_tcp) and net_enable_websockets set to 1. Alternatively fteqtv can be used as a proxy if you want a way to connect to any quakeworld server.

Installing game data from a public webserver is a copyright nightmare though. Users are meant to be able to provide their own additional game data by using drag+drop, which is of course annoying.
It is unfortunate that the paks need to be downloaded in their entirety, which makes downloads excessively large on account of all the maps which might not be played that session. 
@Spike 
Thank you very much for the info =D

Unfortunately i can't mess with the code right now, because it seems that is something wrong with my .NET frameworks :P Codeblocks+mingw refuses to compile any code (keeps asking for more and more *.h file) and Visual C++ 8 doesn't even install :P So, until i fix the .NET i'll stay away from the codes :(

But i downloaded the new version of FTE (5259)... this version doesn't support Hexen2 anymore? All i get when i click the file is a black screen with "Join Server/Options/Quit" :(

I think i'll stick with the old version for now =D 
 
Hi, it's me again

About Hexen2... How can i play music with FTE? I already put the ogg files in the "music" folder inside the DATA1 folder but it's not working, i copied the "music" folder to the main folder, and even created an ID1 folder but nothing seems to work :/ 
@Spike 
Forget about the post above.
The music works now =D 
 
It's me again!

I just noticed if i start the new version of FTE with "-hexen2" the game works :)

And now we don't have those annoying messages about "no-precache" on the top of the screen \o/

Thanks =D 
 
imho hexen2 is just generally too buggy without the mission pack, regardless of engine.
Note that if you rename the exe to fteh2mp.exe then it'll always try running the hexen2 missionpack, regardless of where its run from (unless given eg -quake on the commandline, or an fmf file, or just use -portals for it).
Assuming you actually have the mission pack, that'll fix a number of gamecode bugs that can get really annoying...
I also tend to test portals more often than the original game, tbh its been a long time since I tried.

Hexen2 has a serverside cvar to control the clientside music which I intentionally didn't mimic, and I don't have any midi playback code anyway so it never really mattered.
CD playback should work as in quake. Its just a shame that the midi music uses different tracks. 
@Spike 
I just tested renaming the exe to fteh2mp.exe... Now the "no-precaches" messages are back :P

I also notice that with the new version i can't gib the enemies' corpses anymore... with FTE 5121 i can gib them all :/ 
 
it's nice quake with moderate rag doll physics 
Hurdles With FTE 
I'm trying to get to using FTE for single player again, but there are quite a few hurdles that I'd like to have resolved before the engine drives me away from using it again for a few months:

- There doesn't seem to be a menu option to disable autorun.

- Weapon cycling with the mouse wheel doesn't work when holding down shift.

- Weapon viewmodels: Neither Ruohis's or Plaque's packs have all the weapons modeled, so when I enable both of them in the "updates+packages" menu, some viewmodels overlap (the SG and TB). So I tried to disable both of the packages and use QRP models instead, but FTE would simply revert to the Quake default viewmodels, even if all the QRP packages are installed. Should I just install the qrp packages to the id1 folder the traditional way instead of using the "updates+packages" menu?

- Vulkan mode causes quite a few graphical glitches. Water reflections seem to be out of whack (for example reflecting geometry behind walls, I think) and many particle effects don't work with Vulkan.

- Trying to turn on Direct 3D 11 crashes the game altogether. Seems OpenGL is the way to go.

- Enabling Afterquake in the "updates+packages" menu forces the default graphical presets on startup, so I always have to manually go turn on the cool realtime presets when firing up FTE, which is frustrating.

- underwater sounds are overpoweringly loud if there are a lot of sound sources (ambient, especially) in the map. The issue is particularly problematic when both "static sounds" and "mix in background" are enabled in the audio menu, I think. Can the underwater sound attenuation be coded in a way, that only the sound sources that are in the same liquid body would carry farther out?

- The particle effects menu is quite confusing; I don't know which effects to turn on. If I turn on the Haze particle set, for example, will I no longer have to turn on all the individual Haze particle effects further down in the menu, let alone Haze-lite effects? Should I restart the map/game for the effects to fully turn on?

- torches (with the wooden stem) don't seem to be implemented in the available particle effects. I never see any fire. Sometimes I see only the stem and sometimes not even that either. Would it be possible to have both 3D fire models and particle fire effects?

- rtlights are handled differently in FTE compared to DP. Is there an easy console command or something that would change rtlights interpretation to that of DP, or will I just have to make my rtlights for FTE from the ground-up? DP has an ingame rtlight editor with the command r_editlights but FTE doesn't seem to have it. How can I easily make realtime lights for FTE in... realtime? B] (ba-dum-tss)

Anyone else experiencing similar issues? I'd be especially curious about the audio, Vulkan and Direct 3D issues. 
 
Fte has rtlight/terrain editor

http://fte.triptohell.info/moodles/csaddon/ 
 
disable autorun:
why would you? :o
cl_forwardspeed 200; cl_backspeed 200; cl_sidespeed 350; cl_upspeed 200; cl_movespeedkey 2.0; cfg_save

weaponcycle+shift:
only way I can think of that happening is if you've bound shift+mwheelup to something different from mwheelup (fte understands modifiers). rebinding mwheelup-without-modifiers should also rebind all its modifiers too.

viewmodels:
I really need to get around to editing those packages so that they don't conflict with other stuff.
If you've manually installed that stuff for use in eg DP, then you'll already have all that content anyway.

vulkan+d3d:
these don't get tested as often as they need. so are unfortunately often buggy.
I've only got an nvidia gpu to test vulkan on, and it generally performs worse than opengl. yes it has better cpu usage but it really sucks (for me) in terms of pixel fill rates compared to opengl or d3d. FTE's implementation is mostly complete - read: has more ways to go wrong.
d3d11: windows only junk... plus you're generally better off with d3d9 (the lack of custom hlsl means d3d9's support for oldskool multitexture gives d3d9 the advantage).
ultimately my time is limited and I'm lazy, and focus+test opengl the vast majority of the time. they should normally all be able to run vanilla quake well enough though, so if they can't then that's a bit of a fuckup, but as the opengl renderer still works it doesn't seem that significant.

afterquake:
changing content shouldn't change presets...
remember to use either the menu to quit or to use the cfg_save command if you actually want your config to be saved after changing/reverting any cvar/preset settings.

underwater sounds:
that's your openal implementation for some reason completely ignoring distances when reverb is enabled.
you can set s_al_use_reverb 0, or switch to some other driver/device via the menus (especially if you want something more quakey).

particles menu:
the particles menu is just a list of particle config files to use (the order in which you enable them can make a difference).
do note that particle configs are still configs, and there's a few evil ones that include non-partcle commands (like cvar settings) which don't get forgotten when unloaded, but a properly made effect (one that doesn't have such things) will be fully purged by just changing options.

torches:
the 'fast' preset hides static models (like torches+flames - quakeworld users tend to not like scenary), but the others should still include them.
the QRP models have no flame animation and expect that effect to be provided by a particle effect, which is a separate thing from the model. Yeah, its messy. :(

rtlights:
they're meant to be handled in pretty much the same way, except for editing. note that you might have different .rtlight files installed for the two engines.
if you installed the plugins/ingame-map-editor option via the downloads menu, you can then set ca_show 1, and you'll get some csqc-based editing menu. Be sure to pick the rtlights option... 
Replies And A Couple Of Other Things I Forgot To Mention 
- Well, as a single player, sometimes I like to take it slow and calmly appreciate the level's architecture, and seeing Quakeguy running with each movement sure makes it less of a relaxing experience. Yeah, I'm weird like that. But slower movement does provide some accuracy to platforming sections for example. So yeah, the slower speeds do have their use cases in single player.

- According to more testing the mousewheel weapon cycling starts working when I reconfigure the weaponcycle keys at the keys menu (even if according to the menu the mousewheel was already assigned to it). So, I save my settings, shutdown FTE and restart the game and then try weaponcycling again while holding down shift and the problem returns. So now it looks like that in addition to having to set the realtime lighting presets each time Afterquake configs are enabled in the "updates+packages" menu, now I have to reconfigure the mousewheel, too, every time I restart the program. Extremely frustrating. :(

And to make things even weirder, when I have the Afterquake configs disabled and then save my new weaponcycle bindings (and left shift key binding for the run action) and restart the program, the key bindings have not been saved. Does this have something to do with Windows 10 or system locales or something? Just throwing hunches in the air here.

- I got the underwater sounds working (ie. sounding like I weren't underwater at all) by changing my sound device from default to DS (I presume Directsound). I'm assuming OAL (openal?) was the default audio device. There was also a third device, WASAPI (no idea what that is), but sound was just garbled when using that.

-About the torches: I guess I can only hope someone makes particle effects for the torches with wooden stems at some point, then. (Or then make them myself!) @~@

- Here's a side-by-side comparison of how DP and FTE handle an individual ceiling light in one of my maps. In DP it's a nice subtle gentle light whereas in FTE it's a bright blue patch. (Note that the light radius of 0 is a rounding error from 0.01). Maybe my outlandish values like coronasize 3000 cause problems in FTE?

- A thing I didn't mention in my previous post is that sometimes when I startup the game (OpenGL and realtime lighting) I get models resembling Christmas ligths.

- Another thing I forgot to mention is that cursor keys are only partially supported in the menus. I think only in the main menu you can move up and down between the different options but in the other menus you can only use the right and left keys to adjust sliders. Otherwise I have to use mouse to switch between rows. 
Torches 
Particle effect for torch and big fire is available.
http://quakeone.com/forum/quake-mod-releases/finished-works/6241-small-mod-compilation?p=239369#post239369

Here movie shows a torch effect.
https://www.youtube.com/watch?v=u86vKWSdlm4

Me think you can copy effect. 
@Esrael 
- runspeeds
yeah, sorry, I was just trying to be humerous, and failing. imho its better to set cl_speedkey 0.5 and otherwise with always-run on. if you need the precision then you can hit +speed (for slow), and then you're not required to hold a separate key every single time you encounter a vore etc. but yeah, not 'failthful' or something.
the afterquake menuqc stuff lacks an autorun setting because its not a trivial setting (so wasn't in the first versions), and then got overlooked once the code became more capable.
the engine's built-in menus do still retain the option.

- menu cursor keys
yeah, those menus were written as mouse-first menus.
any menu that might need a scrollbar (when running at lower resolutions / bigger fonts) has multiple tiers of widgets (ie: title+options[option1+option2], and the up/down arrow keys don't propagate properly between tiers - if the upper tier has focus then you can't change between the actual options.
You can disable the replacement menus in the updates menu, if this annoys you.

- binds not saving
fte attempts to sandbox its configs.
if one of the known-configs changes when switching gamedirs then configs will be reloaded.
when saving the config, that config will be saved to the active gamedir if the gamedir contains one of those known-configs and to id1 otherwise.
this means that a mod with its own settings won't propagate any of those settings back to the base game.
basically what I'm saying is that I'm not really sure what's going wrong here.

- sounds
wasapi is what directsound is a wrapper around (since vista). it generally has lower latency (especially if you tweak some cvars to request exclusive access to the hardware). I'm not sure why it'd be garbled, maybe I'm not feeding it enough data (try increasing wasapi_buffersize?). either way, its main thing is that there's a wasapi_exclusive cvar that can be set to 1. :)
otherwise it doesn't really make much difference.

- torches
I thought the hazed particles had something in them. the 'spikeset' ones do, but mneh.

- coronas
the general recommendation is not to hack the radius to some low value and compensate with an extreme corona size, but rather to set the corona scale to 1, set the ambient+diffuse+specular values to 0, and then set radius to directly control the size of the corona. must less hacky that way.
try setting r_coronas 0.25 instead of 1.

- lights
looks more like your r_shadow_realtime_world_lightmaps setting is different in the two engines. FTE has a habit of forcing it to 1 when it couldn't load/import any rtlights (too many buggy maps otherwise), but I've no idea why that could be happening in this case.
when comparing lights, it can help to disable bloom and any iris adaptation stuff (read: hdr), and srgb stuff too. this should make the colours more directly comparable.

- christmas zombies...
... I really have no idea...
does the mod that you're running mess around with .colormod or something? I have no idea why those zombies would each glow/bloom a different colour, unless your mod was using that.
are they still bright colours with bloom disabled?
does r_fb_models 0 help? 
FTE + Arcane Dimensions Mod 
hello, after a long hiatus i am back in quake realms and i have one question. i use darkplaces usually but i am testing FTE right now because DP cant handle forgotten sepulcher.

FTE runs that level fine, everything works - monsters, breakables, extra particle effect. All that works properly but when i get killed and load previous save new particle effects no longer look the way the should. i am talking about torches, power ups and so on... original ad version of these effects is replaced by something ugly. the only way to restore particles is to start level from scratch.

any idea what causes this bug? FTE obviously can handle AD version of particles but when i use SAVE/LOAD the fancy visuals are gone.

jakub 
@jakub 
fte tries to do its saved games differently, and they're still a little buggy right now (particle effect names are not saved).

In the meantime, you can use the savegame_legacy command instead of the regular save command/menu, which should get it to do its saved games the exact same way as any other engine (and compatible too, except for homedir stuff).
(or set sv_savefmt 0 for the same result, if it exists in the version you're using, not sure when I added that.)
(you should also be able to use it to fix a prior save too.) 
Thanks 
hi spike, i tested your suggestion to change sv_savefmt command and it works.

thanks for quick and helpful reply.

jakub 
One More AD Problem 
hi spike, i tested forgotten sepulcher more and there is another problem. particles works fine, even after LOAD/SAVE but something else gets broken. gameplay is really choppy after LOAD, however that can be fixed by applying vid_restart

what is more complicated is that already broken breakables re-appears as invisible walls that can not be broken again. i can shoot them, i see impact particles, they bounce grenades and i can shoot them indefinitely but they will not break again.

any idea?

jakub 
Version Info 
i use win64 client version 5259 
R_glsl_offsetmapping_lod In FTE? 
Spike, I want to try to get up my lazy butt and address your replies later, but in the meantime, I noticed that FTE doesn't have the command r_glsl_offsetmapping_lod and r_glsl_offsetmapping_lod_distance, like DP does. I noticed that it improves performance with bumpmapped textures hugely (especially in large areas) without noticeably lowering visual quality. Any chance of it being implemented in FTE, yes? :3c 
FTE/Afterquake Spotlights In Realtime Rendering 
Hi,

when I'm trying to use spotlights (both using target or mangle) it seems that this information is ignored in realtime rendering mode for the lights as I get surfaces lit which actually lie outside the desired cone. Static lighting looks correct though - am I missing some option? 
 
rtlight importing doesn't support all features from maps.
spotlights have been implemented for a while (and sometimes even working), buts its only recently that they've actually been importing from maps - you'd need an svn build for it to work. 
FTE/Afterquake Spotlights In Realtime Rendering 
Ah ok, then I'll probably have to wait a bit longer, thanks! 
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2018 John Fitzgibbons. All posts are copyright their respective authors.