News | Forum | People | FAQ | Links | Search | Register | Log in
FTE Engine
This engine needs its own thread... also!

FTE's homepage:

This thread is for the discussion of using FTE's enhanced features, and/or drawbacks, for Quake level design/modding and/or gaming in general.

First | Previous | Next | Last
One More AD Problem 
hi spike, i tested forgotten sepulcher more and there is another problem. particles works fine, even after LOAD/SAVE but something else gets broken. gameplay is really choppy after LOAD, however that can be fixed by applying vid_restart

what is more complicated is that already broken breakables re-appears as invisible walls that can not be broken again. i can shoot them, i see impact particles, they bounce grenades and i can shoot them indefinitely but they will not break again.

any idea?

Version Info 
i use win64 client version 5259 
R_glsl_offsetmapping_lod In FTE? 
Spike, I want to try to get up my lazy butt and address your replies later, but in the meantime, I noticed that FTE doesn't have the command r_glsl_offsetmapping_lod and r_glsl_offsetmapping_lod_distance, like DP does. I noticed that it improves performance with bumpmapped textures hugely (especially in large areas) without noticeably lowering visual quality. Any chance of it being implemented in FTE, yes? :3c 
FTE/Afterquake Spotlights In Realtime Rendering 

when I'm trying to use spotlights (both using target or mangle) it seems that this information is ignored in realtime rendering mode for the lights as I get surfaces lit which actually lie outside the desired cone. Static lighting looks correct though - am I missing some option? 
rtlight importing doesn't support all features from maps.
spotlights have been implemented for a while (and sometimes even working), buts its only recently that they've actually been importing from maps - you'd need an svn build for it to work. 
FTE/Afterquake Spotlights In Realtime Rendering 
Ah ok, then I'll probably have to wait a bit longer, thanks! 
Is it fair to say anything that DP can do so can FTE? Put another way, Would it be appropriate to say FTE is a suitable replacement? 
not 'anything', just 'anything that matters' imho.

That said, fte favours more vanilla-type compat than for dp, so don't expect dp-only mods/content to work as-is without obscure cvar tweaks.
cvar reconfiguration sucks. :( 
Good To Know 
For this progs_dump project I am seeing a potentially game breaking bug only in DP and want to direct people to try FTE instead.

I'll address it later (I will need help ofc) but in the meantime, I will steer people to FTE as an alternative to DP for this release.

I think most of my target audience for the mod will be in the QS or QSS world. 
I would think that's a safe bet. FTE is active as well as QS, but with more feature readily available if needed.
Nothing against QS or any other engine, for that matter, people can use what they need. and knowing what is available for their needs only make our world that much better.

Silly Question 
So when using FTEQCCGui and FTEQW how can I force my current config file (the FTE default in My Games) to run? I'm not sure how to configure this when it runs from FTEQCC. The mod I am creating already has a config. 
go into the options dialog, make sure there's no -nohome in the arguments box (those 3 unlabeled text fields are: exe, working directory, and arguments). click save and it should remember those settings next time you run fteqccgui. 
Okay changed that. Getting somewhere but will not accept any changes/saving options in the engine after I launch with F5. I am using fteqw64.exe

Defaults to 640x480 full-screen even if I change and save. As a test I changed my playername and pants/short colors. It did not save either.

When I go to Documents/My Games there's no sub-folder for the mod I am working on. And yes, the mod is loading properly from the -game switch. I am baffled. Shouldn't there at least be a sub folder in My Games? I have a shortcut to the mod directory and my settings are correct when I use that.

One last thing: I have multiple versions of FTE in different folders on my pc. 
Re: -nohome 
I hated this in DP and I hate as well in FTE!

Maybe someone can explain the benefit that actually justifies this behavior, for Quake?

Since it's opt-out, without being clearly obvious no less, instead of opt-in... it's very easy to not understand what is going on with game settings and config files.

Example, after screwing up settings once in FTE and making the game look like trash I just deleted the whole folder and started over as that's the typical way it works. BUT... since I didn't know about this "home" directory shiz at the time... my fresh new game looked exactly the same. This was frustrating.

Having to instantly create shortcut's, or needing to know about adding -nohome into a game launcher(SQL1/2) without any prior knowledge of such Quake config file saving behavior is just a bad decision.

Again, what am I missing? 
Mixed Feelings 
I agree somewhat with damage_inc on this. Perhaps Opt-out by default but write and use fte.cfg instead of config.cfg. Would that work? 
Quake was originally developed for MS-DOS, which wasn't a multi-user OS. MS-DOS evolved into various versions of Windows 3.x, Windows 95, 98, 98 SE and ME, at which time that line was killed.

None of them were multi-user OSs, none of them had security, and this stuff just worked.

Windows NT was developed from the ground up as a new OS and new kernel (that just happened to share some common shell and UI elements with the other Windows). From the very first it was a multi-user OS with proper security, admin/user separation, etc.

Windows NT evolved into Windows 2000, XP, Vista, 7, 8, 8.1 and 10.

The benefits of placing per-user content in user profile directories are:

- These are the only directories that non-Admin users are guaranteed to be able to write to.

- If more than one person uses the PC then your saves and cfgs won't mess up somebody else's, and vice-versa.

So, try playing a stock install of Quake on a PC with more than one user, and logged on as a non-Admin user, and see how far you get. 
There are a big amount of users in different Quake forums reporting difficulties with the fact that configs are stored in a VERY different location.
But we NEVER heard difficulties from people with non-Admin issues or multiple users config issues.

For a simple Quake engine? This modern-OS behaviour is way over the top. It only produces trouble and frustration. And in the end... like many affected users did, they change the engine to a better one without this modern-OS behaviour. --> Like all the other Quake engines have.

Other engines never produce trouble like this. They all work as expected and intended.

The honorable intention to implement modern-OS features into a Quake engine ends up useless and even counterproductive in reality.

So, take a minute and think about it. ;) 
yeah, it sucks. I hate it and always use -nohome myself.

that said, using homedirs is the safe option, even if its not the preferable option.
and its NOT nonsense, there are various installers for quakeworld mods that install into "c:/program files/", which then screws everything up when users try other engines in the same dir. maybe not for the nq community, but it IS a problem for the qw community.
its also very common on linux, too, what with debian/ubuntu's quake package requiring it and all.

windows also has a tendancy to lie about whether access is possible and to then write the files somewhere else that's even harder for the user to find, this makes it really messy to try to autodetect whether homedirs are needed or not.

side note: the afterquake thingie expects the user to unzip and add in some paks, and contains a file to explicitly instruct the engine to disables homedirs (because it doesn't expect to have to fight other installers).

winnt actually predates win95, and unix has always been a multi-user system. this is NOT modern-OS stuff. 
Is FTE networking P2P? Does it have NAT punchthrough? 
yes, but only via the xmpp plugin (the method requires a third-party server to relay messages through in order to establish a connection), and that requires accounts and passwords and urgh, so none bothers with it.

the web port can use an existing/3rdparty fte server as a broker for webrtc (but it needs that 3rdparty server to be configured with eg `sv_port_tcp 27500;net_enable_webrtcbroker 1`). You can then host with `sv_port_rtc rtc://brokerip:27500/mygamename` and connect to that server with the same uri.
I keep meaning to implement something equivelent with the desktop ports, but I can never get around to it. 
Found This On Twitter 
Splitscreen Sound 
By default, the game sound only plays for the left screen (first player). Is there a way to enable sounds for all other screens, too? 
Splitscreen Sound 
switch the audio device away from openal(the default) to any of the other audio drivers (like dsound/wasapi/alsa/sdl), typically via the menu.

openal does its own mixing and only supports a single 'listener', whereas fte's own mixer is smart enough to select the nearest player as the appropriate listener on a per-sound basis. 
That does the trick, thanks. 
Muzzle Flash *issue 
Is it a non-avoidable side effect that whenever I enable r_waterstyle > 1 that I basically lose the weapons muzzle flash?

I state it as "basically" because sometimes I do get the the muzzle flash effect but I can't determine exactly why. And it's sporadic.

Sorry that I don't know the name of the actual cvar, its just the flash when you fire the weapons, explosions etc. 
Broken Coop? 
Hi, I tried to get coop to work with the 5361 Afterquake package and it seems that the server is either not running or it actually starts in single player mode. Deathmatch works fine. Am I doing something wrong, or is there a trick to get it running with some cvars? It worked with a previous version (although I couldn't figure out back then which variable would have set no friendly fire - maybe it was just deathmatch which used my coop player starts?). 
works for me...

make sure you've not somehow messed up any cvars - these are the ones that come to mind:
deathmatch 0 //boo hiss
coop 1 //hurrah! friendly mode
maxclients 8 //quakeworld engines limit clients and spectators separately, which is a little messy.
sv_playerslots "" //auto - 32 when deathmatch||coop, otherwise 1. max of 255.
samelevel 0
sv_progs progs //force preference for NQ gamecode over QW gamecode - QW mods tend to have no coop, in case you have a qwprogs.dat from other sources.

really, the only difference between coop and deathmatch as far as the engine is concerned is that coop is set instead of the deathmatch cvar.

to disable friendly fire, not only do you need teamplay set, but you also need the players to use the same lower colour (in nq). 
I set the values with the console and it worked; maybe the menu command didn't reset everything that was required correctly. 
Pants, he means same color pants so you don't hurt each other. 
FTEqw64 version 5361 isn't compatible with Arcane Dimensions?

I'm asking this because i can't load a savegame when i'm using this mod.

When i press F9 or even loading a savefile from the menu, the engine crashes to the desktop and show me this error message: "Bad Entity Lump: 'Particle' not recognised (last ent was 894)"

Even with "sv_savefmt 0" the engine crashes when i press F9.

I also tried the "savegame_legacy" command, but the console says "Error: hidden name (.sav) Unable to use legacy save format"

help :( 
Is there a way to change console sliding speed to be instant...curious if you can instantly hide the console on map start? 
scr_conspeed 2000(def) increase it until it's near instant. 
Anyone knows if FTE has god-rays auto-generated from the sky?

I remember, a while ago, testing this... i just wrote something in the console and BANG... god-rays from the sky...

but i can't remember the command or even if i was using FTE engine or something else :( 
r_sun_colour ( R G B )

Load up start map and try .4 .4 .4 
Thank you very much =D 
Is there any way to make snow or rain in Hexen2 maps with FTE? 
I could be wrong on this but I'd imagine it's no different than for Quake. Since the particles/configs configuration is engine based and not game based.

So the discussion we had recently about Qmasters 2018_xmas map most likely would apply for Hexen2.

But this time I didn't test it so... ymmv! 
But... to make rain or snow in quake i have to open the map with MarkV, use "tool_texturepointer" to find out the sky's texture name, use "copy ents" to make the ent file, and finally edit the ent file with the sky's name calling the weather effect...

How can i do all of that if MarkV doesn't open hexen2 maps? :/ 
Are you trying this for stock H2 maps? 

here is what i already tried:
i opened the bsp with quark to know the sky name from the first map and i opened the bsp with notepad++ and copied all the ents to make a ent file (i saw someone talking about this in QuakeOne forums) but even with an ent file calling the rain it doesn't work

but the good news is: the second map came with an ent file (i think it's from an update) i edited it and it worked! Now i have rain in there \o/

in other news... it seems the command line "r_sun_colour (R G B)" to make godrays doesn't change anything in hexen2 :/ 
FYI: from he console in FTE "sv_saveentfile"

Will be located in "[.../YourGameDir]/fteh2/maps/"

I used TexMex to open the .BSP to find the sky's name. I didn't get the snow/rain to work on a map load though... I have to exec the .cfg from the console to get it to start! 

Your method will save me a lot of time =D 
Now I see whyyy I didn't have particles on map load, because I didn't have it ENABLED in the particles menu :faceplam: 
With your method i was capable of make rain in the first map. Thank you! =D

One thing i noticed... when you are at the courtyard (player-starting-point) and you look down, the rain stops... when you look straigh or higher (or right down to the floor), the rain starts again :P

This bug doesn't happen in Quake

anyway, i'm happy to see the fte_weather working in Hexen2 :) 
Hi, there!

I'm trying to play FTE with effectinfo (quakespasm-spiked custom particles)... all particles are working fine, except for the blood particles when you hit an enemy. I can see blood particles falling from gibs, but not when i hit an enemy...

anyone has any idea how can i fix this? 
r_particledesc "high effectinfo"
or something. or classic instead of high.
(there's some naming differences that prevents the blood particles from loading) 

"r_particledesc classic effectinfo" is perfect =D 
FTE QW Single Player Is Broken. 
I cannot start a single player game with this client. The paths are all correct in the menu. I have everything where it should be and when i go to play a single player game nothing happens when I try. It doesn't load Quake at all. Whats funny is if i download anything with the quake injector I can play the mods fine. Any help with this weird issue would be appreciated. 
QSS has the same problem. Trying to start a single player game from the main menu does nothing. 
maybe -nohome can help 
I was having issues with singleplayer in the latest build of FTE. Often freezing on level load/change, and sometimes nothing happening on selecting new singleplayer game.

On a suggestion from Spike in the discord I set sv_nqplayerphysics 1 before trying to load a singleplayer map. That fixed the map load freeze. I haven't tried the "new game" selection yet to see whether that is still flaky.

You might or might not already have sv_nqplayerphysics set to 1. I think it is by default, but in the setup you get from the AfterQuake package it appears to be 0. Anyway, if it's 0 for you currently, try setting it to 1. 
Thanks for the responses. Neither command fixed the issue with selecting single player. I added -nohome in a bat file and I also entered the sv_nqplayerphysics 1 in the console. Nothing. What's funny is that in 5399 everything worked fine. The last two updates broke the new game selection for single player. :/ Oh well hopefully the fte qw team is aware of the issue. 
It's A Single Executable 
Why not just go back to 5399? 
Because I deleted it. Can't find it anywhere and the fte qw site doesn't keep old versions on their page. 
BTW, sv_nqplayerphysics doesn't seem to be the panacea for me after all. Weird edge friction going on. If my player model is overhanging a ledge and I tap the walk button once in a direction pointing along the edge, often the player will "grind the rail" all the way along the edge. 
hopefully some of these things are fixed in revision 5424 
Single player fixed with 5424. :) Thanks. Tilding then tapping map e1m1 (or whatever start map) was a little annoying. 
Yah all issues I mentioned above are gone in 5424. :thumbsup: 
RT Lights Are Point Entity Only Yes? 
Without resorting to Q3BSP+Q3map2, is it possible to have in Q1, a texture emit RT Lighting? Using scripts/shaders? 
First | Previous | Next | Last
Post A Reply:
Website copyright © 2002-2019 John Fitzgibbons. All posts are copyright their respective authors.