News | Forum | People | FAQ | Links | Search | Register | Log in
Copper Quake / Underdark Overbright (UPDATED)
A dual release for Quake's anniversary this weekend:

1. >> Copper Quake, a "Vanilla+" mod that polishes and refines Quake's singleplayer gameplay. It grinds off the roughest edges we've all just gotten used to over the last two decades without moving away from what Quake is at heart, and expands opportunity for high-level play. For example: Nightmare difficulty is an actual playable mode!

Read all the detail about it you desire, and download it, from the Copper site:

2. >> A 7+2 map episode to go with it called Underdark Overbright. It's like czg, sock, and headshot had a sexy baby, featuring guest mapper Scampie!

Download it too:
or ogle screenshots:

UPDATE July 16: new version 1.05 is now available, follow the links above.
First | Previous | Next | Last
Link Is Working Now 
Thx for the Update! 
Cool. Looking forward to an id1 nightmare playthrough! 
Wouldn't it make more sense if a fiend were to kill the player by landing directly on their head?
While not fun,it could be useful.....maybe for a horror mod.Maybe. 
Ijazz - Fiend Head Land Bug 
It's clearly a bug in the code though. It happens so rarely that it's not something the player can get used to or anticipate when it happens either, so you just get "what the fuck, why did i die?" instead of "darn it, I failed to dodge the fiend's well-communicated special insta-death attack again that's totally different to his usual jump attack". 
huh....time to mess around with qc and ef_glows 
The teleporter secret in e3m5 does not seem to work with this new version (1.05). I tried with the version quake injector downloads and vanilla witch both worked. I launched the game (1.05) with a new shortcut with -game copper and the problem persisted. 
@A_COC0NUT: I'm not sure why e3m5 is giving you trouble -- if I play e3m5 with Copper 1.05, all secrets work as expected. I'm testing with QuakeSpasm 0.93.1.

If you could give a bit more info, I might be able to help diagnose. My first questions would be:

* Which engine are you playing with (and what version number)?

* e3m5 has two secrets with teleporters: the first secret, which is in the hallway with the flashing lights, and the last secret, which is in the room with the exit portal. Which one isn't working for you?

* When you say the teleporter secret doesn't seem to work, do you mean that the teleporter is failing to teleport the player, or something else? 
sorry I was a bit too vague. It is the first secret in the flashing hall. The teleporter in the secret does not trigger. I am using VKQuake 1.01. Thanks for any help. 
@A_COC0NUT: this is just a guess, but are you by any chance loading a saved game on e3m5?

If so, could you try letting QuakeGuy die, so that the level restarts, and see if the teleporter works after that? 
Thanks. I feel like an ass now since that is such an obvious thing to try in the troubleshooting process. It works now. 
There's no reason to feel like an ass; you've raised an important point, which wasn't obvious, and which might affect other people, too.

The underlying issue seems to be that Copper v1.05 is not backwards-compatible with saved games from Copper v1.00.

Based on your description, my hunch was that you had saved your game with Copper v1.00, then installed v1.05, then loaded the saved game. If I do this, I can recreate the problem you described in e3m5.

Unfortunately, because v1.05 makes a number of behind-the-scenes changes to the code, if a v1.00 save is loaded, some things (like teleporters, evidently) will go out of sync. I expect this would affect saves for any map.

The reason I suggested dying and restarting the level is that that will refresh the state of everything in the current level, which will likely fix issues in most cases (though it may not fix all issues in all cases).

I should emphasize that the lack of save-game compatibility is not a mistake on Lunaran's part. Because of the way Quake save-games work, it's practically impossible to make significant changes to a mod without breaking save-game compatibility. And there were some significant changes in Copper's code between v1.00 and v1.05.

However, I think the fact that v1.05 is not backwards-compatible with v1.00 save-games is not documented anywhere at present?

Lunaran, would it be worth pointing this out to players, if only as a note on the download page or something? 
Yeah, that's a good point. Demos probably aren't compatible either. I've updated the downloads page to mention this.

Regarding Fiends on heads: one of the reasons the land-on-head kill seems like a bug is that it's framerate dependent. Damage happened every frame a touch was called for, which meant more instant death when the engine can call those touches more frequently.

It's worth noting that Fiends (or other leaping melees) landing on your head is still very dangerous. If you don't dodge in time and you do wind up in a stacked bounding box situation, the damage still happens every 200ms, which in a Fiend's case is ~240dps (as opposed to every 14ms, for a ridiculous ~3200dps). That's still pretty scary, but a fraction of a second is actually a decent reaction window in Quake - enough time to get out from under the thing before your situation gets too bad.

It's so rare, though, nor is it really obvious why bounding boxes that touch in two different planes should cause such drastically different outcomes. 
Gro├čartige Episode 
In the last 2 weeks I've played the episode through once. Here is the result of my efforts! That's a complete 100% through run. Right now I'm playing the end level, which you have to load separately.

Copper Quake - Underdark Overbright - Trapped in the Past - [100%]

Copper Quake - Underdark Overbright - Space Jam - [100%]

Copper Quake - Underdark Overbright - House of Pain - [100%]

Copper Quake - Underdark Overbright - Pit of the Living Dead - [100%]

Copper Quake - Underdark Overbright - A Saint Nobody Has Heard Of - [100%]

Copper Quake - Underdark Overbright - Last Waltz - [100%]

Copper Quake - Underdark Overbright - How Deep Is Your Lava - [100%]

Copper Quake - Underdark Overbright - A Drowning - [100%] 
hey those links don't work, it just redirects to "my videos" 
Sorry About The Wrong Links. 
Copper Quake - Underdark Overbright - Trapped in the Past - [100%]

Copper Quake - Underdark Overbright - Space Jam - [100%]

Copper Quake - Underdark Overbright - House of Pain - [100%]

Copper Quake - Underdark Overbright - Pit of the Living Dead - [100%]

Copper Quake - Underdark Overbright - A Saint Nobody Has Heard Of - [100%]

Copper Quake - Underdark Overbright - Last Waltz - [100%]

Copper Quake - Underdark Overbright - How Deep Is Your Lava - [100%]

Copper Quake - Underdark Overbright - A Drowning - [100%] 
That shambler model is so ugly I barely recognized it. 
Holy Fuck. 
That is not only comically ugly looking, but also broken less than a minute in - that Nailgun in map 1 is supposed to be a ramp jump!!! 
Graphical upgrade mods don't get a lot of love around here (although I understand why) but thank you for sharing! 
Pretty Sure This Hasn't Been Posted Here Yet 
Just loaded up the mod for the first time, I'm very excited to try it out. I noticed that the jump sound is truncated when jumping in shallow water, like in the start map of udob. It seems to be linked to water depth, as the sound lasts longer when jumping from slightly deeper water. I guess it stops playing when the player model completely leaves the water brush?

Also loaded up E1M1 with Copper and got the same bug. 
Underdark Overbright
Scale 1-5, Higher is better.
Finished: 2019.10.25
- [x] start 4
- [x] udob1 4
- [x] udob2 4
- [x] udob7 4
- [x] udob3 4
- [x] udob4 4
- [x] udob5 4
- [x] udob6 4
- [x] end 5

Verdict: 5/5 for very high quality across all levels, which is unprecedented. A must play. 
Stuck On End Map 
I can't figure out how to get up on the ledge above the water in the beginning of the End map. The lava looking teleporter doesn't do anything. Is this a bug? 
Since this thread got bump up let me ask a question for Madfox. In the Chasm mod, When a new chasm monster attacks an enforcer, the enforcer will turn around and run towards the attacking monster, but never firing back. I know that the copper mod makes extensive changes to infighting, so I am curious to see how infighting works and what could be causing the enforcer issue? Perhaps Lunaran can shed some light? 
RE: Stuck On End Map 
I figured out what was causing the weird bugs with the lights near the easter egg area and the teleball_spawn on the End map.

My unzip program was set to unzip UDOB without the full paths, so it was putting all the files in the same folder instead of their subfolders. I did a fresh install of Copper and UDOB and got things to work.

There is also a setting to make sure extracted files have a containing folder and that should be turned off. Otherwise, it will create a UDOB folder inside Copper, which will also cause a problem. 
Use 7Zip 
7 Zip 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.