News | Forum | People | FAQ | Links | Search | Register | Log in
The NetRadiant Level Editor
NetRadiant-custom is continuation of NetRadiant, based on GTKRadiant, which supports numerous games, with some emphasis on Quake.

win32 build
win64 build

Simple install instructions are included in q1pack\q1pack.txt
First | Previous | Next | Last
That new NetRadiant is a pro-click btw, for anyone still stuck on the 2012 version. Fixes loads of stuff and runs a lot better! (the 2012 version hogged my cpu when flying around in the 3d view for some reason) 
Not Sure This Thread Is Necessary 
Also somewhat misleading since this is actually about the recently modified "custom" version which is a fork of the original Netradiant. The later seems to have gotten at least a little attention by Ingar up to 2015.

Having said that, this new version does look nice and has the floating windows layout working/fixed - something which the other developers/maintainers seem to have been incapable of doing.

How does one bring back the classic (shift+drag type) selection box? 
I Use Ingar's Version 
Gonna give this a shot. 
Yeah really digging the new bits here and there in this version. Problem is, to find out what's new, you have to read through an eleven page thread. 
you can read the changes in changelog-custom, new mouse shortcuts are documented too. 
One thing I really like in Netradiant is the ability to just click in the 3D window and move around in the map as if in Quake using noclip. I can use the mouse and arrow keys exactly the same way as I do in game. I hope that hasn't been changed. 
you can read the changes in changelog-custom

Lol, oh right :} Chalk me up as another one of those fellas who always misses the readme file...

Rick: 3D window movements are the same as before, and for me it runs silky smooth now (before it was a bit chuggy for some reason). Only crit is that the FOV is locked to 110 (before it was 90), but I have requested the FOV to be exposed in preferences in the q3df thread (my username is SlugWobblerBumbleChops). 
Does This 
have a Mac version? 
Pro Tip 
About where the custom settings are stored, because bugger me it took me a while to figure this out.

If you create a subdirectory called "settings" in your NetRadiant install, the install becomes "portable", that means it'll write its settings there. If you don't do this, it will write its settings in some bullshit random directory like C:/Users/ben/AppData/Roaming/....blah blah blah....

E.g. on my pc, my "portable" settings folder would be:

Now I *think* the new NetRadiant comes with a portable settings folder by default. Old NetRadiants certainly did not though. Check yours to make sure! 
Anyone by chance registered at the q3df forum?

Three things about the Custom Radiant: it crashes if the mouse is locked in camera freelook mode when the camera window/Radiant is moved to the background by some other program taking priority on screen. Floating window layout, but probably occurs with the other modes, too.

There's still (or again?) that feature from 1.5 that adds numbers to the target/targetnames of copied/cloned entities. Always hated that as it does more harm than good. Used to be removed in NetRadiant. I wish it was disabled or at least had a field to customize it where you can choose whether to have it append numbers, letters, any kind of string, or leave the field empty to keep the original names.

When rotating entities with the 90� buttons, it adds 0.000003 instead of "0". 
How do i reproduce that crash exactly?
Was there 'freezepointer: can't freeze' assertion?
There is focusout handler, that disables freelook, once app is focused out and it works well in all 1.5 branch radiants.
XYwnds have that handler too, but one never worked in nonfloating layout, untill i accidentally fixed that by adding some focus-in events -) (in 9.11 release)
Texbro has no such handler atm, thus it's possible to alt+tab, while tracking (m2), and still keep tracking, once switched back; though is unlikely to get crash here, since tracking is done in widget's center

2.Need some more extended data on this, since i can get both types of behavior in all 1.5 branch radiants
What do you do, in what version used to be removed...

3.Is not real problem. Might think of adding some rounding to int later (for gloss) 
I haven't found a reliable way to reproduce the error, yet (although it did occur several times since). Radiant.log doesn't show anything, and there's no error message by Radiant, either (only the standard Windows thing "The application has stopped working").
What sometimes seemed to trigger it is switching to the MP3 player (VLC in this case) with alt+tab or win+tab while mouselook mode is active. Upon switching back, the camera window is behind the 2d and entities windows and mouselook is still active for a brief moment before the error. At other times, it works.

I'll report back here if I have more information.

Target/targetnames: afaik the name change upon copying/cloning entities were introduced in Gtkradiant 1.5 and it was removed in Netradiant (Yngar branch).
I like to keep track of the entity linking myself and adjust it accordingly. When making single player maps, often multiple entities are targeted at once, all with the same targetname; or, when scipting entities, e.g. a chain of triggers or waypoints, it's really annoying if the editor constantly screws up the numbers.

Some other things:

There's an error when using doubleclick on a texture in the texture window:
assertion failure: pointer "archive" is null

Obviously standard Q1 editing, so there are directories or shader lists.

When zooming in and out repeatedly with alt+mouse2, the focal point changes. It doesn't stay at where the mouse arrow was when starting the action.

Dragging the horizontal borders in the entities window, the ones between the entity list/description/keys, is wonky. They appear to be somewhat linked and can't be moved independent of one another in order to enlarge a section without affecting the other.

File menus (open, save, ...) and preferences should be always on top until closed - currently, they can get behind the other windows.

Three ideas: when using ctrl+mouse1 clipper, it would be nice if the clipping could also be executed with mouse3. This way, one could do fast clippings without having to lift the hand off the mouse to reach the enter key.

I noticed that the outer grid coordinates in the 2D window are gone. Can't think of the correct word right now - you know, where it says 0...1024...2048... on the sides. I found them useful, especially since Q1 has restrictions when it comes to map boundaries.

Would it be possible to allow the editor to accept multiple entity types with the same classname in the def file? For example, "trigger_multiple" as both brush and point entity coexisting at the same time. In the other versions of Radiant, there could be only one; the other type would disappear from 2D/3D view.

By the way, I really appreciate your work on this. I had already given up hope of ever seeing useful development on a Radiant-type editor again. Many nice additions/changes on top of Win10 support. Good job! 
Standard Q1 editing, so there are *no* directories or shaders. Only texture wads. 
Windows Error Log 

Stopped working

10/15/2016 11:44 AM

Report sent

Faulting Application Path: D:\Netradiant-custom\radiant.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: radiant.exe
Application Version:
Application Timestamp: 57d5aedb
Fault Module Name: libgtk-win32-2.0-0.dll
Fault Module Version:
Fault Module Timestamp: 5691a1e1
Exception Code: c0000005
Exception Offset: 001e50c2
OS Version: 10.0.14393.
Locale ID: 1033
Additional Information 1: 2beb
Additional Information 2: 2beba6fb4680d73a8c78ca7c24ccdb46
Additional Information 3: 34b8
Additional Information 4: 34b85e01dbe9529312a819250a584bb2

Extra information about the problem
Bucket ID: 66f1dc540daf84cedf9a668c638cfbfd (108433453934)
>>mouselook is still active for a brief moment before the error
Is not healthy, must autoquit freelook on unfocusing
Idk what to start with... best errors are reproducible ones, so you can trigger them, while running in debugger, and see, what exactly happens
Exception Code: c0000005 is very common case, access violation
May be it's not random (can be actually) and is related to some circumstances?
For instance, i'v recently spotted crash on releasing m2 in texbro w/o pressing one b4

Target/targetnames: it is option in 1.4/1.6: prefs-editing-fix target/targetname collisions; def = yes
Is not optional in 1.5/net (always yes)
It only fixes collisions .) Doesn't on clone though. Does on clone-make-unique, on copy/paste.

Ingar's quote: I did not write GtkRadiant or NetRadiant. While I do commit patches, I mostly download the source code, build executables and add documentation and game packs. My goal is to provide a package that is easy to install for anyone who might need it.

>>There's an error when using doubleclick on a texture in the texture window
Is fixed in wip version

>>When zooming in and out repeatedly with alt+mouse2, the focal point changes.
That is bc 'zoom in to mouse pointer' option is on + zoom out does it from center, not pointer
Might do zooming out from pointer too, though i see the only reason to do so (named by you); would be more consistent in general; On the other hand such kind of zooming out doesn't feel natural + it is hard to understand, how to get wanted specific effect, while using one (or it's just me-)

>>Dragging the horizontal borders in the entities window, the ones between the entity list/description/keys, is wonky. They appear to be somewhat linked and can't be moved independent of one another in order to enlarge a section without affecting the other.
Well, those aren't some abstract splits; Those are container widgets, splitting area in two
So, wnd is split in two areas by central one + both resulting areas are split too
It's made linked on purpose, so that all areas were scaling consistently along with containing window (for free)
It is possible to make artificial handler for scaling + make splits unlinked, but that would require quite some investigation + might be risky
For instance, 4 views layout was broken due to using such handler
You can adjust splits just fine now, once start doing that from central one
I like, how it behaves now btw, sorta rubber thing -)

>>File menus (open, save, ...) and preferences should be always on top until closed - currently, they can get behind the other windows.
That appears to be general gtk architecture flaw; Basically it has setting to keep some wnd on top of the other wnd
So all floating wnds are set to be on top of main wnd (and it works almost fine in non floating layouts :p)
I havent been able to google any solution for this... would need something like 'set transient for group of wnds' setting (there is no one, afaik)
Perhaps, can invent some dirty hacks to achieve this; though floating layout isn't the most developed one; luckily it works at least, h3h3
I'v tried really big gtk apps: gimp and inkscape; both have named issue (even though gtk stands for Gimp ToolKit-)

>>it would be nice if the clipping could also be executed with mouse3
M3 would be quite out-of-structure and very specific one tbh (and breaking cam control)
Ic that double click can be used there (since no action, when you click existing point)
Atm you can use right ctrl and enter for efficiency :)

>>I noticed that the outer grid coordinates in the 2D window are gone.
Defaulted 'off', bc aren't too useful for most of games (paint sizing info does the job just fine)

>>Would it be possible to allow the editor to accept multiple entity types with the same classname in the def file?
That is quite a LOT of things to rewrite :X (not sure, if i can handle that even)
In 1.5 branch you can obtain group entities w/o contained primitives
No many ways to do that left in my branch (atm can do via removing whole brush with clipper and then can control via origin key) + there is recent fix to not to save such ones, bc it is a buggy behavior in general: q3, for instance, refuses to load bsps, containing group ents w/o submodel.
What is this behavior needed for? (something like triggers, defined via min/max?) What editors support that? 
- We'll see if I can properly reproduce the error at some point. The only circumstance I'm currently aware of is switching haphazardly between applications.

- Yes, not Ingar; Divverent is the one I meant. I was under the impression it was disabled completely there, not just for cloning. At any rate, it's an improvement over 1.5.

- Multiple types: in Quake (1) certain entities can exist as both point and group entities, for example triggers that have a big touchable volume or triggers that touch only at a single point. Sometimes it's preferable to have them point entities for scripted sequences or to optimize a map towards engine limits. Another example is map hacks where it's also possible to use info_notnull to create custom items/monsters (point) or brush-based things like trigger volumes/doors (group).

Is it intentional behavior that in camera mouselook mode shift+mouse2 selects brushes or entities? I lost quite a few intricate selections by accident because of that... 
- an improvement over 1.5.
Indeed, just rechecked 1.5's behavior; was sure, that it had ability to preserve names. Is quite inconvenient to have no one -)

- Multiple types: atm entity system in radiant is name based, i.e. specific classname must have unique name.
Ic some thirdparty solution
using different classnames for special entities
then batch compilation like:
sed -e 's/oldstuff/newstuff/g' inputFileName > outputFileName
compile outputFileName

- shift+mouse2 = tunnel objects selector in all modes
Were you trying to quit freelook with shift+m2? :-) 
Just selecting multiple brushes, then trying to move the view in order to select some more, but too slow at releasing shift before pressing m2... 
The more power you have, the more control you need -)
Though condition for shift+m2 click/drag selectors is releasing m2, while shift is down.
(+exactly zero move for click and quite big one for drag) 


* ctrl + shift + v: MoveToCamera (translate selection to camera origin)
* m2 in entities creation menu: change classname; ctrl + m2: change classname, don't close menu
* ctrl + m1 in entities creation menu: create entity, don't close menu (+offset every next entity by 8u or gridsize, if > 8)
* m1x2 on clipper point = do clip


* Shortcuts item moved from Help to Edit
* misc->colors->opengl font selector


* do not delete selected on entities creation, just deselect
* ExpandSelectionToEntities: do not select invisible nodes
* fix: snap translation amount on paste/move to camera commands instead of stuff's origin (to keep one with size (2*N + 1)*gridSize on grid)
* MapName build system variable (can use to make build menu entry to run map in a game)
* build->customize: list available build variables
* texture browser: gtk search in directories and tags trees
* fix: build menu->customize Cancel button cancels (was reloading menu from disk)
* build menu->customize Reset button (= reload menu from disk = editor start state)
* fix: laggy selectors, manipulators in mlook mode
* scale free->snapped mode: constrain to two axes, most perpendicular to view direction (i.e. works for two axes in 3d too)
* scale free->snapped mode: use min move delta for scale (was max = hard to scale down); fix ZY projection case
* fix: pointfile was considered as shown, when trying to load missing one
* entity inspector->EntityProperties treeview: Tab keypress = focus Key field
* 2x2 layout: allow gtk to handle separators positions; fixes: unmaximize wnd, maximize = horizontal separators > center
fixes: unmaximize wnd = not updated views glwidget positions on some systems
* fix: paint selector, selecting occluded faces
* camera->field of view option
* wider Texture Gamma preference range
* wad games->texbro treeview: do not group names, using underscore; fixes crash on loading parent; fixes mess if path contains underscore
* fix: do not quit freelook on autosaving
* entity creation menu has ability to be 'tearoff'
* wad games: fix TextureBrowser_ShowDirectory crash on loading common dir (can cfg to load .wad), on loading containing dir (do nothing)
* wad games: fix crash on selecting a shader (not a plain texture) in tex bro
* wad games: more reliable filterbar texturing defaults
* shader for 'caulk new brushes' and 'clipper uses caulk' options is optional via 'shader_caulk' option in .game
* fix: q1 mdl reader out of bounds reading crash
* fix: q1 mdl loading of MDL_FRAME_GROUP case
* fix: rightclick main wnd border, release in texbro glwidget == crash (unfreezepointer)
* texbro: search in currently shown textures
* ask for saving nonsaved map on project settings change
* func_detail to nongame group ents counter
* deiconify main wnd, unmaximize maximized view on app closing to save correct layout data
* close preferences dialog on ESC
* Enter = Ok in global and path settings dialogs
* print renderer stats in XY views too
* global 'show renderer stats' option, def = off
* ~10x faster opengl text rendering
* calculate farplane from g_MaxWorldCoord, g_MinWorldCoord (was const 32768)
* 1.0f nearplane
* numerous code fixes
* texbro search: SearchFromStart option (match start of texture name)
* texbro search: entry is activated/deactivated by mouse pointing
* texbro search: clear button
* renewed q1 gamepack ( by w_w )

Some questionable idea is to remember last action of clipper (clip or split) and use it while triggering action via m1x2 (can confuse...)

Q1 default build menu is open for suggestions: want same simple structure (3 singles, rough test, final)
want bounce for final, may be something else

Question: are filterbar texturing bindings fine in q1 mode? (i'm not experienced in q1 common textures usage) 
forgot .[ExecutableType] in build menu :3
Reuploaded the file 
The Q1 gamepack is somewhat problematic, though (and I accidentally overwrote my own :P). In my view, the way Radiant handles models is impractical for editing, because it displays either the model (if set in the entities def file) or the bounding box. Having only the model can make proper placement awkward. It would be better if the outline of the box was shown around the model as well. As it stands, I deleted all "model" paths again.
Additionally, in Q1 the ammo models are BSP files, so they don't show up in the editor at all. The md3 files referenced in the new gamepack are not included apparently, and furthermore the bounding boxes set in the def file are wrong (all Q1 items are 32*32*56 regardless of their physical size). This can cause items to fall out of the level if placed partially inside geometry by accident.

Q1 build menu: I don't use that personally. If anything, it maybe should have "qbsp only", "quick compile" (qbsp, light, vis -fast) and "final compike" (qbsp, light -extra, vis -level 4) default options, but even these can vary depending on which compilers are used. For instance, current tools all support light -extra4 for smoother lightmaps, but older tools do not.

Filterbar: They don't seem to do much at all. The only special textures used in Q1 are: "trigger", "clip" and "skip" (no variations like weapclip etc). Some new compilers also have rudimentary support for "hint". Liquids are determined by an asterik in texture name, e.g. *water. A few new source ports allow alpha textures, but I think the naming standards differ - like textures beginning with a }, I think. Someone else please clarify.
There are no internal detail brushes or brush flags in general - the only way to achieve this in Q1 is to turn geometry into "func_detail" entities which newer compilers then convert back to structural brushes without generating vis portals for them. 
Having bbox, represented by lines, is one of wished features, it helps, while placing, for sure; though, i'v been told, that entities with models appear ingame exactly, as seen in editor.
There is visual representation of entity origin atm; it is possible to use it for placing, but need to offset halve bbox size in mind -)

md3 models are included (and more things); try q1pack dir, q1pack.txt

Filterbar: it is reconfigured in supplied, would like to know, if fine or not. 
The q1pack included is basically for ease of use. The filterbar enables filtering (m1 click) and texturing (m2 click) for clip, skip etc.
Also added a scripts folder to go in id1 which allows transparent textures/filtering in editor. You can add any texture to the shader for trans - useful for *water n stuff.

As for models, they show in game exactly as placed in editor; bar the ammo boxes which are all 32x32 big box over the 24x24 small box. The box="" sizes I didn't touch =p
Would be cool to see a bounding box along with the models for sure, 

* extradebug_quicker BUILD mode (defines _DEBUG_QUICKER = no slowing down debug renderables)
* draw bbox for having model + selected entities
* disabled depth write for qer_trans surfs and highlight (=any amount of layers is visible)
* 20x faster light radii rendering
* light radii are coloured and additive
* improved q1 pack (common textures, fix entities sizes)
* anisotropic textures filtering option (def = yes)
* GL_TRIANGLE_STRIP light radii spheres (2.5x faster)
* new very fast entity names rendering system
* render entity names in cam within < 768u dist or if selected
* fix: noninitialized lightradii, if light value is not set (example: lightjunior)
* light power is adjustable by mouse drag
* oranje names for group entities, having childrens selected (also no distance cull in cam for those)
* QuakeLive game pack 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.