News | Forum | People | FAQ | Links | Search | Register | Log in
SnapTiles: Tile Based Quake Map Maker (Concept)
SnapTiles -- a proof of concept or thought exercise.

Screenshot | Video | Read Me

Tested on a Windows 7 machine/a Windows 10 machine.

Supplied prefabs mostly from Quake map source release and Rubicon 2 map source release. You can make your own prefabs (see readme), they go in prefabs folder and are scanned on startup.

Just to prove it is possible. Your mileage may vary.
First | Previous | Next | Last
I watched the video he made in another thread. There were a couple attempts at inside3d over the years to make such a thing as well.

It always sounded like an interesting idea to me. 
Bringing 1996 Maps Back In 2018 
Looks like a fun little tool, although not one that I'd ever use. Cool! 
...why make a Doom-2016-like editor for Quake while we already have plenty of real editors? Not trying to rain on your parade, just an honest question.

I mean, unless it's possible to use the prefabs only sporadically in a hand-crafted map, I see little use for experienced mappers or those who have odd design ideas... 
why make a Doom-2016-like editor for Quake while we already have plenty of real editors? Not trying to rain on your parade, just an honest question

I like this question! I am a fan of critical thinking, and think the "why did you bother doing X" type questions create intelligent thought.

Answer: Seemed like an amusing challenge to make one over the course of a couple weeks working on it a little bit and a little bit there. No other reason, really. A tile based editor seemed like a fun little challenge.

That's that! 
You can make your own prefabs
I didn't see this before... It could change everything! 
Is It Possible... further tweak a level made with this in a full-blown editor like TB or JACK? Like, make the basic structure in SnapTiles and then move to TB for detailing? 
This would be very useful for a top-down mod.

That said, the using-keyboard-keys-to-look action in the video is triggering me a little bit. You need to get a nice gamepad! 
I Wish There Was A Facepalm Icon... 
You can also take SnapTiles levels and compile them and then find the .map file and open them in a different map editor for further modification.
Yeah, sorry for the question above... hadn't fully read the readme yet. 
Eh ... maybe with a mod.

Here is a topdown view demo clip: video of topdown view

Hard to navigate in topdown view. Perhaps because Quake guy moves so fast compared to other games and monsters see you before them.

But maybe it could be done with a QuakeC modification or maps that better illustrated what paths to take. 
For When 
a speedmap session using this? 
That is seriously fucking cool.

Yes, that is the sort of stuff this is made for.

The monster AI would need redoing, but the concept is super cool. 
Looks Really Cool 
will definitely give it a try, despite my lack of skill in quake mapping 
Any chance of releasing the source code on Git Hub or something? Also Curious to what this was written in :) 
I'm glad you were inspired by my work! :) I need to revisit it again someday... 
This Is Just Really Cool 
Snaptiles mapjam, I want to believe. 
Tried It, Doesn't Work... 
On first launch, while it was processing the prefabs, the program gave me a few "Snap generation failed for (prefabname) at snap png capture" error messages before pulling a "Run-time error '13': Type mismatch" and shutting down. After a restart, subsequent tries also failed with the same "error 13" message.

System specs:
Dell Inspiron 9400 running WinXP SP3
Core 2 Duo T5500 @ 1.66 GHz
2 Gb RAM
ATI Mobility Radeon X1400 
Needs Windows 7 or later, like Windows 10.

I didn't think anyone was still using XP except maybe Gunter, so I didn't think to put that in the readme.

Thanks for the feedback. I'll update it to say that it needs Windows 7, 8, 10.

A rare documentation omission on my part. 
WinXP SP3 
@Mugwump And @Baker 
Hey @Mugwump,
You need to have it in the root of your drive.

Example: C:\SnapTiles


Otherwise you will get that error. I was battling with that error all night last night. Might be a bug with the application. I do not know.

@Baker - May want to document this as Well. 
I didn't think anyone was still using XP
Heh, yeah, I probably should get around to finally making that long overdue Win 7 update, especially now that Chrome & Firefox have dropped support for XP. I'll try to do that before they also drop support for 7... ;) 
@SquarePeg ... 
I've used several different folders during testing (including testing on a USB drive h:\) but never thought of using the Downloads folder, and AFAIK some of the folders on Windows aren't "real" folders.

Just now I tested on Windows 7 in the Downloads folder and it worked ok. Also did a Windows 10 test without administrator and it seemed to work ok, but my trust level of Windows 10 is about zero and nothing would surprise me with Windows 10.

Short version: It worked for me in "Downloads" on Win 7/10 with fresh install right now, but I certainly believe you! 
Pretty cool and even better than Snapmap since you can actually use your own stuff :D One little annoyance that I found though is that you are either required to point the editor towards a wuake engine exe or copy your id1 folder into prefabs/ which doesn't really work with my organization scheme since I have my id1 folder in the root of my quakedev folder for organization purposes and there is no engine exe in the root for that reason, especially since now I have multiple source ports in there. A little update that adds the ability to just point to a directory instead would be great 
Oh And I Just Found A Bug 
Well I think I just found a bug, as I seem to often be able to do when it comes to quake lol. So like I said when the editor launched it told me to point to a quake exe with id1 in the same folder, and I didn't have any like that since my qdev folder isn't set up that way SO I didn't. So then it told me to put id1 in prefabs/ and I didn't want to do that so I didn't. So basically what happened is it kept giving me those messages over and over and over until it said "subscript out of range" and crashed! So basically it got completely fed up with my sheer stubbornness and decided it didn't want anything more to do with me. Or at least that's what I'd like to think happened ;) 
Ok, so you don't have an .exe in the Quake folder. Sucks to be you. You can fuck off now.

Am I kidding? Hahaha! 
I think Baker means copy paste. He must be having one of those nights again. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.