News | Forum | People | FAQ | Links | Search | Register | Log in
Fitzquake 0.80 Released (finally!)
New in this version: map loading is 4x faster, you can change video modes without restarting, cvar control of anistropic filtering, refresh rate, and vsync, cvar control of max_edicts, r_showtris support, and a typical long list of bugfixes and optimizations.

Go! http://www.celephais.net/fitzquake
First | Previous | Next | Last
ATI 
I have the microsoft ime installed for japanese text input at home, and whilst there is garbage on the screen when running fitz, or any other opengl implementation in fullscreen normally, if I start typing in japanese everything displays properly. under the japanese text that I am typing, which appears in some kind of special mode over the top of the screen. When I get rid of the Japanese text, Quake continues to run fine, but occasionally, especially if there is a screen flash for an item pickup or something, or perhaps even when I enter a new area of a map, the garbage comes back and I can't see what I am doing until I bring up the ime.

Obviously I have no idea how you could fix FQ to work fine on ATI cards, but perhaps this information will be of some use, and as an ATI user I certainly hope so, since I have resorted to always running in a window now :(

Oh, and every GL engine I've tried suffers from the same problem - I think only software Quake was fine. Then again, I didn't try Darkplaces, and since that is perhaps the most heavily modified Quake engine, it may behave differently. 
Btw 
I should have proof-read that message, since it's pretty badly written (lack of sleep from overmapping being the cause!). Hopefully it's understandable ;)

Another bit of info is when I take a screenshot during the time the screen is full of garbage, the screenshot comes out fine as if there was no problem at all. 
ATI? 
it can't be all ATI cards though, because i have an ATI x1950 and fitzquake works great (i randomly get 'cannot set fullscreen DIB mode' very rarely).

is it at all possible you have something else running that is interfering? 
My Card 
is a 4850 1gb ram with the latest (or recent at least) drivers installed. 
Y'all Needs A GTX 295 
Yeah baby! problems all solved (except for the power supply ones, of course P) 
Recent ATI Only? 
Here's what I've experienced:

9200 on Win98 with 6.2 drivers --> fine
x300 on WinXP with ~8.4 drivers --> fine
3100 on WinXP with 8.12 drivers --> no fullscreen
GeForce on above system --> fine

The 3100 is the onboard video, but I use the GeForce instead. I only briefly tested the ATI, with a few Quake engines (Fitz, aguirRe, and my own JoeQuake-based one, IIRC). I'll investigate further sometime.

So is it only me & Than who've seen this? Does anyone have a 3xxx or 4xxx card that *does* work for fullscreen Quake/OpenGL? 
Just To Clarify... 
"no fullscreen" was a poor choice of words. The monitor switches to fullscreen mode, Quake loads normally, but the display is garbled. And as I mentioned earlier, fullscreen D3D works. 
Hm 
well, my desktop ati does get garbled graphics in *some* quake engines. thankfully, fitzquake doesn't, but quite a few others do. i have no idea what causes it either. :S 
Resizable Font? 
greetings, is there pls any way to make in-game font (writings in console, messages...) bigger? it is too tiny when using 1600x1200, unreadable, thanks. 
-conwidth <size> 
works for aguirRe's engine (i.e adding -conwidth 1024 in the command line make the console appears like Fitz)... So dunno whther this option is supported by Fitz, and other engines...
Please test ;) 
 
aah, now I see it, I must use scr_conwdith {0,320...1600} for console text size AND scr_menuscale {1...5} to enlarge menu/centre-screen mssges. SOLVED 
Mouse Speed 
why does the mouse speed goes back to the default when i press F11? sometimes i mistakenly press the zoom key when i want to change the brightness, and the mouse speed always goes back to the default. always wondered about this, from way back to when quake was released :)

i know the easy thing is to just not have the zoom feature mapped on the controls, but i'm curious as to why it happens. 
Oh Yeah 
there is no brighness button in quake1, like in doom [and in most games, its always f11], one can only do this from the main menu, right?

man, i need to change my desk position. and get a new monitor :) 
Mouse Speed... 
the standard F11 zoom alias sets your sensitivity and fov, so if you don't use the defaults it will screw you up. You could write your own that is a copy of the existing one but with modified sensitivity.

(i actually rewrote it to use m_pitch and m_yaw, so that it wouldn't care what my sensitivity was.)

As for brightness, are you talking about the macintosh brightness controls on F9, F10? I have no idea about that, whether quake or the OS has control of those keys, or anything. You can set brightness in the quake menu, but this is video card gamma, which is not the same as the backlight on your macbook screen, which is what OSX controls. 
Just Checking 
probably been answered before but does fitzquake support antialiasing?

I seem to get a few more jaggies in fitzquake than in aguire's engine at the same resolution. 
Nitin: 
there's no engine awareness of anti-aliasing, but most video cards let you turn it on in the driver settings, per application.

Really, should be the same in glquakebjp and fitzquake, as i don't think aguirre added anything for antialiasing. 
Also... 
can you tell the difference in screenshots? 
Antialiasing 
looks good when enabled in fitzquake. It would be nice to have it as an in app option if it is easily implementable. It's especially cool since I can really max it out with 16x anti-aliasing so all the edges are super smooth.

Not sure if I can set it as a per app setting with ati's drivers :/ They are kind of shit.

Mind you, I run at high res so antialiasing isn't really that big of a deal. 
DP Has Antisotrophic Filtering And AA Settings Up To 32x (!)..... 
 
 
As far as I know those things are limited by the graphics adapter or is that something from the early days of this? 
On The Subject Of AA 
I found a while back that setting gl_texturemode to gl_linear and then enabling AA gave the best* visual results.

* looked the best to my eyes at the time with that particular hardware/driver configuration. 
Metl 
that is what I have, AA and Anistropic enabled from desktop.

but aglquake looks smoother.

I'll try frib's suggestion. 
Already Have Gl_linear 
maybe the model overbrights make jaggies more obvious in fitz? 
It's Possible That's What You're Seeing... 
try setting gl_overbright_models to 0 (i think that's the variable) and see if you notice the jagginess go away 
Metlslime 
for brightness, i meant quake's brightness settings, not mac os. one can change the brightness of a lot of games with f11, so i always got confused in quake thinking it had the same thing, so whenever i wanted to brighten the game i end up with a zoomed view and when i zoomed out, i had slow mouse look :)

but anyway, i changed the key binding for it and made it so f11 is for screenshots.

sorry if that didn't make sense before. :) 
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2017 John Fitzgibbons. All posts are copyright their respective authors.