News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread: http://www.celephais.net/board/view_thread.php?id=60097
First | Previous | Next | Last
Has This Ever Happened To Any Of You? 
Resuming, Worldcraft 3.3 + qadapter by Baker doesn't save.

Actually, it's more like it reverts to a previously saved stage.

Example: just yesterday, i was mapping all the evening, saving over the old archive always and testing the changes frequently, and closing the program 2 times on that time frame without reseting. But after seeing that it's going to be dark soon, i save again and close the Worldcraft. I remember i forgot something to do, i load the program and the map again, only to see that the map is at the stage that it was in the middle of the evening. It just choose one random one. I don't think it's related, but if i try to load the .map on Quark to check if the truth is that the last save is still there, it gives me an error and doesn't let me check it. I'll try with Radiant next time. B the way, the .bsp is fine.

I do think it happened again some months ago, when i copied a different map to another computer. This time it reverted to a stage one week previous to the last one when i copied it back into my computer. But i'm not sure about this last one. I still have to check into that other computer.

If anyone knows of this, it would be a great help some advice, if this keeps on, i'll have to quit WC.

Thx in advance to anyone that answers. 
 
i save again

I call BS!

I have lost work before from not saving. You're not the only one. 
Maybe I Haven't Explained Myself Well 
I'll be more precise.

What im trying to say, it's that EVEN if I SAVE the map a LOT of times, it goes back to a previous save, not the penultimate, one or 2, 3, ... even before of that one. Not that it happens all the times.

I'll repeat the first example:
- 0) Run the WC
- 1) Work in my map.
- 2) I save the map.
- 3) Close the Worldcraft, completely.
- 4) Run the Worldcraft again, the map is there as i saved it in 2), no problem.
- 5) Work again on it
- 6) Save again the map
- 7) Close the Worldcraft again, completely.
- 8) Run the Worldcraft again. Load the map, and the map is like it was in 0), but we know that WC saved it in 2) because in 4) we saw that the map was saved.

Is it clear now? :) 
Count Up Total Damage Done At The End Of A Map 
Yeah, wonder why we still don't have a QC or engine mod with more elaborate stats a-la DM: damage done/ received, accuracy for each weapon, items picked up etc. Would fun for players and helpful for designers. 
Cocerello 
I have no idea! That's fucked up. Are you sure you installed Worldcraft 3.3 and not Witchcraft 3.3? Have you tried using Worldcraft 3.4 instead? I don't know, but if that's a bug, maybe they fixed it in 3.4....... 
Cocerello 
Open a dropbox account and save your levels there - that will give you an extra backup if things get lost or broken.

In fact, let me invite you so I can get more free space! 
Mind You 
Might not solve your problem.

Personally I find it's better to save everything to the cloud in any case, just in case. 
 
necros: I was thinking just for level design a quick way to see whats going on enemy wise at various skill levels.

RickyT23: "Witchcraft 3.3" :) it feels that way sometimes late at night when you should have just gone to bed.

slapmap: We should have stats. Might make SP more competitive. 
Wc 
The only advantage to Worldcraft that I see now is the extra texture information, and making very accurate (non terrain) large brush structures. Other than that I find the workflow is very slow in comparison to TB and it doesn't really support complex terrain (amongst many other things).
Personally I haven't used WC since trench came out. 
Thx For The Answers 
I'll probably try to mend this by using ''save as...'', for making different versions, and saving things to another places. I use to do that when working on 3d modelling so i could go back to a previous stage, not that this give an noticiable advantage when mapping, but can be useful.

Fifhtelephant: i should try at least TB, i did try Quark back in the nineties but i didn't like it, but after so many ears with WC is hard to change.

Ijed: that's a good idea, i'll think about it. And i'll do too about your offer :)

RickyT23: about the 3.4, i read that it doesn't provide anything useful for quake mapping. I looked too at the changelog and haven't seen anything about bugs. I read too that 3.4 is considered Hammer, and Valve doesn't give permission to make maps outside HL with Hammer.

Back in the nineties i thought too that it was Witchcraft 1.2, with so many errors and issues at the compiler that i didn't know about.

Now i know most of them thanks to so many useful documents on the net. There is still one that i don't know how it works, after checking everywhere and in the document that is provided with issues for Beng Jardrup tools too: it is the ''can't find /id1/maps/yyy.bsp, there is no such file or directory'' that shows at the compiler and stops it. I usually fix it by removing the last brushes i put in, but it's weird, it shouldn't be related to that. 
I Have The Hammer 3.4 Exe 
You can drop it into the Worldcraft 3.3 directory and it works well.

I can confirm one difference - the pointfile loads and is visible in the 3D view of the editor. This feature does not exist in WC 3.3
You can load a pointfile but it is only visible in the 2D views. 
Hammer 
I uploaded this Hammer 3.51 the last version of Hammer 3.x I found. I converted Quake models to HL format to have them show in editor (not very good conversion). The leak file support is good. Saves time because you don't have to do a complete compile to find leaks. Stop the batch file after the leak is reported and load the pointfile in WC.

http://www.quaketastic.com/upload/files/tools/windows/level_editors/HammerV351wtools.7z 
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2017 John Fitzgibbons. All posts are copyright their respective authors.