News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread: http://www.celephais.net/board/view_thread.php?id=60097
First | Previous | Next | Last
OK, The Compilers 
I assume you might be using an editor that exports a .map file and runs the tools automatically? Whether that is the case or not, realize that the tools are standalone apps. In order to make a playable and lit .bsp file, you need to run three apps, in order.

Export your .map file from your editor and put it in a directory on your root hard drive called 'compile' or something. Now you should't have to worry about the wads not working, because inside the .map file there there is a little bit of text where the full location for the .wad textures are.

Now in order to run the tools, you need to make a batch file, or a shortcut, or preferably usie something like a command prompt (If your on Linux then this should be no problem I guess), and navigate to the directory where the tools and .map file are.
(in Windows i click the start button, type cmd then enter, or go 'all programs'->'accessories'->'command prompt'. Then i would type (without quotes) 'cd c:\compile' then i would see 'C:\>'

Here I can use the tools. The bqsp tools are simple. You just type the name of the tool and the name of the map. So if I had a file called blahmap.map, I would literally type (without quotes) 'txqbsp blahmap'. Once your map has been built (if successful) you could then process the light entities so the light tool can add the shadows information to the map. Here we see how I can use a parameter:

light -extra blahmap


As for the text editor, it doesn't matter what you use as long as it can handle big file sizes, because the file is full of numerical co-ordinates for different brushes, and they can get to be very very big, for a text file... 
The Mapfile 
Contains all of the info for the entities, just like JSON or something like that. So you can edit certain things quite easily like targetnames, and entity names (like a door called 'bob'). But you can also easily edit the path information about the location on the HDD of the .wad files, or .hlwad files - whichever you use. TxQBSP supports .hlwad and .wad files.

Load the .map file into a text editor and search for the word 'wad' - you will find it :) 
TexMex 
If that doesn't do it for you then it's safe to say that it can't be done. Not for Quake anyway. 
Help With Arghrad 
I'm finding on my map I'm getting overly bright red corners on my lighting (even where there isn't a light touching it). Has anyone got any experience with mapping with Quake 2 engine games?

https://www.dropbox.com/s/814f7f7htjgrx0r/Htic2-02.jpg

https://www.dropbox.com/s/vg9zld2x0d0idef/Htic2-03.jpg 
I Think I've Figured It Out Myself. 
I decided to change a bunch of textures on some surfaces. Updating floors, roofs and ceilings etc.

I think surfaces have a maximum allowed size and then Rad starts freaking out. It's a weird problem that doesn't occur in Quake 1 but seems to occur in Quake 2 engines. 
Anyone Know How To Get Quoth 2.2's Fgd To Work With Trenchbroom? 
 
Perhaps... 
You might try downloading it again. The original file, released at the same time as Quoth 2.2, had some syntax errors - it turns out that the worldcraft parser is quite fault-tolerant, in a way that some other editors are not. I uploaded a version about a month later, which had these errors fixed. It now loads in Radiant, where it didn't before, so worth a shot I guess... 
 
where can I get the fixed version? 
 
isn't the fgd included with trenchbroom? 
Here 
http://www.quaketastic.com/files/misc/quoth2.fgd

Necros: Not the 2.2 one, no.

Preach: You may want to update that link in your profile. ;~) 
When I Try To Use The Fgd In Trenchbroom: 
I get this error. Parse error at line 1166, column 44: Expected token type integer number but got decimal number 
 
Change "integer" in that line to "string". 
 
How am I supposed to do that? 
Oh Nvm I Think I Get It Now, I'll Have A Look At It. 
 
Strange 
I changed "integer" to "string" and I'm still getting the error. must be something to do with the "delay between flashes" being set to 0.2 
 
damn, I was just guessing though. Try removing the whole line and see if that helps. Don't blame me later! 
String And Quotes 
wait(string) : "Delay between flashes" : "0.2"

Need "" for string default values, might be it? 
Ok 
that worked, but the models don't show up.
at least it still works. 
RickyT23, Re: Posts 14013 + 14014 
Thanks very much for the detailed explanation.

No, I do realise that the compilers are standalone. I've been using TrenchBroom to map and them LordHavoc's hmap2 to compile (to test stuff), for which I use the terminal (i.e. the Linux "command prompt"). It's just that I could not get qbsp to work, as I clearly wasn't typing the right commands. I'll try it again later, but for now everything's working again and I've fallen back on hmap2. The problem was not with the compiler, but with the fact that I had duplicate (and as it turns out, triplicate, quadruplicate and quintuplicate) brushes), as mfx suggested above.

Still not sure how that happened, but I hope it won't happen again, as it was a pain to track down and remove all those duplicates. And no, I wasn't mapping under the influence! :) 
As For The Text Editor Thing... 
... that's really useful information. I am able to open my map files with my humble text editor (Leafpad) and now I can simply find and replace textures if I suddenly decide to use a different texture on 1000 faces. Thanks! 
 
Checkout jEdit some day, it rules!

Leafpad has some nasty undo bugs that can corrupt everything iirc. 
Quake Brush Limits? 
What is the upper limit (if any) to the number of brushes one can have in a Quake map? I'm not even done with one third of my map's basic layout and there's a lot of detail to be added, and already I've got ~800 brushes ... at this rate I'm going to have thousands of brushes by the time I'm done. Should I be worried?

PS: Thanks, Spirit. I'll check it out. 
 
I don't think there is a limit. The limits exist in the resulting BSP file. 
Limits 
The standard bsp format is bsp29.

There's a newer one called BSP2 which needs support from compilers like Tyrann's: http://www.disenchant.net/

Where you need the -bsp2 switch to make it compile.

There is a size limit on how far away from the world 0,0 you can get - if the player leaves this volume in game then strange things happen. Can't remember the distance.

Finally, the most difficult limit to overcome is your own sanity. Slaving away on a gigantic BSP2 monstrosity is not for the faint hearted and can quickly suck the fun out of mapping if you let it. 
4096 ^3 
 
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2017 John Fitzgibbons. All posts are copyright their respective authors.