News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread: http://www.celephais.net/board/view_thread.php?id=60097
First | Previous | Next | Last
 
i do the same: keep it sealed most of the time, with a solid black brush plugging any doorways/hallways that lead to nowhere.

However, when in the middle of building a large atrium/canyon type space, i do leave it leaky while the outer walls of that space are still in flux though (i'd rather leave it empty than place a box around it, i feel the box will influence the way the space is built and create boxy rooms! :)

Anyway i'm on an old computer and it seems that qbsp and light run a lot faster on a sealed map. It seems that all the outer faces being clipped away speeds up both processes. So i do it for my own productivity. 
This Is A Weird Odd Shot 
anyone have any idea how to make gtkradiant1.5 ok with info_notnull being a both a point entity AND a brush entity? or maybe there's another good entity that can be used as a blank hackentity?

as it is, gtkr only considers the entity to be one or the other... if it's a point in the .ent file, all brush based info_notnulls lose their brush; if it's a brush, the points can't be edited in the editor because they have no brush (thankfully, they retain their origin). it's really inconvenient when trying to use both 
 
The newest version of Netradiant has the same problem. I had just deleted it entirely from the .ent file and my old 2012 version was fine with that, but the newest version defaults to assuming it's a point entity and deletes the brushes.

What would be nice is if the <point name= and <group name= were not locked into also being the classname. The classname should be a separate key something like:

<group name="brush null" ...>
<classname= "info_notnull>

<point name="point_null" ...>
<classname=<"info_notnull">

Also, I started getting sv_touchlink errors using brushed info_notnull triggers in the new Netradiant when. I had to go back to the older version (and older copy of the map for some reason) to get rid of the error. 
 
mm, think I'm just going to map with the point entities as info_null, and then find/replacing them before compile to be info_notnull... maybe should hack qbsp to do this for me... 
 
I could do without the point entity version, but when I made it a group I started getting those sv_touchlink errors. Couldn't figure out how to fix them, so I just gave up and went back to the old version of Netradiant I've been using for years. 
Just Run Sed Before Qbsp 
 
Silly Czg 
i don't use teh lunix 
Wow I Thought U Were A True Dweeb 
 
 
There is a windows compile of all the best Linux programs, including sed and grep! 
Info_notnull 
I remember worldcraft had similar issues with a class being both brush and point, and the best solution in that case was to remove it from the fgd and just enter the classname by hand where needed. 
That's What I Did 
In the my old 2012 version of Netradiant that's what I had done and it worked fine. A couple weeks ago when I got the urge to map again, I downloaded the newest version.

With no entry at all for info_notnull, it would default to a point entity and delete the brushes. I changed it to a brush (group) entity and it seemed okay, except that playing the map I got sv_touchlinks errors when the info_notnull brush was triggered. So back to the 2012 version I went. No big deal, it works fine. 
Madfox And Negke, Thanks. Also... 
Is there a technical reason for not largely using meshes on a Quake level these days? Suppose I'd like to make a barebones BSP and add all detail using meshes, like I would for a Source or UE3 level. What are the limits? 
Using Meshes 
isn't as unheard of now. You can go pretty far if you went and used bsp models for instance, these are good because it helps the design feel consistent. You could go in and use meshes if you wanted to, mods like quoth allow you to add them fairly easily.

Getting the light correct for the models is important, meshes use the lightmap on the floor to tell you how bright the object is, so you're going to need to play a little to make this work. My advice is use quoth for this type of work, or Drake. Socks new mod will allow external models too and I think a few people will want to work on this once it's out. 
 
Getting meshes to light and blend in with the BSP surrounding them is notoriously difficult in Quake. Vert lighting vs lightmaps ... 
@Fifth 
Right, I forgot about lighting. A Quake model doesn't shade itself, right? So, my full blown central computer room, with massive models covering the walls, would look bland. Maybe Sock's mod would take care of it? 
 
... or probably not. 
Collision 
Is also difficult - unless I missed something you need to use clip brushes, and an editor that shows you the model dimensions is a must if you want anything approaching accuracy.

I know there are a couple of tools to convert meshes to brush though... Warren? 
 
Adib 
Socks mod isn't going to take care of quakes lighting. It's just gonna add a shitload of cool new stuff. Really if you want the models to be lit differently you need to be working with something like DarkPlaces so that you can take advantage of the real time lighting. 
Ijed 
I sended you a testmap some time ago.
Check your email, gmail or johnmayal. 
Honey Wads 
Does anyone know where one can find them? They were available for a while via the Honey mapjam thread, but now that link is dead. Can't seem to find them on Quaddicted either...

On a different note, what would cause an item to disappear once a map has been compiled? At the moment I've got a Quad Damage that I can see in TrenchBroom, but when I compile and test the map in Quakespasm, it's gone. 
 
Quad is probably dropping out of the map on load because of being partly in a wall or floor. There's a devmode switch you can use to see messages to that effect. I think it's -developer 1 
 
My bad, it's +developer 1 for the command line switch, but apparently you can set in game also. Type developer 1 in the console and reload your map. 
Thanks, Rick 
I tried that, but I don't see anything about anything dropping out of the map in the console. Not that I know what everything in the console means, though... what sort of message should I expect to see? Something like "item_artifact_super_damage fell out of map"? Because there's nothing like that...

I checked again in the editor, and the QD is not touching brushes or other entities. I even raised it an extra few units from the floor, just in case. 
 
The message to expect is "Bonus item fell out of level at 'x y z'"
You have to raise the console for a second so the first few frames run in order to get the message.

fwiw I just tried in TB1, and the bottom of the quad's bounding box needs to be 16 units above the floor. 
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2019 John Fitzgibbons. All posts are copyright their respective authors.