News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread: http://www.celephais.net/board/view_thread.php?id=60097
First | Previous | Next | Last
 
Hardware from a decade ago is still hardware ten years newer than Quake. 
Idk, It Was A General Improvement 
That was ciscon, he's been helping me test. That spot is unavoidable anyway. Once or if the devs redo the ezquake renderer, I'm pretty sure none of this will be an issue.

Anyway, the reason why I'm making a big deal is that slow spots cause obvious dips that distract from competitive play. It's all worked out mostly now, so that's good. 
 
Now all that's left to do is make some of my own maps. Prolly gonna suck, I would do better working with somebody else since I'm good at making levels, but not necessarily coming up with them. 
Switching To Trenchbroom 
I've been using J.A.C.K. for a while now since it's the only editor I've figured out how to get working but I want to switch to trenchbroom because it just looks like it's a lot more fluid in editing.

my problem is that I can't figure out how to set up the compiler and stuff. the manual just kind of says "open up the compilation dialogue from the menu" but the compile menu is gray'd out and I can't click it, so I'm not sure if I'm supposed to do something else first or if I did something wrong. pls help pls 
 
oh.... I searched the internet for over an hour straight trying to figure it out and apparently the only thing I had to do was save the map to get the compile window to be able to open. 
 
now I'm having some trouble getting it to compile properly. here's what I've got going on https://i.imgur.com/fLu9GT5.png
it's saying "no such file or directory" 
 
Why have you got underscore characters in the parameters?

Like "Program_Files_(x86)" when it should be "Program Files (x86)".

If spaces in the path are giving problems, you can try one of these:
- putting the whole path inside quotes
- using the DOS style shortname for the directory, which is probably "PROGRA~2"
- putting your Quake files in a path that doesn't include spaces 
 
I was using this guy's tutorial, along with some other one I can't find http://steamcommunity.com/sharedfiles/filedetails/?id=1090749598

and using quotes around the path helped, thanks 
 
Also hmm it's not clear to me you even need to give that second argument to qbsp at all. But I haven't used that particular GUI so I'm not sure how you really need to set it up; hopefully someone else can chime in. 
 
OK good to hear you got past that step. :-) 
 
https://imgur.com/TIgJJ78

Use the "+" circled in red to add each a new section.

Use the "..." circled in green to add your tools.

Copy the rest word for word.

This is outlined in the TrenchBroom manual. 
 
I tried filling in the parameters and stuff exactly the way mukor showed but it keeps giving me an error saying the bsp was already in use by another program, even though I have literally no other windows open besides trenchbroom itself

another thing, I tried changing the working directory to ${MAP_DIR_PATH} but it completely crashed TB whenever I typed the first letter 
 
here's what I've got, let me know if I did something wrong https://imgur.com/a/SrFpR 
 
it said it failed to copy, so I removed the 'copy files' part and it compiled fine. is that part important or should I just not worry about it? 
 
Forgot to mention that with that setup you need to start your maps in a directory OTHER than /maps.

I recommend making a folder somewhere near your Quake folder called "Working" or something to that effect.

Do that and you can add the copy part back in. Be sure to add a "Copy" function for the .lit file as well. 
@skizzle 
If you still can't get compiling in TB to work please Google Necro's Compiling GUI and use it. It's much more approachable than TBs compiler. I seen people post here often with issues or confusion. You certainly will be up and running very quickly with the GUI. 
 
If you get TBs compiler working with the copying files, stick with it.

Yeah its a little extra work to get it started, but its definitely worth it. I just compile, open Quakespasm, press up in the console to repeat my last command(usually the map) and bam.

NCGUI will have you open NCGUI. Select your map. Compile. Open file explorer. Move bsp/lit to /maps. Now you can play.

I think people let themselves get intimidated by how setting up the compiler looks like "coding" and they dont even try copying it exactly as shown in the manual. They think they have to decipher some complex language when its literally spelled out in front of them. :P 
@mukor 
You don't need to chime in here dude especially with Dad info. I already said if he still was having issues too. And you are incorrect. I leave NGUI open, save my map and hit Alt-tab the Ctrl+C to compile. The game launches I am in. All the copying is handle by the GUI. I'm not sure who taught you to use Necros' tool.

FyI the compiler UI on TB 2 RC 4 is broken so another reason to avoid it. also the manual in Windows is currently not working on RC 4. There are plenty of reasons people are coming here asking questions. It's not an elegant solution and no, not everyone is comfortable or knowledgeable about paths and shit. 
@mukor 
"bad info"

"FyI the compiler UI on TB 2 RC 4 on OSX is broken so another small reason to avoid it." 
 
The compiler isnt broken so as its completely unusable. They already got it set up minus the fact they were starting their .maps in the /maps directory.

Maybe if theyre deleting a profile:
https://github.com/kduske/TrenchBroom/issues/1917

Or how if you stop the compiling process earlier, a compiling tool might hang:
https://github.com/kduske/TrenchBroom/issues/1864

But not so broken as to completely discourage its use in favor of another tool that just does the same thing.

Heres a better screenshot with the proper tools shown.

https://cdn.discordapp.com/attachments/292236297173467138/395847224699125760/unknown.png

The one i linked earlier shows q3 tools, i think.

The only thing that will be different on yours is where your tools are...and to set that up...click the dots circled in green. 
 
Jesus man I am giving a newb options here why the last word BS? And you didn't acknowledge you are wrong about Necros' GUI.

Some of us literally don't have to time to research this shit and need something that works out of the box. I'm simply trying to help and get pissed when people relay bad info.

You even started your own GUI ffs.

Peace Muk. Let's help people by giving them options huh? 
 
yeah, ive tried using NCGUI and couldnt get it to work as seamlessly as I got TBs GUI working for me.

I recommended it to someone and even they couldnt get it working.

NCGUI isnt as intuitive as one would think.

:shrug:

also, my compiler frontend isnt a gui. its a batch file :P and i made it because NCGUI cant compile batches of maps. 
 
and yes i stand corrected on those point i wrongly asserted. 
 
Fair enough hombre. 
Dumptruck 
How is the compilation UI broken on OSX? I know it has problems, but I didn't know it doesn't work at all. 
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2018 John Fitzgibbons. All posts are copyright their respective authors.