News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread: http://www.celephais.net/board/view_thread.php?id=60097
First | Previous | Next | Last
Map Boss 
It was the red genie looking thing with the claws...and thanks for the video referral 
 
what are yo guys using to compile maps for q1 and q2? 
For Q1 
Stop The Train! 
To get over the time releasing my new map I'm creating a little jumping platform game where trains as platforms are running threw the screen.
I only have one problem.
How can I stop them from running? 
Whistle 
The last point for the func_train could be

"classname" ""path_corner"
"wait" "-1"

if you don't use it in your train path.

Other way would be creating a button that breaks the func_train with kill_target on the moment it needs to stop. Bad thing is it disappears. 
 
You could also use the progs_dump devkit that has the feature of pausing func_trains. 
@Whistle @Esrael 
@Whistle. Thanks for help but I need the trains as a floor.

@Esrael- I'm using progs_dump and thought to find that in the function. Is it a spawnflag or a trigger_function? 
Found It !!! 
Finaly found it after reading the manual the third time. Ahh
It's the retrigger-spawnflag.
Will test it after the weekend.

Thanks again Whistle and Esrael for your help. 
@GunSgtHighway 
The pd_lava map has an example of the RETRIGGER spawnflag if you want to see it in action. 
 
Does anyone know any good set of open source (CC0 or CC-BY) textures? I'm tired of using philipk's. 
Sock Has Some 
Sound Info 
I watched the video on entity properties but what i cant seem to find is a list of properties....i want to use an ambient thunder point entity in my map but not sure how to change the intensity of sound or frequency of its occurence thanks 
 
that industrial set was awesome. thank you. 
@dumptruck_ds 
Thanks.
The retrigger works great!
I made an mini episode with seven platform jump & run levels and am now fixing some map problems.
One of them is realy tricky. Sometimes there are two trains rolling in the same position but I can't find the second one in the editor. Do you now a way to find that brush? 
@dumptruck_ds Re:retrigger Double Brush 
So Ichecked out the brushes and theres no second.
It seems that this's a bug.
When the startingpoint of a train and the retriggerpoint of another train are the same, the second train has a ghost on the second position. 
@GunSgtHighway 
I'm currently helping dumptruck_ds with some stuff for progs_dump. I've taken a look at the train code, and I'm not sure what would be causing that problem. =( Is there any chance I could take a look at the .map file that's exhibiting this bug? If I could, I might be able to work out what's going on. 
@iw 
Sure.

I'll check out the map size. Maybe I can mail it.

Hope that error was a failur of mine and not in the code. 
@iw; Mapfiles 
So heres the downloadlink to the map.
Hope all files are included.

http://www.quaketastic.com/files/tod/neonquakecopy.zip 
@GunSgtHighway 
OK, I think I can see what's happening. The "ghost" train that overlaps the big train at the start is the model of the big, final train that appears at the end.

This one isn't a progs bug. I believe what's happening here is that the map is hitting one of the engine limits, which is that the playable area of a map is +/-4096 units on each axis. It looks like the final train starts at a path_corner so far "north" on the Y axis that its model wraps around and gets displayed at the "south" of the map.

In fact, it isn't just the final train whose model gets wrapped around: the models of the last several trains that should be at the far north are visible in the void to the south of the map when the map starts (try noclipping through the wall behind the player start point to see).

If you're using QuakeSpasm or a derivative, you should be able to see the effect vanish if you enter "sv_protocol 999" at the console and load the map again. (QuakeSpasm defaults to Protocol 666; Protocol 999 is the newer, higher-limit protocol which allows larger maps.)

If you want the bug to go away for all players, regardless of protocol, I think you'll need to modify the map so that there's less distance between the entities that are farthest south and farthest north on the Y axis.

P.S. I liked the retro visuals. =) 
@Wi 
Big Thanks!

Glad to hear that the failer isn't in the progs. I thought on everything but not on the map limits. So i will move the party more southward to get it work.

Best wishes. 
Ericw-tool Light "no Backend Available" 
Hello everyone,

I've set up a mapping environment under Arch Linux, using TrenchBroom + ericw-tools + quakespasm.

Everything works well, aside from the lighting. light is throwing a "no backend available" error at me, and my maps are always full-bright.

I made a small box with a single torch for testing. You can read the log here: https://pastebin.com/h0E8kfcm

Best regards. 
 
Try the linux build from https://github.com/ericwa/ericw-tools/releases (in case you got it from somewhere else?)

What kind of cpu do you have? The raytracing library (embree) requires sse2 so mid-2000s ish. 
@ericw 
Hello ericw,

Thank you very much for answering my message.

Downloading the binaries from github fixed my issue. It turned out I only had the light, vis, and qbsp bianries and nothing else.

I thing I probably have downloaded the source and compiled everything myself.

This is fixed now. Thank you very much for your time! 
Zerstorer Textures Copyrighted? 
I'm building a level which is using some textures from Zerstorer, that famous Quake mod. The WAD was available on Quaddicted, but I've noted the following in the text file that came with Zerstorer.

* This product is property and is copyrighted by Nihilism Unlimited.
* If this product appears on any medium/media without the consent of
Nihilism Unlimited, full legal action will be taken.


I note some textures were used in func map jam 3, which was a Zerstorer themed jam.

The question is, is it OK to use these textures? Obviously I want to respect the authors wishes, but this disclaimer is confusing, as it appears to discourage any copying! 
 
It's fine to use them. It's been 20+ years and everybody from "Nihilism Unlimited", which I doubt was ever any proper legal entity, has since gotten jobs and careers (some of them are still at id). 
 
seems like they don't want it distributed on a physical medium like CD-ROM 
@Borax Man 
A bit of historical perspective:

That warning came at a time when software publishers were downloading maps and mod archives from cdrom.com. They would package them and sell them in retail stores without permission.

Mappers and Modders started adding warning like these back in the Doom days. 
Oh God I Remember That Crap 
Yeah you could literally walk into a high street games retail outlet and buy one of those big cereal-box sized packages with a CD rattling around in it, with "3000 BRUTAL QUAKE LEVELS" written on it in a big red "rubber stamp" font, and 90% of them would be fullbright boxes with a rotfish stuck in the air, big walls tiled with the flashing button texture, and everything more than 10 feet away from you is a great big HOM. 
SM202 Theme Confirmed There. 
 
 
I suspected that would be the case. Good.

I played jamx_bloodshot, which was quite excellent, a map in func_mapjam x.

One thing that appeared to happen after passing through the silver key door, was the player being teleported when they turned their back on the door. I have a few ideas for my level, but the only way I can implement them is to have a func_wall disappear when the player gets close to it. That I can do, but is there Quake C code which allows for a trigger to be fired when LOOKED at? 
 
Triggers can have an “angle” property which requires players to face within a quarter turn of that direction before the trigger will fire. 
Key Values 
is there a list of the key values I can use some where... I wanted to use some ambient sounds but I can't seem to find the key value for volume... i.e. how the ambient light has an intensity key value, I wanted to make the sound of a rumble or something louder... I have typed in things like volume, intensity and what not but not sure how... also I had wanted to put a lightning effect so I wanted to make the lightning have a occurrence so it would happen every five or 10 seconds. thanks. the video on entities tells how to edit and add key values...but not what key values are available and unless i missed it in the manual I can't seem to find it there... 
@gillandro 
Not sure but are you asking about progs_dump?

If so the audio settings are well documented in the manual since version 1.1.0

In a nutshell, the audio defaults to the loudest volume. If you need something louder try and "double up" entities next to each other.

Random lightning effects are too complex to explain here but you will want to take a look at func_counter and the random spawnflag.

I have a new pd_lightning map that will be released very soon with pd_ version 1.1.2 
Lightning 
I have implemented a lightning effect in Lords of Chaos. Actually, the effect is a little more complex than what I'm describing here, but I don't want to spoil too much.

I used a func_counter, which has the "looping" spawnflag set. "wait" is set to the delay between each lightning strike. The counter targets three trigger_relays. The first trigger_relay targets the light which is the lightning effect, and turns it on. The second trigger_relay also targets the light which is the lightning effect, but to turn it off. I have 'delay' set on this trigger at 0.3, so you get a pretty quick flash. The third trigger_relay targets 4 different play_sound_triggered entities spaced a few hundred units apart. I have delay set on this relay to '1', so the thunder sound is a little delayed from the lightning, for realism. These entities all play ambience/thunder1.wav. Of course, you can use your own effect here or change the delay values to change the timing of events.

The trick to making it louder is the 'impulse' key on the play_sound_triggered entities. The default value is '0', which is 'automatic', but I found the sound crackled a little and could drop out. What I did is set each play_sound_triggered to use a different impulse value (1,2, 3 and 4) which means all four entities use their own unique channel. The sound comes out nice and loud if you space them apart just right. My sound entities are about 500 - 600 map units apart. Note this doesn't actually really make it louder than other sound effects, but it does allow you to have it loud over a larger area in a reliable way.

You COULD use one play_sound_triggered instead of four, and set speed to '-1' (heard all over the level), but for my purposes I only wanted it heard where the lightning could be seen. 
Key Values 
when you use the point entity ambient_drone for example... and I look at they key/value spread sheet in entities all I see is the classname, origin, and spawnflags keys... the ambient_drone only seems to be audible if I create it near the player start entity. I wanted to put it some where in the middle of the part of the map it was created in and sort of be loud enough that no matter where I was in that part of the map that it would be heard... thanks hopefully this clears up my question better. 
@gillandro 
ambient_drone (and the other ambient_* entities from the original game) are unfortunately not very configurable; there's no key the mapper can set to change the volume etc.

If you're using progs_dump, it adds a more configurable entity named ambient_general which has the following keys:

- Set "noise" to the path of the wav file to play (if you want the same sound as ambient_drone, that's "ambience/drone6.wav").

- Set "volume" to the volume (1.0 should be full volume, 0.5 should be half volume, etc.).

- Set "speed" to the attenuation factor. "-1" means no attentuation (i.e. should be audible anywhere in the level). The original game generally uses "2" for monster idle sounds, "3" for ambient sounds, and "1" for most other things.

Disclaimer: I haven't tried using this entity, I'm just looking at the source code. 
@Borax Man 
Funny reading your lightning set up. I've done something very similar in a new sample map called pd_lightning. Yours is a bit more involved and mine is more a trap than an effect for ambiance. I used func_counters to toggle the lights in my setup. The new version of progs_dump will be out soon. (I am hoping to get it wrapped up later tonight. 
Thanks 
Is progs_dumps something i can find in the create menu? 
@gillandro 
You mean when you first launch TrenchBroom?

If that is what you mean, the answer is NO.

progs_dump is a mod. You can enable it in the editor at the bottom of the Map Inspector tab. Look for the Mod selection area at the bottom right side of the screen. Then you load the FGD (found in the progs_dump development folder) at the bottom of the Entity Inspector tab. The FGD will allow you to see all of the specific entities like dead monsters, the candle and other entities. 
@gillandro 
I must have misread one of the previous posts, I thought you were using progs_dump. As dumptruck_ds said, it's a mod, so if you did want to use it, you'd need to download and install it, and then set up your map editor to use the mod's entity definitions.

BTW, other mods provide similar entities for setting up ambient sounds with specific properties: e.g. Quoth has ambient_generalpurpose, Arcande Dimensions has ambient_custom_loop, and Copper has ambient_sound. 
Thanks 
only issue is... 1 where do I find it? and 2. can players play maps made with it... or do I need to put my maps some where specific? thanks. 
@gillandro 
Scroll down here for the new version I just posted last night. Please read the readme and manual. I spent a lot of time and most of your questions are answered there.

http://www.celephais.net/board/view_thread.php?id=61633&start=274 
Textures With Incompatible Colors...? 
I have custom textures for a map I'm making but once I convert the texture from an image to a texture and put them in the custom wad and run the map in Quake, I see that the texture's colors are simplified, parts of the texture are simply grey where the colors are I guess incompatible or whatever.
What's going on? Is it a problem with Quake's colormap, a problem or a problem with the WAD? 
 
Do the colors look correct in texmex? (Or which was editor you’re using?) 
Any Quake 1 Texture Artists Still Around And Active ? 
Somehow, in 2019, I need some Quake 1 inspired textures for my indie project. So I am wondering if there are still any good Quake 1 texture artists around and reachable (like Speedy for example, who I have no contact with, unfortunately). 
@DEMONGARBED 
Quake uses an 8 bit color palette. More info here:

https://youtu.be/xnSqmHOh3XQ 
 
is there any engine that allows me to increase the lightmap size for my maps? I was wondering if I could get some nice 2048 or even 4096 lightmaps for cool lighting 
 
misc_poster, you can see Spike and ericw discussing that, starting at post 19263 here: http://celephais.net/board/view_thread.php?id=4&start=19263 
Rspeeds 
I am very close to finishing my map, but am facing a few issues I need to iron out. The one I'm not sure of, is r_speeds, and what they should be for a modern machine.

After building it with a level 4 vis, I find with the FTE Quake Engine, the sound still stutters, where it doesn't with other maps. By stuttering, I mean that the last second of sound or so repeats multiple times while the game keeps running. The frame rate seems to average 60FPS, with the worst frame rate still over 35.

The "draw indices" value indicated by r_speeds can get over 70,000. Is that too high? How do authors today ensure that the maps aren't too detailed? Is the sound issue an FTE Quake issue only? 
Curves And Grid 
Hi and hello! In my first post I'd like to say hi to QUAKE maniacs and thank to people who made trenchbroom (@kristianduske), compiliations tools (@ericw), and @dumptruck_ds for great tutorials and all others people thanks to them I could back to QUAKE maps - thank you very much!
I got two question:
1. Is possible to use on some Q-port patches/curves like in Q3.
2. Is this a big problem to not keep the grid (I know it is very important, but maybe new compilators can handle it without any problems). Here I show my little altars: https://imgur.com/a/cchxDSP as for sure you see they can't handle the grid. Of course I can make altars in the grid but they don't look as good as this style. Is this a real bad idea in building map or I should always handle the grid? Thanks! 
 
Is this a real bad idea in building map or I should always handle the grid?

"Always stay on grid" is like a func_msgboard/terrafusion mantra.

In this particular case it won't really matter, since it's a loose object and not part of anything structural*. But otherwise, yes, you should always try to stay on grid when building in Quake, 2 at the very least.

It is possible to use smooth on-grid curves to achieve your desired result, though.



* - I hope you're going to mark this altar as a func_detail_wall
 
Quake, 2 at the very least.

Grid 2, not Quake 2. I wouldn't inflict that on you! 
 
@onetruepurple - thanks for advice, I always keep in grid in DOOM3/QUAKE4/QUAKE1 but I thought there could be some new feature I didn't know about. I look at my altar once again and it was just easy to see rectangles in triangles chaos. I love brush style mapping! Back to QUAKE mapping thanks new compilers and trenchbroom is like holidays for me. I had to loose work on maps 10 years ago cause compilation time :(
https://imgur.com/a/apwwxXW
Now is good grid 2 units. 
 
Looks great in map, for now without func_detail and _phong 1
https://imgur.com/a/o7j4rpZ 
Grid 0.125 For Life Yeah \m/ 
 
"I Wouldn't Inflict That On You!" 
So is Q2 mapping not really a thing now? Genuine question, since I've been out of the game for a long time and have just started resurrecting a project that I started about 20 years ago.

Cheers 
@geraintwd 
As far as I have heard there are still MP and "jump" maps being created. We have a small group of Quake 2 enthusiast on the Quake Mapping Discord with a dedicated #q2-mapping-etc channel.

I know a few of the regulars there are interested in giving Quake 2 SP mapping a spin. Including myself. Most likely in the new year for me as I am finishing up a project.

Come say hi: https://discordapp.com/invite/j5xh8QT 
Why Thank You! :D 
Have done, thanks! 
 
Someone created a TrenchBroom importer for Godot: https://github.com/ShiftyAxel/Qodot 
@misc_poster 
Cool find, I was recently wondering if there's any sort of support for Quake content in Godot. Too bad that most implementations that aren't derived from Quake support the simplest subset of data formats (either .map or .bsp) and are not concerned with gameplay portion of Quake at all (progs, client-server, etc.). But I guess people work on what they find the most interesting, typically rendering. ;) 
 
Hey

You guys have any idea where I can get a hold of a Wrath ent def file? It's kinda tedious to write your own, trying to figure out all that stuff =) 
AD Item Offset/rotation 
How do I disable it? I'm using jackhammer 1.1.1064 (latest freebie version available) and AD 1.70 P1 with included fgd.

There are a couple of parameters in worldspawn properties that regulate offset and rotation but they have no effect. I tried both Ericw and TyrUtils qbsps, with the same result - items are still rotated/offseted randomly, and will not spawn at all if they dont have more than 64x64 space around them.

There is "Floating" flag that solves the not spawning issue, but it makes items clip through world geometry because they are still offset randomly, but this time with no regard for surroundings. 
 
Yeah the worldspawn keys don't apply anymore in latest AD I think.

You can set an explicit nonzero angle on the item to stop the random rotation. If you really want explicit angle zero, then use 360 instead. 
Works For Me, Thanks! 
But what about position offset? 
 
I think that particular worldspawn key DOES still work. I.e. try setting no_item_offset to 1 for worldspawn. 
 
Yea, apparently "enabled" is actually "disabled". Worked, thanks! 
No Spawn Function For: Func_detail_illusionary 
Console spits this error for every func_detail_illusionary in the map. Am I doing something wrong or this entity just broken? No errors during compilation, playing with quakespasm. 
#20364 
You need to use ericw's compilers.

That ent is just used by his compilers. It will be stripped out of the bsp.

In general, ericw's compilers are the only compilers anyone should even be thinking about using, at this stage.

https://ericwa.github.io/ericw-tools/ 
 
no q2 though :( 
Argh! Hunk_Alloc 
Help!

One year of work and now I got this message after compiling: "Hunk_Alloc: failed on 67108896 bytes".
if I read the crashreport right, "ERROR: SymGetLineFromAddr64" it means stack overflow.

Does someone know what this means and how to repair it? 
Gotta Alloc More Hunks, Bro 
Try your local gym.

Errrr, could mean needing to allocate more RAM, IIRC? try -heapsize 256000 or similar in your Quake exe shortcut. 
@Shambler 
used heapsize. Same failure.
Is there any other way? 
What Is Your Current Heapsize? Try Doubling It 
 
Heapsize 
Where can I find the heapsize setting? 
Not Sure But 
GunSgt

I think you type com_hunkmegs into the console to see what your current settings are. 
Thanks @Shambler, Metlslime, Dumptruck_ds 
Finaly it works with -heapsize 512000. 
 
Just found out about a strange thing with my Xmas map. The player falls into a trigger_push at the start, and in QSS this causes the camera to get tilted by 4 degrees.

Raising the player start by 4 units solves the issue, but copying the unmodified playerstart+trigger to a fresh map does not isolate it.

The trigger has "angles 335 35 0", the player has "angle 30". Messing with these leads to all sorts of weird results (zeroing the player makes the tilt go up to 8 degrees).

So, is it an issue with my map, QSS or AD?


I also had some other issues that were either AD bugs or me being dense:
- Widowmaker doesn't work in deathmatch: can't be picked up again after dying
- "Delayed" monsters seem to activate all monster-sensitive triggers on spawn
- "Non-solid" flag on a func_bob seems to have no effect
- The distance that a func_bob moves seems unreliable and/or goes out of sync over time
- trigger_monsterjump doesn't affect flying enemies despite the specific spawnflag
- It's impossible to trigger-set fog density/color to 0, have to use 0.0001 etc instead
- Brushes with sky texture on one side will behave as pass-through for projectiles on all other sides too(?). Possibly even make the enemies pass-through(?) 
Correction 
non-solid func_bob becomes solid when you walk over a corpse 
Overwriting Default Backpack Values? 
I have a monster_ogre, and when I add a key value pair of
ammo_shells: 20
I gain 20 shells when I kill him and touch the dropped backpack.

This does not work with ammo_rockets however, because in ogre.qc it sets self.ammo_rockets = 2. Is there a way so it respects my values in the entity settings? 
Trenchbroom Q2 Map Leaks 
Hey everyone,

I'm a newbie working on mapping with Quake 2 in Trenchbroom (loving the editor so far!)

Unfortunately I can't seem to generate a map with proper lighting due to a leak while running QBSP3.

I can still launch the map, however after compiling with QVIS3 it will be dark.

In order to troubleshoot I started a new file which is a simple closed off room, ensured my "Snap to Grid" option is on, and that the room is indeed closed off.

Here's what the compiler is doing:

#### Executing 'E:\Games\quake2\baseq2\qbsp3.exe q24'
----------- qbsp3 -----------
original code by id Software
Modified by Geoffrey DeWan
Revision 1.09
-----------------------------
gamedir set to E:\Games\quake2\baseq2\
entering E:\Games\quake2\baseq2\maps\q24.map
0...2...5...7... (0)
**** leaked ****
Writing E:\Games\quake2\baseq2\maps\q24.bsp
0 seconds elapsed
#### Finished with exit status 0

#### Executing 'E:\Games\quake2\baseq2\qvis3.exe q24'
----------- qvis3 -----------
original code by id Software
Modified by Geoffrey DeWan
Revision 1.03
-----------------------------
reading E:\Games\quake2\baseq2\maps\q24.bsp
reading E:\Games\quake2\baseq2\maps\q24.prt

************ ERROR ************
LoadPortals: couldn't read E:\Games\quake2\baseq2\maps\q24.prt

#### Finished with exit status 1

#### Executing 'E:\Games\quake2\baseq2\qrad3.exe q24'
----------- qrad3 ----------
original code by id Software
Modified by Geoffrey DeWan
Revision 1.04
Compiled for Pentium processors
-----------------------------
gamedir set to E:\Games\quake2\baseq2\
reading E:\Games\quake2\baseq2\maps\q24.bsp
Couldn't load E:\Games\quake2\baseq2\textures/__tb_empty.wal
No vis information, direct lighting only.
0...1...2...3...4...5...6...7...8...9... (0)
0...1...2...3...4...5...6...7...8...9... (0)
writing E:\Games\quake2\baseq2\maps\q24.bsp
0 seconds elapsed
#### Finished with exit status 0

Here's the map:

https://drive.google.com/open?id=1Aewjw4W7CVy729usfuW757d1DemlUbZp


Any help would be greatly appreciated! 
@errantcapy 
Have you tried 'File > Load Point File'? It should tell you where the leak is.
Have you tried different textures? The compiler complaining about __tb_empty means you have untextured brushes. Not all textures seal against the void.

I can see that the geometry shouldn't be leaking, but I don't have Q2 or its compilers installed. 
Default Backpack Values 
Hi nathnolt. Afraid that can't be done without modifying the QC. Map hacks involve getting interesting effects from setting values in fields which the QC has assumed are set to default. If the QC explicitly changes a field, you can't tell it not to do that.

Sometimes you can work around things the QC does, either by:
- using a hack earlier on to prevent the offending QC running
or
- running another hack after the offending QC to overwrite the value
Neither of these work for the ogre ammo, because the ammo value is set in the same function which drops the backpack. If you found a way to skip that, you'd skip the backpack spawning as well. If you rewrote the ammo value later (which might not be possible anyway...) you've missed the change for it to count. 
Map Hacks 
Thanks @Preach, both for your reply and your website. Is there a list with the combined knowledge of map hacks and/or entity knowledge? 
Trigger_cdtrack Transfering From AD To Progs_dump? 
Hi.
Now that I'm getting closer to finish alpha-stage of my map, I'm wondering if I could implement the trigger_cdtrack from Arcan Dimensions to my progs_dump.
I have the fteqcc but absolutly no idear where to start.
Is there someone into QC who can tell me how to do this?

best wishes 
GunSgt 
It's pretty involved. AD is a near re-write of the QuakeC logic so lifting anything from AD is a pretty advanced IMO.

That said I have not looked at that code so maybe it's a straight port?

QuakeWiki Modding Tutorial:
https://quakewiki.org/wiki/Getting_Started_Modding

QuakeC tutorial:
http://www.insideqc.com/qctut/

QuakeC Reference Manual in PDF:
http://pages.cs.wisc.edu/~jeremyp/quake/quakec/quakec.pdf

QuakeC Manual website version (with nice text formating):
http://www.cataboligne.org/extra/qcmanual.html

FTEQCC compiler:
http://fte.triptohell.info/moodles/fteqcc/

FTEQCC documentation:
http://icculus.org/~marco/quakec/fteqcc_manual.txt

Progs v1.01 source code:
https://github.com/id-Software/Quake-Tools/tree/master/qcc/v101qc

Progs v1.01 source code: (cleaned):
https://gitlab.com/quakec-v1-01-clean/quakec-v1-01-clean/commits/master

Progs v1.06 source code:
http://www.moddb.com/games/quake/downloads/quake-c-version-106

Hipnotic SDK:
http://www.gamers.org/pub/idgames2/more_idstuff/hipnotic/ 
@dumptruck_ds 
Wow! Thanks!

A lot to read.

Thought of a free weekend. Haha :)

best wishes 
GunSgt 
I will take a look at this qc for you as well but no promises on any real code unless it's something simple! 
Map Hacks 
Hi nathnolt, bit of self promotion but you could start with the map hacks posts on my blog. The earlier ones tend to be the simpler ones...

https://tomeofpreach.wordpress.com/category/map-hacks/ 
More Hacks 
@ZungryWare has compiled an exhaustive list of hacks here:

https://scalar.vector.im/etherpad/p/r.6ad54765f5b9b714d4501dbb1b728c7f 
Thanks 
Thanks everyone for the help & support. 
 
also if you haven't seen it yet, there is a whole long-running thread about map hacks:

Teaching Old Progs.dat New Tricks 
@dumptruck_ds Re:trigger_cdtrack 
I think I've found all necessary functions in the progs and definitions.
I will try to copy and paste after the weekend and tell if it works. 
@dumptruck_ds Re:trigger_cdtrack 
I tried and failed.
Seems I've got to read more into detail. 
@GunSgtHighway 
I will take a look this evening. (I said that before but forgot.)

I will report back here. Adding a reminder on my phone for after work. 
@GunSgtHighway 
I was able to get a CD track to play using the built-in command SVC_CDTRACK

I have a killable Chthon and added this to the end of the function where he gibs.

WriteByte (MSG_ALL, SVC_CDTRACK);
WriteByte (MSG_ALL, 3);
WriteByte (MSG_ALL, 3);

Track 3 played perfectly from my music directory.

You need to repeat the 2nd command for it to work. In Quakespasm I got developer errors about not finding the CD track but that is only in dev mode and the music still plays. If you need further help I would need to see what you are coding.

As far as using the AD functions, that's a bit too much work for me and I am not sure I could get it to work properly. Try the built-in id function first. 
@dumptruck_ds 
Thank a lot!

i was able to find the code for cdtrack in the targets.qc and built it in the progs.dat but finaly struggled, from my point of view, with the definition of the functions.

I*m looking forward to check the SVC_cdtrack this week and tell you if it works.

best wishes. 
Fun Fact Time! 


WriteByte (MSG_ALL, SVC_CDTRACK);
WriteByte (MSG_ALL, 3);
WriteByte (MSG_ALL, 3);

Track 3 played perfectly from my music directory.

You need to repeat the 2nd command for it to work.


The second writebyte is setting a variable called cl.looptrack - which on first glance you would expect would control whether the track loops or not. Surprise! It's not actually implemented in the engine, so the track always loops. You are free to send any number in the second WriteByte, it doesn't need to be the same as the track number.

If you'd like to play a CD track without it looping, the alternative is to use stuffcmd with the console command "cd play 3". You can also replicate the looping cd track from the SVC_ command with "cd loop 3". 
Re: SVC_CDTRACK 
Ok, I thought the whole thing over and came to the conclusion that whatever I will do, I have to make it a trigger_cdtrack. Otherwise it will not work with the mod.
That means getting into the whole qc-thing and read a lot.
So at this point I will finish mapping first before doing anything else.
Thanks to dumptruck_ds and preach for the assistance!
Hope I can ask you again when the job is done.

best wishes 
Trigger_command 
One last thought: If the mod you're using has the equivalent of
trigger_command then you can use the console command to achieve what you're after without modifying it. 
@Preach 
I looked at the code again and wondered why my attemp doesn't work.
I copied the trigger_cdtrack function (is equal to the code dumptruck_ds showed with a -change and -use procedure) from AD's target.qc to my progs_dump/triggers.qc next to the trigger_relay function and compiled the progs.dat.
Then I copied the trigger_cdtrack definition from AD's .fgd to my progs_dump.fgd with the windows editor.
When I entered Trenchbroom and changed to the new fgd (in new progs_dump folder with the changed progs.dat) I got this message: "progs_dump_112.fgd': At line 1, column 1: Unknown entity definition class '//'".
I think I'm not to far from a solution.
Have I missed to change or add something in the progs or done a failur in the fgd? 
 
looks like invalid characters in the fgd 
Byte Order Mark 
Yeah, if you encode the sequence "" in the default windows codeset and decode that as UTF8 you get character FEFF (a byte order mark). Working backwards I guess the program you used to edit the fgd saved the file as UTF-8 and added a byte order mark. Trenchbroom is then opening the file as 8-bit windows codeset text and seeing garbage at the top. Suggest you reopen the cfg file and save it in ascii format, which should get rid of the garbage. 
@Preach 
It should have been saved in ANSI.
I will try to save in Unicode and use notepad if it doesn't work. 
Got It! 
So. This challange is masterd.
For no reasons, the widows editor saves automaticly in UTF-8. So I changed that in ANSI and now theres a trigger_cdtrack in trenchbroom.:)
That's the good news.
The other is that I was wrong about the compiling.

Whatever progs.dat I decompile and recompile ,with fteqccgui64, I get messages like this:"defs.qc:328: error: "ev_field" is not a type in function SUB_CalcMove (line 61), subs.qc:66: error: Unknown value "tspeed"Errors have occured Error in defs.qc on line 328."
The funny thing is that fteqcc shows erros, but
the progs work.

I have absolutly no idea what happens here. 
Job's Done 
Built from the source. Now it works. 
 
how check max entities limin in trenchbroom? 
Urban Mercenary Level 
Please can someone help me I tried to convert a .bsp2 map to .bsp1 for a game that uses the Quake 1 Engine, but it gives me error ModLoadBrushModel has wrong version number .... should be 29, how can I solve? 
A Mystery In Quakespasm 
Hi.
Yesterday I got a fascinating problem.
Got the message Alloc Block: full and started to solve the problem like usual.

replaced every bad texture. -nothing
deleted or repaired every unclean brush. - nothing
deleted over 60 lights. -nothing
deleted all trenchbroom autosaves. -nothing
deleted all the maps .bsp, .lit, config,... and recompiled the map. -nothing

Sollution:
Deleted Quakespasm and reinstalled. No Error anymore.

Has anyone an idea what happend?
I think this would be usefull to everyone.

best wishes 
@GunSgtHighway 
@GunSgtHighway 
Sollution:
Deleted Quakespasm and reinstalled. No Error anymore.


I'm wondering whether you may have replaced an older version of QuakeSpasm with a newer version? The newest is 0.93.2, released November 2019.

From the thread dumptruck_ds linked:

metlslime: This is caused by lightmaps.

From the README for QuakeSpasm 0.93.2:

Lightmaps are now dynamically allocated (from QSS), and BLOCK_WIDTH/HEIGHT raised from 128 to 256.

So if you replaced an older version with 0.93.2, I guess this would be why that error went away? 
@iw 
Ahhh, enlightened!

I installed the newest version.
So it is a change in Quakespam.

Thank you very much.

best wishes. 
As Random As Always 
Who said trisouping can only be used for terrain?

https://imgur.com/g3VitLV
https://imgur.com/MhidjfN 
Textures With Permissive Licenses 
where to find them? CC0, CC-BY, etc. i love evillair stuff 
Lazarus Misc_actor / Target_anger 
Hi guys, nearly got my new Q2 map ready for playtesting but struggling with a particular issue.

I'm using the Lazarus misc_actor to have a friendly marine attack some Strogg enemies but I want the friendly guy to stand still in one place while he shoots the bad guys.

I'm using the "Hold" spawnflag on the target_anger to achieve this:

HOLD Spawnflag (=16)
The target_anger will cause the misc_actor/monster_* to stand in place and not run around.


...but it seems to have no effect. The actor runs around trying to get close to the Strogg and, while he will occasionally shoot them, when he happens to find himself with a suitable angle to do so, he's largely useless and stupid.

Has anyone here used this feature in Lazarus and managed to get the actor to stand still when he's told to? 
Elevator Multi Level And Combining Mods? Help Lease. 
Hi,
New and signed up just for this! Really enjoying my first foray in mapping for quake.
As per title, I know you can make multi direction elevators with progs_dump mod (dowloaded from Dumptruck DS)
However I'm enjoying using AD mods for all the excellent extras it includes. - I cant figure out how to do it (multi level elevator) with AD!
Is there a way to combine mods? I can't find a way to do this anywhere either! ...or maybe a tutorial on how to customize my own mods and features / combine mods?
(on a side note, I spent 4 hours trying to raise/lower water into an electrified basement room!!! Urgh...failed)

Apologies if this has been asked before, please link to post if that's the case. Much appreciated.

Thanks in advance and I'll upload my maps in time! hopefully! 
@XG 
1)NO combining MODS.

2)Load AD and type "map test_2floorplat"
in the console.

Map is in the AD maps folder. 
Elevator Multi Level And Combining Mods? Help Lease. 
@damage_inc thanks for that will reverse engineer, This is a blast. 
21 posts not shown on this page because they were spam
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.