News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread:
First | Previous | Next | Last
Thank a lot!

i was able to find the code for cdtrack in the targets.qc and built it in the progs.dat but finaly struggled, from my point of view, with the definition of the functions.

I*m looking forward to check the SVC_cdtrack this week and tell you if it works.

best wishes. 
Fun Fact Time! 

WriteByte (MSG_ALL, 3);
WriteByte (MSG_ALL, 3);

Track 3 played perfectly from my music directory.

You need to repeat the 2nd command for it to work.

The second writebyte is setting a variable called cl.looptrack - which on first glance you would expect would control whether the track loops or not. Surprise! It's not actually implemented in the engine, so the track always loops. You are free to send any number in the second WriteByte, it doesn't need to be the same as the track number.

If you'd like to play a CD track without it looping, the alternative is to use stuffcmd with the console command "cd play 3". You can also replicate the looping cd track from the SVC_ command with "cd loop 3". 
Ok, I thought the whole thing over and came to the conclusion that whatever I will do, I have to make it a trigger_cdtrack. Otherwise it will not work with the mod.
That means getting into the whole qc-thing and read a lot.
So at this point I will finish mapping first before doing anything else.
Thanks to dumptruck_ds and preach for the assistance!
Hope I can ask you again when the job is done.

best wishes 
One last thought: If the mod you're using has the equivalent of
trigger_command then you can use the console command to achieve what you're after without modifying it. 
I looked at the code again and wondered why my attemp doesn't work.
I copied the trigger_cdtrack function (is equal to the code dumptruck_ds showed with a -change and -use procedure) from AD's target.qc to my progs_dump/triggers.qc next to the trigger_relay function and compiled the progs.dat.
Then I copied the trigger_cdtrack definition from AD's .fgd to my progs_dump.fgd with the windows editor.
When I entered Trenchbroom and changed to the new fgd (in new progs_dump folder with the changed progs.dat) I got this message: "progs_dump_112.fgd': At line 1, column 1: Unknown entity definition class '//'".
I think I'm not to far from a solution.
Have I missed to change or add something in the progs or done a failur in the fgd? 
looks like invalid characters in the fgd 
Byte Order Mark 
Yeah, if you encode the sequence "" in the default windows codeset and decode that as UTF8 you get character FEFF (a byte order mark). Working backwards I guess the program you used to edit the fgd saved the file as UTF-8 and added a byte order mark. Trenchbroom is then opening the file as 8-bit windows codeset text and seeing garbage at the top. Suggest you reopen the cfg file and save it in ascii format, which should get rid of the garbage. 
It should have been saved in ANSI.
I will try to save in Unicode and use notepad if it doesn't work. 
Got It! 
So. This challange is masterd.
For no reasons, the widows editor saves automaticly in UTF-8. So I changed that in ANSI and now theres a trigger_cdtrack in trenchbroom.:)
That's the good news.
The other is that I was wrong about the compiling.

Whatever progs.dat I decompile and recompile ,with fteqccgui64, I get messages like this:"defs.qc:328: error: "ev_field" is not a type in function SUB_CalcMove (line 61), subs.qc:66: error: Unknown value "tspeed"Errors have occured Error in defs.qc on line 328."
The funny thing is that fteqcc shows erros, but
the progs work.

I have absolutly no idea what happens here. 
Job's Done 
Built from the source. Now it works. 
how check max entities limin in trenchbroom? 
Urban Mercenary Level 
Please can someone help me I tried to convert a .bsp2 map to .bsp1 for a game that uses the Quake 1 Engine, but it gives me error ModLoadBrushModel has wrong version number .... should be 29, how can I solve? 
A Mystery In Quakespasm 
Yesterday I got a fascinating problem.
Got the message Alloc Block: full and started to solve the problem like usual.

replaced every bad texture. -nothing
deleted or repaired every unclean brush. - nothing
deleted over 60 lights. -nothing
deleted all trenchbroom autosaves. -nothing
deleted all the maps .bsp, .lit, config,... and recompiled the map. -nothing

Deleted Quakespasm and reinstalled. No Error anymore.

Has anyone an idea what happend?
I think this would be usefull to everyone.

best wishes 
Deleted Quakespasm and reinstalled. No Error anymore.

I'm wondering whether you may have replaced an older version of QuakeSpasm with a newer version? The newest is 0.93.2, released November 2019.

From the thread dumptruck_ds linked:

metlslime: This is caused by lightmaps.

From the README for QuakeSpasm 0.93.2:

Lightmaps are now dynamically allocated (from QSS), and BLOCK_WIDTH/HEIGHT raised from 128 to 256.

So if you replaced an older version with 0.93.2, I guess this would be why that error went away? 
Ahhh, enlightened!

I installed the newest version.
So it is a change in Quakespam.

Thank you very much.

best wishes. 
As Random As Always 
Who said trisouping can only be used for terrain? 
Textures With Permissive Licenses 
where to find them? CC0, CC-BY, etc. i love evillair stuff 
Lazarus Misc_actor / Target_anger 
Hi guys, nearly got my new Q2 map ready for playtesting but struggling with a particular issue.

I'm using the Lazarus misc_actor to have a friendly marine attack some Strogg enemies but I want the friendly guy to stand still in one place while he shoots the bad guys.

I'm using the "Hold" spawnflag on the target_anger to achieve this:

HOLD Spawnflag (=16)
The target_anger will cause the misc_actor/monster_* to stand in place and not run around.

...but it seems to have no effect. The actor runs around trying to get close to the Strogg and, while he will occasionally shoot them, when he happens to find himself with a suitable angle to do so, he's largely useless and stupid.

Has anyone here used this feature in Lazarus and managed to get the actor to stand still when he's told to? 
Elevator Multi Level And Combining Mods? Help Lease. 
New and signed up just for this! Really enjoying my first foray in mapping for quake.
As per title, I know you can make multi direction elevators with progs_dump mod (dowloaded from Dumptruck DS)
However I'm enjoying using AD mods for all the excellent extras it includes. - I cant figure out how to do it (multi level elevator) with AD!
Is there a way to combine mods? I can't find a way to do this anywhere either! ...or maybe a tutorial on how to customize my own mods and features / combine mods?
(on a side note, I spent 4 hours trying to raise/lower water into an electrified basement room!!! Urgh...failed)

Apologies if this has been asked before, please link to post if that's the case. Much appreciated.

Thanks in advance and I'll upload my maps in time! hopefully! 
1)NO combining MODS.

2)Load AD and type "map test_2floorplat"
in the console.

Map is in the AD maps folder. 
Elevator Multi Level And Combining Mods? Help Lease. 
@damage_inc thanks for that will reverse engineer, This is a blast. 
8 posts not shown on this page because they were spam
First | Previous | Next | Last
Post A Reply:
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.