News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread: http://www.celephais.net/board/view_thread.php?id=60097
First | Previous | Next | Last
 
Also does anyone know what map has a "bloodfall" texture? I think I recall playing a map that had one but I can't remember what map. 
@lpowell 
Insomnia map3, end of Travail ep1, probably some Zerstorer/Zer.jam maps 
 
Ah sweet. Reminds me I need to replay Insomnia and Travail. I don't think Zerstorer has one because I'm already using zerstorer.wad. (Love those "viscera" water textures.)

Thanks. 
Same Isue 
Hey mate, any luck with this one?
I have the same issue, trying to find a way to increase, I assume the hunk allocation of memory... so far no luck. Let me know how ya go / went... 
Hunk_alloc 
Hi, please ignore previous post :O
I’m well into my first level now, after following dump truck tutorials. Using AD current version. However, I’ve hit a snag re hunk_alloc when compiling completes. I’m using quakespasm and upon launch, Quake crashes with ‘hunk_alloc at #######’ - I’m fairly certain my level is far from optimised...And it’s quite large. (I will attempt to cut it down and split into multiple maps eventually) but for aesthetic reasons I can’t yet... as it’s a ‘hub’ city / difficulty select / start map and relies on line of site to buildings etc. outside of the play area.
Thanks in advance. I’m new to all this, so I’d also love to share some pics etc. - some of the maps here are AMAZING! I’ve a long way to go!!
Cheers. 
Small Field Of Vision 
Hello,

I have a very large room full of entities. When the player stands in the corridor leading to that room, the walls, floor and ceiling of it restrain considerably the field of vision: just a very small portion of the room is visible and 99% of the many entities are out of sight.

Here is a picture of the setting: http://earthday.free.fr/partages/hexenworld/field-of-vision.jpg
(the red thing is the cone of vision, and the red rectangle its projection onto the room's front face).

Yet there is one brush entity which should be seen because partly in the red and partly out of it, but it's invisible until it suddenly appears when the player approaches very close to it. As if until the very last moment out of sight entities were still taken into account and were to many to calculate, thus exceeding the rendering limits.

Does that make sense?
Is there a way to prevent the engine from calculating out of sight entities over supposedly visible ones?

Any clue will be very welcome...
I precise that I can't move to a more powerful game engine because I'm mapping for Hexen II, so there are so few compatible engines already that if I deliberately exclude some of them, almost nobody will be able to play my map! ^_^; 
How To Make A Conveyor Belt? 
Is there a way to make a conveyor belt? In newer doom source ports you can make a brush with a scrolling texture and it will carry entities. I want something similiar.

I tried making a brush with an animated texture and have a trigger push carry entities but with trigger push affects player's movement in a negative way. Another idea I had was to make lots of small platforms that move but that seems like a really hacky way to do it. 
Convoyer Pets 
It's been a hardbreaker from the moment I tried to lay hold on it. Conveyor belts and quake func_trains don't like eachother, that is what timing concerns.
When you're really as mad as me you might try a static like this.

On ther other hand I spend a few moments to get a solution for it. It isn't that hard, you can do with two func_trains. That is.., when you fine tweak it to the right moment.
Here is an example, although it still has a wig in it. I went really domino after a few houres, but I think it can be done.

"Four feather" has a fine way of doing it, but it are all statics. So no.., I don't have a real solution than tweaking two func_lifts. Size, distance, time. 
Hexen 2 Water 
Hey guys, I'm working on my map using trenchbroom and erics tools; I've got a body of water and I assign it to func_detail but this means the water is not transparent, despite any settings.
If I set it to func_wall, I can provide the spawnflag for translucency, but then it's not water any longer.
Any suggestions on what I do here? 
 
what if you don't assign it to func_detail? I don't see a good reason to make water "detail" 
 
Just like metlslime I wonder the reason why. Could you be more precise about what you're trying to do please? 
Water 
Doesn't need to be an entity to be transparent. You need to set 'wateralpha 0.5' or whatever number you prefer at the console. 
Water 
Like ijed said, set wateralpha to a value you like but remind that it's a key that has to be set in the worldspawn.
The wateralpha only has an effect on the texture "in game". You don't see it in trenchbroom.
For the brush, worldspawn and func_wall always work well. 
Why Am I Getting Full Bright Brushes? 
https://imgur.com/a/Eikqkr2

I've deleted every light entity and light related worldspawn setting I can find but still get it :/ 
Fullbright's & Comments Textures 
Texture of brushes are divided in opaque and fullbright's. Opaque are all brushes that won't reflect light as wall texture. Ornaments like light bulbs or flame mouths are fullbright. They don't need lightning of a map to reflect light.
Like a doormark they glow from themselves, so.., an unlighted map will still make a fullbright texture glow. 
 
Possibly some accidentally-set _minlight field on some func_detail or func_group? 
 
hmm I couldn't find anything like that in the map file but I saved it under a different filename and that fixed it hah 
 
Could have been an outdated .lit file then. 
It's Like Madfox Says 
Those red light textures in particular are from the 'fullbright' section of the palette and ignore lighting, always showing at full.

Listed as 'Brights' here: https://quakewiki.org/wiki/Quake_palette

If you want a dark version, copy then edit the texture in Wally, substituting the colours for ones not on that particular row.

Then you can toggle the textures on it, if you make it an animation and the brush a func_wall.

You can also make those textures actually emit light using EricW's tools: https://ericwa.github.io/ericw-tools/ 
He Wasn't Talking About The Red Lights, Though 
 
 
I like negke's lit file theory.@zqf did you check for that and delete it? 
 
Saving under different filename fixed it, i too do think old lit file is the cause. 
 
Doesn't appear to be a lit file. It isn't present in the directory I'm testing from.
There is an error about a mismatching 'texinfo flags' during compile, could it be that? 
Ahh 
Sorry - saw the image on a phone so blanked on the glaring obvious.

And the incognito name got me :) 
 
Stop blinking headphone! 
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.