News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread: http://www.celephais.net/board/view_thread.php?id=60097
First | Previous | Next | Last
Why Am I Getting Full Bright Brushes? 
https://imgur.com/a/Eikqkr2

I've deleted every light entity and light related worldspawn setting I can find but still get it :/ 
Fullbright's & Comments Textures 
Texture of brushes are divided in opaque and fullbright's. Opaque are all brushes that won't reflect light as wall texture. Ornaments like light bulbs or flame mouths are fullbright. They don't need lightning of a map to reflect light.
Like a doormark they glow from themselves, so.., an unlighted map will still make a fullbright texture glow. 
 
Possibly some accidentally-set _minlight field on some func_detail or func_group? 
 
hmm I couldn't find anything like that in the map file but I saved it under a different filename and that fixed it hah 
 
Could have been an outdated .lit file then. 
It's Like Madfox Says 
Those red light textures in particular are from the 'fullbright' section of the palette and ignore lighting, always showing at full.

Listed as 'Brights' here: https://quakewiki.org/wiki/Quake_palette

If you want a dark version, copy then edit the texture in Wally, substituting the colours for ones not on that particular row.

Then you can toggle the textures on it, if you make it an animation and the brush a func_wall.

You can also make those textures actually emit light using EricW's tools: https://ericwa.github.io/ericw-tools/ 
He Wasn't Talking About The Red Lights, Though 
 
 
I like negke's lit file theory.@zqf did you check for that and delete it? 
 
Saving under different filename fixed it, i too do think old lit file is the cause. 
 
Doesn't appear to be a lit file. It isn't present in the directory I'm testing from.
There is an error about a mismatching 'texinfo flags' during compile, could it be that? 
Ahh 
Sorry - saw the image on a phone so blanked on the glaring obvious.

And the incognito name got me :) 
 
Stop blinking headphone! 
Hiding Brush Edges In TrenchBroom 
It's been years since I last touched TB, but I clearly remember being able to toggle viewing brush edges when I used it back then. In the latest version, I can't for the life of me find this option in any of the menus.

Help...? 
Never Mind 
Found it. Of course, TrenchBroom still for some reason has two separate menus called "view". 
Wheel Of Karma: A Tulku Odyssey - Part 1 
(Sorry to post here since it's not asking for help actually, I already made 2 attempts in the 'News' threads but my post was thrown out :-((( )


Hello everybody,

I am specialized in mapping for Hexen II but some of you kindly offered precious help, advice and even benevolent participation during my mapping process, so I thought you might be interested in having a look at the brand new expansion pack I just released for Hexen II.

So...
PLEASE LADIES AND GENTLEMEN
Let me glady introduce you my very first mapping work: 'Wheel Of Karma: A Tulku Odyssey'
Downloadable here: https://drive.google.com/file/d/12BK7oNYB1YaklJ6fN8fnSA0NdEB6nGlS/view?usp=sharing

It is a sequel to the official 'Portal Of Praevus' expansion game (which is therefore needed) which focuses on storyline, puzzles, a somewhat out-of-the-box touch, unexpected revisits of familiar entities and even a light RPG flavour...

Here is just Part 1, it will be a full campaign of about 20 to 30 maps probably, but I'll release it bit by bit over time.

Please don't hesitate to give tons of feedback: very rewarding for a beginner mapper, and will help me to fix issues in the next releases.
(And sorry in advance for the very amateur touch of the architecture and designs compared to the visual awes you're used to)

Screenshots here (if the link works):
https://www.moddb.com/mods/wheel-of-karma-a-tulku-odyssey/images/

(uhexen2.exe is the only known engine correctly handling the mission pack to date, you'll have to put it in your Hexen II directory) 
 
Inky: I just approved your news submission. I guess all the mods were asleep at the same time, so nobody saw it until now. 
@metlslime 
Oh, great! Thank you! 
Teleport Help 
New to Quake mapping and I'm running into an issue where every time I teleport a wizard it telefrags! I have separate teleport destinations per-wizard. I tried adding different relays per wizard with different delays and it still doesn't work. I tried just teleporting one wizard and he still telefrags.

Is there something I'm missing like maybe my monster closet setup is busted? 
Overlap 
Loveschach - is there any chance you've accidentally got two wizards stacked together? 
Teleport Help Cont'd 
Preach - The teleport destinations aren't stacked. Do they telefrag if they're stacked on the other end? There may be slight overlap. 
 
the trigger_teleports need to be spread apart and the monsters themselves spread out, one per teleport 
Teleport Help Cont'd 
I confirmed with a little noclip and notarget that the teleports will work as long as the monsters don't aggro. For some reason, even though I have the ambush flag set they're always aggroing due to the sounds of shooting. I switched the wizards to ogres and confirmed the same thing happens.

I'm not sure why ambush flag isn't working, is this easily fixable, or if not, is there a way to set an enemy hearing range so I can hack around it? 
 
The ambush flag not working is a surprise, what mod are you using? Or just standard id1?

I’m guessing the teleported triggers are all next to each other and the awoken monsters are walking into their neighbors teleport trigger. One fix would be confining each one into separate boxes so they can’t walk out of their triggers. 
Teleport Help Cont'd 
I'm using Quakespasm with Trenchbroom, I believe this is standard id1 so I'm gonna say yes!

Putting them in separate boxes is a good idea, I'll try that solution. Thank you! 
Teleport Help Final 
Well, I was looking at the output from the compiler and there were some warnings about empty target properties so I decided to take a shot in the dark and it fixed the issue. So for any future people who might have this problem, there you go! 
Disappearing Doors 
Hi, I'm new to quake mapping.

I was very close to finishing my first map and suddenly my func_doors started disappearing. This isn't just a visual problem, the collision is disappearing as well. I have a lot of doors in my level, is there some kind of limit? I tried different tool sets and the same thing still happens. Any advice would be appreciated. 
 
Do all doors have seperated targets? It can happen when one of the door initials is not corresponding.
Are there any compile errors? 
 
I noticed I had some dangling targets then noticed I had a bunch of doors on top of each other that I didn't know about. Deleted the extra doors and it seemed to work, I'm not sure if it was because of the targets or doors. Thanks for the help! 
Teleport Out Of Map 
Hi, Please I have a problem with the map I'm currently working on, it's really strange...
When I get to a certain point the map "teleports" me out of the map in a strange way... I have recorded a video if someone knows wtf is happening...

I have check entirely the log and all its fine

thank you very much!!

https://www.facebook.com/100000983447601/videos/3464460793596668/ 
#20546 
The playable area of a Quake map can't be further than 4096 Quake units from the centre of the world (where the x, y and z axes intersect). When you move beyond that, you see the kind of thing happening like in the video you posted.

Either your map is too big (i.e. bigger than 4096^3), or more likely it's simply off-centre. If the latter, select everything in your map and move it so it extends more or less an equal distance in all directions.

If the map really is too big, there are solutions for that too, but try centring the map first. 
 
Thanks!!!!!! It works!!!!!!!!!!! Very grateful 
Sorry, I Meant 8192^3 Of Course 
No problem; happy to help :) 
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.