News | Forum | People | FAQ | Links | Search | Register | Log in
How To Make A .wad File Into A .hlwad File Using Texmex Under Windows.
OK I think this should work for people who have had no luck converting their .wad files into .hlwad files under Windows.

1. Open TexMex.

2. Drop your .wad file into TexMex.

3. Click on File => Save Copy => Save to WAD3.

4. Pick your output directory and clear the name field, then type (without quotes:- yourname.hlwad and press enter.

5. Navigate to the output directory and find the output file (make sure file extensions are visible on known file types) and rename to file from yourname.hlwad.wad to yourname.hlwad (i.e. delete the .wad extension).

Seemed to work for me so anyone else care to give it a try?

Ricky
Link To Download The Stuff You Need To Do This: 
Another Thing 
You have to delete the All_Wads_to_Hlwads.exe program from your program files\worldcraft\textures DIR. It will attempt and fail to replace all of the texmex output with its own, and some wads will convert with TexMex but not with THAT util due to restrictions. It will do this automatically when you try and run WC3.3. 
It Works 
 
Interesting 
thanks Ricky! 
 
whats really wild is that i needed to know how to do this just two days ago. thanks man. :) 
A Little Help? 
not good with computers so bear with me.

Attempted to do this with jf2.wad.
I can see jf2.hlwad.wad when I look in the textures folder in Texmex, but not when I look in My Computer.
Probably an easy fix, but I'm not quite sure what to do.
Any suggestions? 
Oh 
Also.
I'm on windows 7, and when I see the file in Texmex, there is a small lock on the symbol. 
Hmmm 
OK, try doing it again from scratch, in a seperate DIR on your c:. Once you have exported from TexMex, close TexMex down completely. Then find the file and re-name. Also double-check that you are not running Worldcraft and the bloody All_Wads_To_Hlwads.exe before re-naming the file. Im also using Windows 7 (64), so it should eb possible for u if it's possible for me ;) 
Where Can I Find Jf2.wad 
So that I can try this myself? Doesn't seem to be on quaddicted :O 
At The Rub2 Site 
OK, Thanks Metl 
Well I managed to make the hlwad, I just opened the wad file with TexMex, chose "Save Copy" under the file menu, saved it as "jf2.hlwad"(.wad) then straight away I closed TexMex, then I found the the file in the output DIR (in this case c:\program files\worldcraft\textures\), deleted the .wad extension. BadaBIng, BADABOOM! 
No Badaboom For Me. 
still not working... it just won't show in the output directory in my computer, and still shows up in tex-mex... 
I Had That Problem 
Unfortunately i couldn't figure it out. I think there were little locks on the files also. 
That Sounds 
Like User Account Control blocking it. 
What Happens If You Output 
Then go to 'load' from texmex, navigate to the outputted file, re-name, make a copy of, and possibly 'zip' the file, just from the load panel in TexMex - I think Windows 7 explorer will let you do that. This way you are tricking explorer into seeing the outputted file as a different file. 
Okayt 
just tried and no success yet. From within Texmex load panel I selected the file and then sent it to a zip... which also has a lock on it, and cannot be seen in My Computer.

have to head out now but will try later with UAC disabled. 
So Finally 
UAC was, as so often is the case, the culprit. 
Hmm 
Bloody hell portals. 
Attention! For The People Who Can't See It On The Output Folder 
If you can't see the wad file on your output folder, but when you go back to TexMex and click on openfile and see it with a lock. Just do this:

1.Do the same steps BUT save it to your desktop instead.

2. It will appear, now just rename it to a .hlwad
at the end

3.Now drag the file to your texture folder!

4.Enjoy Making Cool Maps with awesome Textures!!! :-D

NOTE: If you can't see the .wad extension on your file try these steps.

-Go to Control Panel

-Appearances and Personalization

-Folder options

-View

-Then make sure that "show extension files" do not have a check on the box.

Hope this was specific enough :) 
Daffa 
 
Daffa 
 
Rekt 
 
Rekt 
 
Qmaster 
 
Qmaster 
 
CONVERTING WADS 
Ok, I am using worldcraft 3.3 and Texmex and I tried to do the above instruction

1. Open TexMex.

2. Drop your .wad file into TexMex.

3. Click on File => Save Copy => Save to WAD3.

4. Pick your output directory and clear the name field, then type (without quotes:- yourname.hlwad and press enter.

5. Navigate to the output directory and find the output file (make sure file extensions are visible on known file types) and rename to file from yourname.hlwad.wad to yourname.hlwad (i.e. delete the .wad extension).

Seemed to work for me so anyone else care to give it a try?

Ricky


Nothing works there is something seriously wrong with this whole process.

I took a starfields.wad from "https://www.quaddicted.com/files/wads/"

Threw it into texmex

Save to WAD3

Cleared the name field, typed in starships.hlwad, it went into the new directory as starships.hlwad.wad ("Why do you think removing the extension... .wad is going to make this work?") the fact is this file is a .wad and removing the extension does not magically make it an .hlwad file. Texmex doesn't work. Before I tried to create an .hlwad file using texmex, I was told that all I have to do is place the wad inside my textures directory within worldcraft, however, this is not the case because apparently some need to be converted to work with the map editor. This is what I get when I add the .wad and the .hlwad file to my textures directory.

The result from worldcraft

BEGINNING EXAMINATION ...
=================================================
Number of Quake WADS found = 5
c:program filesworldcrafttexturesid_: Ok
c:program filesworldcrafttexturesrub: Ok
c:program filesworldcrafttexturesski: Ok
c:program filesworldcrafttexturessoe: Ok
c:program filesworldcrafttexturessta: Convert
=================================================
Number of WADs to Convert = 1
Beginning conversion ....... COMPLETE: 00:00 elapsed.
=================================================
= ERRORS DETECTED BY WCONV UTILITY - SEE BELOW =
=================================================

Error creating HLWAD: c:program filesworldcrafttexturesstarfields.hlwad ... details ...No log exists.
=================================================
END OF DATA .. Log written to c:program filesworldcrafttextureserror.log

I have also done it with quotes as someone suggested. When doing that the file within texmex changes from yourname.wad to yourname.hlwad but the file disappears. It is not visible within the directory.

I would really like to solve the issue because right now I am totally unable to use any .wad file out there. I can only use the limited textures I have currently.

EARP 
Probably The Good Old: 
Use a path without spaces in it, "Program Files" is problematic, "DirectoryWithoutSpaces" might work. 
OK - It Does Work, Let Me Give Some More Info That Might Help: 
First of all the log file that you output was from the utility that Baker bundled into the Quakeadapter (like a mod for Worldcraft that converts all .WAD files within c:\program files\textures\ to .HLWAD files - just part of the Quakeadapter package).

The point is that that isn't Worldcraft giving you those logs. The logs are irrelevant.

If you load Texmex and load your .WAD file, then click on 'file', then hover over 'save a copy' then select 'save to WAD3', it puts out a hlwad file.

The problem is that TexMex is so ancient that back then .hlwad files were called WAD3 files. And they had the extension 'WAD' (just to be a pain in the ass, they had the same extension as WAD2 files). So the extension is irrelevant.

BUT - YOU ARE HAVING A PROBLEM HERE!

I think that you can open Worldcraft 3.3 or Hammer 3.4 or 3.5 and then click 'Tools', 'Options', 'textures' then 'add wad', and then type into the 'File Name:' field '*.hlwad' (without quotes) and press enter. Then you simply double-click your starfields.hlwad file and it will be loaded into Worldcraft's texture library.

Either that or there is a massive discrepancy with the way my computer is working and the way your computer is working. 
Read Post #2 From This Thread Please 
You have to delete the All_Wads_to_Hlwads.exe program from your program files\worldcraft\textures DIR. It will attempt and fail to replace all of the texmex output with its own, and some wads will convert with TexMex but not with THAT util due to restrictions. It will do this automatically when you try and run WC3.3.

Got to do that part, it's vital.

Would a mod please put that in the sticky? Pleeaaease? I'll map.... 
 
I did

3. Click on File => Save Copy => Save to WAD3.

4. Pick your output directory and clear the name field, then type (without quotes:- yourname.hlwad and press enter.

5. Navigate to the output directory and find the output file (make sure file extensions are visible on known file types) and rename to file from yourname.hlwad.wad to yourname.hlwad (i.e. delete the .wad extension).

Put the file into c:\qtexture

then

moved that to the texture directory inside worldcraft within program files

it doesn't work

I am not sure what you mean by no spaces in directory but it sounds like what i did above

I can't get any texture wads to work at all no matter what wad I download and its frustrating

Error creating HLWAD is what I get everytime

If you mean

Place worldcraft into a different directory than within program files. The computer does not like it unless the program is in program files.

I am at a loss

EARP 
 
what is UAC? I see in this thread that it can be the problem? 
 
Oh user account control? what is that? 
Are You Seriously Trolling This Thread? 
READ THE FUCKING RESPONSE MAN!!!

You have to delete the All_Wads_to_Hlwads.exe program from your program files\worldcraft\textures DIR

If you don't do that, the All_Wads_to_Hlwads.exe will OVERWRITE the shiny new TexMex WAD3 file with a broken one!!!! It does this WHEN YOU LAUNCH THE EDITOR. Delete the file first, THEN repeat the whole process, then if it still doesn't work, we can have a conversation.

Best shiny regards

Richard. 
 
If you had deleted the 'All_Wads_to_Hlwads.exe' program from your program files\worldcraft\textures DIR , you would not even see this when you launch the editor:


BEGINNING EXAMINATION ...
=================================================
Number of Quake WADS found = 5
c:program filesworldcrafttexturesid_: Ok
c:program filesworldcrafttexturesrub: Ok
c:program filesworldcrafttexturesski: Ok
c:program filesworldcrafttexturessoe: Ok
c:program filesworldcrafttexturessta: Convert
=================================================
Number of WADs to Convert = 1
Beginning conversion ....... COMPLETE: 00:00 elapsed.
=================================================
= ERRORS DETECTED BY WCONV UTILITY - SEE BELOW =
=================================================

Error creating HLWAD: c:program filesworldcrafttexturesstarfields.hlwad ... details ...No log exists.
=================================================
END OF DATA .. Log written to c:program filesworldcrafttextureserror.log
 
Chill Winston! 
Seriously bro... 
Yeah I'm Probably Tripping 
 
So There's A Benefit Of Using Hammer Over VC 3.3 
there's no necessary to install editor onto program files folder you can install it wherever you want to.

converting textures using texmex is easier, just go
Click on File => Save Copy => Save to WAD3
an output file would be name.wad but its fully compatible with Hamrre, there's no need to rename extension to hlwad or whatever 
 
@RickyT23

I did

1. tools
2. options
3. add wad

after converting it to the hlwad extension in texmex and it worked

thanks, had so many problems with all of that

Thank God that is over with...

SKY TEXTURES

There is an unwanted effect I get when I place a sky texture on the wall instead of the ceiling, it would be nice to have a sky texture all the way around the board without that parallax error I am getting. In shadow warrior a great first person shooter game that I have played and mapped for, it also produced that error when placing the sky texture on the wall but there was a way to fix it in that game where the effect disappeared. I am trying to see if there is a way to get rid of that effect.

EARP 
EARP 
use a skybox to get rid of that awesome effect. 
 
@mfx yeah i read about that, I will have to see if I can find articles on it later...dang hall of mirrors :( 
Awesome! 
I'm glad you got it sorted :)

Some people like the original Quake warped sky effect! I prefer skyboxes too, but sometimes the old skool sky can go really well, especially in an abstract type of map :)

Skyboxes:
https://www.quaddicted.com/webarchive/kell.quaddicted.com/

How-to:
http://quakeone.com/114521-post41.html

Note: You can just put the sky textures in an id1/gfx/env folder, you don't need to do it within a pak file, as it says in the tut above. 
New Issue With Worldcarft Since Adding Wads 
@RickyT23 I will take a look at the skybox stuff, thanks...

ISSUE since Adding WADS

I am having problem with worldcraft 3.3 since I have been adding wads.

After I add so many wads I always get an error where worldcraft will no longer run for me.

I get "Worldcraft has stopped working" Check online for solution and close the program or just close the program"

I reinstall the quake adapter then it works again until I add the wads. sigh

There were a few wads I had that supposedly needed to have some textures resized before saving and I thought maybe that was the problem but I am still getting the error.

It happens after I close worldcraft and try to reopen the program.

EARP 
How Many Wads? 
I doubt I'll be of any help, but I've had like 20 wads loaded in WC at once.

will it not work even if you just have the normal quake textures (1 wad, all the right size)? 
 
It works fine when I add a bunch, then when I keep adding the ones I have downloaded it blows up in my face. I do not know why it is occurring.

I think I will add one wad at at time and see if I can narrow it down that way.

Maybe it is stupid windows and not the program.

I have never had a problem with worldcraft running until I added the additional wads.

I have been using the textures that are already inside worldcraft when I ran it. 
The Jackhammer Editor 
Is a modernized version of worldcraft with the same interface. 
 
worldcraft ver 3.3 not the 1.6 version (i think the 1.6 version was the older one?)

http://quakeone.com/qadapter/ 
Too Many Wads 
Five is where you will hit a wall in 3.3. I've run into this problem before. Either merge the wads (3.3 can handle large wad files, I want to say 600 textures per wad) or don't load them into the editor. 
OK, I Had Problems Which I Wasn't Expecting 
Found solutions:

Disable F@*king User Account Control

(google 'disable uac', requires restart after following procedure)

Run TexMex as administrator (right click the shortcut or application icon and click 'Run as administrator')

Then you can save your WAD file from TexMex to HLWAD by saving then re-naming.

Dumbassed Windows lol 
^^ Go 'File -> Save Copy -> Export To Wad3' 
 
Maybe This Is What Has Been Fucking Me Up... 
 
Yeah 
I guess I exactly reproduced what you described in #6.

I also have windows set up to display file extensions in folders (worth noting) 
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2017 John Fitzgibbons. All posts are copyright their respective authors.