News | Forum | People | FAQ | Links | Search | Register | Log in
The TrenchBroom Level Editor
Today I am releasing TrenchBroom 1.0 for Windows and Mac OS X. TrenchBroom is a modern cross-platform level editor for Quake.

Features
- True 3D editing, no 2D views required
- High performance renderer with support for huge maps
- Vertex editing with edge and face splitting
- Manipulation of multiple vertices at once (great for trisoup editing)
- Smart clip tool
- Move, rotate and flip brushes and entities
- Precise texture lock for all operations
- Smart entity property editors
- Graphical entity browser with drag and drop support
- Comprehensive texture application and manipulation tools
- Search and filter functions
- Unlimited undo and redo
- Point file support
- Automatic backup
- Support for .def and .fdg files, mods and multiple wad files
- Free (as in beer) and open source (GPLv3)
- Cross platform (Windows, Mac OS X and Linux supported)

Check out a video of TrenchBroom in action here.

You can download the editor here.

If you would like to give feedback, please do that in this thread. If you find a bug or have a feature suggestion, please submit them at the issue tracker.

If you are wondering where the Linux binaries are then sorry, but currently there are none. The Linux version has a few problems which I could not fix before this release. I will get working on those right away so that the Linux version should be available in a couple of weeks, too.

Finally, I would like to thank necros for all his work over the past year. Without his tireless efforts, TrenchBroom would simply not exist. Or it would suck.

Alright, enough of this. Have fun with the editor!
First | Previous | Next | Last
3point 
Hopefully this will help de-mystify what the third point is for, at least to the point where you understand it as well as I do (I'm moderately sure this is all it can do).

Here's a standard, 2-point clip:
http://i.imgur.com/7Mkebev.png

Then... Bam! 3rd point:
http://i.imgur.com/tvD7hDK.png

Try it yourself. Drag the 3rd point around and watch as the angle of the clip changes. Obviously this is a very basic example, but the general idea of it is that you can change the angle of your cut with this method.

I find it most useful for when TB doesn't "get" what you're trying to do because the 1st and 2nd points are too vague, since you can easily direct exactly how you want your cut to work using it.

Another cool trick is placing all your points on a flat plane, like so:
http://i.imgur.com/RuVVxLs.png
http://i.imgur.com/w730DjK.png
The third point tells TB that you actually want a horizontal cut, so you can easily perform that style of cut.

Here are some more fun cuts:
http://i.imgur.com/lqmFJRF.png
http://i.imgur.com/hxoVyW9.png
http://i.imgur.com/rkOTdiv.png

Hopefully that helps people figure out what the 3rd point is for. 
I Give You 3 Points 
Thanks Pritchard, that does help clear things up! 
Pritchard Gets It 
Bonus points for knowing the shortcut if you wish to use an existing face as a clipping plane! It'a in the manual ;-) 
Double Click The Face? 
 
 
A good tip is...unless you need another brush to snap a clipping point to, isolate the brush to be clipped.

If you try to place a clipping point at the edge of a brush where it meets another brush, sometimes itll get placed on the other brush.

I switched my "Hide" "Isolate" and "Unhide" to H I and U for this and other reasons. 
Double Post But While Im Thinking Of It: 
Thank you, Sleep, for implementing issue 1465 "Always show edges of selected brush" and 1460 "inspector keys open inspector window when closed"

Didnt even consider theyd be in the build eric provided so they were a very pleasant surprise to run into.

"Oh hey thats me!" 
Sure 
I made some good progress on 1499 recently and things are looking better. Hopefully I'all be able to provide new official builds soon. 
Always Show Edges Of Selected Brush 
Is going to be magnificent. 
SleepwalkR 
Try loading Shamblernaut's RJ5 map in the latest TB2 beta! 
No. 
If you have found a bug, then create an issue report plz. 
N00b Questions 
i'm learning the very basics of brush work
it's possible to move clipping points with arrow keys, like moving vertex points in the vertex edit mode?

or i just have to drag the orange dots?

can i snap the clipping points to edges and vertices of other objects? or the only snapping is to the grid?

i'm better off in general using CGS substracting if i want to avoid brushes with intersections?

another very basic question:

when you are resizing a face with non-parallel convexing lines (i don't know how to say it) like this:
http://imgur.com/a/oe08L

in one point the lines intersect. is there a way to resize until the two vertices intersect in a point (like a cone) or a line (like a wedge)?

btw i get the 3-point clipping. you need three linearly independent points to define a plane, and the editor makes a "guess" when using 2-point clipping to define a plane. it's like slicing a brush with a cutter 
Negke 
don't blame tb2 for my shitty maps =P 
Topher 
Be sure to check out the help file in About > Help for the basics on a lot of your questions.

If you still have issues post back! 
 
ok...
i quote from the help

"Note that you cannot change the number of faces of a brush by with the resize tool."

i missed that enterely. i think it might be useful. perhaps it's unnecesary, i don't know.
also, it's 'converging lines', that's what i meant.

--

"Alternatively, you can add two clip points at once by dragging with the left mouse."

and

"In the 3D viewport, you can only place clip points on already existing brushes, whereas in the 2D viewports, you can place them anywhere."

now i don't need to move clip points with the arrows.

--

CGS substracting is a question of the type of "is good practice or not?"

--

it seems that i can't snap directly to objects, so it's better to snap brushes to the grid and zoom if they are separated by 1 unit.
and using clipping, CGS and vertex. 
Subtract 
Glad to see the Help file ...helped!

As far as subtracting goes, I think it has come a long way...TB2 handles it fairly well. One thing I do is if I have an odd shape I plan to subtract, I will cut the brush into as small of a square as I can around the subtracting brush. That way there isn't so many crazy things going on after the operation!

For things like basic shaped hallways and such it it probably best to just create the brushes to form said opening. 
Arches? What's Your Method? 
I can never seem to do arches with any consistency. It's not that the end result is bad but I just seem to do mine by trial and error. How do other mappers approach creating an arched doorway? I am using TB2 and would love to how others approach this. 
 
Ive had the outline for an arch tutorial in my head for a few weeks. Lemme whip something up for ya. I think itll make quick sense of the black magic of arches. 
Mukor 
That would be greatly appreciated. And it seems like we have some new blood on Func who would benefit from this too. 
 
At first i tried this:
http://imgur.com/a/xRJqg
angles: 0�,30�,60�

but i didn't like that the arch is narrow in the top

so i made a 30� brush, duplicate, flip horizontally, and rotate with alt+up
http://imgur.com/a/2edZv 
 
You've got the right idea and it's good to see you trying it on your own before asking for help!

TLDR: Triangles!

http://imgur.com/a/tmtmz 
*the angles are:
90� (vertical) ; 60� ; 30�

the brush is 30�/60� 
Another Arch 
and the textures are aligned! i had to rotate 180� the textures of the two top brushes, but other than that...

i tried cliping in two ways, and in both the textures are aligned too. nice.

http://imgur.com/a/ax8oW

pd: yeah, absolutely no lights yet 
Mukor And Topher 
Thanks guys - this is really great and the key for me was slicing the inside corner (step 4). What I have been doing is clipping large sections of square shapes and "lifting" the vertices into position.

http://imgur.com/8YZlU6x

Clipping is so powerful when you see it done "correctly." Thanks again. 
#2404-2411 
Why is this here and not in the Mapping Help thread? It's not Trenchbroom-specific. 
Mugwump 
My bad for starting it here, I honestly thought I had posted originally in Mapping Help but saw the replies here. Going senile. 
 
Mugwump: Refer to post #2408 in this thread. I gave an arch tutorial that specifically mentions "for TrenchBroom 2". He is 100% in the right to post a response here...cause...well thats where the discussion originated. The tutorial mentions keyboard shortcuts specific to TrenchBroom.

topher: im glad i could be of some help. curved shapes troubled me for quite some time. 
 
Honestly, I don't mind and it's not that big of a deal in the first place, but a) the question could have garnered more editor-independent answers than Mukor's TB-specific reply and b) I know people here can be a little sensitive over this kind of things. 
Archie 
Thanks for sharing your technique Muk!

Would have been great to have had this when I was banging my head on how to create them last year! 
 
maybe we went a little offtopic

on topic
"face convex merging"
is this a feature? i didn't see it in the help

this software is very intuitive and full of shortcuts to save time

in a few days and aprox 6 hours of fiddling and some reading i'm getting confortable with shaping this simple brushes

http://imgur.com/a/IIcQ1 
Merger 
Convex merge is a fantastic feature and it looks like you already got the hang of it! To be honest, I don't know if I realized face selection would work with merging but I assume it is intended.

Keep going topher! 
 
Is the lag when clipping a large amount of brushes at once a known issue?

https://dl.dropboxusercontent.com/s/f8im492wkzjic2a/2016-12-21_00-13-13.mp4

I ask because although I've been living with it for a while (like many tb2 bugs - I'm really bad at reporting in a timely manner...), the more I trisoup for this map, the more of my time it takes up. It'd be nice to at least have a "won't fix" response, but I'm skeptical of submitting an issue because it may simply be something that comes with the territory of the operation... 
Clip 
I have encountered this before, sometimes it can happen with just a large brush that I am cutting in half. A bit random at times but infrequent enough that I never regarded it as an issue.

Doesn't hurt to submit an issue regardless. 
Yes, Submit Everything 
Seriously. I'm providing this app for free. The only price you have to pay is reporting the issues you find. Let me decide whether or not they are relevant. Don't sit on issues out of doubt whether they are issues or not. 
Windows Build From Today 
Much Appreciated 
Thank you! :D 
 
I have this irrational fear of annoying people by filling up their issue tracker... If I were running the project, I'd be obsessed with getting the open tickets down to 0 at all times...

I need to stop projecting. 
 
Noticing some... aliasing? is that the right word?

Noticing it on the version you just linked Eric.

http://imgur.com/a/MA4IL

JUUUUST opened it up so thats all I have for now. Ill be getting intimate with TB over the next few hours and Ill report back here or go straight to github with anything else. 
Yeah Same Here 
on macOS.

Is the "previous build" the one I linked to in November, 3cb0140 ? 
Filed An Issue For That: 
 
Yeah, my bad, i couldve been clearer on "previous build". But yep, the last version you linked me was without the aliasing issue present in the current build. 
 
Well thanks for letting me flex my computer know how!

i figured out I can set up AA for specific programs through my video settings! 
Pritchard 
Unfortunately, we'll never get it down to 0 anyway. Don't worry about it. The issue tracker is more like a todo list. 
AA 
Yep, lack of AA on the latest linked build.

However, I did try to reproduce the crash on map switch that I reported and I could not get it to crash! 
Beta 2 On Mac 10.6.8 
my mac is running osx 10.6.8 with opengl2.1 and glsl1.2 - when i run trenchbroom 2.0 out of my applications folder it gives me an error saying not compatible with this version mac. any suggestions? i am looking forward to using trenchbroom to work on quake 2 maps in particular. thank you for making this software - really appreciate the time and care you are putting in. 
Yeah, It's Not 
I think you need 10.9bor later. 
Appveyor 
Are the appveyor builds supposed to be usable? Or do I still need to rely on the guru/wizards of this thread for new builds of TB? I tried downloading the "Latest Build" from there, but it seems to be gutted and non-functional - no art (logo, icons), supported games list is empty, etc. 
 
The recent build is without a build number. I dont think that specific build is to be usable at the moment.

A new build with the fixed context menus would be cool, though. AA can wait as one can set it through their video settings. Im interested in using https://github.com/kduske/TrenchBroom/issues/1526 and https://github.com/kduske/TrenchBroom/issues/1527 
 
Pritchard, they should be usable, however, the "Latest build" button in Appveyor is not reliable at the moment, because it includes test builds for feature branches. It looks like a change earlier today may have caused the "gutted and non-functional" breakage.. I will check it out.

@mukor, the f7fe54e build I posted yesterday should have those two features for the key/value editor :)

There have been a lot of fixes today so I hope to post an updated build tomorrow. 
Stupid Question 
I used to get the latest builds of 2.x off sleepwalker's Dropbox. Where can I get the latest builds for PC? I'm a bit lost on github and cannot compile the code.

Right now I am using the build from the website (2f3c498?) 
Dec 24 Windows Build 
TrenchBroom-Win32-2.0.0-Interim-0e1a90a-RelWithDebInfo.7z

The pauses Pritchard reported when clipping, the entities in the right click menu, and antialiasing are fixed, plus some other fixes in the issue tracker. 
Brilliant! 
 
Actually 
I can't extract the 7z archive at all and WinRAR won't tell me why. 
Weird 
I tested it with 7-zip 
 
7-zip is giving me weird trouble too: http://i.imgur.com/YgXqBBX.png 
Is TB Running? 
 
No 
 
Cheers! 
 
 
No problems extracting here. Maybe retry the download? Perhaps something was corrupted.

Clipping things feels so much nicer now! Getting rid of slowdowns and hangs goes a long way to improving the feel of the application. I'll be sure to report anything else I run into. 
 
"Can not delete output file" - sounds like there is an existing install, try extracting into a fresh directory, or maybe re-download. 
Thanks For The Xmas Present, Eric 
And thanks Sleep for keeping on improving it. Will DL and install later this evening. 
RGB Textures 
Does Trenchbroom in it's current state support any way of applying RGB textures in say, a Quake 1 level? If not, will it ever have Quake 3 BSP support? 
What Are RGB Textures? 
As for the second question, TB does not support any BSP format. It reads and writes map files. Assuming you meant to ask, "Will it ever have Quake 3 support?", then the answer is yes:

https://github.com/kduske/TrenchBroom/issues/583

But I can't say when. I'd like to do it for 2.1 though. 
 
Im talking about full color textures that aren't limited to Quake's 8 bit color pallete or whatever limitation Quake 2 has. 
 
According to a post by MadGypsy in this thread: http://quakeone.com/forums/quake-talk/quake-central/12548-fte-lightmapping-quake-3-format-bsp.html, Quake 3 doesn't support paletted .wad files and works directly with .tga images, so yeah, when Sleep will implement Q3 support in TB, you should be able to use 24-bit textures. 
Oops! 
The site has included the comma into the link, so you need to delete it to access the page. 
Looks Good! 
Just installed Trenchboom to see if it would work. And indeed, it shows up well. Made the setup in my Quake directory and choosed the preference file.

In the texture editor I have a view for the monsters and items.
My texture files are all blanked out, so I use the glass near the Groups and Used to look for my wad file.

It won't show up.
Is there a way to make them so, like a path to my wad file? 
 
Click on "show" at the bottom of your texture browser, then click "+" to search for your wad(s). 
 
I can open a map but my txtbrowser is blanked out. 
Madfox 
Is this under WindowsXP again? 
Madfox 
First of all, Windows XP is no longer officially supported. Second of all, you should be using TB 2. Third of all, you can read the manual (Help menu) to find out how to load textures. 
RGB Textures 
there was a contribution that added support for loading textures from loose files. I think it supported jpg and tga or something like that. It will not be included in TB 2.0 however. 
 
Windows XP is no longer officially supported.
But you did fix this issue some time ago. My TB2 works fine in XP (build 2f3c498). Are you saying that the more recent builds won't work again? 
NO 
read it as it may work, but if not it is only fixable with an OS change.

OS=Operating System! 
Location Outdated? 
TrenchBroom_Win32_1.1.6_381 is the link for download,
I can't find a TB2. 
OS & OS2 
TrenchBroom-Win32-2.0.0-Interim-f7fe54e-RelWithDebInfo and TrenchBroom-Win32-2.0.0-Interim-0e1a90a-RelWithDebInfo.7z
both give a "MSVCP140.dll" was not found.


TrenchBroom_Win32_1.1.6_381.zip works fine on Wi nXp, both S2 S3 Servicepacks and Visualbasic2010.
Strange my items and monsters do appear while textures won't. 
Madfox 
Try the build I mentioned in post #2460, it works fine on my XP SP3. Go to the link provided in the first post, click Download, then Windows, and scroll down the page to find it: oddly, the page displays the 1.16 builds first. As for the missing dll, I bet it's because you need to install the Microsoft Visual C++ 2010 redistributable package (it's a requirement mentioned on the download page). 
Rogue One 
Welp. That was definitely a thing. I found the goody characters rather boring and undeveloped and impossible to give a shit about. Rather charmless. New baddy Krennic chap was good though. However I liked the film overall - a lot actually - because once it gets going, the action is balls-to-the-wall amazeballs and super-ultra-Star-Warsy. I guess that makes me part of the problem. :/

MINOR SPOILER BELOW THIS LINE!!!!
==================================


A certain key human character from the OT is resurrected via CGI...it's pretty awesome that the character is there and has a surprisingly amount of screentime, but the fact that the CG is definitely not perfect just makes it really weird. 
Oh FFS 
That was obviously meant for the film thread. I have had a few pints... 
Thx Kinn 
the warning and stuff, idk... Im spoiled hard right now.. 
 
TB2 switched visual studio versions recently so you need to install Visual C++ Redistributable for Visual Studio 2015

@Madfox, once you install that, build 0e1a90a (the one I linked a few days ago) should work on XP. 
Good To Know, Thanks Eric. 
 
Yes! 
That did the trick.

Hey thanks for this editor, Sleepwlkr & ericw!
And all that helped of course.
I was just accostumed to Radiant, but it has that dark view. 
Windows XP 
will work, but I will not go to great lengths to keep it that way. 
Fair Enough 
I still need to upgrade to 7 anyway, it's only a matter of time. 
XP 
Funny these comments have been happening recently. I came here to say that Trenchbroom 2 does not work correctly on my Windows XP laptop. It doesn't render textures. 
Ebi 
Have you installed the Visual C++ requirement as stated above? 
Ebi 
That can have many reasons. First off, are you sure that it actually finds the textures? You can check out the console to find out if TB has problems locating the textures. 
Visual C++ 2015 
For some reason, download from the Microsoft page linked by Eric in post #2468 fails on my computer. If others encounter this issue, I found a working link here: http://standaloneofflineinstallers.blogspot.fr/2015/12/Microsoft-Visual-C-Redistributable-2015-2013-2012-2010-2008-2005-32-bit-x86-64-bit-x64-Standalone-Offline-Installer-for-Windows.html 
Doin' It Wrong 
Can you spot what's wrong in this picture?
http://i.imgur.com/5CO29uS.png
(Hint: my compiled map and .lit aren't being copied)

Is this a bug, or is there something wrong with my "Copy Files" actions? I can't tell. 
Hmm 
Isn't it MODS and not MOD? But either way, there should be an error message. Please submit an issue. 
TrenchBroom 2.0.0 Release Candidate 1 
Just in time for your weekend mappery: https://github.com/kduske/TrenchBroom/releases/tag/v2.0.0-RC1

Big thanks to all involved, particularly ericw. 
 
It is MODS and not MOD, and after I typed that in it worked.

The documentation for TB seems a little spotty - http://i.imgur.com/xDKUFpk.png I simply copy-pasted the lines from here into the editor to get the results I did. Notice the correct "MODS" in the table above, though.

If someone (perhaps me) were to go through the docs and try and proof read them, would that be appreciated? I might give it a shot. 
That Would Be Greatly Appreciated 
In fact, that would make me very happy! You can create issues on github for errata in the manual btw. Please create one for this, too. 
 
How was the documentation originally written? I'm guessing it wasn't just written in HTML. 
No, It's Markdown 
With pandoc enhancements. If you wish to edit the docs and submit pull requests, we should chat so that we can set up the toolchain. 
 
Alright, shoot me an email or hit me up on IRC. I've been meaning to learn how to get around Github better so it'd be nice to get the chance to educate myself. 
Awesome 
Thanks SleepwalkR! 
 
i'm having a huge problem with Trenchbroom (2.0.0 RC1)
my compilating and launching profiling aren't being saved, i can set them, and use them, but if i close the program, and open it again, they are gone.

also, i'm having one more related issue, there is this old compiling profile that i wan't to delete, but i can't, it crashes trenchbroom instantly. 
 
sadly its a known issue: https://github.com/kduske/TrenchBroom/issues/1640

I THIIIIINK you could get them to save by opening a previous version of Trenchbroom, creating them in there and then they SHOULD transfer to the new version as well.

same for deleting the unneeded one. 
@mukor 
okay thanks 
Ranhcase 
also, i'm having one more related issue, there is this old compiling profile that i wan't to delete, but i can't, it crashes trenchbroom instantly.

This is not a known issue. Can you please submit a crash report on github that includes the file which contain your compilation profiles for Quake? The file is named "CompilationProfiles.cfg" and where exactly you can find it depends on the platform. 
 
I figured the two issues to be related to one another? Settings not saving or deleting? 
TrenchBroom 2.0.0 Release Candidate 2 
Download here: TrenchBroom 2.0.0 Release Candidate 2 is out: https://github.com/kduske/TrenchBroom/releases/tag/v2.0.0-RC2

Changes
- #1655: Ensure that worldspawn colors are treated correctly in smart entity color editor.
- #1655: Show color editor for any entity property matching `*_color`, `*_colour`, or `*_color2`.
- #1655: Properly set selected colors in smart color editor. Switch smart editors in idle event as opposed to in reaction to row selections.
- #1659: Ensure that points on the boundary are not added to a polygon. (#1662)
- #1661: Make sure to reset fly keys when 3D view loses focus. (#1663)
- #1653: Create a log file and add it to crash report. (#1657)
- #1656: Don't start a face drag in brush tool if there is no face under the mouse. (#1658)
- #1649: Fix bounding boxes of item_artifact_* in Quake.fgd
- #1646: Set selected texture when the user clicks on a texture in the texture browser. (#1647)
- #1648: Remove unused image from Linux build.
- #1640: Fix a bug that prevented game engine profiles from being persisted properly. (#1643)
- #1641: Print an error message when an error occurs while interpolating EL expression in compilation window. (#1644)
- #1638: Show message dialog when an exception occurs while launching a game engine (#1642)
- #1624: Change website to redirect to github for downloading releases. 
Thank You Sir! 
 
 
nice

i will continue to report new crashes

RC1 is crashing a lot less than the previous builds 
SleepwalkR 
It's fantastic to see how much progress has been made, thanks SleepwalkR and everyone else involved.

Could you also provide SHA256's alongside the releases? pretty please 
I'm Sure That's Possible 
 
TrenchBroom 2.0.0 Release Candidate 3 
https://github.com/kduske/TrenchBroom/releases/tag/v2.0.0-RC3

Getting fewer bug reports lately... either it's getting stable, or fewer people use TB. 
 
its defintely getting more stable and i cant wait for you to start hammering out those 2.1 features ;) 
Getting More Stable 
 
Good 
Glad to hear it. 
 
I dipped into tb2 a bit more recently. Will probably consider changing to it full time on my main machine. The ui stuff is a bit cramped on my surface though 
We Need Md5 Hashes Of The Md5 Hashes 
 
SleepwalkR 
Thanks, unfortunately MD5 has been unsafe for quite a long time now.

I apologize for not contributing but I'm away from my desktop and there's no release for my current os. (I've never had much luck compiling) 
MD5 Is All Cmake Supports ATM 
So that's all I can do. Anyway, I think these checksums can only ever be used to verify the integrity of the downloaded file. They cannot be used to check whether the file was tampered with on the server. If someone was able to do that, they would also be able to change the checksum files. 
 
Still a bit of a Github Noob, even after all this time spent submitting TB issues (over 30 now I think!), so I'm not sure if contributing a comment to a closed issue will be seen...

https://github.com/kduske/TrenchBroom/issues/1560#issuecomment-277413575 
 
Yep, I get notifications on Github and emails for comments on closed issues, should be the same for SleepwalkR 
Adding Textures 
could some one explain to me how to add textures to trenchbroom (q2)? I have a a .png of Duke Nukem 3D textures, and i would like to add those to my map 
 
https://www.quaddicted.com/files/tools/wally_155b.exe

Wally will let you convert/export that .png to the Quake2 .wal format.

Just open it up in Wally, and File>Export to .wal.

Wally will also be what youll want to use to edit and make your own textures and texture packs, etc. Its a really good, stable tool. 
Trench Broom Supported ! 
@mukor 
thanks, but how to add the textures to trenchbroom so it will appear there? 
Quoting The Help, Try This 
If you want to provide your own custom textures, you need to put them in a subdirectory where TrenchBroom can find them. For Quake 2, this means that you need to create a subdirectory called textures in the directory of the mod you're mapping for, or in the baseq2 directory. Then you need to create another subdirectory with a name of your choice. Then you copy your texture files into that directory. TrenchBroom will then find that directory (possibly after restarting the editor) and allow you to load the textures from there. 
Quoting The Help, Try This 
If you want to provide your own custom textures, you need to put them in a subdirectory where TrenchBroom can find them. For Quake 2, this means that you need to create a subdirectory called textures in the directory of the mod you're mapping for, or in the baseq2 directory. Then you need to create another subdirectory with a name of your choice. Then you copy your texture files into that directory. TrenchBroom will then find that directory (possibly after restarting the editor) and allow you to load the textures from there. 
 
the textures are in baseq2 in a folder called 'textures', but any of then appear in trenchbroom.

I thought that textures had to be stored in a certain file to be added in. don't they? 
Ranhcase 
My TB2 installation is not up to date, so maybe something has changed in the mean time, but try this:

Open TB2. On the right hand side, where you have "Map", "Entity" and "Face", go to "Face" and then below you'll find "Texture collections". Click on it and then on the "+" to browse your computer's drive to add texture files. Doesn't matter where they are located, as long as you point TB2 to the relevant directory. 
@total_newbie 
i think that only works for quake 1. atleast it seems so, the "+" can't be clicked at all in quake 2.(only on q1) 
 
i've managed to add the textures, but they make the brushes invisable/non-existant(?), creating a leak. What do i do to stop that? 
Also 
i noticed that the textures get to white when converting them in Wally, is there a way to make them the same color as they are in the .png file? 
Smart Entity Property Editor? 
I started using the latest TB2 release and so far I'm pleased. Though I can't find for the life of me the Smart Property Editor for entities, as I'm trying to make a door entity toggable. 
Spawnflags 
For func_doors, when you click on the Spawnflags key you should see the ability to check off states like toggle. 
Thanks 
 
How Do I Make Pointfiles? 
This is probably a stupid question
My map has a leak, i can't find it, the editor can open pointfiles, but i can't find them, so how do i make them, and if they are made automatically, where are they?
Quake 2 btw. 
 
With quake 1, qbsp will save it in the same directory as your map, along with the .bsp file. So run quake 2's qbsp on your map, check for a .pts file. 
Transparent Brushes 
Hi, I use Jury-Rigged BJP Tools for compiling Q1 maps (now I'm on TB 2.0 RC 3) and the compiler may utilize "hint" and "hintskip" brushes just like in Q2+ engines.

With proper textures in a WAD and seen in the map I tried adding
{
"name": "HintSkip brushes",
"attribs": [ "transparent" ],
"match": "texture",
"pattern": "hintskip"
},
to the Quake.cfg in the "Games" directory to make the brush "hintskip" textured brush semi transparent - in vain.

Actually when the brush has only hint texture, it is transparent but when I retexture its 5 sides with hintskip, it isn't any longer. Also it can't be excluded from the View menu.

Can anyone help me with this? 
Please Create An Issue On Github 
And I'll look into it 
Thank You! 
Thanks, SleepwalkR. 
 
Does ctrl-selecting multiple rows in the entity editor do anything? 
You Can Delete Them At Once I Hope 
Other than that, no. 
Vertex Mode (Edge Mode, Face Mode) 
Hi, unless I'm missing something I don't seem to be able to go into edge mode without going into vertex mode first (press "V")

This means to manipulate edges in the 2D view I have to go into vertex mode, then click on an edge in the 3d view to enter edge mode, and then the edge manipulation works in the 2D view.

Ideally, as well as "V" I think there needs to be two additional shortcuts that go straight into edge mode, and face mode - this would make edge manipulation in 2D more immediate.

Thoughts? 
Other Bits 
1) would it be possible to set the grid opacity of the 3D view independently of the grid opacity of the 2D view?

2) I can't find a way to change the WASD flymode speed - is there a way?

3) Can grid size please go subinteger, down to 0.125? (So, additional 0.5, 0.25 and 0.125 grid settings a la radiant) For thin trims that need to be a constant thickness as they go round certain curve configurations, the trim sections often have to meet on a subinteger grid. 
And One More For Luck 
I can change the background colour but can't seem to change the grid colour or brush outline colour.

I have a pretty nasty case of palinopsia which means I can't deal very easily with thin light lines on darker backgrounds :{ 
 
Hi, unless I'm missing something I don't seem to be able to go into edge mode without going into vertex mode first (press "V")

Thats just how edges are presented in TrenchBroom. I dont see how adding some other shortcut for edges would be any different than pressing V and selecting an edge that way.

Maybe a video would better explain your issue?


3) Can grid size please go subinteger, down to 0.125?


something i desire, myself. 
 
as for your suggestions, take them over to https://github.com/kduske/TrenchBroom/issues 
 
Thats just how edges are presented in TrenchBroom. I dont see how adding some other shortcut for edges would be any different than pressing V and selecting an edge that way.

To move an edge in 2D view, I have to go into vertex mode, then in the 3D view carefully pick the edge I want, then go back into the 2D view to move the edge.

Why not cut out the middleman? Shortcut "E" (or whatever) straight into edge mode, start moving it around in 2D. So much quicker. 
 
as for your suggestions, take them over to https://github.com/kduske/TrenchBroom/issues

Cheers I will in future. 
 
I played around with this and:

Doing a drag to create a box and select the edge nodes isnt working properly in 2D view, it seems.

Otherwise, you can select a single edge node (in 2D view), then create a "bounding box"(still in 2D view) and itll select the node below it.

is this what youre referring to? 
 
Well actually now i feel like a dummy. I was only thinking of one type of edges. I neglected edges the "exist" between vertices.

Yeah, I can +1 different shortcuts for Edge, Vertex, and Face selection in regards to the 2D view. 
Nice 
yeah I'm just coming from NetRadiant and it's really about streamlining all this stuff for "power users" (god that phrase sounds so smug). I'll be adding a lot of these sorts of requests to the issue tracker :) 
 
At the moment, I can see two ways to implement this:

Separate shortcuts for Face, Edge, and Vertex selection.

This might be limited with how Sleep likes to utilize ctrl, alt, and shift.

- OR -

Retain the current shortcut to display Face, Edge, and Vertex nodes.

While in this mode, perhaps CTRL, ALT, and SHIFT will display only Face, Edge, or Vertices respectively.

A complication to this is, while in this mode, how would a user select multiple brushes if CTRL is for displaying a certain type of node?

The user would likely have to back out of Vertex mode, select their desired brushes, and go back in Vertex mode.


-----------

This is just right off the top of my head for the sake of starting the conversation. Please dont berate me for any undersights :P 
 
I much prefer the first option. Seems to be simpler and quicker from the user's point of view. It's all about less clicks to get to where you want to be. 
As A Rule Of Thumb 
the question to always ask is: "what's the implementation that uses the least number of clicks / key presses?" 
Kinn 
Very much appreciate the input from you. Most of these things won't make it to 2.0 final, but I'll do them right after. Unfortunately I'm in the middle of moving houses and have almost no time for TB for the time being. 
Nice One 
I really appreciate the support!! 
 
I was just thinking today that it could be convenient to have TB play the windows "error sound" or something when you try and use a hotkey in the wrong context. I was shift-clicked on a face to edit its texture and tried to isolate it with ctrl-i, and it took me a little moment to remember that you need to have it selected normally for it to work... some better feedback than "nothing happens" would be good.

That, or make such functions work in more contexts... 
I'm Considering A Second Monitor 
And think it would be awesome if tb supported it. 
 
I have three monitors. Sometimes TB decides that when it starts up it wants to be stretched across all three. You get a really strong fisheye effect with that, kinda neat.

In all seriousness, I'm assuming you're talking about a floating inspector pane, right? I'd love to see that happen too, but I think it's been discussed before and nothing has been done... 
I Think 
I would like the option of orthographic views in one window or a larger texture window 
 
Y'know what'd be cool? Comment entities. That way I could leave myself little TODOs etc. and not forget about them so much... 
Textures 
So I downloaded quake.wad, opened 'Face' section and added the wad (via '+' button), but friggin texture browser is still empty! The entity browser is full of stuff by the way.
Help me solve this problem please. 
 
Another cool thing: clicking on the name of a texture to automatically search it in the texture browser. 
 
Aaaand... can we get the rest of the texture controls added as hotkeys? I feel like making an issue on github for this one, since it feels more like it's something that's been left out rather than a simple suggestion. Not being able to reset a texture with my keyboard sucks. 
 
@Vseznamus Just a shot in the dark here, but could it be that you have the " Used " button turned on, and as such are seeing no textures because none have been used yet? This has happened to me on a couple of occasions making me wonder what the heck is going on and just starting a new map or restarting TB as a result. 
Very Stable 
Just throwing it out there I haven't had a single crash with TB2 (latest release). Thank you for all of the efforts in making this as stable as possible! 
Thanks 
That's great to hear! 
@Bloughsburgh - I Wish I Could Say That 
Granted, I'm on an ancient OS (WinXP), but the software keeps crashing on me like every 30 minutes (I created a bug report some time ago). Miraculously, I haven't lost a single edit due to the excellent crash backup solution - I'm so grateful for that!

And truly, it's the best map editor of all I've ever tried. 
Alef 
that crash should be fixed in the next RC. (also, Muk, that was 90% of the big list of crashes you reported a few months ago.) 
Yeah 
I'll make a new release soon that has the fix. 
 
Is there or could there be these functions:

Group selection of brushes, making brushes transparent so group selection can select brushes behind brushes, scaling brushes or group of brushes.

also in vertex mode there could be a mode where you see the visible plane only, this would make terrain making easier. 
 
You can select a group of brushes by making a large brush that covers the brushes you want and hitting "select all touching"

You can select brushes behind other brushes by selecting a brush and using the scrolll wheel.

Scaling of brushes will be introduced at some point, i believe.

Lastly, i also believe occlusion of "hidden" vertex nodes will be implemented as well. 
TrenchBroom 2.0.0 RC 4 
https://github.com/kduske/TrenchBroom/releases/tag/v2.0.0-RC4

Getting there, but still some open bugs that I want to fix. This RC is mainly due to ericw's work who has held the fort while I was moving houses and settling in. 
Woo 
Thank you SleepwalkR and Ericw! 
How Do I Remove My Maps History? 
As the history of maps you opened on the startscreen isn't the only history I would want to clear...
If it isn't a feature yet then I request it,
If I'm just being dumb again then tell me where to click the UI. 
MRU Keys 
Without checking the configs files for TB, I'd recommend you CCleaner, a cleaning tool that's very good at deleting Most Recently Used file lists. It's also very good for general PC maintenance. 
Wishlist From Screenshots Thread Off Topic 
�Texture projection/carryover as seen on JACK/Hammer: http://www.interlopers.net/forum/viewtopic.php?t=20367
�Click on the texture name when a face/brush is selected to find it in the viewer
�A better way to wrap textures around complex geometry such as cylinders
�Hide duplicate textures
�Alignment tools 
*alignment Snap To Edge Tools 
 
 
Cant you do face and world alignment in JACK/Hammer?

TB needs that.

Throw in texture wrapping with it and TB will be catching up to Texture toolsets of other editors. 
2nded For Face Alignment 
 
Can't Run QS 
http://i.imgur.com/2uX1W1g.png

Does anyone know how to get QS to run through the TB compiler? I tried using -game ad instead of +game ad but it just gave me an error about having the shareware version of the game (?!).

MarkV runs fine through this :( 
 
Your working directory needs to be where the engine is.

If Mark V starts with a working directory and can't find Quake there, it will check and see if Quake lives in the folder where the .exe is .. and use that as working directory instead. 
 
Baker that is a nice feature, it sounds like something QS should steal. 
 
Also, "couldn't load gfx.wad" has never been a helpful error message, that could be rewritten to suggest the most likely fixes. 
@metlslime 
I have tried to get other engines to steal that for years. Tends to get dismissed out of hand as a non-problem. If Mark V actually does get the gfx.wad it very clearly says what is wrong, and then pops a message saying "Opening folder c:\path_to_engine ..." and opens the folder.

/Brief gentle tangent, .. hopefully not much disruptive to the TB thread 
 
I am officially taking Baker's side on this one, it's a serious pain having to use the game dir as your working directory... Especially because the compile tool doesn't have a working way to get the map's directory...

http://i.imgur.com/3i0nthn.png

I think I can use fully qualified names to avoid this, but it makes the parameters of my tools into even more of a mess than before...

Could someone tell me if i'm using ${MAP_DIR_PATH} wrong or something? I think this should probably have a github issue if it's genuinely broken. 
 
engine -basedir ${GAME_DIR_PATH} -window +map foo
or something.
(or +set fs_basedir foo for q2/q3)

some engines ignore -basedir. those engines are annoying.
an explicit path should always take precedence over a fallback/guess.

That said, default compile rules for TB would be really nice... it would save quite a bit of frustraction... at least until someone uses a path with spaces in it, anyway. 
@metlslime 
Hehe

(I didn't have Spike in mind. He even has a different objection than I've seen before )

/@Spike - Mark V honors basedir and can handle paths with spaces in them like -basedir "Path to Quake". 
RC4 Stable Om Win 10 Laptop 
I've been pushing TB2 pretty hard this week especially using undo many more times than I would ordinarily do while mapping (a dozen or more steps back) and have had zero issues. Am I dreaming or did some of the default keyboard shortcut change or go away though? I think the only weird thing I've noticed was the transparency bug noted elsewhere on this thread and on Github. Amazing work guys. 
Qmaster 
I never knew about this functionality in Hammer! 
#2573 
I was able to make that work with QS, but only by using a fully-qualified path rather than the ${GAME_DIR_PATH} one you suggested. Did your suggestion work for you? Maybe there's something wrong with how my environment is set up. 
 
I remember someone setting up their preferred engine in one of the "Tool" slots in the compiler. Bit more intuitive, imo. 
@mukor 
That's what I've done. It's nice because it only takes one click to start the process and when it's done you're instantly in-game with your map.

It's less nice because of all the issues I've had trying to make it work with something that isn't MarkV. 
@Drew 
Pretty much the only reason I use JACK more. That and primitives.

All on Sleepwalkr's list I'd imagine. 
Esrael 
If you read this, please contact me. It's about your TofuQake (hehe). 
 
Tried to load the .map from The Hell That's Coming in TB2 today but it returned this error message and crashed:
Expected integer or decimal, but got '[' (raw data: '[') (line 15, column 96]

Is this worthy of a bug report or is it perhaps already reported? Note that I was still using RC1 in WinXP, will have to check in RC4 to see if it still happens. 
Not A Bug, Just An Unhelpful Error Message 
In the Open window select Map Format "Valve". 
Valve? 
...but it's a Quake level! And it doesn't happen with any other Quake map I've tried to load. Why is this happening? 
 
Because that map you are trying to load uses "Valve" texture mode. Most other dont/didnt until recently. 
OK, Thanks. 
 
Feature Suggestion: Relative Light Adjustments 
I posted this on Github but thought I'd share for discussion.

I'm an video editor and in my editing software I can raise audio levels relative to each other. So if one track is -5dB and another is 5 I can raise them both simultaneously by 2 dB to make them -3 and 7. A real time saver when mixing audio. This gave me an idea for TB. It would be great to be able to select multiple lights and raise their values relatively as opposed to just absolute values. I'm not sure if this would apply to any other key/values. Nothing else comes to mind. It would be wonderful to tweak lighting in large areas in one operation. Just an idea! 
Door Angles 
Is there an easier way to set door angles then entering numbers? Just looking for some TB tutorials. 
Door Angles 
Is there an easier way to set door angles then entering numbers? Just looking for some TB tutorials. 
Door Angles 
Is there an easier way to set door angles then entering numbers? Just looking for some TB tutorials. 
Door Angles 
Is there an easier way to set door angles then entering numbers? Just looking for some TB tutorials. 
Door Angles 
Is there an easier way to set door angles then entering numbers? Just looking for some TB tutorials. 
@Ilpadrino 
Not really. But entering numbers is pretty simple once you get used to it. If you are looking to easily figure out the correct angle just add a monster near your door and turn him facing the direction you want to door to move, note his angle and use this value. I am horrible with this stuff so I had to come up with little tricks like this.

See example here

Also up is -1 and down is -2 in the angle key/value. 
I Plan On Doing Some Video Tutorials BTW 
Won't happen until after MapJam 9999 but if you need help post here. I am on here multiple times a day. 
Video Tuts 
Good initiative! 
@dumptruck_ds 
Thank you for the tip! Still learning and teaching myself as I go. Also is there a way to say draw custom brushes in the editor instead of say a four sided box? Thanks for the info though! 
@Ilpadrino 
There are no "stock" primitives (triangles, columns, etc.) as in other editors but take a look at the Brush tool (tap B). You can click and edit points and then extrude them into custom shapes. It's very powerful.

I made a quick video that makes it clear. Hold Shift to drag out the shape and hit enter to create the shape.

https://drive.google.com/open?id=0B-xkqcrQhLm7NEVDbEJ1TFZlajA 
@dump Truck_ds 
Oh thank you for the video and info! I am learning and testing. I have never mapped before so this is an adventure in itself. 
@Ilpadrino 
A couple of words of advice for all beginners: Start small. Don't do anything too large or complex for your first map. Have people play your maps before you release. You don't want to release a broken map and then have multiple copies out there. Enjoy!

And also: "Go map!" is a good saying here on func_msgboard. 
I Can Dream Can't I? 
Stair brush would be excellent in TB.

https://twitter.com/logicalerror/status/884894816890490880 
Wow 
That's enough to make me switch right there if the alt+right click texture applicator was added too. 
New Version 
Has there been any news about a newer version of trenchbroom? 
Entities Disappearing 
I've been creating some info_null entities and changing their classname to "func_illusionary", in order to make corpses, but TB seems to make the entities disappear after I deselect them. They still compile and appear in-game, but there is no way to edit them or find them again after creating them.

Any idea what might be causing this? 
They Are Moved To The Origin 
I think. 
 
Today I decided to man up and start to use Trenchbroom. Loving it so far. Feeling proud of myself.

Sorry, continue. 
Cross Post 
as soon as I deselect the func_illusionary entities they seem to disappear...

Check the View menu upper left side of 3d window. Make sure you somehow didn't accidentally uncheck func_liiusiionary.

Aside form that you could edit the FDG to include a func_illusionary point entity... but I have no idea how to do that and it could mess up brushes.... gah! I will add a request for this on the TB2 Github because a lot of hack need this type of functionality. Or @ericw might have a suggestion on a workaround? 
 
I just filed a bug: https://github.com/kduske/TrenchBroom/issues/1805

I'm not sure if TB will deal with a classname appearing twice in the fgd (point + brush), it's worth a try though. 
@HexenMapper 
I've run into the same issue myself while doing the same thing (using func_illusionaries to display models) and was actually just about to post it- what's happening isn't that the entities are disappearing, it's that Trenchbroom is hiding brush entities with no brushes included. You can find the missing entities by going to the Issues tab below the map view- look for entries that say 'Entity 'func_illusionary' does not contain any brushes.' If you have a bunch of illusionaries- or a bunch of other, unrelated issues, like brushes with non-integer positions (i.e. you were doing a bunch of clipping at grid level 1), it might be difficult to find the entity you want.

Click the issue and the purple box for the func_illusionary will show up as the entity is selected and you can edit it in the Entity pane, but it'll disappear again once you click on something else in the map view. So far as I remember this bug/feature wasn't present in older versions of TB, I only saw it happen once I moved to the latest 2.0 release candidate (RC4). Word of advice though, so far as I can tell using that method to show models/corpses/etc. means they'll always be aligned to face 'forward' (0,0 by viewpos) so if you want your dead bodies to be positioned more imaginatively, it's better to use info_notnulls with the proper modelindex and model fields filled out instead. 
Yes 
But modelindex isn't too reliable. If you, for instance, delete an earlier placed monster and recompile, the indices might shift on you. 
 
True, it's half-dozen one, six of another when it comes to placing models. Worst comes to worst, get all your enemies and entities set and working how you want before you start detailing things and use the 'edict <number>' console command to find the one you're looking for (as edictlist won't show the whole list if you have enough stuff in your map)- also helpful to prevent precache errors caused by an info_notnull trying to use a model that hasn't been loaded yet due to showing up later in the entity list. 
 
Nice, cheers guys.
Spuds idea of the "Issues" tab reveals the entities nicely so that should be a fine work-around 
Func_detail Button? 
After this latest jam it has come to mind that almost every brush in say: Skacky's or sock's maps are func_detail. greatly decreasing vis times obviously. I wonder if it would be possible to have a toggle button similar to texture lock where as you create brushes they are added as func_detail automatically. I think ideally this would be added to the map "under the hood" and not displayed in the editor by default. I also think it should be independent of groups/layers.

Or perhaps a "Seal Brush" command would be smarter? Every brush is automatically func_detail (again behind the scenes) and you select brushes and remove this attribute as needed to seal your map.

Posting here for discussion first before entering this on Github. 
 
https://github.com/kduske/TrenchBroom/issues/1616

I have a submission for a "Default Entity Hotkey"

One hotkey for turning a brush into the desired brush entity and another for placing the desired point entity.

:) 
 
...or copy behavior from JACK, where you can set what default brush is. You basically type func name and every new brush will be automatically set as specified func.

It's more universal this way, so you can use it in Q2 HL etc. 
Playing Devil's Advocate To My Own Post 
I guess the best way to do this currently is to use layers correctly and select "all in layer" and make them func_detail all at once. I'm just not in the habit of using layers. I only use them for large areas and troublesome brushes. 
Upgrade 
To upgrade TB2 from build 2f3c498 to RC4, can I overwrite or is it better to do a fresh install? 
Just Install To A New Folder 
NP 
Kingpin Life Of Crime 
could you add support for Kingpin loc 
Failed To Copy Log 
When trying to open any map, I am get this error.

Failed to copy the file (AppData/Roaming/TrenchBroom/TrenchBroom.log to "My Documents/trenchbroom-crash.log (error 3: the system cannot find the path specified.)

I can get to this path that TB cannot find so I am confused here. Is there a way to reset where TB thinks the log file is or can tell TB to generate a new one?

Thanks for any assistance. 
Hmm 
It looks like TB actually crashes every time you are opening a map, and then fails to copy the log. Does it really happen with any map file? Can you post the log file? 
Also 
What does "I am get this error" mean, exactly? Is it a dialog? Can you please post a screenshot? 
Sleepwalkr 
Yes it is crashing every time I open a map, even a brand new one. I sent you a message on Twitter so we can discuss at a better pace.

I am get this error was a typo and I meant: "I am getting this error." Which is an error dialog window that prompts when I try to load any map, old or new. 
Please Keep It To Github Issues 
I don't use Twitter that much, and I need to track issues in a single place. 
From That Screenshot 
It looks like you moved your user data directory to a network location and that's not supported by the underlying library that TB uses. 
Github 
Yes that would be what occurred although not my intention of course. I submitted an issue on GitHub.

Thanks! 
Yeah, Let's Continue On Github. 
 
Packages 
I realise you have release packages on github but are there plans for official packages via distro repos? (debian/fedora/arch) or via copr/aur perhaps? 
If Someone Is Willing To Contribute 
I'm all for it once we reach 2.0.0. But I don't have the time to do it. 
Understandable 
I only ask because I can't compile on this machine & TB doesn't work via wine.

Thanks for all your efforts. Scale tool pls! :d 
But There Are Debs And Rpms Available. 
Those don't require compilation, do they? 
Need Zip Support 
Very nice editor im looking forward to use it.
However i would like to request support for pk3(zip) for loading texture packages and loading textures from q3 map files and if possible basic shader support too. 
@Code_Man 
I am waiting for this myself but I don't think this is close yet. The GitHub has and open ticket for it though. It would open up the editor to a ton more games that used the Q3 engine.

https://github.com/kduske/TrenchBroom/issues/583 
 
I've been waiting on Quake 3 support for years at this point. Not gonna pressure the man because he makes his program in his spare time and it's pretty rad so whatever. We can keep hoping. Only time will tell, and hopefully we can finally put that decrepit old Radiant in the ground. I'd honestly be curious to know what makes it so complicated. All I know is something something surfaces. 
Sorry For Making You Wait ;-) 
 
@SleepwalkR 
I'm sure it will be worth the wait. You haven't disappointed us so far. 
Failed To Snap Vertices Of 1 Brush 
What causes this error? I was trying to snap this brush to grid but I got that error. Snapping to integer worked fine. 
Same Issue 
Not sure what causes it but I just snap to integer. If the brushes don't behave I delete them and rebuild the geo. 
Does It Work If You Reduce Grid Size To 1? 
TB refuses to snap the vertices if the result would no longer be a convex brush. Since the grid coords are usually coarser than integers, you will run into this issue more often if the grid is > 1. 
Pritchard 
That brush would become flat because it already is flatter than the grid size. So that's why it doesn't work. 
Good Things Take Time 
Im not in a rush with q3 support.
Take whatever time you need to make it good.
Anyway im more than glad to see that this is on the agenda. 
"image" Format Support 
I have managed to compile the master branch of TB on MinGW 5.10 (let me tell me you, wxWidgets and FreeImage are NOT fun to compile). Now that I have generic PNG support, I can safely call this the best 3D level editor.

Will the next release have this? If not, I'd be happy to upload my custom build if anyone needs it. The only changes I made to TB is disabling wxHandleFatalExceptions in TrenchBroomApp.cpp (it's not declared for some reason), and adding a call to FreeImage_FlipVertical in FreeImageTextureReader.cpp. 
Please Submit A PR 
I'm also interested for detailed instructions for how to compile under mingw. 
MinGW 
I would first need to check if my particular MinGW installation is common enough.

The supplied libraries in lib/bin/win32 didn't work for me, which is why I had to build FreeImage and FreeType myself, then edit TrenchBroomApp.cmake to use my compiled libraries rather than the repo's.

Other than that I followed the instructions in Build.md (building wxWidgets worked fine). After building, I copied my compiled FreeType/FreeImage/wxWidgets dlls into the binary directory.

I can make the FreeImage_FlipVertical PR, though. 
Works Great! 
Tried out TrenchBroom a couple of weeks ago, and it works very nicely!

I'd also like to commend it for the good documentation and easy editing directly in the 3d-view. While I understand some people like to have the option of one or more 2D-view simultaneously (Including myself), I've found that I use the 3D for most things anyway now after a few weeks.

Thank you for your hard work, SleepwalkR!

For reference, I'm running the RPM-binary-version on a Archlinux installation. Trenchbroom version is v2.0.0-RC4. 
Thanks! 
Glad to hear that you like it! 
Quake 3 Support ?? 
Hi, I just found out about your wonderful editor. It amazes me that it took this long for someone to finally come up with a simple yet powerful bsp editor in all these years.

I'm sure this has come up quite a few times already, but are you planning on implementing Quake 3 support in the near future?

Please keep updating this wonderful editor, and thanks for letting noobs like me make great maps :P

Cheers mate! 
Sorry For The Double Post... 
but could you tell me how far you consider a final v2.0 release? 
@LordGrievous 
I follow Tb2 development closely. If the plan hasn't changed, Quake 3 support is planned for the future but there is no real time frame. I would guess that it is quite a ways off. Sleepwalker is the creator of the program. I am not sure how often he checks func so I figured I would chime in. You can watch the development of TB2 here:

https://github.com/kduske/TrenchBroom

You'll note under milestones they are 98% to a proper 2.0 release.

I am working on video tutorials for TB2 aimed at absolute beginners. I am still writing them but should have all or a least a large batch of them completed by the end of the year. 
 
Okay thanks, looking forward to further updates :) 
 
Does anyone know if it's possible to remap the wasd keys with the arrows, for regular navigation?

Not in fly mode, but when you're navigating the 3d view normally.

I never liked using the wasd keys and always navigate with the arrow keys so this is very counterproductive to me :)

I couldn't find anything in the manual so maybe you guys can help me? 
 
https://i.imgur.com/sUuGs8k.jpg

View>Preferences

It brings up a window, click the mouse icon/tab.

Down at the bottom you can change the movement keys. 
 
I tried that already, it doesn't seem to work. It is only for Fly mode and even there it doesn't work.

If I change the wasd keys to the arrows like your screenshot, all it does is change select/unselect the 3d viewport. 
 
Arrow keys must be "hard coded" for nudging brushes and such. 
 
Okay I really hope there is a way to remap those keys. I friggin hate the wasd setup, we use azerty here so it is so utterly terrible to have to use wasd.

I really do hope this will be implemented because I like this editor a lot, but right now I can't even do simple navigational things. 
 
Map it to ZQSD? seems about the only compromise :( 
 
Okay, if I change my keyboard setup to US then it is doable. Still, I hope that Kristian finds a way to make them remapable, even if I can't change them to the arrow keys I would still like to change them.

For now I can work again on my mapping :) 
 
If course this does mess up any keyboard shortcuts that use the wasd keys like ctrl+z for undo.

Sorry for the multiple posts btw, seems more like a chat conversation with a helpdesk :D 
@LordGrievous 
Have you joined Github? You are more than likely to get a quick response or at least an explanation if you post an issue or request there. Link is above. 
 
I prefer asdf, homerow keys. Much more natural. 
 
I'll sign up to github :) 
Problems Compiling Q2 Map 
This is the first time I'm trying to compile my map but I keep getting an error when creating the bsp.

This is my compiler setup and error:
https://ibb.co/gaWY1G

I copied the 64bit compiler and dll files from my gtkradiant 1.6 installation. I didn't want to try the newer separate compilers and start simple with the existing one.

Does anyone know what I'm doing wrong?

Thanks on advance :) 
@LordGrievous 
Looks like your paths are all messed up but hard to see everything in your screenshot. Looks like you have spaces, periods and weird characters and it could be that.

Some advice:

Under Quake make a new directory called "compile".
Download ericw's compile tools here: http://ericwa.github.io/ericw-tools/

Download Necros' compiling GUI here: https://shoresofnis.wordpress.com/utilities/ne_q1spcompilinggui/

Install ericw's entire folder into your new compile directory.
I think you can put Necros' GUI anywhere you want. Instructions are on the page linked above.

Now you have two options to compile. I suggest Necros' GUI for beginners. Try it. If you'd rather use TB then set up the paths in this new. compile directory.

There's a bunch of things that could have gone wrong with your current setup. Best to start from scratch. ericw's compilers work perfectly with default settings, they are backwards compatible and more up to date than what you have. 
 
Okay thanks, I'll give it a go 
 
Just a quick question, is this compiler also for Quake 2 ?? 
Nope 
but can do Hexen2

read the qbsp documentation

https://ericwa.github.io/ericw-tools/ 
Doom 3 Support? 
I know Doom 3 isn't as popular as Half-life or Quake but it's still really fun to map for and I like Trenchbroom much more than the alternatives. Is there any glimmer of hope that we will ever get support for Doom 3? 
You Can In A Way 
TB saves to .map. Make as much as you'd like in TB. Save it. Open in your Doom3 radiant editor. Texture and fill with items/enemies. Compile. 
Thx But... 
Sounds like a rather nasty workflow honesly :/

It would be nice if the author of trenchbroom would clear it up if Doom 3 support is something we will ever get and if not then the reason he doesn't care to include it. 
Ya It's Not The Best Solution For Now 
I wouldn't expect him to, at least for a good long while. He has a long list of features he's talked about implementing for Quake that I'm sure he is more interested in working on for now. 
Sounds Interesting? 
Any examples of the new exiting features that are coming for Quake? 
@hakkarin 
You can check out the milestones at Github here:

https://github.com/kduske/TrenchBroom/milestones

Right now they are working on 2.0.0 and it looks like 2.1.0 is chugging along. 
Doom 3 Support 
I'm sorry, but it's not actively being worked on ATM. I'm very busy with other things and have too little time to work on TB as it is. Also other games have precedence, e.g. before I would start working on D3 support, I'd want to work on Q3 and HL2. 
Disappearing Trigger_secret Points 
Hi!

When I change a point entity's classname to trigger_secret and then deselect the entity, the entity stops displaying in the editor. The entity still exists in the map, because it compiles and gets triggered during gameplay.

Is anyone else able to reproduce the behavior? 
You Might Have Them Filtered From View 
Check your View menu checkboxes. This sort of thing has happened to me before and this was the culprit.

Alternatively, I seem to recall something familiar about this so it could be a known issue. Do the above check to rule that out. 
Esrael 
I think what you described is this bug, which is already fixed for the next release:
https://github.com/kduske/TrenchBroom/issues/1805 
Another Thing 
That's probably it, ericw. Glad that it's accounted for.

On another, somewhat similar note: I've made some groups, but there don't seem to be any checkboxes in the view menu to hide groups. Instead I have to first select them and use the hide tool, which isn't as convenient.

Is there an easy way to hide groups in RC4 or will it be implemented in version 2.0? 
No 
I don‘t see much value in blanket hiding all groups. This is not their purpose. 
 
Being able to hide the TrenchBroom groups has value.

Sometimes I want to manipulate a large group of entities at once(lights for example). To do this I turn off visibility for everything but that one entity type i wish to change.

If i have TB groups, I have to first hide EVERYTHING, this leaves the TB groups visible, then I ctrl+A to select everything, hide the TB groups, then I turn on visibility for the one entity type I wish to see/change. 
 
https://imgur.com/fAzSK68

for clarity, were talking about hiding them with this menu. 
 
Nice workaround, mukor! :) It would still definitely be a lot more convenient if the groups were possible to be hidden with a simple checkbox. 
 
Is it just me, or is there no way of removing individual brushes from groups in RC4? The only options I have when right-clicking a single brush within a group are

Group
Ungroup [unclickable]
Rename [unclickable]
Add Objects to Group [some other group]
______________
Create Point Entity
Create Brush Entity
Move Brushes to World


"Move Brushes to World" used to do the trick in earlier versions of TB (albeit at the cost of turning all selected brush entities to world brushes); it no longer works. Shouldn't there be a "Remove Objects from Group [selected group]"? 
@former_total_newbie 
Hmm, it works for me in RC4.
I am 'inside' a group (double-clicked on it). The group has 2 worldspawn brushes, I select one, right click, and have the option: "Remove Objects from Group Unnamed". Selecting that moves it outside the group, turning it blue.
Can you get reproduce this?

"Move Brushes to World" is only for moving things from "func_" entities to worldspawn, it doesn't affect group membership. This was different pre-RC4 , see: https://github.com/kduske/TrenchBroom/issues/1744 
Might Also Depend On 
Where you right click (selected brush you wish to remove from group vs. other objects). 
@ericw, @SleepwalkR 
I am 'inside' a group (double-clicked on it). The group has 2 worldspawn brushes, I select one, right click, and have the option: "Remove Objects from Group Unnamed". Selecting that moves it outside the group, turning it blue.
Can you get reproduce this?


No, I can't; what you describe is exactly what I want to do. I don't have the option "Remove Objects from Group [name]"; only the options I listed above:
Group
Ungroup [unclickable]
Rename [unclickable]
Add Objects to Group [some other group]
______________
Create Point Entity
Create Brush Entity
Move Brushes to World


Might also depend on where you right click (selected brush you wish to remove from group vs. other objects).

I am definitely clicking the selected brush, but no matter where I click, I don't get the option "Remove from Group".

When I click the selected brush, I get the options above.

When I click the entire group, I get
Group
Ungroup
Rename
______________
Create Point Entity
Create Brush Entity
Move Brushes to World


and when I click somewhere else at random, I get
Group
Ungroup
Rename
Add Objects to Group [some group]
______________
Create Point Entity
Create Brush Entity
Move Brushes to World
 
 
Wait, I just tried again in a new map, and now I do get the "Remove" option.

Sorry! Something else must have gone wrong on my end... 
Ok, I Think I've Got A Reproducable Bug, I Think 
When two or more groups overlap, TB no longer gives you the "Remove" option. I'll open a Github issue. 
Ok, That's Not Quite It Either 
It seems that whenever there's another group behind the group you're manipulating, TB doesn't give you the "Remove from Group" or "Ungroup" options; instead giving you the "Add to Group" option, pertaining to the group that's behind the group you're trying to manipulate.

Isolating groups (View --> Isolate) is a workaround, but this is really bizarre and unwieldy behaviour, I think... 
Report It On Github Plz 
 
Done! 
 
Not Working On Debian 
I tried to install the .deb file and it won't Install on Debian GNU/Linux 9 (stretch) 64-bit stable.

This is what it says:
dpkg: dependency problems prevent configuration of trenchbroom:
trenchbroom depends on libpng12-0 (>= 1.2.13-4); however:
Package libpng12-0 is not installed.

dpkg: error processing package trenchbroom (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
trenchbroom

I could not install the dependency after researching it and I also tried to compile it following the instructions and ran into many issues as well.

Could we perhaps get this added to the Debian repository so it can be installed automatically with APT? 
Could You Please File An Issue On Github? 
 
 
I thought this was an already documented issue? At the very least, the solution (this worked for me on Ubuntu 17.10) is https://askubuntu.com/questions/840257/e-package-libpng12-0-has-no-installation-candidate-ubuntu-16-10-gnome/840268 
 
(obviously that would have to be adapted for Debian) 
Thank You For TrenchBroom 
I just got around trying TrenchBroom 2, and found it to be very easy to get into and overall to be very pleasant and powerful. I've now switched from NetRadiant for my Quake 1 mapping needs.

Thanks a lot for creating this editor! (Is there a donation link somewhere?) 
Libpng 
Apparently there is no libpng12-0 on current debian derivates. Instead there is libpng16-16.

I don't fully understand however there is another fix that doesn't require a download of some library from somewhere.
We just edit the deb and edit the libpng dependency to match the current libpng16-16


dpkg-deb -x TrenchBroom-Linux-v2.0.0-RC4-Release.x86_64.deb tmpdir
dpkg-deb --control TrenchBroom-Linux-v2.0.0-RC4-Release.x86_64.deb tmpdir/DEBIAN
sed -i 's/libpng12-0 (>= 1.2.13-4)/libpng16-16/g' tmpdir/DEBIAN/control
dpkg -b tmpdir Edited-TrenchBroom-Linux-v2.0.0-RC4-Release.x86_64.deb
dpkg -i Edited-TrenchBroom-Linux-v2.0.0-RC4-Release.x86_64.deb
aptitude install


@Sleep if you are still building the linux package on an old distribution (pre Ubuntu 16.04 or Debian 9/Stretch) it might be time to switch. The build tooling will probably take care of the rest.

@aftershock getting trenchbroom into official debian repositories is definetely a possibility but from what I've heard debian maintainers are very meticulous about package layout and QA to the point that the automated build probably wouldn't do and manual repackaging would need to happen specifically for the debian repos.

PS: Don't forget about the github issue 
Nevermind 
The fix mentioned above doesn't work. Plz ignore that 
Haven't Mapped In A Decade, Getting My Bearings... 
Is there any way to scale whole brushes (not just drag faces) in Trenchbroom? Basically I want to make a round tower with a dome on top, so I used a bunch of rectangles at a 15 degree angle to each other to make a circle of sorts, then convex merged the whole thing to get a solid cylinder, now I just need to dupe this cylinder brush, scale it down, put it in the middle, and do a subtract operation to get a hollow cylinder. But I can't seem to find any kind of scaling tool. Maybe I should just go back to GtkRadiant, since this sounds like an awfully ass-backwards way to create a simple primitive... Thoughts? 
@iriyap 
In a word no. No scaling. It sucks and many of us have asked for it repeatedly. I'm not sure any progress has been made on this: https://github.com/kduske/TrenchBroom/issues/871

I used TB2 daily and I am acclimated to not having this feature. For someone coming in fresh I can absolutely understand how frustrating this can be. However, for me the benefits of TB2 far outway its limitations.

I've only had this happen once where I really needed to scale something up. Save your shape as a map file. Bring into Radiant and scale it up. Save as a map and re-open in Tb2. Yes it's a pain, yes it's dumb not to be able to scale brushes or groups. And yes Tb2 is still great. 
@iriyap 
I wanted to add that development is ongoing and there are some very nice features being worked on over the few weeks. I think a proper v2 is very close to reality. Fingers crossed. 
Thanks 
It sucks that there's still no 100% feature complete modern replacement for Radiant. Oh, well. 
Scaling 
@iriyap There is a thread open on Github for scaling: https://github.com/kduske/TrenchBroom/issues/871

GTKRadiant accidentially dropped support for Quake1: https://github.com/TTimo/GtkRadiant/issues/555

There is NetRadiant: https://github.com/Garux/netradiant-custom/releases

There is also J.A.C.K which you can get on Steam or other places.

I checked them all out recently before starting (Including QuArK) to edit and I think Trenchbroom is the best bet, but just wait for it to develop features. Either that or maybe combine editors. 
Debian Install Issue Filed On Github 
The issue of Trenchbroom not installing on Debian is now filed on Github.

Issue #1900:
https://github.com/kduske/TrenchBroom/issues/1900 
 
Any ETA for RC5? 
Ditto 
I was thinking actually that it'd be great if someone could compile the current version and upload that here or something at least. I really need some of the bugfixes that have been made since rc4... 
6 posts not shown on this page because they were spam
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2017 John Fitzgibbons. All posts are copyright their respective authors.