News | Forum | People | FAQ | Links | Search | Register | Log in
The TrenchBroom Level Editor
Today I am releasing TrenchBroom 1.0 for Windows and Mac OS X. TrenchBroom is a modern cross-platform level editor for Quake.

- True 3D editing, no 2D views required
- High performance renderer with support for huge maps
- Vertex editing with edge and face splitting
- Manipulation of multiple vertices at once (great for trisoup editing)
- Smart clip tool
- Move, rotate and flip brushes and entities
- Precise texture lock for all operations
- Smart entity property editors
- Graphical entity browser with drag and drop support
- Comprehensive texture application and manipulation tools
- Search and filter functions
- Unlimited undo and redo
- Point file support
- Automatic backup
- Support for .def and .fdg files, mods and multiple wad files
- Free (as in beer) and open source (GPLv3)
- Cross platform (Windows, Mac OS X and Linux supported)

Check out a video of TrenchBroom in action here.

You can download the editor here.

If you would like to give feedback, please do that in this thread. If you find a bug or have a feature suggestion, please submit them at the issue tracker.

If you are wondering where the Linux binaries are then sorry, but currently there are none. The Linux version has a few problems which I could not fix before this release. I will get working on those right away so that the Linux version should be available in a couple of weeks, too.

Finally, I would like to thank necros for all his work over the past year. Without his tireless efforts, TrenchBroom would simply not exist. Or it would suck.

Alright, enough of this. Have fun with the editor!

Update: 2.1 here:
Features "cool shit".
First | Previous | Next | Last
This video is closed caption so you can watch in your native language: 
Can you upload the map file and post a link? 
The link takes me to your setup tut 
YES!! it is a video that you can play in your native language as I typed above. The section where the compiling is setup should play automatically. 
Referring To This Comment 
I find it difficult to converse in a language I am not functional in.

Maybe I misunderstood. 
thanks for interest/reply

trying to remember what I was doing that could have triggered this weirdness but it's a little unclear as I didn't realize it wasn't making changes for bit (assumed I messed up in the editor as it isn't my comfort zone etc)

please let me know if more info required 
Why Doesn't Someone Write A Tut For Compiling Q2 Maps Out Of 
Trenchbroom? I have seen two other threads that fizzled when the user was asking for help to do just that. I am wondering if there is an issue with Trenchbroom that won't allow for it. Heck, if there was one for how to do it with Quake that might suffice. I am hoping someone takes up the challenge. As for the statement "I find it difficult to converse in a language I am not functional in. " I was referring to my inability to understand even basic code speak. 
I did it before. It can be done. Just try it out. If I can figure it out anyone can. Sorry I don't have the answers for you but I have a new computer and those files are on another I don't have access to. You can Google for Quake 2 compiling tools and find this:

Write a batch file to compile your map and FFS GO MAP. 
and go here for some info: 
The map file looks fine. Could you post the entire error message, it might stem from one of TB's other configuration files. 
I've got it

// entity 25
"classname" "monster_zombie"
"origin" "744 136 200"
"angle" "270\"

Last entity at file has misprinted backslash - escape character. Just remove it using notepad. 
Good Find! 
Appreciate it. Thank You. Too much for me though. I am now using Quark's internal compiling. It is no more time consuming then using the compiling GUI. So I build in Trenchbroom and compile in Quark, my problem is solved. 
Mission Accomplished. 
(re #2918 AND #2920, clearly)

So is this \ a byproduct of something I did in the editor or just my fat fingers 
Drew A.k.a. Fat Finger 
Seems like you pressed it in pair with Enter 
TB should warn about this though. 
You have to validate string on focus lost at least. BTW only useful escaped symbol for entity fields is "\n" 
What he said 
TrenchBroom 2019.2 
TrenchBroom 2019.2 is out with md3 support and some fixes and performance improvements | 
TrenchBroom 2019.3 
TB 2019.3 is out with several bug fixes: 
Hiding Vertices/edges/faces Behind Brushes? 
Is there a way to do this, or in the works? The screen can be a real mess when working with a lot of grouped brushes. 
I Don‘t Understand What You Mean 
Please explain in more detail. 
Re: I Don‘t Understand What You Mean 
Ah sorry, I see there's already an issue open under "Draw occluded vertex handles shaded #1568" detailing pretty much the same request. 
imagine how cluttered it got when Vertex, Edge, and Face nodes were all displayed at the same time. 
Quake 3 Bug 
I am sorry, may be I am just stupid but seems like I found a strange bug. When I open quake 3 .map in TB and then save, it turns into quake 1 map (I use windows version of TB 2019.3). I asked few people to do the same on their PCs and they have same bug. Seems like TB converting quake 3 maps into quake 1 format when it opens it. 
Also Quake 3 Bug 
Also wierd bug. Not all md3 models are displayed in TB. Check it out, here are some models that I use: 
Wad3 Textures 
Seems like wad3 textures can not be loaded in TB 
Q3 Maps 
As per the output in the log, TB does not fully support Quake 3 maps. Quake 3 maps are Quake 2 maps with two additional structures: Patches and brush primitives. Neither are supported, so when you save a map, these structures will be lost.

TB also won‘t display models that consist of multiple md3s that are connected by tags, or models with external skins.

The Quake 3 config expects tga, jpg or png textures. WAD3 is a Quake 1 thing, if you want to use it, you need to create a custom game config. See the manual. 
Wad3 Support 
Got wad3 textures with this confing
"textures": {
"package": { "type": "file", "format": { "extension": "wad", "format": "wad3" } },
"format": { "extension": "C", "format": "hlmip" },
"attribute": "wad"
So I Hear There's A New Quake Engine-based Game Announced. 
Might be a good opportunity to hype up Trenchbroom and get new people interesting in Quake modding and mapping. ;) 
I think this release will be huge for our community. 
Rotating 2D View? 
Is this is secret feature or a bug? It's happened a couple of times now while I've been editing but not sure how. 
I Don‘t Know What You Mean 
How does it rotate? Did you take a screenshot? 
TrenchBroom 2019.4 
As If It Was Rotated 180° 
I'll take a screenshot and create issue if it happens again, as I'm not quite sure how to reproduce it yet. 
Oh, I Was Using 2014.4 RC1 
I'll update and see if I can repro it. 
I'm using Trenchbroom for my UE4 game and I just wanted to say thanks to you SleepwalkR. This is the most intuitive and fun map editor out there. The fact that its open also allows me to tweak stuff to my workflow and it works great. 
Glad it is helpful to you! 
TrenchBroom 2019.5 RC 1

Adds support for ASE models, greatly improves model loading times, you can now click the model to select an entity. Also fixes an out of memory problem on Windows when opening a lot of large pk3 files. 
TrenchBroom 2019.5 RC 3

Improves the rotate tool and fixes a number of bugs! 
Textures Not Shown In Browser 
Hi. just installed a fresh version on win10 and created a new q2 map, but textures are not shown in texture browser, only black squares with names. any suggestions on that? 
looks like this bug is only in 2019.5 RCs, 2019.4 works fine 
TrenchBroom 2019.5 RC5 
TrenchBroom 2019.5 RC6 
There was a bug that would result in TB not reading its preferences. RC6 fixes it: 
TrenchBroom 2019.5 
Adds ASE support, better rotate handle and visual improvements.

Get it here: 
TrenchBroom 2019.6 
Bug Report 
Hello, I am working on one map in q3 format. I updated TB (sorry, I do not remember which version I had before). Now when I open the map it just crashes. And here is the crash file:

OS: Windows 7 (build 7601, Service Pack 1), 64-bit edition
wxWidgets Library (wxMSW port)
Version 3.1.1 (Unicode: wchar_t, debug level: 1),
compiled at Feb 18 2018 18:36:35

Runtime version of toolkit used is 6.1.

GL_RENDERER: Intel(R) HD Graphics 4000
GL_VERSION: 3.3.0 - Build
TrenchBroom Version: 2019.6
TrenchBroom Build: v2019.6 Release
Reason: std::exception: bad allocation
Stack trace:

I renamed the textures folder so the editor could not find it and now the map can be opened! After that I disabled all texture collections on the map and I gave the correct name for textures folder so editor could find it. After I add one texture collection by one and in one moment the map crashes again. I dont know how it works. May be the editor has some limitations for allocated memory. How can I fix that? 
Can you post the map that crashes at please? Using any .pk3's with third party textures or all stock q3 textures? 
Yes Post An Issue Please 
I suspect you are loading too many texture collections and run out of memory. Please also post your machine specs such as how much memory it has. 
Reply To Ericw And SleepwalkR 
Hi! Thanks for reply!

In editor I am using textures, which are located in folders, and I dont use any archives for editing maps. I am using my own textures. I thought that the problem can be in one of the textures (may be format is incorrect or some texture crashes the editor by some other reason). So that would mean that some of my texture catalogues contain the "problem" texture and I tried to find it. But each catalogue (folder with textures) can be opened freely without any crashes. But if I try to open more than 3 texture collections the editor crashes. Seems like the problem is in allocated memory

My laptop is 7 or 8 years old but I dont think that it has not enough memory to open the map. I have 8 gb of RAM, intel core i-7-3600 processor and Geforce 650m (idk if this information is needed).

I wonder if there are some limitations for the RAM that can be used in editor? If yes, how can I change it? 
How Many Textures Are You Trying To Load In Total? 
Also Can You Give A Total Of The Disk Space That These Textures Occupy 
Textures occupy 465 mb of disk space. There are 1034 textures in total 
2 posts not shown on this page because they were spam
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2019 John Fitzgibbons. All posts are copyright their respective authors.