News | Forum | People | FAQ | Links | Search | Register | Log in
FTE Engine
This engine needs its own thread... also!

FTE's homepage:

This thread is for the discussion of using FTE's enhanced features, and/or drawbacks, for Quake level design/modding and/or gaming in general.

First | Previous | Next | Last
Single player fixed with 5424. :) Thanks. Tilding then tapping map e1m1 (or whatever start map) was a little annoying. 
Yah all issues I mentioned above are gone in 5424. :thumbsup: 
RT Lights Are Point Entity Only Yes? 
Without resorting to Q3BSP+Q3map2, is it possible to have in Q1, a texture emit RT Lighting? Using scripts/shaders? 
Quake Injector 
Quake Injector not showing in menu anymore with latest build. 
for the quake injector option to be displayed, you must have the qi plugin loaded, and is normally obtained+enabled in the updates menu.
(you can also 'plug_load qi; qi' to load it without using the menu, assuming you manually downloaded the extra dll) 
Stuttering Frame Rate 
After playing in FTE for a little while, the game starts to get jittery. The frame rate is smooth for a while after launching but maybe 5 to 10 minutes later, there's a bit of stuttering that really messes with my eyes. Any idea what's up?

Also what's the cvar for square particles? 
R_particles 2 
works for most engines 
I have downloaded all plugins and enabled them and none show. 
r_particles isn't recognized as a command in FTE. Only way I can get square particles is to use the vanilla video mode but I still can't find the cvar for square particles alone.

Also after playing around in FTE a bunch, it seems like the stuttering frame rate starts pretty consistently at the same time every time. Doing a vid_restart smooths out the game again but then 5 minutes later, it's back to stuttering. It seems to get jittery even sooner when I alt+tab out and then back in. 
r_part_classic_square 1 ??? 
#157 P2 
btw, I had the graphics preset on "spasm". 
That works, thanks. 
it does support webrtc, but only between itself, and it requires a broker to do so.
web server: sv_port_rtc rtc://BROKERADDRESS/GAMENAME
web client: connect rtc://BROKERADDRESS/GAMENAME
non-emscripten server: net_enable_webrtcbroker 1; sv_port_tcp BROKERPORT
(it is possible to omit the BROKERADDRESS args by including a usable value inside your site's fmf file, but you'll need a reliable broker for that.)

Unfortunately this does not work for me.
I've started server like this:
| ./fteqw-sv64 +sv_port_tcp 27500 +net_enable_webrtcbroker 1 +map frenzy

Then on web-server I've entered:
| sv_port_rtc rtc://<serverip>:27500/magic
and got following output:
| Listening on ws://<serverip>:27500/magic

At the same time on dedicated server a message appeared:
| Websocket request for /magic from ws://<clientip>:64509 (rtc_host)

Then using another instance of web-client I tried to connect like:
| connect rtc://<serverip>:27500/magic
and got following output:
| Connecting to rtc://<serverip>:27500/magic...
| No route to host, giving up

Could you, please, help me with this? 
What would you guys say it's the most stable build of FTE? 
Clean Win64 install from fresh download today, plugins such as the Quake Injector one don't want to load, "plug_load qi" returns "Couldn't load plugin qi". Something I'm missing? 
Aha. Plugin items reappear in menu with 5529 update. Quit the game, reload FTE, they're gone. Disable/reenable in updates+packages brings them back and seems to be only way to do it ("plug_load" doesn't work). Quit, gone again. 
Stuttering Sound 
I'm having a problem with a level that I'm creating, and I'm not sure whether it is the level, or FTE. Note that I don't have this issue with Darkplaces or Quakespasm.

The problem is that at some places (often the same places), the sound starts to stutter. More specifically, some of the sound effects have the last one second repeated a few times. While the sound is repeating, the game keeps running and the other sounds are occurring normally.

The framerate is at its lowest 30FPS. I've tried more complex levels, and not been able to replicate this problem. Even in a large level, like those in Ter Shibboleth, which brings FTE to a crawl, the sound doesn't repeat. The level I am is using progs_dump, if that makes any difference.

Any ideas on how I might be able to troubleshoot? 
Sound Follow Up 
A clarification. What is occuring, is the entire sound effect is being repeated. I put snd_show to 1, and it appears that as the sound is being repeated, is is registering as an additional sound being played. 
Sounds Repeating 
BoraxMan, regarding the fact that this is a progs_dump map, would you be able to give a bit more info about what entity (or entities) are generating the sound effects which are repeating?

I'm particularly wondering whether it's an entity setup involving any of the "new" features of progs_dump which weren't in vanilla Quake?

In terms of debugging, one way you might be able to definitely rule out progs_dump is to load up your map without progs_dump and see if the problem persists.

To do that, just copy the .bsp file into your id1/maps directory, then start FTE without progs_dump, and play your map. I assume the gameplay of the map will be more or less broken depending on how heavily it relies on the mod's features; however, you should still be able to use noclip to get around. If the sound problem is still present, that would mean it's definitely nothing to do with progs_dump. 
Sounds Repeating 
The problem still persists. I'm suspecting there is something structurally wrong with the map? It might possibly exceed the 4096x4096 size limit or there might be invalid brushes.

I note that FTE gives this error many times (hundreds) in less than a minute of gameplay.
AL lib: (WW) alSetError: Error generated on context 0x556480415e50, code 0xa005

Whereas for other levels, it might only appear a few times. So I'm now thinking it is my level at fault here. 
Possible Problem Found 
I found that removing all the wall torches solved the problem. So perhaps there are too many of them, as each wall torch contributes a sound?

I should note here, that in the areas where the sound was repeating, there were not necessarily many, or ANY wall torches in the nearby area. There were only 5-7 sounds playing at a time in these instances.

There are 171 in the level, though all spread out. It is a large level. I might remove some, but I'm not sure why this should be a problem in areas where there are not many within earshot. 
Was Your Map Fully Vised? 
Normally I test with a fast vis, but one of the first things I tried when I noticed the problem was a level 4 vis, as I thought it could simply be performance. The problem exists with it fully vised. 
For what it's worth, the 0xa005 error code appears to be the audio library reporting that it's run out of memory. So it makes some sort of sense that having a lot of something would cause that error (in this case I would guess it's all the simultaneous sounds from the wall torches and other entities).

BoraxMan, I don't mean that to sound like your map is at fault. From what you've said it sounds like this is an issue that affects FTE but not other engines. I'm unfortunately not familiar enough with the code to be able to say exactly why this is happening. You might need Spike or someone else knowledgeable to weigh in on this.

In the meantime, you could try confirming the problem by testing another map that has a large number of wall torches. One such map is bbin1 which has 198 wall torches (according to a quick grep). As indicated above, I doubt it's wall torches specifically that are the problem (I would guess it's the number of simultaneous sounds), but either way, I suspect that bbin1 might give you the same sound issue? If it does, you'd at least know it's not just your map. 
I run into an error, "No Free Edicts" when trying it. I tried to use -num_edicts 2000 and higher values, but I don't think FTE supports this parameter?

For what its worth, I tried my level on a Windows machine I borrowed, and the problem didn't come up. I use Linux, so perhaps this problem is specific to the Linux client (both 32 bit and 64 bit clients were tested and the error was replicated).

Lastly, I understand that you didn't mean that my map was at fault. It was me that brought up this possibility, because I do have a weird clipping issue on a specific stair I can't get rid of, and Quark reports a few invalid brushes, though I can't seen to find where they are because Trenchbroom and QBSP see no problem. BSPUTIL --check reports some clipnode problems (though I note other maps also have this). It's a guess that perhaps this might be resulting in something screwy, I'm not sure.

I'm going to be putting the level up for Beta testing soon, so perhaps that will be a good opportunity to see if anyone who happens to use this engine also experiences the same.

I have some programming knowledge, so I might have a look through the code see if anything pops out at me. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.