News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread:
First | Previous | Next | Last
But since it changes a lot of things, it has to be introduced to player somehow. Only way might be letting player to make mistake in a non-dangerous situation, if not using text messages and stating that fact directly to the player that something is changed and the experience might be different. 
Pushing My +3Buttons 
Dumb question but my mind is fried.

What would be the reason when I push a button the texture doesn't switch to its off texture?

These are just the standard quake symbol textures I've used plenty of times before with no issue. The same thing is happening with shoot buttons as well. I thought maybe it was the .wad but it is happening for any +# textures for buttons.

Including It 
Are you including the +abutton frame in your map anywhere? Some compilers don't automatically include the animation textures, try applying that frame to a hidden face on a brush and recompile, then see if it works that time. 
I thought all the modern compilers fixed that problem, but yeah that could be it. I used to always include every texture in the sequence of any animated textures on a random brush somewhere, just in case. 

Why does my double door start open when the level starts...but then closes after it's designated wait time. It then acts like a normal door from then on out.

Trying "Don't Link" causes the doors to not open at all. They do not have a targetname and are set to just be normal doors.

"Start Open" is not checked.

Da hell. 
And Answer 
Ugh, hate when I figure something out after finally submitting to asking.

Apparently doors want to try to open themselves for one time at the start of a level if there is a func_button nearby? What's the explanation for this occurrence? Solved but moving the button a few units away...but the button was already about 16 from the side of the door.

Is there a trick to making this work? 
Ahem.. this is a bad solution but, try giving all of them targetname, that way I fixed problems on my rj6 map. (I guess warnings about not using targetname, isn't critical?) 
I think you have something else going on to cause your doors to act like that.

I have a "" that I try things out in when someone posts a problem like this. I couldn't duplicate it :(

I created a brush, then shift drag/copied it right next to itself, set each one separately as a func_door setting their open directions to opposite each other. Didn't do anything else to them.

Then I created a func_button and no matter where I placed it, my doors didn't open on map start. I even had the button inside the doors!

I'd say spend a few minutes creating a test map and see 
Ugh, Meant To Hit Preview 
I guess my above post is finished enough even though I accidentally hit submit instead of preview :(

Anyway, sorry couldn't help more. 
No Idea 
Yeah I have no clue, but the only thing I do know is that moving the button to another place in the room away from the door resolved the issue.

Thanks for trying to test stuff out! :) 
I even had the button inside the doors!
I didn't know that was possible! Did it work fine? It's giving me an idea for doors in base/tech environments. 
Only Quoth (afaik) has a special func_button variant that can be attached to a door: 
I just made a small hole in the door, I mean once the door opened, you could look into the frame of the door into a hole where the button sat. 
don't kill, the light, just turn it off by targetting it. 
okay, disregard that, i was replying to a question 700 posts ago. 
Better Late Than Never! 
Thanks Eric! 
That's aweso... oh, Quoth. Damn. 
DP Alpha 
Does DarkPlaces not support { alpha textures?

I am using vines from ad_start.wad and it works fine in every engine but DP...I get the pink texture along with the vines instead. 
Scratch That 
Uses the latest autobuild and the vines work fine so that's great.

But there is a kicker. Does DP support the alpha key on func entities?

Looks like my func_illusionaries are using alpha 1 even though set to .65.

Blah, as long as the vines work that's cool with me. 
Post #18000, nice.

Also, I'd be very surprised if DP didn't support brush entity alpha. Perhaps it was broken in the most recent autobuild or something? I wouldn't know, I don't use the engine. 
.alpha Requires Progs Support In DP; Doesn't In FitzQuake + Company 
DarkPlaces supports .alpha, but it must be a field in the progs.dat

Since id1 doesn't have an .alpha field in the progs, stock id1 in DarkPlaces won't support .alpha but Quoth or Arcane Dimensions would since they have a .alpha field in the progs.

FitzQuake automatically "inserts an .alpha field into the progs at load time" if protocol 666 is being used, so the progs doesn't matter. 
.alpha is a fully transparent entity, like a translucent glass window.

Entirely different from alpha masking "{", which current DarkPlaces autobuild does support. Using "{" will simply "just work" all the time in any supporting engine. 
Ummm... Alpha 1 
Works in my DP's with stock id1, I just tested it. You use "alpha" btw, not ".alpha".

Also, I know in Gotshun's Jump map we used "alpha"(for translucent windows) and { (for the alpha masked frame) together for the windows and it was stock progs. Worked fine.

Just relaying my experiences. 
Just a box map with a player start, 2 lights and a func_wall with an alpha key set to .6

Note that, I only got this effect with func_wall's, illusionaries and detail was no bueno.

DP build is in the console, but I'm pretty sure this has worked for years for me. 
Thanks Baker that pretty much explains the current situation. The { work fine I just needed a newer build but the alpha key does not...and it also explains why Quoth and AD work but not id1.

damage_inc: Ah there we have issue is happening with func_illusionaries...I actually do not have any func walls using alpha. Thanks for testing! 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.