News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread: https://www.celephais.net/board/view_thread.php?id=60097
First | Previous | Next | Last
Huanlopan 
There's no flag to disable it in Quoth or ID1. In Quoth an alternative is to construct a fight using the Death Guard/Death Knight/Death Lord triumvirate as they never infight with each other - they are treated as variants of the same monster. 
 
@Preach
I see, thanks for the response. No way around it: Have to be clever with enemy placements. 
@huanlopan 
I used to hate infighting in my maps. But once I saw some of the clever ways players use it in a tactical sense I got over it. It's part of the game play.

But yes, you can mitigate it in enemy placement. And remember, in id1 only Grunts will infight each other. The rest of the gang will ignore their own type. 
 
^Thanks for the tip, and hey, thanks for the Trenchbroom tutorial series. It's the whole reason I'm here right now. Really enjoying making my own small map. Hoping to make bigger, more traditional Quake ones soon. 
Collision Box Rotation? 
Hi there!

I was triyng put my custom models on my map, but when i try to rotate the objects, the collision boxes remains in the same spot and not rotate with the model, how can i fix this?

A screenshot

https://imgur.com/gallery/sfFhXPr 
Flags 
If it is a model or static give them a flag :
"angle 180" or any number 0/360. 
Thanks Madfox!! 
Useful as always, thanks bro! 
Well.., 
I am still wondering how you obtain that transperant shape. Is that fence a static entity or a brush with texture? 
Infighting 
FWIW: You can make Ogres infight by using monster_ogre vs monster_ogre_marksman.

marksmen also don't play their alert sound. 
For Madfox 
Its a model, looks better this way in quake engine.. 
Random Teleporting Out Map Boundaries 
Hi everyone, I'm new into Quake mapping. I want to create a singleplayer map but encountered a weird issue. When I move around my map, I get teleported outside the level into some location way outside of it. Can anyone tell what is going on?

For the record, I've placed only ground floor on the level, simple paths just to check it out.

Here's the shot from the map:

Screenshot -> https://ibb.co/x2JHHJy

The points with 'teleport area' are the places where if I move close to it, I get teleported far away.

Cheers 
@Syon 
One possible reason is if you are building really far away from the origin. Your map is very small so that seems unlikely, but if that is the case, move everything close to the world origin. The standard boundaries are ±4096 from the origin. 
@metlslime 
Yes, that was it! Moving it closer to the world origin helped. Thanks for the help :) 
Raising/Lowering Stairs Using Func_doors? 
Hello folks, new mapper here trying to make a Quake 1 vanilla map using Trenchbroom 2.0, ericwtools, and quake.fgd entity definitions. Have watched all the Quake Builder and dumptruck_ds tutorial videos on youtube. Only started in the last couple weeks so I'm still learning a lot of basic stuff like how all the entities work together.

In the map I'm working on I'm wanting to make a set of stairs that raise from the floor when the player presses a switch or walks through a trigger brush. Is this possible? I know it's easily accomplished using a single switch/trigger and a single brush but I'm wanting to do a sequence of steps. The idea being the player triggers the steps and then they rise out of the floor slowly in sequence one after the other.

I'm currently trying to use func_door brushes linked by trigger_relay point entities that are initially triggered by a switch, where pressing the switch triggers the first step which in turn triggers the next step via a trigger_relay which triggers the next step via another trigger_relay and so on.

But since it's not working I'm obviously doing something wrong in setting up the brushes and relays or I'm just going about it the wrong way completely.

The current setup I'm experimenting with is as follows (A switch and four steps):

-A func_button entity with a wait value of "1" targeting func_door entity "step1", all other values default
-A func_door brush entity targetname "step1" sized 144x144x32 units with angle "-1", dmg "0", lip "16", speed "20", wait "-1", targeting a trigger_relay entity targetname "triggerstep2", all other values default
-A trigger_relay entity "triggerstep2" with delay "1" targeting func_door brush entity "step2"
-A func_door brush entity targetname "step2" sized 144x144x48 units with same angle, dmg, lip, speed, wait and other default values as "step1" targeting a trigger_relay entity "triggerstep3"
-A trigger_relay entity "triggerstep3" with delay "1" targeting func_door brush entity "step3"
-A func_door brush entity "step3" sized 144x144x64 units with same angle, dmg, lip, speed, wait and other default values as "step2" targeting a trigger_relay entity "triggerstep4"
-A trigger_relay entity "triggerstep4" with delay "1" targeting func_door brush entity "step4"
-A func_door brush entity "step4" sized 144x144x80 units with same angle, dmg, lip, speed, wait and other default values as "step3" targeting nothing (this is the final step in the sequence)

And that's it. When I compile and test it the button presses in but the steps do not rise. They just sit in the floor. Perhaps this just isn't possible? Any help is appreciated! 
Examples Are Easier To Understand 
Watch this staircase_lift.map.
Probably you missed the orientation of the pathcorners. 
Arktos 
Hi Arktos - I have an alternative suggestion to try with your setup. Apply the DON'T LINK spawnflag to all of your func_door entities. This will save you from lots of problems where the doors get clumped together. 
 
Also you can take a look at the id1 map source. This is in a few places in e1m6 Door to Chthon. 
Many Thanks! 
Thanks for the responses everyone! I've loaded the map file madfox provided and the behavior there exhibits as intended yet when I try to recreate the same setup in either my current working map or a totally new map just for this test I experience the same type of error:

Essentially, on compile the four func_train entities do not display except for one and it only displays until the button is pressed, at which point it disappears. Further, it doesn't display in the correct location but rather at some offset location near the origin. The location it temporarily appears at seems to stay the same regardless of where I move the whole setup, whether I move everything further or closer to the origin, higher or lower elevation, etc. So for instance if I move the whole room down 48 units then the func_train appears in the same location only 48 units above.

It's interesting that the error is persistent across maps but only the ones I've created since madfox's still loads and operates just fine. Is it possible I've introduced some error in trenchbroom while working on my first map that is causing problems in any subsequent map I make? Probably it's just something I'm not understanding about the behavior of pathcorners but even then it should still work when I recreate madfox's room on my own but it isn't.

I'll keep troubleshooting this and I'll also check e1m6 to see how it's done there and go back and rewatch the tutorials on entities. Thanks again. 
Water Does Not Show Textures 
I have stumbled this a few times while making maps.
I have a liquid brush with water texture. First I create it, compile the map and everything is fine and dandy. However after playing around with alpha values the water is there but does not show its surface texture. Even recreating the whole brush does not reset it. Also I'm modding for Arcane Dimensions.
Once I had this similar issue when testing a map with water that worked fine on my dev folder, but as described above when testing it on my main quake folder the texture is missing. Any ideas what causes this and how this can be fixed? 
It Could Be 
your water brush is too large and is overlapped with solid brushes?
Only time I saw my waterbrush got lost was when I made it too big and had to divide it in smaller parts. 
Nope. 
Thats not it. I noticed that if you remove the alpha values from the brush and then run the map with the mod, at first the brush does not show up. But when you reload the mod and map, the brush works fine. Maybe the engines predefined water alphas contradict with manually set alphas. 
Lighting Compile Error? 
Hey all,

I'm coming back to mapping after a hiatus and I'm running into an issue with compiling the lighting in my map.

I've gone so far as to open previous versions of the map, remove all lighting, rebuild, recompile, delete previous compilation builds, etc with no results. So I'm 99% sure it has to do with the compiling process, I'm just not sure how to fix it.

Screenshot: https://imgur.com/a/k5jtyVP

Any input is appreciated. Thanks! 
 
Bullseye8841: any chance there is an old .lit file with the same name as your bsp? If yes, be sure to delete that too. If that is not the case, maybe like you say it's a compile issue, what is your process for compiling?

Bloodfury: is it a water brush entity (func_water or something), or is it just water that is part of the world? 
@ Metlslime, Lighting Issue Continues 
I use ne_q1spCompilingGUI to compile everything with ericw-tools. I rarely mess with the settings when building maps, just standard compiles.

I went ahead and deleted everything (lit, vis, etc), but the issue persists. I'd really like to get to the bottom of it, just in case I run into it again. 
Bloodfury 
Water shouldn't need alpha values - you just plonk a brush down with the water texture and it will work, using r_wateralpha as set in the worldspawn.

Unless the water is a brush entity, setting an alpha shouldn't even do anything AFAIK. 
_phong 1 
Is there a limitation to this. I mean, could you set every single brush to phong 1. 
Bloodfury 
No limitation at all, it just changes how light.exe calculates the lightmaps, it's totally reverse-compatible with original Quake and doesn't change performance or anything. 
Phong 
Will make everything look like playdough if applied to all over though. You need to pick and choose. 
Thanks 
Good to know. As I like to make extremely detailed maps with lots of brushes. :) 
Extrude From Face.. 
Hello, does someone know how to extrude from face in NetRadiant? 
Infinite Loop Avoided - Not Loading Map 
Hello Everyone!
Thank you for all posting amazing and helpful info on here. I am new to the world of mapping and have been using trenchbroom to create a map. I was trying to clean things up a bit for distribution of my map when I suddenly started to get an error in game while trying to load the map. It says "Couldn't Load [map_path/map_name] Infinite loop avoided". I'm not sure what started this error. I had just been retexturing a few surfaces as well as trying to compile the map on the default setting. I have tried to undo some of my retexturing - without any change. I have run a quick compile several times and still cannot get it to work. It is currently compiling with default settings using Q2BeaVeR. Any insights would be greatly appreciated.

On a separate note, I was having an issue with func_wall and func_train brushes not displaying when in open (not in a building) parts of the map. Any thoughts on this are also appreciated.
Cheers! 
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.