News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread: https://www.celephais.net/board/view_thread.php?id=60097
First | Previous | Next | Last
Glass And Ladders 
does anyone know how to create the glass look in quake or making a ladder that allows the player to climb it ?

i have not found an answer to the glass and i have witnessed a ladder, i do not remember the map names but i am looking for the one that has the glass in it (it was see through and i am not sure if it was breakable or not. 
Earp: 
For glass, just set the entity “alpha” to a value less than 1. (Requires engine support but almost all popular engines support it)

Ladders: requires a mod, the exact implementation depends on a mod. Some mods include rubicon 2, rubicon rumble pack, alkaline, arcane dimensions, quoth, and I think progs_dump.

Without a mod, you can make ladders as an extremely steep staircase where each rung/step is 16 units tall and one unit deep. 
@metleslime 
thanks for the reply back

does glass require a special texture to work? 
Earp: 
no, but some textures will look more like glass than others. you'll have to experiment. 
@earp 
there's a great glass texture from ad_tfuma here:

https://cdn.discordapp.com/attachments/466357751749279746/514312585953280000/ad_tfuma_glass.wad

Make sure and give credit to AD mods in your readme 
 
Pretty sure that glass is from Half-Life. You know, speaking of credits. 
Chedap - Let Sock Know If It's True 
ARTWORK
------------------------------------------------------------------------------
* GFX menu artwork created by SimonOC tweaked by Sven Ruthner
* All new HUD artwork created by SimonOC based on org ID software art
* Skybox - Adgreensky made by Gavin Edgington
* Skybox - Asap from Richard Whitelock (free godotengine asset pack)
* Skybox - Moonhigh and Moonrise made with Terragen 3.x by SimonOC
* Skybox - Interstellar, Swampn and Violent made by Hipshot
* Skybox - Snowmoon from Kothic Compilation made by KellMcD
* Skybox - Voidsmoke from grimmnight by Hipshot and red sky from Doom3

* Textures Daikatana various (ad_test4, start, ad_lavatomb) by Ion Storm
* Textures Egyptian stone (ad_test6) by Rogue Software, +extra added
* Textures Hexen2 stone/trim (ad_magna) by Raven Software, +extra added
* Texture Set - Knave brick/library (ad_test7) by KellMcD, +extra added
* Texture Set - SpeedBaze (start, ad_crucial) by Speedy, +extra added
* Textures - ad_ac many new/modified by SimonOC (Org Id Software)
* Textures - ad_akalakha many new/modified by SimonOC (Org ID Software)
* Textures - ad_azad many new/modified by ... (Org ... )
* Textures - ad_crucial some new/modified by Impel Development Team
* Textures - ad_magna many new/modified by SimonOC (Org Raven Software)
* Textures - ad_metmon many new/modified by SimonOC (Org ID Software)
* Textures - ad_mountain many new/modfied by SimonOC (Org Rogue Software)
* Textures - ad_necrokeep many new/modified by Matthew Breit (Org Id Software)
* Textures - ad_obd many new/modified by SimonOC (Org Id Software)
* Textures - ad_scastle mostly by Rogue Software with some new by SimonOC
* Textures - ad_sepulcher many new/modified by SimonOC (Org ID Software)
* Textures - ad_swampy many new/modified by Maik Franz Xaver (Org Id Software)
* Textures - ad_tears by Benjamin Hale and Benoit Stordeur
* Textures - ad_tfuma consoles by SimonOC, some modified from Than Base set
* Textures - ad_zendar many new/modified by SimonOC (Org ID Software) 
 
Uhh, okay. I will. Here's what the originals look like
There's also uncredited use of stecki's decon and metlslime's obtex in the same map though. 
 
@metlslime

i am unable to get anything to work as far as getting a see through glass effect like i have witnessed in one of the maps played. it was my first time seeing the glass effect and was possibly in an id map. can't remember the name of it.

i even have trouble making textures that are used for vines, everytime i attempt that the texture flickers (disappears and then reappears)

i am obviously doing something wrong but thats the way it goes with mapping for quake

@dumptruck_ds

i will take a look at the textures you posted but i am not running ad but i have downloaded the ad stuff 
Gravity 
Sm213 Low Gravity
#4313 posted by dumptruck_ds on 2021/08/13 09:51:18
sm213-low-gravity

Make a single player, low gravity map with the latest version of the SMP mod. You can set your level's gravity amount in the worldspawn. "Ziggurat Vertigo" (e1m8) was set to 100 but your map can be anything below 800 as long as it's bouncy, floaty and gib-filled! Make Sir Isaac Newton proud, GO MAP!


i enjoyed playing the E1M8 map with the low gravity and it is something i want to add to a map as well

i have tried to add a gravity key to the world spawn using "sv_gravity" and setting it to lower than 800 but it does not work (this only works from the console).

i used "gravity" as the key as well and that doesn't work.

can this be done by adding a key to the world spawn or does it rely on a mod or change in code?

how about maybe my key is not properly named/set up?

gravity for me needs to just be there without having to type in the console (like in E1M8).

i am running dark places as my engine
i am using trenchbroom v 2021.1
i am not running any mods
inside worldspawn i set sv_gravity to 100

EARP 
E1M8 
If you look at the sources of original game's E1M8.MAP or look at the extracted entities from E1M8.BSP, the worldspawn does not have anything related to gravity at all:

{
"sounds" "10"
"worldtype" "1"
"classname" "worldspawn"
"wad" "gfx/metal.wad"
"message" "Ziggurat Vertigo"
{...

The explanation is that in original game the low gravity for that level is set by the QuakeC code - https://quakewiki.org/wiki/Sv_gravity

I'm not sure if there's some sneaky workaround for that. 
 
@gila

yes, i know that it was done modifying the quake c code - no one put inside worldspawn a gavity key to get the results of e1m8.


with my set up gravity is not a feature that i have found using trenchbroom so it cannot be added from the worldspawn.

nothing pops up when typing in gravity or even the letter g (something should pop up if it is actually coded into it).

all i can do is type in the console to get gravity and that isn't good enough.

i have ran across info that says gravity can be turned on and off using a trigger but there are no trigger functionality within trenchbroom to do this. in my search i found a trigger called trigger_gravity but it doesn't exist for me.

the only way to get it done the right way is to copy what was done for e1m8 using quake c apparently.

the gravity thing is neat and would like to add it to a map in the future 
EARP: 
Low gravity needs a mod.

"Sm213 Low Gravity" announcement said that you should use the "SMP progs" which is dumptruck's mod intended for speedmapping. That progs has the gravity feature and you specify it in the worldspawn.

Link to that announcement: https://www.celephais.net/board/view_thread.php?id=10196&start=4313&end=4313#4313

There are probably other mods that also support gravity in the worldspawn, but I don't know off the top of my head which ones. 
EARP: 
regarding glass:

create a brush for the glass
make it a func_wall
set the "alpha" on that func_wall to a number less than 1, greater than 0

that should work -- in some engines. You say in another post that you are using darkplaces. I can't say whether this will work in that engine. Fitzquake and its variants will support alpha without a mod. There may be some engines that will only support it if running a mod that also supports it. 
 
@metlslime @dumptruck_ds, @gila

i appreciate the feedback,

quake is one of my favorite games, have played it a long time with my 2 brothers, one reason why i am working on building some maps (will be fun to play something that i created).

@metlslime

yes, i am using dark places

i tried to use quakespasam and when i tried to run it i received a message saying i had to buy a copy of something to run it (i already have quake so i have no idea why it gave me that message).

i have not used fitzquake i do not believe.

i see that it is referencing a mod, seems like i over looked that important piece of info my bad 
Map Is Fully Lit - No Leaks 
I'm not sure whats going on here. I've been playing with my lights then all of a sudden my map compiles fully lit despite having no leaks.

Here is my lighting log:

---- light / ericw-tools v0.18.1 ----
Raytracing backend: Embree
running with 24 threads
LoadBSPFile: 'KillBox.bsp'
BSP is version 29
--- LoadEntities ---
23 entities read, 18 are lights.
--- OptionsSummary ---
"light" was set to "325.000000" from map
Embree_TraceInit: Embree version: 2.15.0
Embree_TraceInit:
44 sky faces
1838 solid faces
0 filtered faces
0 shadow-casting skip faces
SetupLights: 18 initial lights
SetupLights: 18 after surface lights
SetupLights: 18 after jittering
--- EstimateLightVisibility ---
0....1....2....3....4....5....6....7....8....9..
Final count: 18 lights 0 suns in use.
Colored light entities/settings detected: .lit output enabled.
--- LightWorld ---
0....1....2....3....4....5....6....7....8....9....
Lighting Completed.

lightdatasize: 30780
Writing KillBox.lit
0 switchable light styles (32 max)
Writing KillBox.bsp as BSP version 29
0.166 seconds elapsed

stats:
2.501321 lights tested, 1.470226 hits per sample point
0.000000 bounce lights tested, 0.000000 hits per sample point
15 empty lightmaps 
Out Of The Blue 
Did you delete the earlier *.lit file from your directory? 
Textures Not Showing In Compiled TrenchBroom Quake Maps? 
So, I've been trying to get into some Quake mapping with TrenchBroom lately(I'm new to this entirely). However, I can't seem to get textures to work; They show up perfectly fine in the editor, but in-game I just get a checkerboard pattern. I've been trying this with the QUAKE101.WAD file.

I've been trying to find info on how to fix this but can't find anything. Here's the compile log if it helps: https://pastebin.com/6GtEByYu 
Air 
Okay well, this message from your compile log is a good clue:

*** WARNING 01: No valid WAD filenames in worldmodel

In Trenchbroom, can you look at the worldspawn entity and see if it has a "wad" property? That should point to the filename and path to your intended wad file.

If that seems correct, maybe it has to do with how you're compiling. Does Trenchbroom handle compiling for you, or are you manually running a batch file? If a batch file, perhaps it can't find the relative path to the wad based on the batch file's working directory. 
 
The worldspawn seems to be correct, and I've been using TrenchBroom itself for compiling.

https://imgur.com/a/tEAKYRC
Here's the parameters, I wouldn't be too surprised if something's off there. 
 
Okay, it seems to have started working once I moved the .map file to the base folder that I'm using, rather than in id1/maps 
Reign Beta - My First Q1 Map!!! 
Hey guys, just "finished" my first multiplayer map for Quake 1 and thought I'd post it here for some feedback.

Had a couple questions:
1. How do define my map as a multiplayer map? Its loading as single player map despite me placing multiple deathmatch start entities in the map.

2. How do I get my map to show up in the multiplayer map selector on Quake Remastered?

Map: https://www.dropbox.com/s/hpx1evwrd7oiqty/ReignBeta.zip?dl=0

Screenshots 1: https://www.dropbox.com/s/mjth3xz5tug71ha/20210904214013_1.jpg?dl=0

Screenshot 2: https://www.dropbox.com/s/4zklg6z8n3k1tr8/20210904214022_1.jpg?dl=0

Screenshot 3: https://www.dropbox.com/s/iqgiltdyub7ewk1/20210904214135_1.jpg?dl=0

Screenshot 4: https://www.dropbox.com/s/btjimdjamnyveme/20210904214239_1.jpg?dl=0

Screenshot 5: https://www.dropbox.com/s/35uz08p650g94ds/20210904214252_1.jpg?dl=0

Screenshot 6: https://www.dropbox.com/s/om0of4bexprs9mr/20210904214311_1.jpg?dl=0 
 
#1 - You must be in multiplayer/deathmatch mode. Can do this by setting "deathmatch 1" ( or 2, 3, 4, see https://quakewiki.org/wiki/deathmatch ) and then loading your map. If you start multiplayer game through the menu, that's what the game basically does, setting deathmatch no non-zero (or coop 1 for cooperative play).

#2 - Maps showing in the level select menu I think are configured in a special file you can find in \Steam\steamapps\common\Quake\rerelease\id1\pak0.pak\mapdb.json though I don't know if editing it is a good idea. In case you want to experiment, don't put the edited mapdb.json back into pak0.pak (although you can always verify installation in Steam and redownload 'wrong' files), but rather pack it into pak2.pak file 
@Pectabyte 
Did you happen to add bot waypoints to this map? If not you might consider it. I haven't tried this but eventually I hope to do a tutorial on it.

https://steamcommunity.com/sharedfiles/filedetails/?id=2580864534 
Permanent Powerups 
Is there a hacky way (in vanilla or copper) to make a timed power-up (Quad, Biosuit etc.) last for the duration of the map after picking it up? 
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2021 John Fitzgibbons. All posts are copyright their respective authors.