News | Forum | People | FAQ | Links | Search | Register | Log in
Quake Injector Alpha2
A new version of:
The Quake Injector is a tool to download, install and play Quake singleplayer maps from the archive. Ever been annoyed by an excruciating installation process? Could not figure out how to install a certain map? Well, this tool makes it a piece of cake. Simply pick the map and click Install.

-Scan your Quake directory for already existing maps -and mods
-More stable and safe, less bugs
-Icon by the graphical genius Starbuck
-Rating is shown with golden stars
-Progressbars for anything downloading
-Better engine config dialog
-Window that shows you the engine output
-Links open in browser
-Downloads are stored locally
-Uses a custom user-agent when downloading
-Conflict handling

Quaddicted Spam:
First | Previous | Next | Last
OK Updated With Proper Credits 
New download link:

1. credits given in a credits.txt
2. changed name of setting file in .\id1 from dooomer.txt to setting.txt
3. changed readme.txt in .\QuakeInjector\doc to be notepad friendly
4. changed darkplaces.txt in .\port to be notepad friendly
5. kept the QuakeOne folder name to avoid confusion. You may simply rename it
6. the url in point 5 of my previous post should be 
Ah Fuck, I Uploaded The File 
to instead of !

Can someone move the file to tools and update the download link in post #111? 
OK, The Updated File 
has been deleted by admin of Quaketastic because it was uploaded to the wrong place.

Will upload again to the correct path later today. 
Bug Report 
Recent version of quaddicted_database.xml from seems to contain incorrect information resulting in only one entry shown on injector.

I opened it up in text editor and found that id for every entry is now 1374765832, thus only one entry is shown. Manually changing the id seems to correct the issue, but it's apparently impossible to edit every entry because it's extremely time-consuming. 
Should be fixed by adjusting an ugly hack to a changed database scheme. Sorry and thanks for reporting!

Maybe someone knows how to make it not a hack:

My query is SELECT * FROM maps LEFT OUTER JOIN (SELECT zipname, GROUP_CONCAT(bsp) AS startmaps FROM startmaps GROUP BY zipname) AS group_subselectbsp ON group_subselectbsp.zipname = maps.zipname LEFT OUTER JOIN (SELECT zipname, GROUP_CONCAT(dependency) AS dependencies FROM dependencies GROUP BY zipname) AS group_subselectdep ON group_subselectdep.zipname = maps.zipname WHERE maps.type!=4 ORDER BY maps.zipname;

With one array per row it leads to the ['zipname'] being empty but the numeric id ([2] here) being fine:

[0] => 1
[id] => 1
[1] => 1374765832
[timestamp] => 1374765832
[2] => 100b2
[zipname] =>
[3] => 2
[type] => 2

I have no clue why. 
Bug Fixed ? 
Just tried again a minute ago, and the bug seems to be gone now. Thanks Spirit! 
can you describe more what the problem is? what is the hack in your query? 
The problem is that somehow I do not get the column name of "zipname". I instead I access it by the number [2] (was [1] before I added a column, that's what broke). No idea if it is a PHP problem, if I use the sqlite3 CLI tool it does label the columns correctly. 
use names instead of * ? 
have you tried creating views in your DB instead and then just querying the views?

also, is there somewhere i can see the DB structure? 
Spike: That did it. I had three "zipname" columns so no wonder it went weird. I only select what I need now and it works like a charm. Thanks!

necros: There is an older database linked in . Only change since then is the addition of a timestamp column for all tables: timestamp DATE DEFAULT (strftime('%s','now'));

You mean views for the subselects, right? That might be a good idea indeed! 
i actually meant a view for the entire query. i don't know if it's the right thing to do, but i always prefer to store all my queries in the db itself so that my front ends are only ever doing queries like select * from my_view. this way, it simplifies my front end and hides everything about the db. 
There's a corollary of post #26 in the Quoth Launcher thread that might be worth dropping in here, for any Quake Injector users that are ignoring that thread...

So: For various reasons, I like to launch Quake through Steam. If you are in the same boat, it turns out it's way easy to use Quake Injector to do this. In the configuration dialog:

* Make sure that "-applaunch 2310" is at the beginning of the "Quake commandline options". You can have more options after that; it just has to be first.

* Set your "Quake Directory" to be the directory where you have installed Steam. For me this is "C:GamesSteam"; for you it might be "C:Program Files (x86)Steam".

* Set your "Quake Executable" to "Steam.exe".

Now when you launch Quake using Quake Injector, it will run Quake through Steam.

Unfortunately this is limited to running the Winquake.exe file in the Steam Quake folder, but nothing is stopping you from replacing that file with a QuakeSpasm executable or DarkPlaces or whatever. 
Hmm one sticking point there.

The "Quake Directory" actually has to be set to the steamapps\common\quake folder in order for new downloads to be installed correctly.

However that makes Steam print some warning messages about not being able to find a localization resource. Not sure yet how much that matters. 
Yeah, setting "Quake Directory" to the steamapps\common\quake folder is the way to go, and things work pretty well. To tie it all up:

1) The warning message about not finding a localization file appears to be mostly harmless. The localizations won't even be used unless the Steam bootstrapper encounters some issue running Quake.

2) You can make the message go away by copying the relevant folder and file (Public\steambootstrapper_english.txt, or whichever is appropriate for your language settings) from the Steam folder down into the Quake folder. This is kind of ugly though, and might break if a later Steam update changes the file. Actually creating a shortcut might also work; didn't try that.

3) It's easy to change the Quake Injector code to be more tolerant of these situations where the exe is not in the basedir. In the case of this Steam hack, the change would make it run Steam from the right working directory so that it finds the localization file.

4) Even if I get rid of the localization problem, I also see another warning in the case where Steam hasn't been launched yet: "[0406/] Failed to load C:\Games\Steam\bin\chrome.pak". It turns out that the current version of Steam always generates this message when I start it; I just usually won't see it unless I dig through Steam logfiles. It's harmless.

So, because of 1) and 2) it's workable. As for 3), I don't know if a new release of QI will ever be in the cards, but I'll mail Spirit about the patch. Fixing 4) is above my pay grade. 
There is some work going on at the moment and I would like to make a new release soonish. If you have some (small) issues that are not yet in , now is the time to speak. 
Could someone test ze Quake Injector on Windows 10? 
Works on Windows 10 for me. I've tried install, uninstall, and Quake-launching.

However there's currently a build error in the master branch. I have a proposed fix at ... I know I can merge that myself, but I'll wait a bit just in case I'm missing something. 
BTW, any opinions about issues that would be essential to take care of before the next release? Lots of ideas have been accumulated there on GitHub over the years... I'm not sure which (if any) are really jumping up and down for attention.

(Especially minor fixes as opposed to big new features.) would be great for user-friendliness. Right now a failed download will require the user to notice/remember it and manually remove the file. 
Seems like atm I can not connect to the database.
This is what I get:

"Database parsing failed! org.xml.sax.SAXParseException; lineNumber: 7284; columnNumber: 44; The entity name must immediately follow the '&' in the entity reference."

Worked just fine a couple hours ago. Something wrong with the server? 
Now it works again. Must have been some weird hickup 
Yeah.... some hickup... 
1 post not shown on this page because it was spam
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.