News | Forum | People | FAQ | Links | Search | Register | Log in
Quakespasm Engine
This engine needs its own thread.

Feedback: I like the OS X version, but I have to start it from the terminal for it to work and can't just double-click it like a traditional OS X app. I'm sure you guys already know this, either way great engine.
First | Previous | Next | Last
If I do -listen 2 -game arwop +map start

I see INADDR_ANY in status on Windows. My Mac can't connect.

So I can't host a coop game on Windows. And I tried it on my Mac. Same issue.

However, I *can* use FitzQuake 0.85 to host a coop game on Windows and make my Mac connect = my dreams come true!

I have 3 computers: a Vista laptop (playing Quake on that blows), a Mac Mini and an XP desktop.

Now I can play coop with the 2 desktops!

Argh! FitzQuake 0.85 Bug 
Trashed player skin.

I thought that was fixed.

Will post screenshot next time. 
OS X version got some love recently. Networking for OS X was using my SDL_net driver, which is horrendously broken. The launcher should work in 0.85.2 though, at least it does for me. 0.85.3 will add networking fixes that should allow you to host games as well as connect to games hosted on other OSs. It also includes automatic updates to future versions and I hope to add a command line history for the launcher if time permits. 

Btw ... I love the "disc causes core dumps" note in Quakespasm changelog. Now, I'm rather OS X weak and rather Linux weak, but the disc is going crazy in FitzQuake 0.85 with ARWOP paused (!) in coop.

I'm thinking that disc isn't part of the solution, but part of the problem in any version of Quake. 
i use quakespasm currently as fitzquake has the w7/multicore timing bug. there are a surprising number of engines that have the timing bug, actually.

anyway, it's awesome except there's some kind of bug that causes the engine to not recognize the numpad. kind of annoying as it seems like some kind of oversight. 
Hmm... the numpad seems to work for me under linux and winXP, so i'm not sure what the problem might be.

We have been fixing networking code (cheers SleepwalkR). You can check-out subversion, or try this recent win32 binary 
Multicore Timing Bug = 
w7/multicore timing bug = Sys_FloatTime

Sys_DoubleTime should replace it in FitzQuake 0.85. The SDL version including FitzQuake SDL 0.80 doesn't have this issue just due to the alterations and the library or at least FitzQuake SDL's implementation of it.

Clock fixed NQ engines = DarkPlaces, JoeQuake, Qrack, ProQuake. All QW engines have the fix.

A symptom of the problem: demos play all jerky. 
Dear Quakespasm team,

your website is confusing and awkward to use. I have to hover the links to find out what hides behind the pretentious names. When there is text and links mixed, the text stands out more, suggesting it is a link. 
Cd Stuff 
Ha ha.. i made the cd player to work in dedicated mode. quakespasm -dedicated -cd inits the sound and cd subsystems. Also added "cd next" and "cd prev" commands... It's only about 20 lines of bloat, but SDL is so common and works mostly that this is quite handy for me. I should reinstall QNX and see if i can get it going there. Baker.. what do you think ?? The code's in svn, and i've updated the above windows bin too.

I figured out the windows device format too for when it doesn't get auto-detected. It's something like quakespasm -cddev F:\ 
@Stuff I Don't Know 
I should reinstall QNX and see if i can get it going there. Baker.. what do you think ??

No clue what QNX is, well except Googling it.

I'm not very Linuxy, although I am very adaptable. 
Nah..i'm just wondering about the uselessness of a quake/sdl command-line cd player. It advances tracks now, though it's possible i've broken something somewhere. 
I'm wondering about that, too. What's the point? 
A few lines of code saves me installing bloatware like microsoft mplayer just to play CDs. 
but I don't care either way. Just don't turn QS into an emacs clone. 
0.85.3 is up downloads, changes.
Nothing major, mainly just the networking stuff previously mentioned. 
Gamma Patched LibSDL 
For people with newish systems (Xorg >= 7.5) and broken brightness slider, these patched libSDL binaries should hopefully fix the thing.

libSDL 32 bit
libSDL 64 bit

I guess there could be side effects, as it's not officially included with libSDL. 
Quakespasm Statusbar 
Hello everyone. Only recently decided to venture into Quake once more. It's been since.....well it's been too long. DOS! I'm amazed at all the work that has been done, especially the engines and I've tried more than a few and Quakespasm comes out on top as far as I'm concerned but there is one thing that's bugging me and I can't seem to find the answer or their isn't one.
I'm running the Linux and Quakespasm performs outstanding for the most part but I have no statusbar....Any ideas how to enable it? I've Googled for several days and read countless joy. Any help would be appreciated. 
try viewsize 100 at the console

then you can use scr_sbarscale to adjust the size.. (1 being normal, 2 being twice as big.. 1.5 also works) and you can also use scr_sbaralpha 0.99 (instead of 1) to get it to sit 'in' the view rather than below it, which imo feels nicer

quakespasm is basically a modified fitzquake, so having a copy of the FQ readme is helpful for commands n stuff: 
Viewsize 100 
Great that works. I knew there must have been a command somewhere. I was assuming it would be under scr_something. Now how to get it to persist. What would I put in my .cfg file?
Yea I did look over what documents were available but I would never have seen the relationship between the two. Good man. I had already figured out the size and alpha blending but the non-appearance of the bar was a mystery. 
No Worries 
i just have an autoexec.cfg file in id1 which sets it each time. you may be familiar with them but if not, it's basically just a list of commands fired each time you start quake, regardless of mod 
*familiar with that. i know what i meant 
I had edited that but edited as view "100" rather than viewsize "100", which I had correctly entered in my config.cfg file. I have corrected my autoexec.cfg file and all is well. Thanks a million. This has led me to search for other commands to finesse my configs...which I find are numerous and make Quake a very personal experience. 
Need For Speed 
Another question.....the speed I have set as..
_cl_forwardspeed "999"
but that has no noticeable effect. It's still not fast enough for my taste. Syntax correct? 
you must also change sv_maxspeed 
I don't have a sv_maxspeed listed in my configs.
Is the syntax as you have written correct and in what increments is it set? 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.