News | Forum | People | FAQ | Links | Search | Register | Log in
Quakespasm Engine
This engine needs its own thread.

Feedback: I like the OS X version, but I have to start it from the terminal for it to work and can't just double-click it like a traditional OS X app. I'm sure you guys already know this, either way great engine.

http://quakespasm.sourceforge.net/
First | Previous | Next | Last
Problems Using DSR Resolutions 
After finding much success with EZQuake and 3620x2036 DSR enabled via NVIDIA settings I notice that QuakeSpasm cannot handle the DSR resolutions well: the console rendering gets all whacked. 
 
Define "all whacked"
I can run it in 7680x4320 and it looks just fine.
Have you tried changing scr_conscale? (also scr_menuscale, scr_sbarscale) 
Chedap 
Well, this is odd: I tried to take some screenshots to show exactly how it is "all whacked" only to realize that screenshots in fact show the console and the entire screen rendered correctly. It's only on my actual screen where things look wrong.

As I started paying more attention I realized that going above the screen native resolution of 2560x1440 increases the overall "zoom level" of the screen. When using DSR resolutions, I can clearly the the bottom "status bar" dissapear and the left side of the console window falls outside the viewpoint. As the DSR resolution is increased further, so increases the amount of this "zoom" leaving out borders of the screen out from view.

Are there some other cvars involved? 
Nevermind 
Apparently QuakeSpasm was trying to used windowed mode instead of fullscreen. 
Cl_bobcycle Causing Grey Screen 
Setting cl_bobcycle to "0" makes the screen go grey.
Found this out after a long battle to get things to work again. 
#3631 
Setting cl_bobcycle to "0" makes the screen go grey.
There's a division-by-zero in the original code with cl_bobcycle 0 - "cycle = cl.time - (int)(cl.time/cl_bobcycle.value)*cl_bobcycle.value;" - whether or not it makes your game go nuts probably depends on compiler options/etc and unfortunately in the original engine it was OK but in some ports it's not.

So just set it to a really low value until the QS devs fix it. 
 
I think the intent was "cl_bob 0", not bobcycle 
 
I had an config file which works good with many engines. At some point though I only got this grey screen in quakespasm. After finding the solution I wanted to post here to help anyone experiencing the same problems. 
 
Yes, "cl_bob 0" is obviously the intended way to disable bobbing in the engine, but unfortunately "set cl_bobcycle to 0" is one of those items of "Quake lore" that gets passed around, which accidentally works some of the time, but which is actually wrong.

Fortunately it's an easy fix in the code: just check if it's 0 and set cycle to 0 if so: https://github.com/id-Software/Quake/blob/master/WinQuake/view.c#L117 
Dynamic Shadows 
So, I woke up at 3am, bored, and well here's this..

https://youtu.be/2SABwkUnqRE

in r_alias.c

i just added the shade variable in GL_DrawAliasShadow
after..

R_LightPoint (e->origin);

shade = (((lightcolor[1] + lightcolor[2] + lightcolor[3]) / 3)/128);//R00k

//then

glColor4f(0,0,0, shade * (entalpha));//R00k: fade light based on ambientlight

//before

GL_DrawAliasFrame (paliashdr, lerpdata); 
 
un-private the video fella 
Doh! 
Needed Features 
Hello. There are any chances to see WinQuake's software render with oldschool look/atmosphere and QuakeWorld servers support? 
 
Quake Qbism. 
 
qengine
engoo 
 
"QuakeWorld servers"
Zquake 
 
There is no Vanilla based engines with those features, so I want to see it in QuakeSpasm. 
 
tyrquake 
 
Its exactly the same as WinQuake even with no proper widescreen resolutions support and this port has its own bugs, so it has no sense. 
 
tyrquake, compared to WinQuake, can render more complex maps (BSP2 support) and has model interpolation. It also has alpha support for models and liquids, including the software renderer.

I'd say it's otherwise close to WinQuake, but it certainly has improvements. It certainly is not on the feature-level of quakespasm.


Talking of which: I noticed vkquake included QSS' support for decoupled render/physics framerates: https://github.com/Novum/vkQuake/commit/ffc9adf2ec52d3b786f6e80c61f3eabea697eacf

Looks surprisingly non-intrusive and should not alter behaviour for framerate caps up to 72. Is this something that can be considered for upstream inclusion? 
 
iirc the 'decoupled render/physics' is from quakespasm-spiked. And it does have limitations.
if you are on a huge map and your frames drop below 72 it starts to produce a slow-motion effect the further away from 72 you go. And on the opposite end, the higher you go over 500fps, it gets faster.
but, for the 72-500 range it works fine. And it's not the logic of the code, it also happens on othe independent physics code i have tested. 
 
Yeah, that's code from quakespasm-spiked.

As for problems above 500 fps - well, capping it at (pulling a number out of thing air) 300 fps would still enable a match for all modern display devices, so that's the easy case.

Slowmo below 72 fps, of course, is a problem. I wonder if the engine could detect that and switch dynamically as per situation. 
 
Basically, grab the current fps value, if its < 72 then turn off the independent physics code, and let the engine run like normal. 
 
same for > 500 too. 
 
You could also run multiple physics frames of the renderer is running slow. 
Setting Server Ip On Linux 
is anybody able to use the -ip flag on linux? it works fine on windows, but it seems to be useless on linux. other flags like -game or -dedicated work fine, so i don't think it's an issue with flags in general. it defaults to 127.0.0.1 no matter what ip is specified, which does not seem to be a problem as long as you have a linux client and server, but windows clients can't connect to a linux server in this configuration. i've tried it with regular qs and qss 0.93.2, both have the same problem. using qss the problem can be avoided by launching an automatically configured server from the menu, but running it as dedicated still gets you stuck at 127.0.0.1. 
Can't Play Quake Via QuakeSpasm Engine 
I bought first Quake and its mission packs in Steam. As many people recommend, I installed QuakeSpasm, and even installed soundtrack for all three games, and got Steam Overlay work with QuakeSpasm.
QuakeSpasm menu works OK - options and everything. But I pushed to start a new singleplayer game. Spasm crashes. Then I looked up, that I downloaded x64 version cause i'm using Win10x64. I reinstalled to x32(86) - the same problem.
Also, I tried to enter the game through console - "map e1m1" - the same problem - crash.

Sorry for my bad english, I tried to be correct as possible as it can be for me. 
#3653 
Are you on a laptop? What video card are you using? Can you play with a software rendered engine like Super8? http://super8.qbism.com/

How about a WinQuake?

You can also try Mark V's version of WinQuake: http://quakeone.com/markv/builds/1099_mark_v_windows_revision_4.zip 
#3653 - QuakeSpasm Crashes 
I've been able to reproduce this and fix it (or work around it) on a test machine by running with -noglsl.

The symptoms were broadly the same as you - the engine starts up OK, I can navigate the console and the menus, but as soon as I start a map (in any way) it exits silently and nothing is logged.

That seems to suggest that something's going wrong in the VBO loading code, and I hope to get a debug build going on this device soon-ish. 
#3653 - QuakeSpasm Crashes 
Bit of an overdue update.

It doesn't crash in a debug build, only with the released binary. I guess you need to run with -noglsl then. 
Down With "file Merging"; Up With "basegame" 
I did a quick hack of my own build of Quakespasm so that it supports "-ad" and "-copper" arguments in a similar way to the existing "-quoth" argument. It has made playing AD or Copper map releases so much nicer; just bang them into their own gamedir and away you go. No manual file merging, no mixing of savegames, easy cleanup/uninstall.

I realize this is probably not the right way to do it as a general feature for public consumption. FTE for example has a generalized "-basegame" feature that seems to work for this purpose.

I don't want to relitigate "well then just use FTE" here -- often I do, there are reasons why sometimes I (or others) don't -- that's old ground and in any case Quakespasm will continue to be popular for a long time. I'm posting here just from general curiosity about whether there's a gotcha that has prevented this sort of feature from showing up in Quakespasm. I dimly remember some past arguments/discussions about why or why not to implement this. (Although I don't know why "-quoth" got a free pass.)

Also I'm kind of generally curious about the state of QS development and whether there's a process for contributing to it. I took a look at the Quakespasm repo on Sourceforge and there's activity, but it seems to be pretty buttoned-down as to who can open a ticket or otherwise contribute.

Anyway... if I had to enumerate the stumbling blocks that I see folks running into on reddit or Steam forums or GOG or wherever, the lack of a Mods menu would probably be #1, but this thing about needing to do file-merges to play AD or Copper maps would be somewhere in top 5. 
 
Here's an example of the (clean but hacky) approach of just adding "-ad" and "-copper" support:
https://github.com/neogeographica/Quakespasm/commit/d38492f24deffd765792d117292ddde6c54cc5a4

And here's an example of a feature supporting a generalized "basegame". Gets quite a bit messier because of maintaining backwards compat for other existing messy behaviors, so I'm not sure if this is actually the desirable solution, but it works for me. Described more in the commit comments:

https://github.com/neogeographica/Quakespasm/commit/5b849b3abe32809f7047b24b790b177a0a8dc60c 
Warp It 
Are there any chances to add vanilla-style underwater warp? Right now, Mark V is the only port I know that pulled it off. 
SDL2 Binaries 
Where can I download SDL2 version of QuakeSpasm? The http://quakespasm.ericwa.com/job/quakespasm-sdl2/ link is dead. SDL1 does not allow you to change refresh rate and defaults to 60. 
 
http://quakespasm.sourceforge.net/download.htm

"quakespasm.exe" is what you run from among the files in the downloaded archive (assuming Windows). 
Thanks 
I somehow had managed to find the quakespasm-sdl12.exe binary in both my gamedir and a downloaded archive, but not the "quakespasm.exe" which is the sdl2 binary. 
 
👍 onward! 
 
@NightFright, vkQuake has vanilla underwater warp and is based on QuakeSpasm. It uses Vulkan for rendering. It's my main Quake port, partly because of the water. 
R_drawclipbrushes 
Could we have a command like r_drawclipbrushes to show playerclips in a similair fashion to showbboxes? 
Couldn't Spawn Server Error Upon Loading Saved Game 
What could cause this? It's happening with this map, and based on the first comment it got on Quaddicted, I'm not the only one. I'm really trying to understand why this is happening more than anything else.

The map loads and plays fine, but won't reload from a saved game:

Couldn't spawn server maps/_by_humankills:__0/_79____.bsp
Couldn't load map


It kind of looks to me as if the engine is unable to locate the .sav file, but I can locate it in my id1 directory. Besides, I always thought the "Couldn't spawn server" error happened if the engine can't find the .bsp in question, and not the .sav...?

It also looks as if it's trying to find the .sav in /maps instead of in id1. And why is it looking for the third line of the .sav file (as I saw when I opened the file with a text editor), instead of "s[some number].sav"? 
And A Different Error When Trying To Load A Saved Game 
With another map (retrojam6_danzadan), I get this error when trying to load from a saved game:

Host_Error: ED_ParseEntity: EOF without closing brace

I assumed this meant that the .sav file ends without a "}", and when I opened it in a text editor, that was indeed the case. Why would something like this happen?

Out of curiosity, I added a closing curly brace manually to see if that would let me load the saved game, but all that did was to give me a new error message:

Host_Error: ED_ParseEntity: closing brace without data

:D

I should note I can usually load from saved games without any trouble. This weirdness is just happening with two maps (that I've noticed). 
 
Looks like a corrupt save file but I can’t explain why. Is it consistently happening with this map? Or does the save sometimes work? 
 
The two errors I described in #3666 and #3667 both happen consistently with the respective maps: the "Couldn't spawn server" error always happens with autumn_sp and the "Host_Error: ED_ParseEntity: EOF without closing brace" error always happens with retrojam6_danzadan.

Other maps work fine.

Don't know if this is related, but I remember that back when the first retrojam was released, retrojam1_skacky had an issue where saved games wouldn't load. A subsequent Quakespasm update fixed that, though, so I'm guessing these two maps have a different problem... 
 
Have you also been running these maps in Darkplaces, by any chance? Darkplaces has a nasty habit of putting things into save files that are incompatible with other engines. 
 
I do get the same issue with Earlu Autumn, but retrojam6_danzadan loads fine from a save for me. Noticed that the autumn_sp saves don't have any kill counts, which I don't think I've ever seen before. Not much help otherwise. 
 
*Early* 
 
Have you also been running these maps in Darkplaces, by any chance?

Nope, just Quakespasm.

Noticed that the autumn_sp saves don't have any kill counts

You mean in the Save/Load menu? Heh, that's true; I hadn't noticed that before. When I open the .sav files in a text editor, though, they do have kill counts listed right at the beginning (third line from the top). 
 
You seem to have put a newline of some sort in the level name
https://sourceforge.net/p/quakespasm/quakespasm/ci/15a41d21693fca935e41f81d2faf29b493247974/ 
I Am Not The Creator Of The Map 
I guess you mean human[rus] (the author of Early Autumn) put a newline in their level name. :)

Thanks for the response! 
PS 
Any idea what could be causing the "EOF without closing brace" error for me in retrojam6_danzadan?

(I'm not Danzadan either!) 
 
Click on the "download snapshot" button here for the latest code.
https://sourceforge.net/p/quakespasm/quakespasm/ci/master/tree/
Sorry, but i don't know much about it. It's possible in some world editor CR/LFs can get inserted into level names ?? Oz said he's seen this bug/little idiocy before, but wasn't until yesterday he'd tracked it down. 
Other Characters 
I think I've seen embedded " characters in strings cause the same error sometimes, but that's off the top of my head... 
You Mean As Part Of The Map Title? 
Because that seems to be the common theme in the case of retrojam1_skacky and autumn_sp.

Still wouldn't explain what's happening with retrojam6_danzadan on my end; I checked the source and there are no odd characters, hidden or otherwise, in the worldspawn message. Or did you mean something else?

Thanks for the link to the latest build, stevenaaus. 
 
If you could share a copy of your save file somewhere it would help. At this stage it's not something obvious, nor is it easily guessable. 
@mh 
Sure, here you go: https://pastebin.com/Ru2G5SiK 
 
That save file is corrupted and missing most of the save data, so it'll never work. 
@mh 
Yeah, I gathered as much. What I was wondering was why Quakespasm consistently generates corrupted save files when I try to save while playing retrojam6_danzadan (whereas other maps save/load properly).

But never mind; I seem to be the only person experiencing this, so I'll just put it down to some weird anomaly on my system. It's definitely not a serious problem for me. Thank you taking a look and thanks again to everyone else who responded. 
 
Thank you FOR taking a look, I meant to write. 
 
No problem.

It's interesting that it failed at the "WAD" key in worldspawn - I wonder is that part of it consistent too? 
Something 
The wad key for that file is

C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\quake.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\BlueQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\CopperQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\MedievalQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\MetalQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\RockQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\WizardQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\WoodQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\AncientQMP.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\BaseQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\rmq_darkmet.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\ABrutTx.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\AB\abEgypt.wad

So it's 983 character long - is it overflowing a buffer somewhere? 
An Additional Thought 
Could it be the combination of a long string and needing to escape loads of backslashes? Perhaps the buffer overflow is in the string escaping part of the code? 
 
That's probably it. Edict writing to a save file goes through PR_UglyValueString which is 512 chars by default but which QS at some point increased to 1024. 
@preach 
I keep receiving a noreply.com on my email, even when using no addons. your email was bounced
You're having quiet a restriction on your box. 
My Bad 
off topic 
Hi Madfox 
I haven't done anything like that myself! I can only think that it's something automated the email service has done, possibly a spam filter malfunctioning? Or if you're emailing with an attachment it could be a false positive on the virus protection. I've added you as a contact now so try again and see if that helps. 
Sorry For My Late Response 
It's interesting that it failed at the "WAD" key in worldspawn - I wonder is that part of it consistent too?

Yes: I checked again by creating a few separate saves and they all fail at "wad".

And after reading #3686 - #3688, I tried a little experiment where I extracted the textures from the bsp into a single wad and then recompiled the map with a short and simple path/to/wad. That solves the problem: saving and loading work as expected now. So I'm guessing that confirms your theory, Preach? 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.