News | Forum | People | FAQ | Links | Search | Register | Log in
Quakespasm Engine
This engine needs its own thread.

Feedback: I like the OS X version, but I have to start it from the terminal for it to work and can't just double-click it like a traditional OS X app. I'm sure you guys already know this, either way great engine.

http://quakespasm.sourceforge.net/
First | Previous | Next | Last
 
Looks like a corrupt save file but I can’t explain why. Is it consistently happening with this map? Or does the save sometimes work? 
 
The two errors I described in #3666 and #3667 both happen consistently with the respective maps: the "Couldn't spawn server" error always happens with autumn_sp and the "Host_Error: ED_ParseEntity: EOF without closing brace" error always happens with retrojam6_danzadan.

Other maps work fine.

Don't know if this is related, but I remember that back when the first retrojam was released, retrojam1_skacky had an issue where saved games wouldn't load. A subsequent Quakespasm update fixed that, though, so I'm guessing these two maps have a different problem... 
 
Have you also been running these maps in Darkplaces, by any chance? Darkplaces has a nasty habit of putting things into save files that are incompatible with other engines. 
 
I do get the same issue with Earlu Autumn, but retrojam6_danzadan loads fine from a save for me. Noticed that the autumn_sp saves don't have any kill counts, which I don't think I've ever seen before. Not much help otherwise. 
 
*Early* 
 
Have you also been running these maps in Darkplaces, by any chance?

Nope, just Quakespasm.

Noticed that the autumn_sp saves don't have any kill counts

You mean in the Save/Load menu? Heh, that's true; I hadn't noticed that before. When I open the .sav files in a text editor, though, they do have kill counts listed right at the beginning (third line from the top). 
 
You seem to have put a newline of some sort in the level name
https://sourceforge.net/p/quakespasm/quakespasm/ci/15a41d21693fca935e41f81d2faf29b493247974/ 
I Am Not The Creator Of The Map 
I guess you mean human[rus] (the author of Early Autumn) put a newline in their level name. :)

Thanks for the response! 
PS 
Any idea what could be causing the "EOF without closing brace" error for me in retrojam6_danzadan?

(I'm not Danzadan either!) 
 
Click on the "download snapshot" button here for the latest code.
https://sourceforge.net/p/quakespasm/quakespasm/ci/master/tree/
Sorry, but i don't know much about it. It's possible in some world editor CR/LFs can get inserted into level names ?? Oz said he's seen this bug/little idiocy before, but wasn't until yesterday he'd tracked it down. 
Other Characters 
I think I've seen embedded " characters in strings cause the same error sometimes, but that's off the top of my head... 
You Mean As Part Of The Map Title? 
Because that seems to be the common theme in the case of retrojam1_skacky and autumn_sp.

Still wouldn't explain what's happening with retrojam6_danzadan on my end; I checked the source and there are no odd characters, hidden or otherwise, in the worldspawn message. Or did you mean something else?

Thanks for the link to the latest build, stevenaaus. 
 
If you could share a copy of your save file somewhere it would help. At this stage it's not something obvious, nor is it easily guessable. 
@mh 
Sure, here you go: https://pastebin.com/Ru2G5SiK 
 
That save file is corrupted and missing most of the save data, so it'll never work. 
@mh 
Yeah, I gathered as much. What I was wondering was why Quakespasm consistently generates corrupted save files when I try to save while playing retrojam6_danzadan (whereas other maps save/load properly).

But never mind; I seem to be the only person experiencing this, so I'll just put it down to some weird anomaly on my system. It's definitely not a serious problem for me. Thank you taking a look and thanks again to everyone else who responded. 
 
Thank you FOR taking a look, I meant to write. 
 
No problem.

It's interesting that it failed at the "WAD" key in worldspawn - I wonder is that part of it consistent too? 
Something 
The wad key for that file is

C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\quake.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\BlueQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\CopperQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\MedievalQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\MetalQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\RockQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\WizardQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\WoodQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\AncientQMP.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\BaseQ.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\rmq_darkmet.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\Repacked\ABrutTx.wad;C:\Program Files (x86)\Webteh\New folder\quack\Textures\AB\abEgypt.wad

So it's 983 character long - is it overflowing a buffer somewhere? 
An Additional Thought 
Could it be the combination of a long string and needing to escape loads of backslashes? Perhaps the buffer overflow is in the string escaping part of the code? 
 
That's probably it. Edict writing to a save file goes through PR_UglyValueString which is 512 chars by default but which QS at some point increased to 1024. 
@preach 
I keep receiving a noreply.com on my email, even when using no addons. your email was bounced
You're having quiet a restriction on your box. 
My Bad 
off topic 
Hi Madfox 
I haven't done anything like that myself! I can only think that it's something automated the email service has done, possibly a spam filter malfunctioning? Or if you're emailing with an attachment it could be a false positive on the virus protection. I've added you as a contact now so try again and see if that helps. 
Sorry For My Late Response 
It's interesting that it failed at the "WAD" key in worldspawn - I wonder is that part of it consistent too?

Yes: I checked again by creating a few separate saves and they all fail at "wad".

And after reading #3686 - #3688, I tried a little experiment where I extracted the textures from the bsp into a single wad and then recompiled the map with a short and simple path/to/wad. That solves the problem: saving and loading work as expected now. So I'm guessing that confirms your theory, Preach? 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.