News | Forum | People | FAQ | Links | Search | Register | Log in
Map Flickering In Quake
Put Quake on another PC, and it is having graphical problems for some reason. Oddly enough Q3A works fine. I'm not too knowledgeable when it comes to computers therefore I apologize if anything I say is stupid. OS is the newest Lubuntu, using what I assume is Nouveau driver. I tried using the Nvidia current driver, but Quake doesn't start on that one. The engine is Quakespasm.
That's annoying. Couple of questions.. What version of QS is this? The version is printed in the lower right of the console. Could you post a screenshot, or just give more details about what is flickering (what map, what part of the screen, etc)? Also useful would be to run "gl_info" in the quake console, and post the first 3 lines of output (gl_vendor, renderer, version).

there's a known flicker problem called z-fighting that shows up in some places, usually where an elevator, button, or door is touching a wall, but I'm assuming you're seeing a more severe problem.

If you're running QS 0.90.0 you could try launching with "-novbo", this will disable some renderer changes that could possibly have bugs. If you're running 0.85.9 it could be worth upgrading to 0.90.0. unfortunately we dont have linux binary snapshots so you'd have to compile from source.

btw for next time, this would better go in the quakespasm thread, new threads are meant for long-term discussions. 
Couldn't figure out how to make my own thread on the QS forum sorry. Parts of the map just flicker as I walk, as does the HUD occasionally (when it isn't invisible). Using version 0.85.9 the one from the Lubuntu software center. I'd use the latest if there was a .deb file for it since it makes using software on Linux user friendly. The console output is:
gl_vendor: nouveau
gl_renderer: Mesa DRI NV17 x86/MMX/SSE2 
gl_clear maybe, whatever that was? 
Hm, it's hard to say what is wrong. Trying "gl_clear 1" sounds like a good idea. also, you could try "r_oldwater 1" (should be the default anyway).

Good point about usability, I may look into making a linux binary of qs for the next release.

Also, darkplaces is worth a try, I think it comes with a linux binary in the zip download. 
Tried those two commands, but had no effect. Looked at Darkplaces but it doesn't have a .deb and I wouldn't know how to install and uninstall it how I'm used to. Would prefer a low resources and accurate engine if you know one since I'm using an old PC. 
Good point about usability, I may look into making a linux binary of qs for the next release.

That would be (to use a clich�d term) awesome! 
After writing those posts I had the GUI crash on me several times while checking that flickering mess again. 
Probably Drivers. 
I always use nvidia binary drivers, and i'd invest the time into getting them going.

Does the problem reproduce in fullscreen.
Also try "-nosound" just to make sure thats not it.

The Nouveau devs might appreciate bug reports/help debugging, or you could mess around with the GL settings and you might get lucky and find some combination of settings that are solid.
I'm not a cutting-edge linux user but .. 
Tested nosound and fullscreen, and both did not help. I hesitate to mess with GL settings ever since I could not get the Nouveau driver to work again after replacing it with Nvidia current. 
learn how to make backups, it's actually pretty easy with linux. eg just boot from usb and rsync everything somewhere or use some smart tool or partimage or something. then you can experiment safely (if your distro is not actually easy enough to switch between drivers) 
Darkplaces should be in debian/ubuntu if you want to try it, "sudo apt-get install darkplaces". Not sure how it would run on a geforce 4mx, may be ok if the effects are turned off.

while it could be a bug in quakespasm, qs 0.85.9 has been tested on a lot of different GL implementations and it should be solid, so I would lean towards this being a nouveau bug. I would suggest reporting it as a bug in nouveau.

Your best bet might be trying the nvidia binary driver, but you'll have to install an older OS :( .. apparently the binary driver only works up to Xorg 1.12 and can't be installed in recent versions of ubuntu (because they use newer xorg). here is the debian package for reference: 
Quakeforge should also be available, I think it is even just called "Quake". 
Darkplaces worked better but no without its issues. By default I could see the sky through the level (or Ranger took shrooms because it was pretty psychedelic). Changing it to 16 bit took care of that, but some lighting settings would not function properly. Toying in the menus I got it to look almost ok, however the framerate was rather inconsistent. Just wish it played and looked like stock Quake. Quakeforge seems to have no .deb files. The "Quake" listing on the Ubuntu packages comes with Quakespasm. 
(Sorry about the double post, don't see how to edit previous ones.) Forgot to mention I've tried the old Nvidia driver before it became incompatible and no luck. 
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.