News | Forum | People | FAQ | Links | Search | Register | Log in
J.A.C.K. 1.1.1058 Public Beta Is Out!
Hi all!

Jackhammer has been renamed to J.A.C.K. because of copyright issues, but there is also good news: we've finally passed Greenlight. This means that J.A.C.K. will be eventually released on Steam (Q4 2016). Thanks everybody for support! Today we are presenting the last pre-Steam version with more bugfixes and improvements. Further, there will be two versions of the editor: the Steam one, commercial, with SteamWorks features and automatic updates, and non-Steam, completely free, although updated not very often.

New version highlights:

* Hexen II Support: now the editor supports Hexen II, the game based on Quake engine. There are compilers, FGD file and palette in the install package. Game configuration of the editor is identical to Quake's.
* VMF Format: now one can import and export maps in VMF format; this is a Source engine format. Although the support is still in beta mode, and not all the features are supported (e.g. the editor can't process Displacements), you can use the feature to transfer your projects between VHE4 and J.A.C.K., and also to include other utilities to the development pipeline (e.g. HammUEr - an UE4 plugin).
* User Cameras: now it is possible to place, move and delete user cameras, like in VHE. There is also an ability to load and save such cameras to JMF, RMF and VMF formats.
* Triangulation: a special command enables triangulation of non-planar faces that frequently arise during vertex manipulation. This helps to get rid of many "Invalid Solid Structure" errors, and to facilitate creation of curved columns and other complex geometry using vertex rotation tool. Simply triangulate your complex stuff after you're done. This command, along with others, is added to a new context menu in Vertex Manipulation mode.
* Incremental Save: a new version saving command automatically adds version number to the file name. Such behaviour is familiar to 3DSMax users; it enables easy creation of checkpoints during prolonged project development.
* Improved Entity Report: now hidden entities in "Include Hidden Objects" mode are marked in italic; also there are Hide and Unhide buttons added, to hide and show selected entities. Besides the dialog remembers last parameters entered, even between sessions.
* Advanced Patch Texturing: Naturalize and Set patch texturing functions now account not only for scale, but also for shift and 90-fold rotation (i.e. 0, 90, 180 and 270 degrees). Along with that, Set function now performs in "naturalized" mode, i.e. taking into account segment lengths. These features greatly facilitate texturing of curves in Quake 3.
* Other Useful Stuff: tabs in Texture Browser, ability to hide triggers and unknown entities, ability to "lock" texture axes in Scale Vertices operation during vertex manipulation, display of selection center in status bar, tear-off mode for submenus, support for deformVertexes autosprite and autosprite2 in Quake 3 shaders, and many more.
* Lots of Improvements: the new version traditionally contains lots of bugfixes and improvements in comparison with the previous release. The editor became much more stable and functional. Please view a changelog for the details.

This version supports Quake, Hexen II, Quake II, Quake III, Half-Life, Gunman Chronicles and their modifications.
Supported operating systems: Windows, Linux.
Supported architectures: x86 (32-bit), amd64 (64-bit).

Web page
Feature list
Changelog of version 1.1.1058


Again, thanks for suggestions and bug reports, some features were added because of your requests.
First | Previous | Next | Last
I think it is only selectable in the game setup. Check your quake setup and see if valve map format is selected. Otherwise maybe copy that format and make a quake-orig profile or something. 
Yes, Thanks. 
I finally did find the option in the game config setup I overlooked. 
I'm Curious ... 
Have you added a way to move brushes that are grouped without ungroup them before?

After i updated to 1.1.1064 from 11700 (Win32), i kept finding brushes grouped with others that out of nowhere were moved a few units in horizontal or in vertical.

At first i thought that maybe was a mistake from my part, but i kept getting more, till i i got a leak and found out that a brush in a group i never touched much less ungrouped, in months was moved a few units in vertical, so it can't be a mistake from my part, except the only explanation i can think of is if you added such feature of editing inside groups.

I have also gotten always since i began using JACK times when one of the views i wasn't working in zoomed out a lot out of nowhere even though none of my fingers were even close to the numbers to zoom in and out and those are all the shortcuts i use, but i always thought that i was accidentally pressing some shortcut i didn't know of, but after what has been happening these last weeks, i am not so sure ... 
Ignore Groups (IG) 
Allows to move brushes in a group without ungrouping. Present in VHE since the very beginning (AFAIR) and in JACK too, of course. 
Zoom Jumping 
Don't bump the numpad. It instazooms to different levels. 
Cascaded Groups 
Is this possible?

This would be more flexible than Ignore Groups. Click on a group in the 3D view to select it, and each subsequent click would select a subgroup, all the way to individual brushes. 
FYI About Ignore Groups(ig) 
With this feature enabled brush entities will not show their properties in the Object Properties window. 
They do show properties even in the IG mode.
But! You can't select them. That's the point. 
Out of interest did you see the feature requests I posted in post #53 of this thread?

I just re-read them and realised I didn't communicate #2 well, it should read: The ability to snap a vertex along the edge of another brush, rather than to grid.

Is there any chance we might see some of these included in a future version? 
I Have Version 1.1.1064(64 Bit) 
Maybe a different version does but this version does not show properties, only the Visgroup tab. Which is fine, I understand the point.

I only brought it up to let people know in case they forget and leave it on, like I did. Had me scratching my head for a few minutes, hehe. 
could you change it back to use the bounding boxes sizes for entities that come with the .fgd? Right now it uses as boxes ones that are the size of the model, but the collision boxes are different on most cases which makes harder to map as you do not know if they fit where you put them or not or if they are in the right position for something. They are also sized in xx.xx numbers.

Ignore Groups (IG)

Allows to move brushes in a group without ungrouping. Present in VHE since the very beginning (AFAIR) and in JACK too, of course.

Then its definitely not that what happened to me. If it were it should have been happening for years, not when i updated the program. Also pressing by mistake ctrl+Shift+W is near impossible, taking into account i don't use any of those keys at all in JAcK or Hammer.

I will investigate more into the matter and come back.

Zoom Jumping

Don't bump the numpad. It instazooms to different levels.

Whats that? Looks like it does match the second problem i reported, but I searched around in JAcK and could not find anything similar. 
Vote On Greenlight For Game Whit Jack Support ! 
Selection Issue 
So I'm running J.A.C.K. on a laptop, and all seems fine except trying to select a brush or object within the 3d or 2d view will freeze J.A.C.K. for a few seconds, then finally selects the desired object. It also freezes for the same amount of time when deselecting an object. Everything else, including manipulating objects, resizing, texture application etc is instantaneous as it should be.

I'm running JACK 1.1.1064 on Windows 10, Intel GPU and CPU. All configuration settings are correctly configured for Quake. Any idea on what could be the issue? 
Have you tried disabling hardware acceleration? 
There is no hardware acceleration. 
I Got The Same Thing... 
It makes selecting multiple vertices quite irksome. :^( 
Jedi Outcast/Jedi Academy Support ?? 
Hi, really neat engine you've made here. I'm hoping to use it instead of GTKradiant for jedi mapping.

So my question is wether you're planning on adding official support for Jedi Academy in your editor?

I don't think it should be that difficult since it's basically built on the Q3 engine.

I know that there's unofficial support on moddb to add JA to the editor, but it isn't as good as official support, the maps take a long time to load and the editor gets stuck often.

So if you could please add official support for the Jedi Academy game, that would be awesome!

Keep up the good work :) 
So MalwareBytes keeps tagging the JACK exe from Steam as having generic ransomware in it ... what's up with that? 
The last reply by XaeroX was in January. 
Ask In The Steam Version Thread 
Orl / Generic 
re: #97/#98

Sorry to bump an old (superseded) thread... but just been searching to see if anyone else had experienced this problem - did you manage to sort it eventually?

Weirdly I've already imported a 10k+ brush Worldcraft map and edited it in J.A.C.K. with no problems, but starting a new map from scratch I get the same bizarre incredibly long lag when selecting anything. 
Do you have both maps open at once? Could be a bug where it checks all open maps. I haven't seen it myself though. 
Yes, I managed to fix the issue by manually updating the drivers for my laptop's Intel GPU. Once I did that, selecting objects in the 3d view was instantaneous as it should be.

So I guess my only advice would be is to update your GPU driver and hope that it fixes the problem. 
Thanks Orl, I was convinced that was the problem when you said that (also using an Intel laptop with, as I learnt, a massively out-of-date GPU driver). But having updated to the latest version I'm still getting the problem. And it now affects the 10k brush map, so that may have not had anything to do with it.

Thanks Qmaster too but no, nothing like that. I can't recall making any config changes in the program either so expecting it's something external.

I'll try and contact XaeroX I guess. 
Just in case anyone else comes across this problem, reinstalling J.A.C.K. with the 32-bit option selected solved it for me. Hooray! 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.