News | Forum | People | FAQ | Links | Search | Register | Log in
Spiked Quakespasm Modding/Coding Help Thread
Thread for figuring out all the new particle and modding features in the "Spiked" version of Quakespasm.
-----

Actual QSS engine download:
http://triptohell.info/moodles/qss/

-----

Tutorial on how to enable rain and snow on the Quake start map:

1. Video of snow: https://youtu.be/DvqxsJChXH0
2. Video of rain: https://youtu.be/NRud8T88tDc

Steps:

1. Put this start.ent download in c:/Quake/id1/maps folder. Tells it what textures emit snow and rain.

2. Put this weather.cfg download in c:/Quake/id1/particles folder. Indicates spawn information on particles and how they behave.

3. Enter r_particledesc "weather classic"; map start in the console. I assume "weather" is the name of cfg. Also seems to work with just r_particledesc "weather".

Stuff:

Q: How do you find out the name of textures?

With Quakespasm I don't know that you can, but in Mark V just type "tool_texturepointer 1" in the console and look at a surface and it displays the name of any texture you look at on-screen. screenshot

Q: How is the external ent file made and what does it need?

Open up Mark V and type "map start". Now just type "copy ents" and the entities for the entire map is on the clipboard. Open a text editor and paste. Save it as c:/Quake/id1/maps/start.ent

The first few lines of the file look like this, add the 2 bolded lines that tell the particle system that the texture names are "sky1" for snow and "wizwood1_8" for rain.

{
"sounds" "4"
"classname" "worldspawn"
"wad" "gfx/start.wad"
"_texpart_sky1" "weather.tex_skysnow"
"_texpart_wizwood1_8" "weather.tex_skyrain
"message" "Introduction"
"worldtype" "0"
}


A devkit is also available HERE http://fte.triptohell.info/moodles/qss/QSS_DevKit.zip with source code examples of how to create your own custom HUD using CSQC. The examples show CSQC recreations of the classic HUD as well as variations for the missionpacks and should serve as a good starting point for your own creations. There's a few other goodies in there too (e.g. particle stuff), so check the readme inside the devkit.

Discord
There's now an official Discord for FTE and QSS, find it here: https://discord.gg/E6fTcgB3ev
First | Previous | Next | Last
@Tribal 
Tried and it didn't help. 
In The Meantime 
There have been a few updates to QSS. Maybe it got fixed? 
 
> MD3 model support, basic IQM support.

What does "basic IQM" mean? 
IQM 
Short for "Inter-Quake Model". It is (or was?) intended as a replacement for MD5 and SMD skeletal animation formats. It was used in Cube 2: Sauerbraten.

If you want to read a bit more about it:
http://sauerbraten.org/iqm/

Anyway, I don't think it's a relevant feature for the average Quake player, rather a feature to cover all bases. 
100% Crash On QSS Version 0.94.1 And Higher 
Starting from version 0.94.1 and higher the QSS engine constantly crashes when switching between replacing models with MD5 from Quake Release and standard MDL models of Quake ID1 and then loading another map or restarting. Moreover it was tested with upgraded folders (particles/progs/textures, etc.) and with a standard ID1 folder and without MD5 models. All the same, versions 0.94.1-0.94.2 100% crashes when switching and loading another map or restart. On QSS version 0.94.0, everything works fine. Who solved this problem and how? 
QSS Error 
QS already fixed:

Changes in 0.94.3
Allow loading textures not aligned to 16 pixels and warn about them.

QSS 14.10.21:
https://quaketastic.com/files/screen_shots/qss_error.jpg 
Re: QSS Error 
Which mod is this with? 
Arcane Dimensions 
Texture 64x8 pix. 
#294 
I scanned ad-1.8p1, found nothing named 'litebary'. Which map is this?

BTW, the fix in qs-0.94.3 is _not_ meant as a free passport to used non-16-aligned textures: it is an open warning so the modded should fix his thing for compatibility with every other engine. 
 
That seems more like a bug in AD, since that is not a valid size for a texture in vanilla quake (therefore most engines) 
 
Just to be clear - the 16-alignment requirement only applies to BSP textures, and the reason for it is for storing all 4 miplevels for use by the software renderer; so: 16, 8, 4, 1 are the minimum allowed dimensions for each miplevel.

The requirement doesn't apply to other texture types. 
 
That seems more like a bug in AD, since that is not a valid size for a texture in vanilla quake (therefore most engines)

Indeed it is a bug (just like the bad sky textures sizes in ad_tears), but, as I said, what I can't find is the specific texture mentioned in #292 in ad1.8, i.e. this particular issue doesn't actually seem to be in pristine ad1.8 release. 
#297 - Ignore The Brain Fart 
 
This Is Texture From Custom Wad 
for my wip map. Of course I have already changed the texture size to 64x16 and error gone. But there is few custom wads with such "nonstandard" textures and now in Quake enhanced too. Ericw tools compiled map with this texture as usual. 
Same Error Appearing 
while trying to run horde2 map from 2-nd updated mg1 episode. 
 
for my wip map. Of course I have already changed the texture size to 64x16 and error gone. But there is few custom wads with such "nonstandard" textures and now in Quake enhanced too. Ericw tools compiled map with this texture as usual.

The big fat warning is there so that they fix their thing.

Same error appearing while trying to run horde2 map from 2-nd updated mg1 episode.

Their dev said that it was an unintentional mistake. But it still is a mistake, which we worked around and warn in qs and vkquake. 
 
I apologize for unwittingly raising a tempest in the glass, forcing you to look for an error that I generated myself. I want to thank you for your constant willingness to correct the mistakes arising from such idiots as me, nevertheless it is not so easy this is your personal time the most precious thing we have. Thanks to people like you, enthusiasts who spend their personal time, this sailing ship named Quake still keeps afloat, and not only keeps, flies in full sail thanks to the efforts of many. Quake Enhanced was released thanks to the efforts of enthusiasts, former enthusiasts and for the same enthusiasts, united by a common idea. Thank you for your hard work! 
Last Build Of QSS 14.11.21 
has issues with proper entities spawning.
Spoike, please bring back to Your site release 14.10.21 wich has no any issues.
Thank You. 
QSS 14.10.21 
I put the version on my Google Drive account some time ago. Have fun with it.

https://drive.google.com/drive/folders/19CjLzhEZPjFqERY3rQNXzCz8-qzvSd1h?usp=sharing 
So It Was Fixed 
And then it broke again or it's a different issue? I know some builds had enemies or items appearing in weird places or not at all. Right now I am using Ironwail, anyway. 
 
I noticed that the latest build now has sv_gameplayfix_setmodelrealbox set to 0 by default. AFAIK this is more like original Winquake behavior but differs from longstanding Quakespasm behavior.

For you guys that are seeing issues, do the issues go away with sv_gameplayfix_setmodelrealbox set to 1 instead? 
 
If so, it would be good to list some specific examples. I'm not sure why Spike wants to change this default but if it's a real problem, maybe evidence could be compiled toward changing it back. 
 
 
Can someone please add the FTE / QSS discord link to the top post for those who want to use it? There is a QSS dedicated channel there: https://discord.gg/E6fTcgB3ev 
@Qmaster 
added 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2022 John Fitzgibbons. All posts are copyright their respective authors.