News | Forum | People | FAQ | Links | Search | Register | Log in
FTE Engine
This engine needs its own thread... also!

FTE's homepage: http://fte.triptohell.info/

This thread is for the discussion of using FTE's enhanced features, and/or drawbacks, for Quake level design/modding and/or gaming in general.

Discuss...
First | Previous | Next | Last
 
For all your webassembly mp needs: https://github.com/coturn/coturn 
Weird Fps Drop In Ad_swampy And Sound 
I've been trying out FTE over the last few days.
I stumbled into a weird bug with AD in ad_swampy. Whenever I fire the SSG I get a huge drop in fps for just a few ms. It remains playable but it's not optimal.
I've set the fps counter to show the worst fps and indeed it shows drops from 150fps to 20/25fps when I fire the super shotgun.
I don't have the issue in the start map or in sepulcher, which is super strange to me.

I'm using the spasm graphic preset but I have tried messing around with the settings but nothing fixes it.
I even tried with no audio because I also have another issue where the underwater sound is way too loud.
On a sidenote it seems the audio output device menu is bugged when there are spaces in the device name (the console says the engine tries each part between spaces in turn before reverting to default device)

I have tried versions 5660 and 5529 of FTE.

Any idea what might be causing those problems? 
 
I don't get the FPS drops. Try with "impulse 130" (hitscan shotguns), would that fix it?

The issue with spaces is specific to OpenAL I think. So is the weird loud underwater reverb. I've found that you can use e.g. "s_device dsound" to set the device from autoexec or console, without the exact device name.

Note also that music is going to sound bad regardless of chosen device, unless the sound frequency matches the one in the music files. FTE defaults to 48khz, commonly shared ogg and mp3 rips are 44.1. Especially obvious in the E1M1 track. 
 
I have tried with the hitscan shotguns but it gives me the same issue. I've also tried deactivating AD particles (with the temp1 cvar flag), but that does not do anything.
I've tried a minimalist quake install (with only pak0.pak and pak1.pak in id1 and fresh AD 1.70 folder) with the "-nohome" argument. It's a little better, with dips into the 30/40 fps range when I fire the SSG (I also have the issue with the shotgun but to a lesser extent).

Thanks for the snd_device command. It did work with my minimalist install, but does not work with my main quake folder, I don't know why (snd_restart gives me no sound with s_device = "dsound").

I seem to also have the issue BoraxMan mentioned above where the game gets slower at I spend time in a level.

I guess I'll stick to QSS for AD for now.
I still think FTE's a nice engine with cool features for a lambda player like myself. 
MWHEELUP - MWHEELDOWN 
Hi,
I've been trying out FTE over the last period. I like it very much. An engine capable of dealing with huge single player maps and, at the same time, providing access to quakeworld multiplayer network!

However, I've a problem with Rhoenie's built for Mac. MWHEELUP and MWHEELDOWN can be assigned, for example for changing weapons, but they do not work.

The same config works perfectly under windows.

Regards 
 
bind mwheelup "impulse 10"
bind mwheeldown "impulse 12"

@R00k 
yes the binds are there. They work under Win but not in OS. This is why I'm reporting! thanks 
Fence Textures In Hexen 2 
Tried func_detail, func_detail_fence, nothing. Both with color index 0 and 255.
Is it even supported at all in Hexen? 
Func_detail Is Ericw Compile Add On 
Func_detail is a compile parm specific for quake compiling. Nother sure if HexenII compiler can use it. 
Hmm 
There is a func_detail and a func_illusionary for HexenII (in Trenchbroom) as well though.
I'll take a look at the source. 
I Think 
I twisted map compiling with code compiling. 
 
whats the most stable FTE build for 64 bit linux? latest master crashes too much :( 
Vulkan Support 
Hi there! I was drawn to this engine for it's features, ease of use and Vulkan support. Unfortunately, I can't seem to get Vulkan working. When I select it and Apply the change, my screen starts to flicker and the engine eventually crashes.

I'm running Windows 10, v1909 with an AMD Radeon Vega 64 on current drivers - 20.5.1. GL drivers for AMD cards are known to be poor, but Vulkan tends to run with great performance.

I'd love to get Vulkan working if you have any thoughts on recommended settings or tweaks that might help.

Thanks! 
Vulkan Support Additional Information 
Just thought I would add if it helps, I have tried builds 5529 and 5695, both 32 and 64 bit versions. I would be happy to take a look at older potentially working builds but I don't see anywhere they can be downloaded from.

Thanks again. 
Vulkan Error 
I find I am getting the following error - ERROR: vkAcquireNextImageKHR: VK_NOT_READY - Perhaps this helps troubleshoot. 
@ Placo 
Regarding the huge FPS drop, yes, this I think is a sound driver issue, add: `snd_device dsound` to you `autoexec.cfg` 
Reshade 
I love FTE but recently I tried using Reshade with it and I can't seem to get it to work. I have FTE and Reshade set to use GL but no luck. Any ideas? 
Just Started Using This Sourceport Because Of AD 1.8 
Some basic questions:
Why my graphics settings doesn't save after quit?
Why crosshair and console text is smooth when everything else from textures to particles can be made crispy pixelated? 
MP3 Music 
Bump alert, sorry in advance.

Was wondering how to get MP3 music working? I used the tracks that play just fine in QSS, put them in a "music" subdir in my id1 folder and then... nothing. Am I missing a DLL or something? Trying with latest build 6051 in Win 10 x64. 
 
FTE is, for sure, the most advanced engine out there. There are so many toggles, so many options and configurations... quite overwhelming. Thank you for the hard work and effort, spike!

I've been looking for an engine that adds networking features to Quake, things like input prediction, lag compensation, entity interpolation.

https://developer.valvesoftware.com/wiki/Lag_compensation
https://developer.valvesoftware.com/wiki/Interpolation

Are there any hidden toggles on FTE that would enable those? Even if in beta? 
 
After digging a little bit, I found this: https://github.com/svn2github/fteqw/blob/6871fd24f2a247310a8c31912f300816a4ef1035/engine/server/sv_user.c#L61

Which led me here:
https://github.com/svn2github/fteqw/blob/6871fd24f2a247310a8c31912f300816a4ef1035/engine/server/world.c#L2493

So, it seems that if you set that cvar to 3, then lag compensation should work well. Testing that next. 
Arm64 Build? 
I stumbled on to the armhf binaries for FTE in moodles and got them running on a Raspberry Pi 4B in 32bit Rasbian Buster. At 1920x1080 with mild overclocking, I get about 30fps. It’s very playable at 720p.

Given that PiOS 64bit is out, would it be possible to get a set of arm/aarch64 binaries similar to what is already posted? I tried compiling myself but it errors out. I don’t know much about coding. Any help? 
 
OK, so after a lot of testing and playing with friends from Europe and South America, tweaking the CVARS of both FTE and Darkplaces... DP wins, with the defaults from Nexuiz Classic.

I think this is maybe due to the earned experience from the Nexuiz team with a lot of players and constant feedback. It's not that FTE is bad at all, it's just not battle tested. 
 
FTE is best for specific projects that required scripting. As an engine itself, it's actually not that strong. But anyone who wants to weave a story through cutscenes would see use out of this. 
 
is there any trick for higher-resolution lightmaps in FTE? 4096x4096 maybe? 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2022 John Fitzgibbons. All posts are copyright their respective authors.