News | Forum | People | FAQ | Links | Search | Register | Log in
FTE Engine
This engine needs its own thread... also!

FTE's homepage:

This thread is for the discussion of using FTE's enhanced features, and/or drawbacks, for Quake level design/modding and/or gaming in general.

First Up, Replacement Textures And Lighting. 
Shaders not included ;)

Playing thru Fallout: New Vegas I really liked the subtle use of surface materials. Normals, gloss, reflections etc. I basically know what Darkplaces expects for replacement textures(files/names) but cannot find the information for FTE.

Or is it the same?

I know they share some commonality of certain features but I also know FTE has it's own extensions/capabilities as well.

If anyone has a link or can post the information I would appreciate it.

As far as lighting, to use surface materials, what in the menu's are the bare minimum I need to enable? Lighting Mode: Realtime and Offset Mapping? Or does Dynamic Lighting have to be used also?

My purpose here is to use the bare minimum solely for texture effects. Not complete RT rendered and shadowed Quake.

That's a start ;) 
Yay! It would be nice if FTE were discussed more.

1) Single player modern maps. Runs them all.
2) Co-operative play is an option because it has Spike's superior form of the Quakeworld protocol ...
3) -- which is backwards compatible, so it can online deathmatch also.
4) Conservative in appearance by default.
5) Compatibility and expected behavior. (Sorry, DarkPlaces).
6) Extended capabilities available -- support for more model formats, Q3 maps, is the source of the effects available in Quakespasm Spiked, QuakeC extensions.

Weakness: No Mac build, although there are only 15 Mac users in all of Quake. It is understandable since it almost requires a Mac to compile for a Mac.

Minor gripe ... the useful "apropos" should be renamed "find" modelling after the (successful and user-friendly) Half-Life 2 engine (Source) -- instead of mirroring the goofy name for a (unsuccessful with average people and not user-friendly) Linux operating system command that DarkPlaces chose (lemmings, cliff, and all that). Why not mimick winners instead of user unfriendliness?

If there were one engine that can do the most things that Quake/Quakeworld can do and do it right, it is FTE.

FTE has a wiki with documentaton:

(Link to wiki on FTE page is broken? Or is there a new wiki?) 
dynamic light aspect is interesting, i was thinking about making a map with the level of destructibility of hexen 2 but have concerns with how with how pre-baked is going to play with things like that.

Also if i made a map exclusivly using dynamic lights i think you may actually have to take geometry complexity and map size into consideration.

maybe... it runs pretty well for all the graphic addons usually ports like this have all kinds of input problems and just dont feel like the original. 
that was my post, weird forum 
I've Been Testing FTE 
...this week on my new/old map. I found an issue last night but I will be damned if I can recall what it was... it was at the end of the night and not a crash. I will go back later tonight and see if I can jog my memory.

maybe physics? I dunno. I was swapping between engines last night.

I do know I would love FTE to have FF and REW of demos. 
gl_load24bit 1 // otherwise you get no high-res textures.
gl_specular 1 // enables specular (aka: gloss)
r_glsl_offsetmapping 1 // uses the height values in the alpha channel of the normalmap
r_deluxemapping 1 // combines the normalmap with pre-baked lighting directions (light your map with -lux). No RT lights needed.

r_shadow_realtime_dlight controls whether to attach rtlights to stuff like rockets and explosions. should not normally be used at the same time as r_dynamic (ie: lightmap-based dynamic lights, doesn't affect lightstyle animations).
r_shadow_realtime_world controls whether most static rtlights should be used. note that each static rtlight has a 'mode' field that allows it to be enabled by either rtdlight OR rtworld (or if either is enabled).
r_shadow_realtime_world_lightmaps controls the strength of the lightmaps when rtworld is on.

texture naming is basically the same as DP, except more permissive for fuhquake/ezquake compat reasons.
q3-shader is compatible with q3 instead of dp, if you want to use shaders made for DP then you can try r_programmify 2, but its a global setting. That said shaders that don't specify any glsl probably shouldn't be used anyway.
Here's an example shader that explicitly names all the textures to use:
program defaultwall //the glsl to use to draw this surface. use defaultskin for mdls/iqms.
diffusemap foo
normalmap foo_norm //alpha should be height values for offsetmapping
specularmap foo_gloss //alpha is an exponent multiplier
fullbrightmap foo_luma
//uppermap foo_upper //not normally needed for walls
//lowermap foo_lower //not normally needed for walls
reflectmask foo_mask //mask for cubemap reflections
reflectcube somecubemap //better to set VF_ENVMAP in csqc than use this
width 64 //explicit sizes avoids weirdness with .maps (which lack the size info from embedded mips)
height 64
You may wish to throw in an explicit pass if you want the shader to work properly in DP or without glsl, or if you want to specify a blend mode.
The program term can be used to load custom glsl code for your surface (eg altwater that samples from reflection/refraction fbos for 'pretty water' type stuff). You can pass args by appending #foo=bar onto the program's name (or adding #foo onto the texture name in the map, if you can avoid q1bsp's 16 char limit).
Custom glsl can do lots of stuff, but is more likely to break (eg: with the d3d renderers).

r_shadow_realtime_dlight can enable static dlights without affecting static lighting. When combined with a few spotlights, the result should be much more efficient than trying to light the entire map with omnilights.
Or stick to fence textures for your destructables, and flag them as not casting shadows.
The real issue with rtlights is that mappers have no idea which setting the user is actually using, which means either lots of work, or users complaining that its bugged or whatever.
sidenote: if you want authentic hexen2, then remember that hexen2 has a habit of just forcing absolute light levels, ignoring the prebaked lighting entirely on various bmodels. 
demo rewind is _far_ from trivial once you have proper delta compression and sporadic stuff like player updates (or worse...). While it would theoretically be possible to create a 'reverse' copy of the demo, that sort of thing would be a _lot_ of work, and probably be buggy more often than not.
That said, demo_jump -10 will jump 10-secs backwards by restarting the demo(when jumping backwards) and instantly replaying it up to that target point, or you can give timestamps.
cl_demospeed can be used to provide fastforward or slow motion stuff. You just can't set it to a negative value.

regarding physics, fte defaults to qw physics for prediction to work. set sv_nqplayerphysics to 1 if you want nq physics instead, but its probably best avoided in multiplayer. note that one or two of the presets also set this. 
Glad to have the option for the physics and that was what I was trying to remember after all! I recall trying to make some very specific jumps to a very narrow ledge and slipping off a bit. I am so used to NQ with QS that it's extremely noticeable. I have quite a few jumping puzzles in the map I am testing.

mmmm thats bad how the lighting setting would need tweaking to look right in the first place for users .

I did some experiments with breakable furniture, i guess it dosnt look to bad when its not casting a shadow, the AO these new compilers have kinda helps it not look to shitty.

Its always fun to play with new toys tho, especially all the render option this one has, is there an FGD file for the entitys i wouldnt mind playing around with it. 
@Spike - Thanks For The Info 
I'm not concerned with DP, just wanted to know what translated that I already knew. This would simply be for FTE only mapping. 
.fdg files are a human-friendly and easily editable. It's very to edit a .fgd file to add what you want.

Beginner level mapping stuff, really. Open one and look. 
Great Job! 
Just wanted to say that r_softwarebanding is a seriously awesome feature, very similar to gl_tonemap=5 in GZDoom (

Just wish it would be ported to Quakespasm (maybe the "Spiked" fork?) someday. It's the only "feature" that's still missing from DOS/WinQuake.

On another note, how did you fix the texture seams when upscaling the HUD in Hexen 2? It's still broken in Hammer of Thyrion after all these years. Did you change GL_CLAMP to GL_CLAMP_TO_EDGE or what was it? 
Surprisingly Good 
I've heard positive things about FTE, so i decided to put it to the test. Not only did it load both really large maps shib3 and shib5, it performed really well, marginally better than Quakespasm. Of course FTE does have it's minor problems.

Many distant scenery had details missing, and there were odd holes in the cliff side wall. In addition, at some point transparent textures and static entities disappear. Could this be hitting an efrags limit?

Shib 5 had less visual issues, but more prominent ones. The mountains in the background disappear completely until you get fairly close to them, which you typically cannot do, so the scenery looks really bland.

Despite these visual defects, the maps themselves run fine with no gameplay issues

The other odd issue that can be game breaking is every so often, the player will just spontaneously warp to a completely different spot in the map, either inside or outside. It just happens randomly without rhyme or reason.

But despite these small setbacks, it appears to be a terrific engine with lots of customizable options to suit the needs of any players. 
Shib requires gl_farclip 256000, which FTE doesn't seem to support. 
all that jazz and no VR support?

these older games play really well in VR for some reason if VR is modded in correctly the new quakespasm sdl2 works great.

hacky injected forced VR however is poison 
Mirrors, True Rotation, Etc. 
Spike once said FTE has recursive mirrors. (99% on this).

FTE also has true rotation available and ericw-tools map compiling tools true rotation as an option. (To get the most out of true rotation -- like doors and drawbridges and such -- requires QuakeC, the Remake Quake game code QuakeC has that available ). 
Am I reading that right?

Just need to add RMQ's rotation QC code to a progs compile and all the pieces(ericw tools + progs + FTE) are in place for true rotation? 
Re: #17 
I already tested this so, it worked. No need for a reply.

Such an easy setup. Only downside left is the "choppiness" of the rotation. But every Quake rotation has this as well. 
That is correct. Should work in DarkPlaces as well. DarkPlaces also supports true rotation.

Rotation particularly is required for, say, func_door. You have to modify the door code.

As I understand it, it's probably a notch or 2 above novice level -- so if you are completely QuakeC clueless/coding adverse you'll either need to commit to doing a QuakeC tutorial or 2 to move yourself above novice --- or find a QuakeC literate friend and either bribe him/twist his arm to doing the task or helping you along the way.)

If you use something like WinMerge (a user-friendly file app to compare files or whole folders) to compare versus vanilla progs 1.06 source code to the below, you may find this useful as a start ... (ignore all the engine code on that page like world.c, sv_phys.c -- that ain't QuakeC).

Nothing about it is "hard". But will require a medium commitment to detail.

I, in fact, was quite newbie writing that tutorial and used WinMerge to extract the door rotation QuakeC from Avirox's source code. I doubt I understood much about the actual QuakeC -- but I didn't need to. Then I made a test map with Rubicon wad setting angle and such.

The QuakeC source is included with the sample map. 
Choppiness of the rotation should be able to be fixed. It needs higher precision angles.

I would expect that in DarkPlaces it may be smooth as silk because I believe DarkPlaces protocol 7 uses precise angles by default.

FTE may need some kind of "hint" to cause smooth angles.

I don't know how to do that.

Hopefully Spike notices your angle precision needs. FTE has protocol extensions (etc.), but I am not versed on those. 
You might be able to do "sv_protocol 999" in FTE. It may immediately resolve it if it is available, although if 999 is available in FTE, I'm not sure that FTE doesn't have something better available that would be a better choice in the long run. 
Spike can confirm, but I think it's "sv_bigcoords 1" 
Silly Me 
I had vsync enabled(hate screen tearing), it is smooth as silk now.

Thanks Eric, Baker, Spike and the RMQ peeps. 
gl_maxdist 0 will give you an infinite projection matrix, at the cost of depth precision.

@damage_inc / Baker
sv_bigcoords 1 is equivalent to sv_protocol 999, but also applies to fte's qw protocol too (and is required for the server to use dpp7, also).
this setting provides both 32bit coords and 16bit angles.
enabling vsync or setting cl_netfps lower, or making the thing rotate faster can avoid two sequential snapshots with the same angle (ie: the rotation periodically stops), giving better use of the precision that's already there. 
I'm not sure what that command has to do with what I described, considering its always on 0 by default. 
-lux Light Question 
Ok, I've been testing with this since I started this thread. Here's something I'm curious about.

I have a completely stock install of FTE making sure that these are set in my autoexec.cfg, and are working as intended:

gl_load24bit 1
gl_specular 1
r_glsl_offsetmapping 1
r_deluxemapping 1

Compiling, Light gets this:

-lux -extra4 "$bspdir/$file"

Nothing else, as far as the engine and the mapping, is changed for this test.

I am of course using some replacement textures each with normal maps and one including a specular map(floor).

My issue is, you know how we use "muzzle flash" from the weapons to light up dark areas? Or even just general rocket/grenade usage that lights up areas as well...

That doesn't seem to work for me mapping like this. Or it's inconsistent.

The dark areas most of the time just stay really dark(black/unlit) or... for no reason will light up occasionally and then stop again.

This of course looks strange.

Any thoughts on what I can do to correct this? 
I Tried To Screenshot It... 
... but no matter what window mode I select, FTE writes only a transparent image and my Windows "Print Screen" button seems disabled(?) as well!

Hope the info I provided is enough. 
I used OBS to record and grabbed images from video: 
How Deep The Rabbit Hole Goes ... 
rabbit holes, explore 2 or 3 with an advanced engine ... eventually ... you don't return at all.

Quake is successful because of the limitations (256 colors, etc.) and the many things you cannot do force an author to limit the scope of their project.

With an advanced engine, what starts as a project morphs into exploration drift -- then you find bugs or limitations.

I mention this because it is very uncommon to find a completed project that targeted DarkPlaces or FTE.

The specs of the project increase and increase, exponentially growing the labor hours required for the result --- until the number of labor hours passes the event horizon ... never to return.

A paradox ensues --- offering more capabilities dramatically increases the possibilities but decreases the probabilities.

So planned projects that plan to target the engine capabilities increase, but completed projects that actually do target the engine decrease --- usually to a specific number --> zero.

/Thought of the day 
Yes And No 
Having an engine with more advanced capabilities seems a dubious problem. Evidently there are projects built on UE4, CryEngine, Source, etc that do get completed.

Having the capability to mod the engine is IMO more of a problem. But blaming the engine is only half the story. Mod teams need to exercise discipline and restraint too. 
Limits Didn't Define Quake 
quake defined the limits higher.

This is accurate, in my limited experience. I have since imposed a set of limits on my project so that it will be coherent and actually make it to completion. IMO, setting limits was a great move both logistically and creatively. 
Weapon Bob In FTEQW 
Is it possible to change the weapon bob in FTEQW? Quake's default bob is annoying, the weapon just goes up and down, but it looks like it's stretching or some crap. Is it possible to change it to something like Doom, left and right?

I've noticed that DP has something similar:

FTE has cl_bob, cl_bobcycle, and cl_bobup. 
Fancy Weapon Movements 
If you're willing to write some CSQC code, you can just set cl_bob 0 and then implement whatever crazy viewmodel movements you want.

All you really need to do is avoid the MASK_VIEWMODELS flag in addentities and to then add an entity yourself using something like:

static entity ent;
if (!ent) ent = spawn();

The maths your mod uses are then entirely up to you.
(RF_VIEWMODEL is responsible for sticking the ent to the view, which avoids the need for matrix stuff, RF_DEPTHHACK messes around with the ent's projection to prevent it from poking through walls.)
(note that the above code lacks interpolation, its .frame2+.lerpfrac for that, but it makes examples messy. use .frame1time and frame2time if you want control over framegroups.)

Shpuld's TurboQuake mod is a good example of the value of csqc controlling viewmodels:
That said, its worth noting that using the vanilla content for it is more painful than it otherwise should be - like spinning the SNG barrel (read: spinning the entire model around a point which is not its origin). 
Where's FTE irc located at now?
The quakenet one listed at the site is empty, not even a bot in there.
I needed some assistance with FTE cvars and can't reach out it's chat hangout place, bummer. 
“also make sure you don't have both vid_conwidth+vid_conheight lingering from other engines - those other engines tend to have screwed aspect ratios. As a general rule you should only use ONE of them, with the other set to 0. “
true if the engine does console sizing correctly it will
autoadjust the height based on the proper
aspect ratio 
What's best place to find you for questions or documentation for FTE? Here? The Wiki seems pretty out of date. Is Sourceforge still the best place to report bugs?

5121 Win64 Dell Win10 laptop. I'm having keyboard input issues similar to buttons being held down. I confirmed the physical keys are fine and this behavior doesn't happen in other ports. I had changed some video settings prior to the issue. Restarting app had no effect. 
Is there any sane way to animate weapons and models from QC? Without having to tie frames and game logic and without having to declare each and every frame as a var and then as a function? 
Best way to poke me is generally via #qc, if I'm on. Or if you're on discord I got harassed into joining the Quakeworld one.

I don't know what would be up with the keyboard input. you could try toggling in_rawinput (followed by in_restart) which may or may not help, but I've not seen similar issues in the windows builds. I also don't use win10, but hey.

framegroups would be the obvious answer there.
however, animating with framegroups from ssqc is kinda messy as there's no way for the server to force a framegroup restart, which makes firing animations de-sync.
csqc has full control over the time into framegroups though, and because that's the answer to everything, you can use it to detect toggles of some bitflag and convert them into restarting whatever framegroup.
and if you're using csqc, you could also use it to position the various bones of eg an iqm via the skeletal objects extension, which allows things to spin independently of whatever animation they're otherwise meant to be playing, for smooth chainguns or whatever. 
Where i can find any examples of CSQC framegroups? Do they work normally with MDL and MD2? 
md2+md3 do not natively support framegroups, while mdl+iqm do.
csqc is quite explicit when it comes to animation, so there's about 5 fields that need to be updated each frame.
.frame+.frame2 define the two framegroups/animations to lerp between, eg when the animation changes.
.lerpfrac says how much of .frame2 to use (and thus how little of .frame to use). 0 uses excusively .frame, 1 uses exlusively .frame2, other values linearly interpolate.
.frame1time+.frame2time define the time into the two animations.

So, to switch from one animation to a new one, you copy .frame to .frame2 (and .frame1time to .frame2time), set .frame to the new animation (and .frame1time to 0), set .lerpfrac to 1, and then slowly decrement it over time (depending on how smooth you want the animation switch to be, probably lerpfrac=max(0,lerpfrac-frametime*10);
additionally, you need to increment both .frame1time and .frame2time by frametime. You can scale it or whatever if desired.

note that if you want to restart an animation, you will likely want to do it with lerpfrac (and .frame1==.frame2) instead of trivially resetting .frameNtime to 0, as this avoids sudden snaps.

when it comes to viewmodels, they're not really any different from any other entity. Just make sure MASK_VIEWMODELS isn't used, spawn a private entity with renderflags|=RF_VIEWMODEL|RF_DEPTHHACK, setmodelindex it to getstatf(STAT_WEAPONMODEL), and update its frame to getstat(STAT_WEAPONFRAME) as appropriate.
use some bit in the frame stat to signify animation restarts, and have the csqc restart the animation when its toggled by the ssqc or so.

So yeah, quite a bit of code that really needs some proper example code to fully understand. I don't really have easy-to-read code to link though, so I'm sorry about that. 
Thanks a lot for the information! I'll try to figure it out. Sounds very complex :D 
Does FTE support AD? The site says it doesn't, but I keep seeing people suggesting it... 
Should work for most AD maps. Might not work on sepulchre, swampy, or other megamaps. Spike can correct me, but I don't believe FTE has support for sv_protocol 999 even though it does support bsp2.

Spike could have done some updating though. I highly recommend he does since "can it play AD" seems to be the new standard for whether a Quake engine is "worthy" (initial AD release only specified Quakespasm as supported, leading to a lot of questions on other engines). Orl maps are a concern too since they are very very large as well. 
@idiot And @Qmaster 
use sv_bigcoords 1 for 999 maps (per Spike in a prior post in this thread) 
ad_sepulcher: worked okay last time I tried it.
ad_swampy: I really have no idea why anyone would think this map would have a problem.
999: sv_bigcoords 1; if its need isn't autodetected (if for some reason you want 999 specifically, also set cl_loopbackprotocol fitz;cl_nopext 1).

I'm not aware of any limits that are lower in FTE than QS, while I am aware of the reverse (even vs QSS).
That's not to say that there are no issues whatsoever, just that any issues are more likely to be due to qw-by-default player physics, or other such 'minor' incompatibilities that could affect ANY map...
And this is why you never fix what are obviously bugs. :(

But yeah, if I was aware of any issues with any of those maps that were mentioned, then I've either fixed them or just forgotten about them... Feel free to try them and shout at me should they somehow crash and burn. This is not a warranty - if it causes your computer to explode and destroy your entire city, then you probably shouldn't have been playing quake inside a nuclear reactor. or whatever. 
Any advancement on the control pad issue that myself and Kinn were experiencing? 
As I said in the other thread, I got PrimalLove to give me a list of changes on that front, which are now implemented in the latest build.
Most of it was just cvar changes, so you'll need to do 'cvarreset joy*' or to wipe that part of your config some other way. 
So... this is news for me... i've been playing quake with FTE for 6 months now and never experienced crackling sound :/ but when i play sm181_coce1 and sm181_coce2 i can hear some annoying cracklings... and if i go to "menu/audio options/restart sound" the cracklings stops, but if i load the map again, or just press F9, the crackling returns :(

Why is this happening? And why only in these two maps? :/ 
snd_restart doesn't restart static sounds.
there's a crackly static sound played near all wall torches.
I've no idea how you wouldn't have noticed that on other maps too though, maybe you've just been playing maps that use regular lights. 
I Suppose 
that in the first one the crackling comes from the torches, and in the second from light_fluoro or light_fluorospark (i don't remember which right now). But torches do a very different sound from the fluoro ... so maybe its another thing.

There is no logic gates or other sounds that repeat save the idle sounds from the enemies so it isn't from that, it can't be from performance as one is very open and the other took visibility seriously ... so I have no idea. 
Ok, i've made a video showing what i'm talking about =D

I choose "coce2" because it doesnt have torches, so there will be no mistake here ;)

After 00:27 you can hear the crackling sound. At 00:50 i restart the sound, and the crackling is gone, but the "wind" sound is gone too... So, at 01:30 i've loaded the map again to show that if you reload the map the crackling is back, and this time i fought some death-knights to prove that the crackling has nothing to do with the "wind" sound, since you can hear it when i'm fighting...

And at 02:15 i loaded the same map with quakespasm to show that there's no crackling sound in this engine.

But, as i said before, coce1 and coce2 are the only maps that i heard this annoying crackling ;) 
No Idea 
but it is not from my maps, as it isn't any of the sounds Quake does. I also used a completely clean install (just FTE.exe and the two .paks) of the game to check and heard none of that in any of the two maps so maybe it comes from your configuration.

What i noticed and will be interesting for the developer is something on coloured lighting: i have coloured lights everywhere on the map, but there is only one not coloured. It's values are 1 1 1 to make a very dark light, so i suppose that FTE misunderstood it as a light with values between 0-1 instead of 0-255 and made it pure white. Look back on the spawning point on skill 1 and you'll see it.

I also noticed that on default config hell_knight projectiles don't leave a trail. Rechecked it with E2M5 and the same happens so its not from my map. Gotta check which option puts that well. 
try using directsound instead of openal.
snd_device dsound
(or pick an explicit outpur driver+device via the menus)
or wasapi or sdl2 or alsa... etc...

this is the problem when there's a complete lack of standards.
you may wish to provide an .rtlights file with your map, so that the engine doesn't have to guess at all.

missing trail particles:
QS rounds up - particles get thicker at high framerates, making it harder to see enemies.
FTE rounds down - particles get thinner. This is consistent with other QW engines. Unfortunately they can get so thin that they become invisible...
I need to do something about this, I'm just not entirely sure what. The scripted particles do not have this issue (they have working distance tracking).
In the meantime, cl_maxfps 150 (or vsync), or 'r_particledesc high' will 'fix' it, assuming a lax definition of fix. 
Thank you!! Changing to directsound did the trick! =D 
what's the command to get q2-style noclip movement? (fly in direction you are looking). For some reason this keeps going away and I end up back with sucky vanilla noclip style 
#57, Kinn 
that's nq player physics for you. oh, so NOW you don't want it faithful! pah! :P
sv_nqplayerphysics 0 will give qw physics, which don't have that annoyance (yes, there are a few mods that depend on the vanilla behaviour, which just makes things messy). its default varies by preset, which is awkward. 
Hehe, well I don't consider noclip as "part of the game", so how that works can be as unfaithful as I like :}

Is there anywhere I can read about the differences in player physics between qw and nq, because it sounds pretty interesting, and is something that I've never really come across before, having been a single player all my life, and never actually played qw. 
Stunting the player experience is faithful!

Fucking hell. 
missing trail particles:
QS rounds up - particles get thicker at high framerates, making it harder to see enemies.
FTE rounds down - particles get thinner. This is consistent with other QW engines.

It's a little more complex than this.

If you run your favourite Quake engine at 20-30 fps - which is the best that most people would have been getting in 1996 - you'll see that the intended behaviour of particle trails is not a straight, continuous trail of particles, but actually a trail that drops "clumps" of particles at discrete intervals.

There was a .plan or something from Romero back in the day that exactly describes this effect, but I don't have a link to it handy.

So both NQ and QW are actually behaving incorrectly at higher framerates.

The correct way to "fix" particle trails is to track an "ent->oldtrailorigin"; if a certain timespan has passed (something between 1/20 and 1/36 seconds works good) drop a clump (using standard R_RocketTrail from ent->oldtrailorigin to ent->origin) and update oldtrailorigin from origin. Add in some reset behaviour for when a new ent is spawned or an existing one is culled, and you're done.

This way works consistently at any high framerate and doesn't excessively spam particles in timedemos either. 
Crunchy Piskels 
Ok, so I can set 3d filter mode to "nearest" and 2d filter mode to "nearest" to make the world and the HUD cruncky pixels, but is there a way to make the console / text pixelly? Currently it's blurry and the text has some line artifacts around it, which seem to be a result of the filtering.... 
Kinn: QW Physics Vs NQ Physics: Everything You Ever Wanted To Know 
Noice, cheers. 
Spike, Controller Question 
It's working much better now but I want to be able to rebind the controller, seems you can't do this in the quake menu?
Also look up/down on the right analog is inverted! How do I undo this? 
controller 'keys' are prefixed with GP_, you should be able to use argument autocompletion on the bind command for the full names.
their default actions are not listed in the menus on account of how I set up their defaults, but if you actually bind them (either via menu or console) then they'll appear in the menus. Note that fte only shows two keys per binding, rather than 3 or whatever.

to invert pitch, either set joypitchsensitivity -1 or so, or set 'joyadvaxisu lookdown' instead of lookup.
I don't recall if m_pitch affects it too. 
Cheers Spike. 
Will check this out at home 
doesnt show anything in the console for me.

setting joypitchsensitivity to a minus figure does correct the invert look though. 
Played a bit of deathmatch with my girlfriend. It works well, but rebinding is a huge faff. Would love to be able to do it easily in the menu (would also like to bind direct weapon impulses like in Quake 3) 
So... there's this game breaker bug with FTE when you can not get out of water sometimes... you can see in this video at 02:20

This happended to me a couple of times with other maps, but it never bothered me, because i can just start the map and play it again in quakespasm or markV... BUT, today i was thinking: what if this happen when i'm playing an episode with a lot of maps? I would have to go back all the way to the first map and play all the maps again :P

Surely i'm not the first one to notice this... is there something i can do to avoid this? some console command like "fix the get-out-of-water physics please"? XD 
Set Sv_nqplayerphysics To 1. 
Technical mumbojumbo gibberish:
NQ's waterjump distance is framerate dependant (due to a frame's delay - waterlevel is set from the frame before so is set despite the player being out of water that frame).
QuakeWorld's physics does not have this issue, thus there is no extra 'slop'.

sv_nqplayerphysics 1; can be used to switch to NQ physics for players.
(you can change it mid-game without any real issues, though it probably only matters for coop).
This also disables prediction (hence why its not enabled by default).
And remember that waterjump heights are still framerate dependant - you can increase waterjump heights by decreasing the framerate by increasing sv_mintic, but you should only need that in extreme cases.

Obviously this will affect other bits of player physics too, making all the various fancy jumps more like other nq engines too. 
Thank you very much, Spike =D

You're awesome =D 
What is the easiest way to implement blood splat in FTE? I mean, like these awesome dark red decals here:

These images are from a modification that Bloodshot12 made in particlefont.tga for Quake 1.5... Unfortunatly it is a darkplaces mod.

I know there's a way to do this changing the progs.dat, but i don't want to mess with progs.dat because i want the blood splat working with other mods, like DMSP2 and the official mission-packs =D

So, is there a easy way for me to do this or is too complicate? :P 
WebAssembly + WebRTC? 
Does the Emscripten build of FTEQW support WebAssembly and WebRTC for multiplayer? 
r_particledesc effectinfo is the lazy way.
you can also use r_converteffectinfo (iirc) to see what it would look like in fte's native particle syntax.
you can use r_part_redirect to rename a single existing effect to some other name, although this is usually only useful for weird people who want to mix multiple different effects without editing the particle configs.
FTE's embedded particle configs don't contain any decal effects on account of decals generally needing much high res artwork in order to look good. That said, if you use 'type cdecal' then you will get an effect that spawns as clipped decals, but you'll want to provide your own textures.

no, it doesn't use webassembly yet, though I imagine it wouldn't be too hard to update emscripten and tweak the compile flags in the makefile.

it does support webrtc, but only between itself, and it requires a broker to do so.
web server: sv_port_rtc rtc://BROKERADDRESS/GAMENAME
web client: connect rtc://BROKERADDRESS/GAMENAME
non-emscripten server: net_enable_webrtcbroker 1; sv_port_tcp BROKERPORT
(it is possible to omit the BROKERADDRESS args by including a usable value inside your site's fmf file, but you'll need a reliable broker for that.)

Otherwise you'd need to use websockets to connect to an existing server, eg 'connect ws://server:tcpport', but this only works for fte servers with both a tcp port open (controlled eg via sv_port_tcp) and net_enable_websockets set to 1. Alternatively fteqtv can be used as a proxy if you want a way to connect to any quakeworld server.

Installing game data from a public webserver is a copyright nightmare though. Users are meant to be able to provide their own additional game data by using drag+drop, which is of course annoying.
It is unfortunate that the paks need to be downloaded in their entirety, which makes downloads excessively large on account of all the maps which might not be played that session. 
Thank you very much for the info =D

Unfortunately i can't mess with the code right now, because it seems that is something wrong with my .NET frameworks :P Codeblocks+mingw refuses to compile any code (keeps asking for more and more *.h file) and Visual C++ 8 doesn't even install :P So, until i fix the .NET i'll stay away from the codes :(

But i downloaded the new version of FTE (5259)... this version doesn't support Hexen2 anymore? All i get when i click the file is a black screen with "Join Server/Options/Quit" :(

I think i'll stick with the old version for now =D 
Hi, it's me again

About Hexen2... How can i play music with FTE? I already put the ogg files in the "music" folder inside the DATA1 folder but it's not working, i copied the "music" folder to the main folder, and even created an ID1 folder but nothing seems to work :/ 
Forget about the post above.
The music works now =D 
It's me again!

I just noticed if i start the new version of FTE with "-hexen2" the game works :)

And now we don't have those annoying messages about "no-precache" on the top of the screen \o/

Thanks =D 
imho hexen2 is just generally too buggy without the mission pack, regardless of engine.
Note that if you rename the exe to fteh2mp.exe then it'll always try running the hexen2 missionpack, regardless of where its run from (unless given eg -quake on the commandline, or an fmf file, or just use -portals for it).
Assuming you actually have the mission pack, that'll fix a number of gamecode bugs that can get really annoying...
I also tend to test portals more often than the original game, tbh its been a long time since I tried.

Hexen2 has a serverside cvar to control the clientside music which I intentionally didn't mimic, and I don't have any midi playback code anyway so it never really mattered.
CD playback should work as in quake. Its just a shame that the midi music uses different tracks. 
I just tested renaming the exe to fteh2mp.exe... Now the "no-precaches" messages are back :P

I also notice that with the new version i can't gib the enemies' corpses anymore... with FTE 5121 i can gib them all :/ 
it's nice quake with moderate rag doll physics 
Hurdles With FTE 
I'm trying to get to using FTE for single player again, but there are quite a few hurdles that I'd like to have resolved before the engine drives me away from using it again for a few months:

- There doesn't seem to be a menu option to disable autorun.

- Weapon cycling with the mouse wheel doesn't work when holding down shift.

- Weapon viewmodels: Neither Ruohis's or Plaque's packs have all the weapons modeled, so when I enable both of them in the "updates+packages" menu, some viewmodels overlap (the SG and TB). So I tried to disable both of the packages and use QRP models instead, but FTE would simply revert to the Quake default viewmodels, even if all the QRP packages are installed. Should I just install the qrp packages to the id1 folder the traditional way instead of using the "updates+packages" menu?

- Vulkan mode causes quite a few graphical glitches. Water reflections seem to be out of whack (for example reflecting geometry behind walls, I think) and many particle effects don't work with Vulkan.

- Trying to turn on Direct 3D 11 crashes the game altogether. Seems OpenGL is the way to go.

- Enabling Afterquake in the "updates+packages" menu forces the default graphical presets on startup, so I always have to manually go turn on the cool realtime presets when firing up FTE, which is frustrating.

- underwater sounds are overpoweringly loud if there are a lot of sound sources (ambient, especially) in the map. The issue is particularly problematic when both "static sounds" and "mix in background" are enabled in the audio menu, I think. Can the underwater sound attenuation be coded in a way, that only the sound sources that are in the same liquid body would carry farther out?

- The particle effects menu is quite confusing; I don't know which effects to turn on. If I turn on the Haze particle set, for example, will I no longer have to turn on all the individual Haze particle effects further down in the menu, let alone Haze-lite effects? Should I restart the map/game for the effects to fully turn on?

- torches (with the wooden stem) don't seem to be implemented in the available particle effects. I never see any fire. Sometimes I see only the stem and sometimes not even that either. Would it be possible to have both 3D fire models and particle fire effects?

- rtlights are handled differently in FTE compared to DP. Is there an easy console command or something that would change rtlights interpretation to that of DP, or will I just have to make my rtlights for FTE from the ground-up? DP has an ingame rtlight editor with the command r_editlights but FTE doesn't seem to have it. How can I easily make realtime lights for FTE in... realtime? B] (ba-dum-tss)

Anyone else experiencing similar issues? I'd be especially curious about the audio, Vulkan and Direct 3D issues. 
Fte has rtlight/terrain editor 
disable autorun:
why would you? :o
cl_forwardspeed 200; cl_backspeed 200; cl_sidespeed 350; cl_upspeed 200; cl_movespeedkey 2.0; cfg_save

only way I can think of that happening is if you've bound shift+mwheelup to something different from mwheelup (fte understands modifiers). rebinding mwheelup-without-modifiers should also rebind all its modifiers too.

I really need to get around to editing those packages so that they don't conflict with other stuff.
If you've manually installed that stuff for use in eg DP, then you'll already have all that content anyway.

these don't get tested as often as they need. so are unfortunately often buggy.
I've only got an nvidia gpu to test vulkan on, and it generally performs worse than opengl. yes it has better cpu usage but it really sucks (for me) in terms of pixel fill rates compared to opengl or d3d. FTE's implementation is mostly complete - read: has more ways to go wrong.
d3d11: windows only junk... plus you're generally better off with d3d9 (the lack of custom hlsl means d3d9's support for oldskool multitexture gives d3d9 the advantage).
ultimately my time is limited and I'm lazy, and focus+test opengl the vast majority of the time. they should normally all be able to run vanilla quake well enough though, so if they can't then that's a bit of a fuckup, but as the opengl renderer still works it doesn't seem that significant.

changing content shouldn't change presets...
remember to use either the menu to quit or to use the cfg_save command if you actually want your config to be saved after changing/reverting any cvar/preset settings.

underwater sounds:
that's your openal implementation for some reason completely ignoring distances when reverb is enabled.
you can set s_al_use_reverb 0, or switch to some other driver/device via the menus (especially if you want something more quakey).

particles menu:
the particles menu is just a list of particle config files to use (the order in which you enable them can make a difference).
do note that particle configs are still configs, and there's a few evil ones that include non-partcle commands (like cvar settings) which don't get forgotten when unloaded, but a properly made effect (one that doesn't have such things) will be fully purged by just changing options.

the 'fast' preset hides static models (like torches+flames - quakeworld users tend to not like scenary), but the others should still include them.
the QRP models have no flame animation and expect that effect to be provided by a particle effect, which is a separate thing from the model. Yeah, its messy. :(

they're meant to be handled in pretty much the same way, except for editing. note that you might have different .rtlight files installed for the two engines.
if you installed the plugins/ingame-map-editor option via the downloads menu, you can then set ca_show 1, and you'll get some csqc-based editing menu. Be sure to pick the rtlights option... 
Replies And A Couple Of Other Things I Forgot To Mention 
- Well, as a single player, sometimes I like to take it slow and calmly appreciate the level's architecture, and seeing Quakeguy running with each movement sure makes it less of a relaxing experience. Yeah, I'm weird like that. But slower movement does provide some accuracy to platforming sections for example. So yeah, the slower speeds do have their use cases in single player.

- According to more testing the mousewheel weapon cycling starts working when I reconfigure the weaponcycle keys at the keys menu (even if according to the menu the mousewheel was already assigned to it). So, I save my settings, shutdown FTE and restart the game and then try weaponcycling again while holding down shift and the problem returns. So now it looks like that in addition to having to set the realtime lighting presets each time Afterquake configs are enabled in the "updates+packages" menu, now I have to reconfigure the mousewheel, too, every time I restart the program. Extremely frustrating. :(

And to make things even weirder, when I have the Afterquake configs disabled and then save my new weaponcycle bindings (and left shift key binding for the run action) and restart the program, the key bindings have not been saved. Does this have something to do with Windows 10 or system locales or something? Just throwing hunches in the air here.

- I got the underwater sounds working (ie. sounding like I weren't underwater at all) by changing my sound device from default to DS (I presume Directsound). I'm assuming OAL (openal?) was the default audio device. There was also a third device, WASAPI (no idea what that is), but sound was just garbled when using that.

-About the torches: I guess I can only hope someone makes particle effects for the torches with wooden stems at some point, then. (Or then make them myself!) @~@

- Here's a side-by-side comparison of how DP and FTE handle an individual ceiling light in one of my maps. In DP it's a nice subtle gentle light whereas in FTE it's a bright blue patch. (Note that the light radius of 0 is a rounding error from 0.01). Maybe my outlandish values like coronasize 3000 cause problems in FTE?

- A thing I didn't mention in my previous post is that sometimes when I startup the game (OpenGL and realtime lighting) I get models resembling Christmas ligths.

- Another thing I forgot to mention is that cursor keys are only partially supported in the menus. I think only in the main menu you can move up and down between the different options but in the other menus you can only use the right and left keys to adjust sliders. Otherwise I have to use mouse to switch between rows. 
Particle effect for torch and big fire is available.

Here movie shows a torch effect.

Me think you can copy effect. 
- runspeeds
yeah, sorry, I was just trying to be humerous, and failing. imho its better to set cl_speedkey 0.5 and otherwise with always-run on. if you need the precision then you can hit +speed (for slow), and then you're not required to hold a separate key every single time you encounter a vore etc. but yeah, not 'failthful' or something.
the afterquake menuqc stuff lacks an autorun setting because its not a trivial setting (so wasn't in the first versions), and then got overlooked once the code became more capable.
the engine's built-in menus do still retain the option.

- menu cursor keys
yeah, those menus were written as mouse-first menus.
any menu that might need a scrollbar (when running at lower resolutions / bigger fonts) has multiple tiers of widgets (ie: title+options[option1+option2], and the up/down arrow keys don't propagate properly between tiers - if the upper tier has focus then you can't change between the actual options.
You can disable the replacement menus in the updates menu, if this annoys you.

- binds not saving
fte attempts to sandbox its configs.
if one of the known-configs changes when switching gamedirs then configs will be reloaded.
when saving the config, that config will be saved to the active gamedir if the gamedir contains one of those known-configs and to id1 otherwise.
this means that a mod with its own settings won't propagate any of those settings back to the base game.
basically what I'm saying is that I'm not really sure what's going wrong here.

- sounds
wasapi is what directsound is a wrapper around (since vista). it generally has lower latency (especially if you tweak some cvars to request exclusive access to the hardware). I'm not sure why it'd be garbled, maybe I'm not feeding it enough data (try increasing wasapi_buffersize?). either way, its main thing is that there's a wasapi_exclusive cvar that can be set to 1. :)
otherwise it doesn't really make much difference.

- torches
I thought the hazed particles had something in them. the 'spikeset' ones do, but mneh.

- coronas
the general recommendation is not to hack the radius to some low value and compensate with an extreme corona size, but rather to set the corona scale to 1, set the ambient+diffuse+specular values to 0, and then set radius to directly control the size of the corona. must less hacky that way.
try setting r_coronas 0.25 instead of 1.

- lights
looks more like your r_shadow_realtime_world_lightmaps setting is different in the two engines. FTE has a habit of forcing it to 1 when it couldn't load/import any rtlights (too many buggy maps otherwise), but I've no idea why that could be happening in this case.
when comparing lights, it can help to disable bloom and any iris adaptation stuff (read: hdr), and srgb stuff too. this should make the colours more directly comparable.

- christmas zombies...
... I really have no idea...
does the mod that you're running mess around with .colormod or something? I have no idea why those zombies would each glow/bloom a different colour, unless your mod was using that.
are they still bright colours with bloom disabled?
does r_fb_models 0 help? 
FTE + Arcane Dimensions Mod 
hello, after a long hiatus i am back in quake realms and i have one question. i use darkplaces usually but i am testing FTE right now because DP cant handle forgotten sepulcher.

FTE runs that level fine, everything works - monsters, breakables, extra particle effect. All that works properly but when i get killed and load previous save new particle effects no longer look the way the should. i am talking about torches, power ups and so on... original ad version of these effects is replaced by something ugly. the only way to restore particles is to start level from scratch.

any idea what causes this bug? FTE obviously can handle AD version of particles but when i use SAVE/LOAD the fancy visuals are gone.

fte tries to do its saved games differently, and they're still a little buggy right now (particle effect names are not saved).

In the meantime, you can use the savegame_legacy command instead of the regular save command/menu, which should get it to do its saved games the exact same way as any other engine (and compatible too, except for homedir stuff).
(or set sv_savefmt 0 for the same result, if it exists in the version you're using, not sure when I added that.)
(you should also be able to use it to fix a prior save too.) 
hi spike, i tested your suggestion to change sv_savefmt command and it works.

thanks for quick and helpful reply.

One More AD Problem 
hi spike, i tested forgotten sepulcher more and there is another problem. particles works fine, even after LOAD/SAVE but something else gets broken. gameplay is really choppy after LOAD, however that can be fixed by applying vid_restart

what is more complicated is that already broken breakables re-appears as invisible walls that can not be broken again. i can shoot them, i see impact particles, they bounce grenades and i can shoot them indefinitely but they will not break again.

any idea?

Version Info 
i use win64 client version 5259 
R_glsl_offsetmapping_lod In FTE? 
Spike, I want to try to get up my lazy butt and address your replies later, but in the meantime, I noticed that FTE doesn't have the command r_glsl_offsetmapping_lod and r_glsl_offsetmapping_lod_distance, like DP does. I noticed that it improves performance with bumpmapped textures hugely (especially in large areas) without noticeably lowering visual quality. Any chance of it being implemented in FTE, yes? :3c 
FTE/Afterquake Spotlights In Realtime Rendering 

when I'm trying to use spotlights (both using target or mangle) it seems that this information is ignored in realtime rendering mode for the lights as I get surfaces lit which actually lie outside the desired cone. Static lighting looks correct though - am I missing some option? 
rtlight importing doesn't support all features from maps.
spotlights have been implemented for a while (and sometimes even working), buts its only recently that they've actually been importing from maps - you'd need an svn build for it to work. 
FTE/Afterquake Spotlights In Realtime Rendering 
Ah ok, then I'll probably have to wait a bit longer, thanks! 
Is it fair to say anything that DP can do so can FTE? Put another way, Would it be appropriate to say FTE is a suitable replacement? 
not 'anything', just 'anything that matters' imho.

That said, fte favours more vanilla-type compat than for dp, so don't expect dp-only mods/content to work as-is without obscure cvar tweaks.
cvar reconfiguration sucks. :( 
Good To Know 
For this progs_dump project I am seeing a potentially game breaking bug only in DP and want to direct people to try FTE instead.

I'll address it later (I will need help ofc) but in the meantime, I will steer people to FTE as an alternative to DP for this release.

I think most of my target audience for the mod will be in the QS or QSS world. 
I would think that's a safe bet. FTE is active as well as QS, but with more feature readily available if needed.
Nothing against QS or any other engine, for that matter, people can use what they need. and knowing what is available for their needs only make our world that much better.

Silly Question 
So when using FTEQCCGui and FTEQW how can I force my current config file (the FTE default in My Games) to run? I'm not sure how to configure this when it runs from FTEQCC. The mod I am creating already has a config. 
go into the options dialog, make sure there's no -nohome in the arguments box (those 3 unlabeled text fields are: exe, working directory, and arguments). click save and it should remember those settings next time you run fteqccgui. 
Okay changed that. Getting somewhere but will not accept any changes/saving options in the engine after I launch with F5. I am using fteqw64.exe

Defaults to 640x480 full-screen even if I change and save. As a test I changed my playername and pants/short colors. It did not save either.

When I go to Documents/My Games there's no sub-folder for the mod I am working on. And yes, the mod is loading properly from the -game switch. I am baffled. Shouldn't there at least be a sub folder in My Games? I have a shortcut to the mod directory and my settings are correct when I use that.

One last thing: I have multiple versions of FTE in different folders on my pc. 
Re: -nohome 
I hated this in DP and I hate as well in FTE!

Maybe someone can explain the benefit that actually justifies this behavior, for Quake?

Since it's opt-out, without being clearly obvious no less, instead of opt-in... it's very easy to not understand what is going on with game settings and config files.

Example, after screwing up settings once in FTE and making the game look like trash I just deleted the whole folder and started over as that's the typical way it works. BUT... since I didn't know about this "home" directory shiz at the time... my fresh new game looked exactly the same. This was frustrating.

Having to instantly create shortcut's, or needing to know about adding -nohome into a game launcher(SQL1/2) without any prior knowledge of such Quake config file saving behavior is just a bad decision.

Again, what am I missing? 
Mixed Feelings 
I agree somewhat with damage_inc on this. Perhaps Opt-out by default but write and use fte.cfg instead of config.cfg. Would that work? 
Quake was originally developed for MS-DOS, which wasn't a multi-user OS. MS-DOS evolved into various versions of Windows 3.x, Windows 95, 98, 98 SE and ME, at which time that line was killed.

None of them were multi-user OSs, none of them had security, and this stuff just worked.

Windows NT was developed from the ground up as a new OS and new kernel (that just happened to share some common shell and UI elements with the other Windows). From the very first it was a multi-user OS with proper security, admin/user separation, etc.

Windows NT evolved into Windows 2000, XP, Vista, 7, 8, 8.1 and 10.

The benefits of placing per-user content in user profile directories are:

- These are the only directories that non-Admin users are guaranteed to be able to write to.

- If more than one person uses the PC then your saves and cfgs won't mess up somebody else's, and vice-versa.

So, try playing a stock install of Quake on a PC with more than one user, and logged on as a non-Admin user, and see how far you get. 
There are a big amount of users in different Quake forums reporting difficulties with the fact that configs are stored in a VERY different location.
But we NEVER heard difficulties from people with non-Admin issues or multiple users config issues.

For a simple Quake engine? This modern-OS behaviour is way over the top. It only produces trouble and frustration. And in the end... like many affected users did, they change the engine to a better one without this modern-OS behaviour. --> Like all the other Quake engines have.

Other engines never produce trouble like this. They all work as expected and intended.

The honorable intention to implement modern-OS features into a Quake engine ends up useless and even counterproductive in reality.

So, take a minute and think about it. ;) 
yeah, it sucks. I hate it and always use -nohome myself.

that said, using homedirs is the safe option, even if its not the preferable option.
and its NOT nonsense, there are various installers for quakeworld mods that install into "c:/program files/", which then screws everything up when users try other engines in the same dir. maybe not for the nq community, but it IS a problem for the qw community.
its also very common on linux, too, what with debian/ubuntu's quake package requiring it and all.

windows also has a tendancy to lie about whether access is possible and to then write the files somewhere else that's even harder for the user to find, this makes it really messy to try to autodetect whether homedirs are needed or not.

side note: the afterquake thingie expects the user to unzip and add in some paks, and contains a file to explicitly instruct the engine to disables homedirs (because it doesn't expect to have to fight other installers).

winnt actually predates win95, and unix has always been a multi-user system. this is NOT modern-OS stuff. 
Is FTE networking P2P? Does it have NAT punchthrough? 
yes, but only via the xmpp plugin (the method requires a third-party server to relay messages through in order to establish a connection), and that requires accounts and passwords and urgh, so none bothers with it.

the web port can use an existing/3rdparty fte server as a broker for webrtc (but it needs that 3rdparty server to be configured with eg `sv_port_tcp 27500;net_enable_webrtcbroker 1`). You can then host with `sv_port_rtc rtc://brokerip:27500/mygamename` and connect to that server with the same uri.
I keep meaning to implement something equivelent with the desktop ports, but I can never get around to it. 
Found This On Twitter 
Splitscreen Sound 
By default, the game sound only plays for the left screen (first player). Is there a way to enable sounds for all other screens, too? 
Splitscreen Sound 
switch the audio device away from openal(the default) to any of the other audio drivers (like dsound/wasapi/alsa/sdl), typically via the menu.

openal does its own mixing and only supports a single 'listener', whereas fte's own mixer is smart enough to select the nearest player as the appropriate listener on a per-sound basis. 
That does the trick, thanks. 
Muzzle Flash *issue 
Is it a non-avoidable side effect that whenever I enable r_waterstyle > 1 that I basically lose the weapons muzzle flash?

I state it as "basically" because sometimes I do get the the muzzle flash effect but I can't determine exactly why. And it's sporadic.

Sorry that I don't know the name of the actual cvar, its just the flash when you fire the weapons, explosions etc. 
Broken Coop? 
Hi, I tried to get coop to work with the 5361 Afterquake package and it seems that the server is either not running or it actually starts in single player mode. Deathmatch works fine. Am I doing something wrong, or is there a trick to get it running with some cvars? It worked with a previous version (although I couldn't figure out back then which variable would have set no friendly fire - maybe it was just deathmatch which used my coop player starts?). 
works for me...

make sure you've not somehow messed up any cvars - these are the ones that come to mind:
deathmatch 0 //boo hiss
coop 1 //hurrah! friendly mode
maxclients 8 //quakeworld engines limit clients and spectators separately, which is a little messy.
sv_playerslots "" //auto - 32 when deathmatch||coop, otherwise 1. max of 255.
samelevel 0
sv_progs progs //force preference for NQ gamecode over QW gamecode - QW mods tend to have no coop, in case you have a qwprogs.dat from other sources.

really, the only difference between coop and deathmatch as far as the engine is concerned is that coop is set instead of the deathmatch cvar.

to disable friendly fire, not only do you need teamplay set, but you also need the players to use the same lower colour (in nq). 
I set the values with the console and it worked; maybe the menu command didn't reset everything that was required correctly. 
Pants, he means same color pants so you don't hurt each other. 
FTEqw64 version 5361 isn't compatible with Arcane Dimensions?

I'm asking this because i can't load a savegame when i'm using this mod.

When i press F9 or even loading a savefile from the menu, the engine crashes to the desktop and show me this error message: "Bad Entity Lump: 'Particle' not recognised (last ent was 894)"

Even with "sv_savefmt 0" the engine crashes when i press F9.

I also tried the "savegame_legacy" command, but the console says "Error: hidden name (.sav) Unable to use legacy save format"

help :( 
Is there a way to change console sliding speed to be instant...curious if you can instantly hide the console on map start? 
scr_conspeed 2000(def) increase it until it's near instant. 
Anyone knows if FTE has god-rays auto-generated from the sky?

I remember, a while ago, testing this... i just wrote something in the console and BANG... god-rays from the sky...

but i can't remember the command or even if i was using FTE engine or something else :( 
r_sun_colour ( R G B )

Load up start map and try .4 .4 .4 
Thank you very much =D 
Is there any way to make snow or rain in Hexen2 maps with FTE? 
I could be wrong on this but I'd imagine it's no different than for Quake. Since the particles/configs configuration is engine based and not game based.

So the discussion we had recently about Qmasters 2018_xmas map most likely would apply for Hexen2.

But this time I didn't test it so... ymmv! 
But... to make rain or snow in quake i have to open the map with MarkV, use "tool_texturepointer" to find out the sky's texture name, use "copy ents" to make the ent file, and finally edit the ent file with the sky's name calling the weather effect...

How can i do all of that if MarkV doesn't open hexen2 maps? :/ 
Are you trying this for stock H2 maps? 

here is what i already tried:
i opened the bsp with quark to know the sky name from the first map and i opened the bsp with notepad++ and copied all the ents to make a ent file (i saw someone talking about this in QuakeOne forums) but even with an ent file calling the rain it doesn't work

but the good news is: the second map came with an ent file (i think it's from an update) i edited it and it worked! Now i have rain in there \o/

in other news... it seems the command line "r_sun_colour (R G B)" to make godrays doesn't change anything in hexen2 :/ 
FYI: from he console in FTE "sv_saveentfile"

Will be located in "[.../YourGameDir]/fteh2/maps/"

I used TexMex to open the .BSP to find the sky's name. I didn't get the snow/rain to work on a map load though... I have to exec the .cfg from the console to get it to start! 

Your method will save me a lot of time =D 
Now I see whyyy I didn't have particles on map load, because I didn't have it ENABLED in the particles menu :faceplam: 
With your method i was capable of make rain in the first map. Thank you! =D

One thing i noticed... when you are at the courtyard (player-starting-point) and you look down, the rain stops... when you look straigh or higher (or right down to the floor), the rain starts again :P

This bug doesn't happen in Quake

anyway, i'm happy to see the fte_weather working in Hexen2 :) 
Hi, there!

I'm trying to play FTE with effectinfo (quakespasm-spiked custom particles)... all particles are working fine, except for the blood particles when you hit an enemy. I can see blood particles falling from gibs, but not when i hit an enemy...

anyone has any idea how can i fix this? 
r_particledesc "high effectinfo"
or something. or classic instead of high.
(there's some naming differences that prevents the blood particles from loading) 

"r_particledesc classic effectinfo" is perfect =D 
FTE QW Single Player Is Broken. 
I cannot start a single player game with this client. The paths are all correct in the menu. I have everything where it should be and when i go to play a single player game nothing happens when I try. It doesn't load Quake at all. Whats funny is if i download anything with the quake injector I can play the mods fine. Any help with this weird issue would be appreciated. 
QSS has the same problem. Trying to start a single player game from the main menu does nothing. 
maybe -nohome can help 
I was having issues with singleplayer in the latest build of FTE. Often freezing on level load/change, and sometimes nothing happening on selecting new singleplayer game.

On a suggestion from Spike in the discord I set sv_nqplayerphysics 1 before trying to load a singleplayer map. That fixed the map load freeze. I haven't tried the "new game" selection yet to see whether that is still flaky.

You might or might not already have sv_nqplayerphysics set to 1. I think it is by default, but in the setup you get from the AfterQuake package it appears to be 0. Anyway, if it's 0 for you currently, try setting it to 1. 
Thanks for the responses. Neither command fixed the issue with selecting single player. I added -nohome in a bat file and I also entered the sv_nqplayerphysics 1 in the console. Nothing. What's funny is that in 5399 everything worked fine. The last two updates broke the new game selection for single player. :/ Oh well hopefully the fte qw team is aware of the issue. 
It's A Single Executable 
Why not just go back to 5399? 
Because I deleted it. Can't find it anywhere and the fte qw site doesn't keep old versions on their page. 
BTW, sv_nqplayerphysics doesn't seem to be the panacea for me after all. Weird edge friction going on. If my player model is overhanging a ledge and I tap the walk button once in a direction pointing along the edge, often the player will "grind the rail" all the way along the edge. 
hopefully some of these things are fixed in revision 5424 
Single player fixed with 5424. :) Thanks. Tilding then tapping map e1m1 (or whatever start map) was a little annoying. 
Yah all issues I mentioned above are gone in 5424. :thumbsup: 
RT Lights Are Point Entity Only Yes? 
Without resorting to Q3BSP+Q3map2, is it possible to have in Q1, a texture emit RT Lighting? Using scripts/shaders? 
Quake Injector 
Quake Injector not showing in menu anymore with latest build. 
for the quake injector option to be displayed, you must have the qi plugin loaded, and is normally obtained+enabled in the updates menu.
(you can also 'plug_load qi; qi' to load it without using the menu, assuming you manually downloaded the extra dll) 
Stuttering Frame Rate 
After playing in FTE for a little while, the game starts to get jittery. The frame rate is smooth for a while after launching but maybe 5 to 10 minutes later, there's a bit of stuttering that really messes with my eyes. Any idea what's up?

Also what's the cvar for square particles? 
R_particles 2 
works for most engines 
I have downloaded all plugins and enabled them and none show. 
r_particles isn't recognized as a command in FTE. Only way I can get square particles is to use the vanilla video mode but I still can't find the cvar for square particles alone.

Also after playing around in FTE a bunch, it seems like the stuttering frame rate starts pretty consistently at the same time every time. Doing a vid_restart smooths out the game again but then 5 minutes later, it's back to stuttering. It seems to get jittery even sooner when I alt+tab out and then back in. 
r_part_classic_square 1 ??? 
#157 P2 
btw, I had the graphics preset on "spasm". 
That works, thanks. 
it does support webrtc, but only between itself, and it requires a broker to do so.
web server: sv_port_rtc rtc://BROKERADDRESS/GAMENAME
web client: connect rtc://BROKERADDRESS/GAMENAME
non-emscripten server: net_enable_webrtcbroker 1; sv_port_tcp BROKERPORT
(it is possible to omit the BROKERADDRESS args by including a usable value inside your site's fmf file, but you'll need a reliable broker for that.)

Unfortunately this does not work for me.
I've started server like this:
| ./fteqw-sv64 +sv_port_tcp 27500 +net_enable_webrtcbroker 1 +map frenzy

Then on web-server I've entered:
| sv_port_rtc rtc://<serverip>:27500/magic
and got following output:
| Listening on ws://<serverip>:27500/magic

At the same time on dedicated server a message appeared:
| Websocket request for /magic from ws://<clientip>:64509 (rtc_host)

Then using another instance of web-client I tried to connect like:
| connect rtc://<serverip>:27500/magic
and got following output:
| Connecting to rtc://<serverip>:27500/magic...
| No route to host, giving up

Could you, please, help me with this? 
What would you guys say it's the most stable build of FTE? 
Clean Win64 install from fresh download today, plugins such as the Quake Injector one don't want to load, "plug_load qi" returns "Couldn't load plugin qi". Something I'm missing? 
Aha. Plugin items reappear in menu with 5529 update. Quit the game, reload FTE, they're gone. Disable/reenable in updates+packages brings them back and seems to be only way to do it ("plug_load" doesn't work). Quit, gone again. 
Stuttering Sound 
I'm having a problem with a level that I'm creating, and I'm not sure whether it is the level, or FTE. Note that I don't have this issue with Darkplaces or Quakespasm.

The problem is that at some places (often the same places), the sound starts to stutter. More specifically, some of the sound effects have the last one second repeated a few times. While the sound is repeating, the game keeps running and the other sounds are occurring normally.

The framerate is at its lowest 30FPS. I've tried more complex levels, and not been able to replicate this problem. Even in a large level, like those in Ter Shibboleth, which brings FTE to a crawl, the sound doesn't repeat. The level I am is using progs_dump, if that makes any difference.

Any ideas on how I might be able to troubleshoot? 
Sound Follow Up 
A clarification. What is occuring, is the entire sound effect is being repeated. I put snd_show to 1, and it appears that as the sound is being repeated, is is registering as an additional sound being played. 
Sounds Repeating 
BoraxMan, regarding the fact that this is a progs_dump map, would you be able to give a bit more info about what entity (or entities) are generating the sound effects which are repeating?

I'm particularly wondering whether it's an entity setup involving any of the "new" features of progs_dump which weren't in vanilla Quake?

In terms of debugging, one way you might be able to definitely rule out progs_dump is to load up your map without progs_dump and see if the problem persists.

To do that, just copy the .bsp file into your id1/maps directory, then start FTE without progs_dump, and play your map. I assume the gameplay of the map will be more or less broken depending on how heavily it relies on the mod's features; however, you should still be able to use noclip to get around. If the sound problem is still present, that would mean it's definitely nothing to do with progs_dump. 
Sounds Repeating 
The problem still persists. I'm suspecting there is something structurally wrong with the map? It might possibly exceed the 4096x4096 size limit or there might be invalid brushes.

I note that FTE gives this error many times (hundreds) in less than a minute of gameplay.
AL lib: (WW) alSetError: Error generated on context 0x556480415e50, code 0xa005

Whereas for other levels, it might only appear a few times. So I'm now thinking it is my level at fault here. 
Possible Problem Found 
I found that removing all the wall torches solved the problem. So perhaps there are too many of them, as each wall torch contributes a sound?

I should note here, that in the areas where the sound was repeating, there were not necessarily many, or ANY wall torches in the nearby area. There were only 5-7 sounds playing at a time in these instances.

There are 171 in the level, though all spread out. It is a large level. I might remove some, but I'm not sure why this should be a problem in areas where there are not many within earshot. 
Was Your Map Fully Vised? 
Normally I test with a fast vis, but one of the first things I tried when I noticed the problem was a level 4 vis, as I thought it could simply be performance. The problem exists with it fully vised. 
For what it's worth, the 0xa005 error code appears to be the audio library reporting that it's run out of memory. So it makes some sort of sense that having a lot of something would cause that error (in this case I would guess it's all the simultaneous sounds from the wall torches and other entities).

BoraxMan, I don't mean that to sound like your map is at fault. From what you've said it sounds like this is an issue that affects FTE but not other engines. I'm unfortunately not familiar enough with the code to be able to say exactly why this is happening. You might need Spike or someone else knowledgeable to weigh in on this.

In the meantime, you could try confirming the problem by testing another map that has a large number of wall torches. One such map is bbin1 which has 198 wall torches (according to a quick grep). As indicated above, I doubt it's wall torches specifically that are the problem (I would guess it's the number of simultaneous sounds), but either way, I suspect that bbin1 might give you the same sound issue? If it does, you'd at least know it's not just your map. 
I run into an error, "No Free Edicts" when trying it. I tried to use -num_edicts 2000 and higher values, but I don't think FTE supports this parameter?

For what its worth, I tried my level on a Windows machine I borrowed, and the problem didn't come up. I use Linux, so perhaps this problem is specific to the Linux client (both 32 bit and 64 bit clients were tested and the error was replicated).

Lastly, I understand that you didn't mean that my map was at fault. It was me that brought up this possibility, because I do have a weird clipping issue on a specific stair I can't get rid of, and Quark reports a few invalid brushes, though I can't seen to find where they are because Trenchbroom and QBSP see no problem. BSPUTIL --check reports some clipnode problems (though I note other maps also have this). It's a guess that perhaps this might be resulting in something screwy, I'm not sure.

I'm going to be putting the level up for Beta testing soon, so perhaps that will be a good opportunity to see if anyone who happens to use this engine also experiences the same.

I have some programming knowledge, so I might have a look through the code see if anything pops out at me. 
From It's Own Thread..... 
Few FTEQW/QuakeC Questions [EDIT]
Posted by 3t0 on 2020/03/25 10:58:25
As I broke my leg very badly in february and as whole city got quarantined due to infection, I was "given" some time to mess with Quakes again. For now I left my Doom "experimentation" on back-burner.

BTW, congratz to Trenchbroom team for releasing QT port, it seems to work awesomely!

Normally I am Quakespasm Spiked user, but recently I got to compile FTEQW (finally found the compile instructions). So far it seems to work rather well, besides one most annoying glitch ever.

What is driving me insane, gameplay wise, is that when I am riding a vertical platform (or a lift) in FTEQW, whole object is "jumping" and stepping along the path like crazy (like in old Half-Life/CS, and I don't play HL/CS anymore, so I am not sure if that one got fixed, but it used to be as horrible as here). In both Quakespasm and QSS, movement of platform under player is silky smooth. Am I missing something, like some cvar or what? Is FTEQW (which seems otherwise incredibly capable) missing platform movement interpolation, or is it something else? This seems to be happening with AD as well as with Copper and vanilla.

After dissecting some mods and doodads from internet, it appears that FTEQW is indeed very powerful. Seems like good basequake to mess with, to try hack together quake-like "games". What I am always interested in most engines is skeletal model format support (due to reasons). FTEQW natively supports awesome Cube2/Sauer's IQM model format which is great. What I would really like to know, is if anybody had some luck in using IQM attachments to bind things together?

Second thing is QuakeC. It seems it moved forward quite lot, especially in FTEQW. From my initial spelunking, it seems that one can finally do "modern" C function prototypes with `funcname(args...)` which I am more used to. Does anybody knows whether FTEQW really has JITs interpreter for QuakeC code? QCJIT conditional in codebase suggests there is support for that, which sounds awesome, but maybe it's just a scaffolding for something unfinished? JIT referencing chunks of code seem rather small.

Finally how can one get hold of this demigod Spike? I guess it would be much saner and polite asking him these stupid questions privately, than to spam this forum.

#1 posted by chedap on 2020/03/26 10:52:05 spam
AFAIK platforms are a framerate/physics issue. Try setting "cl_maxfps 72" in FTE, should behave same as QS. QSS and vkQuake have physics independent from framerate.

Can't help much with IQM/QC.

#2 posted by misc_ftl on 2020/03/26 14:28:35 spam
the only thing that bothers me with FTEQW is the huge amount of unused code everywhere, tons of conditionals like that one you mentioned and, well, just cruft. It feels like a lab experiment. An awesome one, but kind of messy to base your stuff on.

I highly recommend using QSS. It feels leaner and has all the goodies from FTEQW without the cruft.

Another interesting base is this:

i think that's Spike's attempt at a minimal engine 
Is There A Darkplaces Thread Too? 
Just asking.
FTE always was intriguing too me, yet, as mentioned above, always made a very experimental impression.

Thats why i stick with darkplaces. 
For all your webassembly mp needs: 
Weird Fps Drop In Ad_swampy And Sound 
I've been trying out FTE over the last few days.
I stumbled into a weird bug with AD in ad_swampy. Whenever I fire the SSG I get a huge drop in fps for just a few ms. It remains playable but it's not optimal.
I've set the fps counter to show the worst fps and indeed it shows drops from 150fps to 20/25fps when I fire the super shotgun.
I don't have the issue in the start map or in sepulcher, which is super strange to me.

I'm using the spasm graphic preset but I have tried messing around with the settings but nothing fixes it.
I even tried with no audio because I also have another issue where the underwater sound is way too loud.
On a sidenote it seems the audio output device menu is bugged when there are spaces in the device name (the console says the engine tries each part between spaces in turn before reverting to default device)

I have tried versions 5660 and 5529 of FTE.

Any idea what might be causing those problems? 
I don't get the FPS drops. Try with "impulse 130" (hitscan shotguns), would that fix it?

The issue with spaces is specific to OpenAL I think. So is the weird loud underwater reverb. I've found that you can use e.g. "s_device dsound" to set the device from autoexec or console, without the exact device name.

Note also that music is going to sound bad regardless of chosen device, unless the sound frequency matches the one in the music files. FTE defaults to 48khz, commonly shared ogg and mp3 rips are 44.1. Especially obvious in the E1M1 track. 
I have tried with the hitscan shotguns but it gives me the same issue. I've also tried deactivating AD particles (with the temp1 cvar flag), but that does not do anything.
I've tried a minimalist quake install (with only pak0.pak and pak1.pak in id1 and fresh AD 1.70 folder) with the "-nohome" argument. It's a little better, with dips into the 30/40 fps range when I fire the SSG (I also have the issue with the shotgun but to a lesser extent).

Thanks for the snd_device command. It did work with my minimalist install, but does not work with my main quake folder, I don't know why (snd_restart gives me no sound with s_device = "dsound").

I seem to also have the issue BoraxMan mentioned above where the game gets slower at I spend time in a level.

I guess I'll stick to QSS for AD for now.
I still think FTE's a nice engine with cool features for a lambda player like myself. 
I've been trying out FTE over the last period. I like it very much. An engine capable of dealing with huge single player maps and, at the same time, providing access to quakeworld multiplayer network!

However, I've a problem with Rhoenie's built for Mac. MWHEELUP and MWHEELDOWN can be assigned, for example for changing weapons, but they do not work.

The same config works perfectly under windows.

bind mwheelup "impulse 10"
bind mwheeldown "impulse 12"

yes the binds are there. They work under Win but not in OS. This is why I'm reporting! thanks 
Fence Textures In Hexen 2 
Tried func_detail, func_detail_fence, nothing. Both with color index 0 and 255.
Is it even supported at all in Hexen? 
Func_detail Is Ericw Compile Add On 
Func_detail is a compile parm specific for quake compiling. Nother sure if HexenII compiler can use it. 
There is a func_detail and a func_illusionary for HexenII (in Trenchbroom) as well though.
I'll take a look at the source. 
I Think 
I twisted map compiling with code compiling. 
whats the most stable FTE build for 64 bit linux? latest master crashes too much :( 
Vulkan Support 
Hi there! I was drawn to this engine for it's features, ease of use and Vulkan support. Unfortunately, I can't seem to get Vulkan working. When I select it and Apply the change, my screen starts to flicker and the engine eventually crashes.

I'm running Windows 10, v1909 with an AMD Radeon Vega 64 on current drivers - 20.5.1. GL drivers for AMD cards are known to be poor, but Vulkan tends to run with great performance.

I'd love to get Vulkan working if you have any thoughts on recommended settings or tweaks that might help.

Vulkan Support Additional Information 
Just thought I would add if it helps, I have tried builds 5529 and 5695, both 32 and 64 bit versions. I would be happy to take a look at older potentially working builds but I don't see anywhere they can be downloaded from.

Thanks again. 
Vulkan Error 
I find I am getting the following error - ERROR: vkAcquireNextImageKHR: VK_NOT_READY - Perhaps this helps troubleshoot. 
@ Placo 
Regarding the huge FPS drop, yes, this I think is a sound driver issue, add: `snd_device dsound` to you `autoexec.cfg` 
I love FTE but recently I tried using Reshade with it and I can't seem to get it to work. I have FTE and Reshade set to use GL but no luck. Any ideas? 
Just Started Using This Sourceport Because Of AD 1.8 
Some basic questions:
Why my graphics settings doesn't save after quit?
Why crosshair and console text is smooth when everything else from textures to particles can be made crispy pixelated? 
You must be logged in to post in this thread.
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.