News | Forum | People | FAQ | Links | Search | Register | Log in
Q1SP: Through The Gates Of The Silver Key
This is my first finished quake map. It uses id1 and is loosely inspired by dm1. Easy, normal and hard skills are implemented.

Download:

http://quaketastic.com/files/single_player/maps/throughthegatesv3.zip (UPDATED LINK)

Screenshots:

http://www.quaketastic.com/files/ttg2.png
http://www.quaketastic.com/files/ttg3.png
http://www.quaketastic.com/files/ttg5.png
http://www.quaketastic.com/files/ttg6.png
Screens Look Nice But Map Is Unsealed 
Screenshots look nice and chunkily old-school, but you should seal and vis your map before releasing. On a fairly new, fairly decent computer my framerate plummets when loading this.

That .pts file you included in your download is a clear indicator that the map is not ready for release. It is called a pointfile and it is meant for you, the mapper, to find and fix the leak(s) in your map.

Turning things like those statues into func_detail will help.

Also test your map with "developer 1" before releasing to catch things like monsters stuck in world geometry. 
Agreed 
Can confirm seeing some framerate issues and a shambler stapled to a teleporter. Otherwise, nice map! 
 
(Pro-tip to players: turning off dynamic light with r_dynamic 0 will bring back the framerate to acceptable levels)

Skill 2 demo, one death

The snafu with vis aside, this is a nice first map. The DM1 vibe is tight, though I think the map would have benefitted from breaking convention a little, with a little more texture variety maybe.

The statues are an A+ visual.

Wasn't too hot on the layout or the progression, - a bit too much backtracking, and maybe not enough of organically revisiting old areas from new angles - but it was an enjoyable map, and again, a very solid first effort. 
 
Thanks for the feedback, I didn't know about .pts files.

I have fixed all the leaks and run a -fast vis (full vis was getting stuck for some reason).

I also fixed a few other issues like the stuck monsters.

http://quaketastic.com/files/single_player/maps/throughthegates.zip 
Gold Key Room Broken? (Spoilers) 
I can't progress past the room with the GK and the nice statues. Picking up the key only causes the gate to close behind me, but doesn't trigger the ambush that's presumably supposed to happen ... so I'm just stuck in the room forever with nothing happening. Am I missing something? 
Second Version Is Broken. 
After picking up the GK nothing to happens. I run this map on QSS build 0.93.2 29.08.20
The initial release has no issues.
Map is very nice in any way. 
 
It seems by fixing the map I broke the ambush.

I'll try to sort it out in a bit. Hopefully I won't have to update it anymore 
Always Test With Developer 1 
The second version has 10 "walkmonster in wall" errors:

walkmonster in wall at: '2352.0 736.0 25.0'
walkmonster in wall at: '2352.0 864.0 25.0'
walkmonster in wall at: '2576.0 848.0 25.0'
walkmonster in wall at: '2704.0 720.0 25.0'
walkmonster in wall at: '2704.0 448.0 25.0'
walkmonster in wall at: '2352.0 592.0 25.0'
walkmonster in wall at: '2352.0 464.0 25.0'
walkmonster in wall at: '2576.0 592.0 25.0'
walkmonster in wall at: '2496.0 592.0 25.0'
walkmonster in wall at: '2496.0 864.0 25.0'

You can use the coordinates in TrenchBroom to find the stuck monsters (View --> Camera --> Move Camera to...). From a quick glance at the source it seems they're all in the box from where the monsters are supposed to teleport into the GK room. That might well explain why the ambush isn't working.

Note that if you place monsters or items directly on the floor, they sometimes get stuck/fall out of the world. The solution is to move them up just a couple of units. 
Third Version 
Third Time's The Charm 
It's good that you took the time to fix those issues, because this is a very pleasant little map.

Played on skill 1. Gameplay was fair and well-paced and progression interesting yet clear. Found 3 out of 6 secrets. No idea where the rest are, but I'll keep looking. The RL secret in particular was fun, as was the red herring/window (or is indeed connected to a secret somehow? Hmmm...).

I did notice a misaligned ceiling texture in the room with the first silver key, but overall the map looks good. Construction feels solid and satisfyingly chunky and there are some nice details sprinkled throughout.

All in all a very good debut. ;) 
 
Ditto what 3kids said above; glad you got this one sorted out. FWIW I ran through it on skill 2 and had a good time... ammo was a little tight, but in a good way, and I probably could have made more use of infighting. (One really nice infighting setup in there BTW.) 
Pulling My Chains 
For an oldschool style map of this size, I'm impressed how you managed to break so many limits at once. Turns out the reason is that every single link of the chains is an individual func_illusionary entity! Next time turn the entire chain into a single one (or even all three chains into one entity if they are this close together). It probably would've made the vis process stalling go away, too. 
 
Thanks for the suggestion, I didn't realise at the time but it makes a lot of sense. To be honest I didn't really understand func_detail until I had finished the map. 
You must be logged in to post in this thread.
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.