News | Forum | People | FAQ | Links | Search | Register | Log in
ADSP : Imhotep's Legacy
Hi there, after one year with interruptions, I finally finished it. here is the release.

Arcane dimension 1.8 is needed you can download it here

You can found a trailer and screenshots here

Most textures are from Sock's "egypt themed" pack.

I used sounds from :
-MarkieMusic's soundpack
-Noctuern made the pyramid sounds
-The music was made by Alekswithak from Dwell pack.

Beta testers :

I hope all of you will have fun into this map.
Holy Sh!t 
This makes the original id1 maps look like kindergarden drawings. I haven't played AD since a while, so I dunno about latest content, but this looks so good, I can hardly imagine it isn't going to be included in the next AD release. Gotta check this out. 
Amazing map. Perhaps the most beautiful Quake map I've ever seen, together with Tears of the False God. Several inventive contraptions, some awesome set pieces and a bunch of fun quad/pentagram runs plus an epic final battle at that. Perfect music as well. 
Looks Amazing 
The map looks pretty amazing in those screenshots. Just looking at them is a treat so I'm really looking forward to checking this out. 
Serious Serious Sam Vibes Here. 
At the end I was geniunely expecting an UFO, but... Probably I haven't collected all the secrets yet, only 10/12 to open a secret ending or grand easter egg of sorts. 
By The Way, I Got The Blue Scarab Key 
But where's the door which can be opened by it? 
-Sorry no easter egg :(
-A clue for the blue door. 
Seems To Be So Rangers Name's Jim? 
means this:

After opening blue key door, BKey still on top of the pillar? 
Let This Key... 
and go ahead, this key is a false one just to activate the trap 
Yeah, door already opened, but key was on the pillar. With the help of jump boots, blast belt and RL you still can get to the pillar top. There is no room for standing, but if you get close, you'll still be able to grab it. 
I already beaten Judicator, so just roaming among the level in search of last two secrets. And finding some rough edges. For example, in the pentagram room for you to get upwards you need to jump right at the propeller's center, or you won't get high enough. Not convenient! Invuln seconds are costly, y'kno. I wanna get to the vore and quad in time without letting one hair off my head! 
Or this windows in the shambler roasting room. With jump boots you can easily backtrack there right from where you stand, but forced to make a detour through cliffside. Some vent or hole would do a great service there. 
..or Even Make Them Breakable 
Cause you can't jump that far in the first encounter either way. 
I've gotten overflow crashes twice during the last battle using vkQuake. It has worked twice as well, so seems a bit finicky perhaps. I'll try QS and see if it is more stable. 
Got the same issue with QS the first time I tried, but QSS worked fine, so I'll stick with QSS. 
Third Time's A Charm 
Update on overflow issues. Seems fixed with vkQuake by upping heapsize to 524288. At least I've had no issues two times in a row now. 
I'm using the latest release of QSS and AD 1.80 patch 1 but I have a small issue with this map.

I don't really know the jargon and I don't know the inner workings of all things Quake so please forgive my 'noob' description of the issue.

Every so often the baddies seem to 'snap' to different positions - sometimes just animation frames, sometimes actual position while moving. It's very slight but it's pretty jarring. It's almost like lag when playing online with a high ping but not as pronounced.

Is this just me? Is it a QSS limitation? Am I just imagining things?! 
When you say latest QSS do you mean the "stable" release or "dev" release?

The dev release has some bug fixes, including something much like what you are describing. According to Spike there's no reason not to use the "dev" release currently, he just hasn't bothered to call it the new stable. 
@arkngt, my map is at the limit of heapsize I have to optimize it a lot during the construction. But I checked and did not have the issue with QS/QSS/FTE I'm testing my map on these 3 engines.

@Hipnotic Rogue, it can also come from AD. I had lots of bug while using nailpiercer (that's why there is no neilpiercer in the map), and some player are laggy because of particules effects try to use this command : "pr_checkextension 0" and see if it's less laggy 
Thanks Folks 
I tried both the stable release and the dev release and I tried "pr_checkextension 0", too. It's still there.

I recorded a demo but upon playback I couldn't see it. It's more a 'feel' than anything else and I only get it on this map. It's really weird. My partner thinks I've just become too sensitive to these things and it's just a 'me' problem. *shrug*

Other than that small personal issue, the map is glorious! I'm still having a lot of fun. It really is great stuff. :) 
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.