News | Forum | People | FAQ | Links | Search | Register | Log in
Compiling Zircon On Linux
Following up on this QuakeOne thread:

I am trying to compile the June 16 version of Zircon on Linux, but I get this error:

`sdl2-config --cflags` -D_FILE_OFFSET_BITS=64 -D__KERNEL_STRICT_NAMES -I../../../ -DCONFIG_MENU -DCONFIG_CD -DCONFIG_VIDEO_CAPTURE -O3 -fno-strict-aliasing -fno-math-errno -ffinite-math-only -fno-rounding-math -fno-signaling-nans -fno-trapping-math -c ../../../dpsoftrast.c -o dpsoftrast.o -msse2
../../../dpsoftrast.c:239:22: error: size of array element is not a multiple of its alignment
239 | typedef ALIGN(struct DPSOFTRAST_State_Thread_s
| ^~~~~~~~~~~~~~~~~~~~~~~~~
../../../dpsoftrast.c:45:36: note: in definition of macro ‘ALIGN’
45 | #define ALIGN(var) var __attribute__((__aligned__(16)))
| ^~~
make[2]: *** [ dpsoftrast.o] Error 1
make[2]: Leaving directory '/home/[user]/Downloads/games/Quake/zircon_616/zirconsource20230610/build-obj/release/darkplaces-sdl'
make[1]: *** [ bin-release] Error 2
make[1]: Leaving directory '/home/[user]/Downloads/games/Quake/zircon_616/zirconsource20230610'
make: *** [ sdl-release] Error 2

I guess it's a GCC-11 error?

Ran make clean and tried GCC-10 (if the method of switching compilers worked?) and got a different error.

I think I got a different different error with GCC-9.

This is on ubuntu 20.04.

Anyone have any ideas?
I have included a Linux binary in the newest version. I hope that helps.

I compiled using GCC 9.3 on Ubuntu 20.04.2 on AMD-64. 
It does help, and works great!

Thank you, Baker :) 
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.