News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread: http://www.celephais.net/board/view_thread.php?id=60097
First | Previous | Next | Last
Compiler Wars? No, We've Got Compiler UI Wars Now... 
All I want for christmas new years is for the TB2 compiler UI to be able to launch engines ;-; 
Damage Riding Func_door Downwards 
I'm currently working on a small set piece with a descending floor, with the floor being a slow-moving func_door.

In Quakespasm I can easily receive damage in certain spots, sometimes being squished withing fractions of a second ("player was squished") despite the func_door having a dmg of 0. There is no obvious obstacle. Same in Mark V.

In Darkplaces everything is fine, but then again DP's collision system works differently.

Is there something a mapper can do to create safe door rides? 
 
Is your host_maxfps bigger than 72? 
@sleepwalker 
You have to enter the paths to compilers manually in rc4. The "..." Buttons don't work. There was a Git report on this quite a while ago.

I'd.linknto it but I am on my phone and can barely read this text right now.

I don't use OS X any longer. I just bring a pc laptop to work when I can map there on slow days. 
@otp 
host_maxfps is 72.

Tested also in WinQuake. Same problem, so this is "vanilla".

I'm using ericw-tools (qbsp / TyrUtils ericw-v0.15.11) to compile things. Using hmap2's BSP stage doesn't change anything.

I zipped up .map and .bsp at https://maikmerten.de/stickylift.zip - can somebody have a look? Just push the button and keep standing there, that's one spot that seems troublesome for no apparent reason. 
Still Squishy 
tried turning the descending floor into a train. Doesn't change the getting-squished problem. Hmmm. 
Okay.... 
so, I decreased host_maxfps to 36 and the problems seem to go away. Of course, this is not a solution.

Instead, increasing the movement speed from 25 to 35 qu/s seems to fix/alleviate the problem as well. I guess that the platform has to travel a minimum distance between physics tics to avoid problems. This can be done by lowering fps (host_maxfps) or by increasing the speed.

Darkplaces has the physics decoupled from the rendering fps, so that may explain why DP had no problems.

Does this make any sense to engine devs? 
 
how do I get a trigger_push (wind tunnel) to push up or down? 
 
nvm I figured it out 
J.A.C.K Configuration Help Needed 
I have a lot of experience with hammer and its compiler, but I wanted to try my hand at quake mapping

I am having trouble setting up the jack directories and compiling a simple map. I have the free version of jack and quake on steam.

Here's my compile log: https://pastebin.com/pT9vJfp4

The relevant part I think is the "Token too large on line 6". I tried googling this and it looks like it happens when a map has too many wads, but I only have 2.

Here's the directories I have, I do not know if they are right. https://imgur.com/ZlFmgRC 
Hrm 
I believe it is the string of wads having more than 256 characters. E.g. "C:/Path/wad1.wad,C:/Path/wad2.wad,...wadn.wad" where path goes to your steam directory.

I believe ericw's compile tools fix this:
http://celephais.net/board/view_thread.php?id=61542&start=1

These are the ONLY compile tools you should be using for Quake. 
 
That fixed it for me, thanks! 
Level Optimization? 
So I’m using the makaqu engine to run a full on game I’m making, but it doesn’t seem to run at a consistent framerate. Is there any command line optimizations that can make it run smoother and use less memory? The one thing that is bugging me is that it says I have a leak in the compiler when there are none! It’s really weird. Can anyone help? 
 
You'll need to fix the leak and run vis to get good performance. If qbsp reports a leak it should save a .pts file, open this in TrenchBroom or jack, or type "pointfile" in the console in quake to help find the problem. 
I’ll Try That! 
I’ll try to do that when I get home! Thx! 
AD: Swinging Sign 
Could I use a func_train to create a slightly swinging/swaying sign?

Or more precisely, what would be the best way to go about this, if possible?

It's just for ambience, will be coupled with an ambient_custom sound. 
Yes You Can 
You can certainly do this sort of thing with func_train in but it depends on what your vision is. I am picturing say a sign hanging in front of a Western Saloon. The sign will swing back and forth ever so slightly.

You can do this put your 2 path corners very close together, say 8 units. And give it a very slow speed key <40. The problem is there isn't really a great way to make the "rope" holding the sign sway accurately because in reality it would pivot around the point it is secured at. You could ignore this and just make the ropes very small (1 unit) in width so there lack of movement is not as noticeable, or just make the ropes move with the train, but it might look awkward.

I think ORL made flapping flag posts with func trains moving extremely fast over small distance. Its an optical effect.

Or make a .mdl and give it animation frames... 
Func_bob 
Also lets you make something hover up and down very slowly for a nice effect, but I think it can only be done vertically. I used them to make some hovering objects in ad_paradise, but again it depends on what type of sign you are picturing. 
 
wouldn't a hanging sign be better with func_rotate? 
Saloon Mini-Map! 
Func_train can work really well for this depending on what you want. The problem I forsee with a rotate_object is that it typically only rotates one way; a func_rotate_door can rotate back the other way but you need a trigger to do this and switch between the 2 states. This could make it exceedingly complex.

Using a func_train with path corners only 4 units apart and a speed of ten, a made this swaying Saloon sign that is really atmospheric:

Check out this demo map with source:
http://www.quaketastic.com/files/misc/saloon.zip

Screenshot:
https://i.imgur.com/YxkbXR1.jpg

NOTE: Arcane Dimensions is needed to play this map. I made this in AD but it you can make the func_train in ID1 of course. 
FYI 
The map is a tiny demo of the func_train only. No exit trigger or anything. So I hope no one gets mad at me:( And I hope this doesn't end up on quaddicted somehow. 
Wow, Thanks A Lot Redfield 
Very cool example map you made for me.

But... I already made that with your single entity func_bob suggestion. Apologies for not posting about it, it was really late when I did it so I just went to bed.

Also, I made a test ambient_custom_loop squeaky sound, placed it centralized to the sign and... all was good.

Thanks again for all the assistance.
- damage_ 
Also, Swaying With Rotation... 
There is the "path_rotate" and "func_rotate_train" entities that may still be the answer, but I didn't figure those out last night.

What I was doing kept screwing up the game(on load player position stuck at path_rotate location and no ability to move, even with noclip!)

If I get this sorted I will post it up. 
Lots Of Options 
There are quite a few ways you could do it I guess. I forgot func_bob can go in any direction with angle key, and this is probably the most efficient way to make a swaying sign. I'm not sure how to visualize a func_rotate_train, as the object itself will rotate between path corners, but if you make it work it would be interesting to see.

Yeah I got carried away with that saloon, I was just going to throw a func_train in a test map and see what happened, but I had this image in my head, and it just kept going. Started making textures and several hours later an insane test map. Best way to answer a question is to make a map. Maybe I will turn it into a little western map one day. 
Is There 
a way to kill Chthon without QC? Telefrag or ridiculous high damage on a trigger_hurt doesn't seem to work and setting the lightning_event its a pain the way this map works. 
Hmmm 
Try adding a key|value of th_die|boss_shockc1 to your monster_boss. Then when you hurt it it should die after 4 damage. Not tested. 
Thanks Qmaster 
I tried damaging the guy with a trigger_hurt, a door and myself with Quad rockets just in case and the guy didn't show even pain with that key on him.

What i learnt with all of this is that he cannot be moved with doors as they just pass through him, which is a pity. 
Ah Right 
I forgot that the boss is not technically a monster in the sense that it doesn't use AI normally. It is basically a turret with animations and very special code. Seems like I remember a killable chthon hack somewhere though. You might need to make an info_notnull hacked boss. 
Progref 
mechtech made a handy map that includes a whole bunch of map hacks for reference here, and a quick glance at the killable Chthon in the map shows it's done with an info_notnull with a bunch of extra fields filled out to match what the boss entity would normally have so it behaves correctly. 
Link Is Dead 
but i found it on Quaddicted. Thanks.

https://www.quaddicted.com/reviews/progref.html 
GLQuake Not Rendering Map Correctly? 
Hey there! So I got my map working and fixed all the leaks, but for some reason, when I run the map in GLQuake, it renders a far off distance like it's clipping! Is ther anyway to increase the drawdistance like in winquake with r_maxsurfs and r_maxedges or is it impossible? Could it be a mapping problem itself? Compiler gives no errors! 
The Real Question Is... 
Why in 2018 does anyone use original GLQuake?

I really want to know! 
GLQuake 
Because it's the best engine that comes with the Steam version.

Well, the second best, but the default one.

It's worth remembering that's the out-of-the-box experience, when you're looking for the largest possible quake audience. 
@Preach 
Thanks, I never even considered that. 
To Answer Rizzo 
Download an engine with enhanced limits such as MarkV, Quakespasm, or FTE. 
GLQuake Far Clip Is Hardcoded At 4096 
 
Thanks! 
Thanks guys! Guess I'll have to go with another engine! 
VIS Job Farming? 
I'm new to mapping, i've been using EricW's tools. In regards to the VIS proccess, has there ever been any consideration into farming out jobs over a network? I am sure i'm not the only mapper who has a second PC that is idling alot. I can picture small communities of mappers providing their PC's for VIS jobs. And not just 1 map/PC (that could already be done with some kind of file monitoring script). I'm talking about splitting one bsp over multiple PCs to get the completion time down. It seems with multithreading the individual threads are operating independently anyway once they get their work chunk.. granted i don't know anything really.. just my assumption. This seems to be the biggest bottleneck in dev time. Maybe the couple guys i am in a group with are inefficient mappers but the VIS'ing has taken days and days on an 8 thread i7. It would be cool if network nodes could just be seen as additional threads. 
Detail Brushes 
Should be helping with the vis times. Unless you are building a gargantuan map that rivals Ter Shib in size I can't see VIS taking this long with 8 cores. I vised a bsp2 size map in less than 1 min. on 3 threads with ample use of detail brushes.

Again this could depend on the size and complexity of the map, but if you are new to mapping, you should be using detail brushes on objects like pillars, stairs, loose bricks, small details etc. or else VIS might take days where is should be seconds. 
Yeah 
With func_detail, vis should not be the longest part of the compile any more.

Make sure you are using ericw's tools:
https://ericwa.github.io/ericw-tools/ 
Detail 
I saw detail brushes but wasn't sure what to do with them. I'll try that. thanks guys! 
Use Func_detail To Turn Your Map Into Rectangular Areas 
For instance, anything angled, off-grid, small, thin planks, trim, light panels, crates, pipes, broken walls, debris chunks,
trisoup (terrain e.g.) etc. etc. should be func_detail (solid) or func_detail_illusionary (not solid).

This lets vis deal with very simple rectangular areas and drastically speeds up compile times. It also can help you add specific lighting features to some details, such as _phong (nice and smooth shading) on rounded columns or terrain trisoup. 
 
Aside from wanting to apply phong shading to columns/pipes/whatever (which can be done with standard func_walls as well), if you're willing to eat the compile time instead that seems like going overboard a little with the details. Won't you run into issues with vis not blocking off *enough* due to details making up walls and such and possibly cause poor map optimization and lower framerates on less powerful machines? Not to mention the extra effort of making a solid rectangle area outside of any part of the map even slightly skewed or clipped-'n-vertex-edited. 
Balancing Act 
Depends on balance between CPU and GPU time per frame. Loads of objects to render = long GPU time. Loads of vis leafs to calculate against = long CPU time.

E.g. in a level with 10ms CPU and 20ms GPU, it would help to render less, so yes more leafs could help.

If instead you had 20ms CPU and 10ms GPU, then fewer leafs would help improve performance then func_detail would help.

I honestly don't know what the bottleneck would be or how to check it. 
 
gpus are quite fast nowadays, they don't really care about a few hundred more quads.
overdraw is still a concern (so you still want your various rooms to be properly sealed with structural brushes to avoid the worst of it), but otherwise if the engine has decent batching then you won't see much of a problem if all the details+pillars+etc are flagged as details.

tbh, its the leafs themselves that are the expensive things. 
I Was Under The Impression 
That in quake, you can't appreciably change the number of leafs with func_detail, only the vis compile times. Has this changed? 
 
no, you have the leafs whether they're detail or not.
you can't fold leafs using q2-esque cluster stuff, because the bsp format doesn't support it.
and you (usually) can't merge leafs due to the engine calculating a parent leaf - each one must have a single parent node so no multiple routes through the bsp tree (side note: this doesn't apply to hulls 1+2).
so the only way you can merge them is if two leafs share a parent node, have the same contents value, and together form a convex area (such merging can happen recursively so long as those conditions still hold true).

less leafs means fewer marksurfs, fewer nodes, fewer frustum checks, smaller pvs data (and for every other leaf too), and fewer cache misses throughout.

arguably surfaces could be merged into a concave mesh on the condition that there is still 1 truely central vert somewhere.
the geometry works even if they're on different planes, but lighting and texcoords would likely be broken because of it.
whether it would break software rendering, or gl engines that pick the wrong edgevert is a different matter, but hey, most gl engines should cope without realising it. 
Kinn 
Yes func_detail shouldn't create more Leafs 
Spike 
Engines should be able to recover detail clusters by recursively merging leafs that have the same visofs. This has the benefit of working on released maps and won't risk breaking anything. Once you recover the clusters you could generate lists of faces per cluster, new compact visdata, etc. 
Using Scourge Of Armagon Assets In TrenchBroom 
Hello,

Longtime quake player, trying to create a custom version of DM3 with some Scourge of Armagon assets for team deathmatch. I used pak explorer to extract the DM3.bsp from pak1 in id1 and was able to convert the bsp file to a .map file, which allows me to then open it in TrenchBroom. I think I get how to recompile this back into a usable .bsp (doing the light/vis stuff etc.), but I'm curious how to actually use Scourge of Armagon assets. I have the add-on pack (it's in a subfolder called hipnotic), but I'm unsure how to use those pak assets in TrenchBroom.

Any help would be appreciated :) 
@Michael 
Cool idea to update Dm3 for SOA. The source for DM3 is available at Quaddicted. So use that instead of a decompiled bsp.
You'll have more luck.

https://www.quaddicted.com/files/maps/sources/quake_map_source.zip

Next, you will want to load up the mission pack fdg in Trenchbroom. I have been searching for it but cannot seem to find the link. But it's out there.

When you have the fgd you will go to the entity tab in TB and at the bottom load external and select that fgd file. After that you should have the entities available to you in the browser. You will also want to load the mission pack as a mod in TB in a very similar fashion. It's on the map tab I believe. 
^^^^ 
Triple Post - Woot! 
I might as well pimp a DM level I made that includes a Hipnotic version of the map. It's called Lividus. Maybe you and your pals will enjoy it along with DM3.

https://secretlevelsite.wordpress.com/my-levels/ 
 
Thank you for the help and taking the time and all the links provided! I managed to figure most of this out through a bit of trial and error and talking to the devs from qrack and fte. Some of those old assets are indeed hard to find!

I still play TDM with a group of oldschool quakers on DM3. Matches on most weekends. I was looking to create a fun tweak of DM3 that would preserve what works about the level for teamplay, i.e. the idea of level/item control without messing up the balance too much.

But due to having played it 9999999 times, I thought adding some SOA assets would be fun. I added the proximity grenade launcher at the opposite side to standard GL, replaced the SNG in the SNG room with the laser cannon, replaced the standard nailgun (useless in DM) with the SNG, and put mjolnir outside by the pent. I feel like these weapons could lead to a few interesting tweaks in gameplay (e.g. setting traps with proximity mines, using laser cannon to blast into areas by bouncing shots, mjolnir to close proximity attack somebody with weapons).

If anyone's curious, here's the first iteration. Requires the hipnotic pack to work (i.e. whatever executable you're using -game hipnotic -hipnotic for command line switch):

https://nofile.io/f/arGY5npZyZ3/dm3a.bsp 
 
in trenchroom, I made a button and set its target for one door but it opens all doors on the map. what do? 
 
That means all your doors probably have the same targetname.:D 
 
will I have to name all of my doors? because the other ones being triggered don't have names 
 
will I have to name all of my doors? because the other ones being triggered don't have names 
 
nvm, that just stopped the door from opening automatically. I'm looking at all my entity links and none of them go to the irrelevant doors, only to the ones I told it to go to. 
 
and it only happens with a button, not the trigger_multiple I have already 
 
it also triggers doors with different names?? 
Set The Don't Link Spawnflag On The Doors 
 
 
that didn't work, but it broke my unnamed door :L 
 
it's weird, whenever I change any properties on my unnamed door it just totally stops working 
 
here are my button's properties. maybe it's something to do with the button. https://i.imgur.com/lHqqReg.png 
 
Please try and avoid the triple posting.

What do the door properties look like? 
 
O, sorry.
and here are the doors (four doors that sink into the ground) targeted by the button https://i.imgur.com/RDWDmBn.png
keep in mind it's also triggering a pair of doors named "d2" 
 
The two groups of doors are too close too each other.

Add "dont link" to the D2 doors as well. Remove that Wait of 0. just remove the Wait key entirely. No need for it if youre also using the Toggle flag, as far as i can tell. 
 
oh and do "r_showbboxes 1" in the console and youll see the trigger volumes and such. This should make the problem a bit more evident. 
 
I've tried adding "don't link" on all the doors.
I did a video just so you can see exactly what's going on.
https://www.youtube.com/watch?v=9ZOH1YmMnNo&feature=youtu.be
there are 3 sets of doors, the four downward-moving doors (d1); the doors above d1, which the player gets launched up through (d2); and the unnamed door which is off to the right and there's nothing special about it.

I've tried creating a new single func_door away from the others with no changed properties, and it still opened.
I've also deleted and redone the button to make sure I didn't accidentally change a property.

if it turns out to be something really simple I goofed up on plz don't laugh at me ok?? <:l 
 
Maybe upload the .map? 
 
 
Remove the blank "target" and "wait" from the d1 doors for starters.

But, beyond that...the issue isnt happening for me when I compile the .map. The button only opens d1. I didnt change anything either. 
Ha Ha Hi Hi Ho Ho 
yep that did it! I didn't realize the unnecessary target and wait would do anything. mystery solved, we can all go home now 
 
no dont go home. go map. 
 
Are there any good beginner resources around?

GTKRadiant, NetRadiant, and Trenchbroom seem to be the most popular editors, and ericw-tools seems to be the current suggested toolchain for compilation, but all the documentation and stuff I've found seems 
Dang Accidental Post 
...to assume that you know what you're doing, which I really don't.

Sorry about the halfpost, interface bugged out. 
Re: 19413/19414: Beginner Resources 
This might help to get you started with the very basics: https://quakewiki.org/wiki/Getting_Started_Mapping 
Make Sure And Register 
...for this site so we know who you are. :) Maybe prepare a list of specific questions you have too. We'll be happy to answer.

JACK is also a popular editor for those with Valve/GoldSrc/Worldcraft experience:

http://jack.hlfx.ru/en/
http://store.steampowered.com/app/496450/JACK/

I use TB2 and can answer questions. Also Terrfusion on Discord is a good real-time resource as well. 
Nobody Has To Register If They Don't Want To 
and it's not a prerequisite for asking questions. 
It Should Be 
 
 
I smell shrimp 
 
Shit is arguably better than shrimp. 
Registering 
...was simply a friendly suggestion. Not a demand. You know, to get to know someone in a more personable way? 
Nope, But You Do Have To Register If You Want To Post Abuse 
and it's a prerequisite for trolling (i.e. some form of accountability). 
#19423 
@dumptruck_ds: Yeah, I get that. :) Of course registering has its benefits, but it should be the person's own choice, and I thought the way you phrased it, it sounded a bit like a demand/pressure/prerequisite.

In any case, my comment was directed more at whoever posted the question in 19413/19414, than at you. People may have various valid reasons for not wanting to register and sign up, and it would be a shame if they feel pressured to register and then stay away completely as a result.

And (re: #19424/Shambler) of course I'm talking about people asking for mapping help, contributing knowledge, etc. and not about trolls/people posting abuse. I can understand the argument there, although there are plenty of people happy to troll and post abuse while logged in anyway. So I'd argue that even then, whether or not someone is registered or logged in is irrelevant: just don't be a troll and don't be abusive. 
 
can a mod delete / move the above BS into the beef thread?

It would be nice if any visitors coming here wouldn't be greeted with this as their first experience here. 
Snaut. 
Would if I could. I think there's no beef here now tho. All good. 
 
how do I get spike traps to shoot more/less frequently? 
 
ah nvm, got it (it's 'wait') 
Bit Of A Technical Question Here 
Been trying to get my head around the Valve220 map format.

https://developer.valvesoftware.com/wiki/MAP_file_format

What's the point of the "rotation" field?

There's a not-particularly-clear description of it on that page, but I still don't get why it's required when you already have two vectors defining the "right" and "up" of the texture.

Possibly related, but in Netradiant, if I do a fractional texture rotation (e.g. 13.6 or whatever), only the integral part (13) gets saved to the "rotation" field in the .map, yet the extra precision is not being discarded, because it's generating different "right" and "up" vectors, compared to if I just rotated it by the integer 13.

It's almost like the "rotation" field is just for show, but why? 
Rotation Field 
It's a cheat. Rather than the editor (JACK or Hammer only) having to calculate the relative rotation of the texture UV space every time it loads a face into a brush, it merely calculates this during save and puts it into the .vmf or.map.


At least U think thats what it's for. Old Worldcraft 3.3 needed some hackery if I recall to read it. Whoever did the WC3.3 patch might know for sure. 
 
That field stores the knob position of the Hammer UI. It's not used by qbsp when compiling the map.

I guess the reason it was done this way is, you can rotate the brush with texture lock on, and this won't cause the texture rotation knob in the UI to change on its own. 
Knobs And Things 
interesting cheers, so it's pretty irrelevant. 
 
what's a good method to creating arches that match up with the arch textures? in JACK I would use the primitives and CSG but that was funky sometimes and TB doesn't have those functions at all. 
 
 
derp. a description would probably be nice:

theres an arch tutorial for Trenchbroom. 
_bounce In Ericw-tools 
Hi!
Is there a way to control/turn off the bounce lighting specifically on _sunlight and _sunlight2? 
Not At The Moment Afik 
but it's a good suggestion! 
Thank You, Love Your Tools 
 
Engine Question 
Is there any difference in physics whatsoever between a trigger that was created in the editor as a brush model, and a trigger that was spawned dynamically in the QC? I'm guessing the answer's "no", but wanted to double-check. 
#19440 
no. either way, solid_trigger is an aabb. the shape you set in the editor is irrelevant, only the bbox extents are meaningful.
so one uses setmodel and then discards the model, the other can just directly use setsize. same result. 
Nice One 
That's the answer I was expecting and indeed hoped for. Cheers :) 
Colored Lighting 
Working on some colored lighting in a map. I had been tinkering around with the Arcane Dimensions stuff, and left those settings on when I originally setup the lights. My lights look really good in AD. Later, when playing the map in Quakespasm with no mod, I noticed the colored lights are pretty crappy by comparison, and I'm not sure if its a matter of settings or if Arcane Dimensions just had a different lighting setup than Quakespasm can do on its own. I feel like there's a setting I'm missing or something, perhaps a rendering setting in the engine I need set in the config?

Shabby Lighting
Screenshot 1 with Quakespasm: https://imgur.com/bhmaPJv
Screenshot 2 with Quakespasm: https://imgur.com/avdiEJk

Pretty Lighting
Screenshot 1 with Quakespasm + AD mod: https://imgur.com/jA1Jjys
Screenshot 2 with Quakespasm + AD mod: https://imgur.com/fcMKFl1

Bonus Question: Does Arcane Dimensions mod always use the new health and ammo models or is there a way to tell it (in map settings) to use the classic models?

OS: Windows 7 64bit
Client: Quakespasm v0.93.0 x64
Editor: J.A.C.K. 1.1.1064 64bit 
Skip Textures 
I created these for the video tutorials I am working on. Not pretty but you may find them useful.

Link on Quaketastic

Screenshot 
Problem Adding Textures 
Hello, I'm having difficulties setting up textures in trenchbroom. I have followed instructions and added Texture compilations WADs, but the textures doesnt show up in the browser...am I missing something here? 
Problem Adding Textures 
I noticed I get the following error message when adding a WAD:

Could not load palette file 'gfx\palette.lmp': File not found: 'gfx\palette.lmp' 
Maybe!! 
Quake path not set? 
@spjuver 
click "face" right up screen, aside Map Entity.
texture browser +
Add texture wad set path
@spjuver 
Has to be your Quake directory. As Pyro said. 
@19443 
I don't think there's anything different lighting-wise in AD, or at least there shouldn't be given lighting is baked into the map, and a quick look at the documentation file and configs doesn't show anything. Normally if you're getting issues with colored lighting, it's due to the engine not supporting it so it either doesn't show up at all or shows up as standard white lights, but you've clearly still got some kind of color going on in the standard QS screenshots. I tried replicating it with multiple lights overlapping, different light values/types, etc. and couldn't get that 'colored outline' effect, would you mind uploading the map (and your own compiled .bsp) to see if the same thing happens to others?

Bonus Question: Does Arcane Dimensions mod always use the new health and ammo models or is there a way to tell it (in map settings) to use the classic models?
AD always uses its new models IIRC; there's a couple variants including a metal-sided style based off the id1 boxes (the same way AD includes updated weapon world models, enemy models, etc) but they're normally limited to the base worldtype, being replaced by the wood-sided boxes and health potions in medieval/runic. Glancing at the qc files shows there's a skin_override key available for both health and ammo entities that you can use to force one model or the other though, so give that a whirl. 
Trenchbroom Error / Help 
Hey guys. First-time mapper here working on a, hopefully, exciting map that I'm eager to finish and release. I've been working on it daily for the last 7 days and learning as I go. I'm having an issue, however, that maybe someone could help me with? So the level is coming along and I'm moving into a new section. It's at the end of a hallway and then I'm trying to make a path to the left. Everything compiles right with that new path but when I extend it to make it longer, there is an error compiling. It says "Mixed face contents in leafnode near (835.43 -192.00 72.00)" and I sort of know what that means as I've had to fix those kinds of errors before. Problem with this one is this hallway, floor, etc are not bumping into anything, are connected properly, and all that. There's literally nothing for it to run into so I'm not sure what's happening. Any ideas? 
Error (cont) 
Run into meaning sky and wall, for example. That's where I saw that error before was when my sky was encroaching on some walls. Cleared it right up after editing it a little but this error I'm having currently is really confusing the hell out of me. I don't know why the new section will compile right when it's a small size and then cause everything to screw up when I extend it a few meters down. I've tried building other stuff in that area and it seems that there is a point of no return kind of deal going on. 
 
It's for Quake 1, if that matters. 
Griffin 
That's usually something you get when you have a face with sky texture touching a face with some kind of liquid texture, or a trigger. Sure there's not something like that going on? 
 
Yeah, I'm almost certain. I do have a skybox in one section but fixed all the problems there and never had any more issues until this hallway part which is a good distance away from the skybox. I've narrowed it down to the point I can't go past as well and there's nothing in the way whatsoever. If I extend it even one small block it won't compile. Really frustrating. 
 
Deleted the skybox completely and tried it and still won't compile so can narrow that out at least. 
 
Oh weird. Fixed it but still not sure why it was a problem. I constructed a little table in the hallway and made a shiny gold necklace on it and used zoomed in lava for the gem part to give it a cool glow. This didn't cause any problems prior either but I just deleted it and now I can keep going with the hallway. Weird. I wonder why it would work to a certain distance and then stop considering the necklace is also away from the place I'm now building. You did help me though. You said "liquid texture" and it gave me the idea to delete it and see what happens. Thanks, man. Woo! Was getting worried for a second. 
 
Bummer about the necklace though. It looked awesome. 
Griffin 
Maybe with some screenshots of how you've set things up people will have some ideas of what could be going wrong. 
@griffin 
I've had "bad geometry" cause leaks before but never got that mixed face error. It sounds like you had lava just on one face of the brush in this case. Maybe a custom full fright texture would have a similar effect? You can probably use something from the prototype wad here: http://khreathor.xyz/site/prototype/ 
 
Yeah it's all sorted now anyway so no worries. I'll come back to the necklace when I finish everything and see if it goes through. Are these leaks you mention a major problem? I've seen some leaks pop up during compiling but I'm still able to play the level and all that so I figured it wasn't a huge deal. 
 
I'm liking those textures. Thanks man. 
Trenchbroom Compilation Question 
Hello, I started to use Trenchbroom and had a problems with compilation so I found some guides covering the newest version of Trenchbroom that lead me on right direction though did'n help at all. So I referred to Trenchbroom's manual pic named "Compilation Dialogue" and my map seems to compile just fine with qbsp.exe. So I tried to compile using other tools, again referring to mentioned manual pic and just don't understand what shoud I type instead of ${CPU_COUNT-1}. Please help 
Tamagotchi 
Could you upload a screenshot of what your compile UI looks like? And what tools are you trying to use? 
 
sorry I don't know how to upload that. in manual pic everithing that has ${} thingies must be replaced with directory of the game or folder with map and I have no clue what I should replace the ${CPU_COUNT-1} with. In output it tells me: Could not interpolate expression '-threads ${cpu_count-1} mymap.bsp': Cannot subtract value '1' of type 'Number from value 'undefined' of type 'Undefined' 
Just Leave CPU Count Alone? 
From the manual:

CPU_COUNT | Tool | The number of CPUs in the current machine.

Usually we just set path's for compilation. 
Griffin 
Mixed face contents is where you have a mix between the 3 face types in Quake: world, water, sky. Never have a brush with water on kne side, world on another. Or sky mixed with water, etc. 
Triggering Monsters (Quake 1) 
Hey dudes. Me again. I'm trying to set a trigger on nailgun pickup that summons two demons at the end of the room but I'm unsure of how to do this exactly. I've set up a room apart from the map that they'll teleport from but that's about it. I've been experimenting with the trigger functions and just can't figure it out. The manual does not seem to cover this topic and google isn't yielding much. 
Additional Question (not Too Important) 
While I'm here I figured I'd ask another question: is there any way to see how my lighting will work in the editor itself? I have to compile and run the level every time I make adjustments and it's starting to take a while. 
Triggering Monsters (Quake 1) 
For teleporing monsters via trigger once.

1. Make some monsters and place in into "trigger_teleport" brushes. Each monster in separate "trigger_teleport" entity. All teleport entities must have one targetname.
2. Add some teleport destinations - one "info_teleport_destination" for one "trigger_teleport", and connect it one to one.
3. Connect your "trigger_once" to "trigger_teleport" ents. 
@griffin 
Spawn a monster in. (I know you've done some of this but for others:)

How to teleport in a monster upon triggering something:

1. make an area outside your playable level and place your your monster
2. make a brush with the trigger texture that covers the center of the monster.
3. right click and make the trigger brush into a trigger_teleport give it a targetname (i.e. monster1) and a different target (i.e. dest1)
4. place a info_teleport_destination where you want the monster to teleport to give that the targetname of the target in step 3 (in this case dest1)
5. set your trigger (in your case above it's picking up a nailgun) the target of the nailgun should match the trigger_teleport targetname in #3 (monster1.)
6. make sure you keep track of your targetname and targets - it's easy to get these confused. Just remember targets trigger targetnames in other entities

something to note: if you are spawning in two at the same time they need their own info_teleport_destination entities so they can share a targetname and be triggered at the same time but they each need their own separate target. If you use one destination they will telefrag each other! And you may want to add a key of delay and a value of 0.1 to the second monster so there is a tiny delay between their spawns. I recall this solving an issue before so try it if you see problems.

2. there's no real-time lighting preview right now in any of the editors. NetRadiant will show you a representation of the falloff of a light. ericw had hinted he might do an application that does realtime lighting preview at some point. Which would be instantly popular. 
@griffin 
@doomer is correct and I wasn't clear above. Each monster needs its own trigger brush and separate destination but they can share a targetname. Also I think you can just add a target to the nail gun instead of making a trigger_once. But if you wanted the monsters to teleport as you walk into a room then you'd make a trigger brush right click and make it a "trigger_once" Good luck!!! 
 
Awesome. Thanks guys. I love your levels and you're both big reasons why I started learning Trenchbroom. You guys, Sock, Ionous, Skacky, etc are incredible at this. 
@griffin 
Wow, that's very kind of you. I am currently working on video tutorials for Trenchbroom. You seem to figuring out thing on your own though! The first one will be out early next week. As time progresses there will be some advanced tuts you'll want to check out. I'll post here on fucn with links. 
 
Beautiful. Got it on the first shot as you guys explained it perfectly. Definitely looking forward to the tutorials. Thanks again, guys. You rock. 
Just To Be Safe 
I made a post about this, but I might have made a mistake with that. Here's what I wanted to ask:

I've been looking for a tutorial on the use of Jackhammer for a few hours now, but I can't seem to find anything. Is there a tutorial out there I can use to see what's up? 
@7663 
If you can't find any tuts for JACK then you have some options that will get you close.

First, JACK is based on Valve's Hammer editor. You will find tutorials for Hammer out in the wild. There are many similarities between the programs. I believe JACK has more features but I haven't used it too much.

The other option is to use Worldcraft tutorials. JACK is based on Hammer which was based on Worldcraft and many concepts from Quake will carry over.

https://www.quakewiki.net/archives/worldcraft/tutorial/index.html

Good luck and consider trying TrenchBroom 2. I will be publishing a Quickstart video tutorial sometime this weekend (or before) and you may like what you see.

http://kristianduske.com/trenchbroom/

The tuts will be on my YT channel is here 
Artifacts In Q2 Sun/lightmap 
Hello guys, this is my first post here. It's interesting to finally have some reason to post here. I'm following func_msgboard for sometime, following all the cool maps and mods are being born here... Good stuff :)

Anyway, i decided to try something in Q2 engine. Right now, i'm having some problems when using _sun. Compiling with qrad3, i get this result:

https://imgur.com/a/AZDM3

it doesn't happen when i compile regular lights only, just when I use Sun... :/ Anyone have some idea? Thanks! 
Ah, Arghrad 
Arghrad solved my problem :D
back to work 
Scaling Models 
Is there a way to scale (prop) models easily? I have downloaded Preach's crane and helipad models from his site, and after placing them on my map in Trenchbroom they look so small, about the size of a cat. Quite endearing, actually. xD

Will I have to resort to some mdl editing in a separate editor? D: Guess I'm going down the deep end of Quake custom content creation, no more simple map making, huh? xD 
#19481 
I usually just jump into QME here? and scale the model: https://i.imgur.com/zCDf0EZ.png

Of course, QME sucks ass and tends to mangle models if they look at it funny so... have fun? 
 
QME likes to break mdls. Should only be used to view models. :( you may get lucky tho. 
Mdl Scale 
Scale is defined by just one float in the .mdl binary file, I think (Can anyone confirm? Does anything else need to be tweaked other than this one float?)

If so, you could be able to just hax0r it with a hex editor. Preach - any ideas? 
 
Actually it's a vector of 3 floats

http://tfc.duke.free.fr/coding/mdl-specs-en.html

you'll probably want to scale bounding radius too. 
Scripting 
Yeah, you only need to change those 4 floats, so a hex editor will do the trick. If you prefer, you can install the qmdl python module then run the following script against the model.

from qmdl.helper import Helper

#read the model file
mymdl = Helper()
mymdl.load("crane.mdl")
#rescale
mymdl.mdl.scale = tuple ([i*4 for i in mymdl.mdl.scale])
mymdl.mdl.boundingradius = mymdl.mdl.boundingradius * 4
#save again
mymdl.save("bigcrane.mdl")

This is multiplying the scale by 4, vary the value as required. 
It Worked! 
Thanks guys, you just keep helping out, no matter what I keep throwing at ya', AND always in a timely manner, might I add! :)

And for your information Preach, I used your script on a newer Python version 3.6.4. 
Adjusting Mdl Centerpoint 
I'm guessing it's model dependent, but I noticed that the larger I made the helipad, the further away the model diverged from the model entity (or is it in this case just a handle?) in Trenchbroom. Is there a centerpoint in the mdl I should adjust? Can it be done with qmdl or should I use something else? 
Yup 
One of the quirks of the mdl format is that the model keeps the bottom left corner fixed when you rescale it, rather than the centre. If you add a line like

mymdl.mdl.origin = (-64 -64 -64)

after the mymdl.mdl.boundingradius line in the script from the previous point, you can specify the coordinates you'd like the bottom-left point to be at. Play around with the values! 
Thanks 
I figured it would be something like that. Thanks a heap for going through the trouble of helping me out! :) 
No Worries 
It's cool to see someone using it, I worried that it being a python module was a bit off-putting 
Func_train Question 
How to make train move through four path_corners? I named each correspondingly and gave paths corresponding direction. 
@Tamagotchi 
I made a sample map linked below. It's pretty easy to do as you'll see.

I made 4 path_corners. t1 - t4 make sure the target/targetnames are correct and that they close a "loop" - that's the part that people mess up on the most.

I don't think you need to specify a direction. I didn't in this case. Sorry for the weird name. Also you can use Quake101.wad or q.wad for the textures in this map.

http://www.quaketastic.com/files/Box_Mac.map.zip 
@dumptruck_ds 
Thank you for your help! watched your tutorial on tuesday so thaks for that as well! 
@Tamagotchi 
You're very welcome. LMK if you have any requests for tutorials. :) 
Texture Wads 
New to mapping (thanks @dumptruck_ds) and wondering where everyone gets their textures?

For the moment I'm just looking for the default Q1 textures, but it'd be good to know where to get custom textures come from too. 
Here's A Start. 
 
Texmex will let you open a map/bsp and save as a wad 
Tex Mex 
Does TexMex have a homepage somewhere? Or is it just floating around, no longer developed. 
Looks Like Floating Out There 
Looks Like Floating Out There 
[Texmex] 
Guessing this one is the one people are using
https://www.quaddicted.com/files/tools/ texmex_34 
 
This is more of an engine question but does quakespasm or vkquake support increasing the playback speed for animated textures using the +0, +1, +2 naming convention?

DP lets you circumvent this with Q3 shaders but i'm just curious if there's a more universal option for having an animated waterfall look smoother 
 
Not that I know of, but there's a tutorial on Preach's site about using func_wall's on-trigger function (switching texture between two sets) to double the framerate from 5FPS to 10 using two sets of premade textures. 
I Should Add.. 
That the method in the tutorial is a bit convoluted, because it describes how to get the effect in unmodified Quake. It would be much better to achieve the same effect with a simple mod that added QuakeC code to perform the switching between the textures. 
I'm Using Func_illusionaries 
So i guess i'll just deal with the low framerate.

I have another question/problem - I made a huge lift in my map that goes up slowly, it's a door -

https://i.imgur.com/GaKblfA.jpg

It has items on it, but seemingly at random while the player is riding it he will get snagged on it and take damage, and send the lift back down.

Is there any reason for this/workaround? I know i could make it so you ride it down slowly instead of up, but I have to redesign it if i do that. I wanted to avoid using a func_train but if it's some sort of engine problem I'll switch.

I'm using quakespasm btw 
Wait What? 
I switched to a train and the collision does not match up with the position of the train - i tested in quakespasm and vkquake and it's broken in both, but oddly enough in darkplaces the collision of the train is correct

I have no idea what's going on 
 
Check for an "angle" or "angles" key on the func_train and delete it if there is one. 
 
I feel like a dope, that was it. Leftover from converting door > train

Thanks. 
Check Your Server Fps Too 
Another thing that can cause weird physics glitches, like the one you had with your elevator, is setting the server fps too high in the config (default 72, if I recall correctly). When I use Quakespasm, setting it to 150 still seems to allow everything to work correctly. 
I Actually Kept Quakespasm Running At 72 Fps 
It still would happen. Sometimes the train gets caught too and does a point or 2 of damage but it's alright since it doesn't break the whole sequence 
Yes 
I had the same stubborn func_plat that caused me headaches to solve.
Glad finding the solution here.

(for the the func_plat head) P: 
Lava Alpha 1 
It's been asked many times, but here I go. There is a worldspawn key to set the lava alpha for that particular level, right? Which one is that, again? 
Meet The "alpha's", Hehe (Hope This Is Correct) 
Worldspawn

----- Alpha Options -----

water_alpha(string) : "Water Alpha" : : "Set the transparency of water (ex .70), which are brushes textured with a water(ex *04water) texture. This setting tranfers directly to the other 'liquid' types and teleporters, UNLESS you are using an engine that supports individual 'alpha's' for each(see below). NOTE - Defaults to the players own 'r_wateralpha' settings if no value is assigned."

lavaalpha(string) : "Lava Alpha" : : "Set the individual transparency of Lava, brush solids textured with a lava(ex *lava1) texture. Default inherits the 'water_alpha' setting. If 'water_alpha' is not set then it defaults to the players own 'r_wateralpha' setting."

slimealpha(string) : "Slime Alpha" : : "Transparency of Slime, works the same as 'lavaalpha' except for solids textured with a slime(ex *slime0) texture."

telealpha(string) : "Teleporter Alpha" : : "Transparency of Teleporters, works the same as 'lavaalpha' except for solids textured with a teleporter(ex *teleport) texture."

This works for me and I believe it to be accurate but if it is not, please let me know otherwise. 
I Forgot To Bold This... 
... and it threw me when I was testing:

IF 'water_alpha' is NOT set, then it defaults to the players own 'r_wateralpha' setting."

That means, that to set lavaalpha, it IS necessary to set a starting water_alpha to get the results you desire! 
@damage_inc 
 
Sorry For The Empty Post Above 
Is this Quakespasm? Do these work in other engines? 
@dumptruck_ds 
Yes, Quakespasm. I just assumed it was a QS related question since it was a specific lava alpha question, maybe that was wrong?

I tested with DP, FTE, AD-MOD/QSS etc... I only remember I had mixed results, not the specifics to what each one did upon map load. 
Thanks, But 
I hope I can still set water_alpha 0.5 and lavaalpha 1, transparent water and opaque lava. Will try later. 
Water_alpha Is An AD Feature 
It works on any engine, but only with the AD mod.

Quakespasm and MarkV both support "_lavaalpha" and "_wateralpha" worldspawn keys. These work on any mod includong id1. This is relatively new (last 2 years ish) and not sure if any other engines recognize these keys. 
Really Wish I Could Edit My Post, Grrrr 
I should have used my modified version of Daz's FGD for reference, doh. I forgot the subtle differences.

Which has the correct entry for wateralpha, which is:

wateralpha(string) : "Water Alpha" : : "Set the overall transparency of liquids, default = (1.00)"

This I just tested with stock id1. No underscore needed at all?

Apologies for the confusion. 
 
Just checked MarkV and QS source, they will both accept underscore or no underscore. 
What About Telealpha For Mark V? 
In my map it's not recognizing it? 
MarkV Doesn't Seem To Support A Telealpha Key 
 
@ericw 
I think were technical reasons for not doing it.

Mark V has automatic underwater transparency detection (which isn't hard to implement, btw --- I told qbism how to do it and he added it qbism super8).

But the underwater transparency test cannot be applied to all teleporters because a small teleporter might not even materially affect vis.

Recommendation: Add automatic underwater transparency to Quakespasm (you'll like it) and then also remove support for tele-alpha.

Qbism added automatic underwater transparency to super8 because if a map isn't water-vised, honoring the user's r_wateralpha value (unless r_novis 1) is just silly looks horrible.

If you add automatic underwater transparency, you'll never see that ugliness ever again! 
Original Id1 Wads 
#14672 #14678
"Are the original id1 wad files somewhere? I wanted to re-compile all the maps to try this but got a lot of missing textures when I used wads from my collection.

base.wad
jr_med.wad
medieval.wad
metal.wad
start.wad
tim.wad
wizard.wad"

For example: I was also looking for the original wads and after finding these two posts I decided I was bored enough today to do this:

http://www.quaketastic.com/files/texture_wads/id1_complete.zip

I found that the available METAL.WAD had only 99 textures in whereas mine now has 144.

Method:
I opened each original map from Romero's source and then made a list of which maps used which wads. I then extracted the textures from each map as its own named wad. After that I merged all the wads into their correct wad according to the list I made.

Adding these to /Trenchbroom dir/gfx now allows all the source maps to be textured without having to open Quake101.wad or similar afterwards. 
Amazing! 
I always found the lacking textures super annoying, but oGkspAz, you have finally fixed the problem that has annoyed me for so long.

Thank you thank you thank you! 
Help, I Am About To Release My First Map But I Have Some Problems 
Ok, so I am a long-time Doom mapper and have recently taken up Quake mapping as well. I like it a lot and you can expect to see more stuff from me. Forgive me if I come across as a massive noob. I still feel like an outsider.

I have two problems that prevent me from releasing the map:

First, I have a func_door descending lift but whenever I step on it it only goes 48 units...it is driving me nuts.

Second, the surface of the lift and a brush near it are acting very strangely. If I just walk on them then it alright but if I jump, I get instagibbed. I don't get it...

Would someone mind taking a look at the map? I could also use some feedback on the map itself.

Now I don't know how to package the thing. I just use the compiler but when I drag the .bsp file in Quakespasm, it crashes, so I will just upload the .bsp, .map and .WAD files that I used in a RAR. Again, excuse my noobishness.

I hope you will enjoy the map.

https://drive.google.com/open?id=14HcCX9XRv6p1KIUrx1s1IRIVxj5UCG5I 
 
func_door descending lift but whenever I step on it it only goes 48 units...it is driving me nuts.
func_door will move the extent of the bounding box, minus the "lip" value (but if lip is unset or 0, it uses a default value of.. 8, I think?).

Easiest fix is probably to add a "pedestal" to the lift to give the overall func_door the right height.

If I just walk on them then it alright but if I jump, I get instagibbed.
Check that your host_maxfps cvar is not set above 72. If it's too high elevators will hurt the player. 
 
@ericw

Yay, that worked. I knew it had something to do with the bounding box!

It is not set above 72. I have an instagib trap in a nearby room but I checked and there are none of the brushes going in the affected room. Really werid. 
Instagib 
You get gibbed when jumping there is because of the way the trigger_hurt is done. The size of trigger volumes is always determined by an (axial) box around all of the brushes it's made of. In this case, the trigger consists of two brushes, a big one and a smaller, but the touchable volume spans across both. Check with r_showbboxes 1. You need to make it two trigger_hurt entities, one for each brush; then the space above the lift will be unaffected. 
 
Got it!

Now how do I package the whole map so I can share it? 
@DooM_RO 
You'll want to name your .bsp file in all lower case, no spaces or special characters. You will zip up the following in an archive:

1. your .bsp file (the map)
2. a readme.txt file. please name it <yourmapname>_readme.txt This explains what your map is and any specific info you want to share including your email or social media contacts.
3. it's customary but optional to include your .map file (it's considered polite in these circles.)
4. if you have any colored lighting in your map there will be a .lit file with the same name as your bsp. Make sure to include that as well.

Congrats on making a map!! 
@dumptruck_ds 
Hey dumptruck! Your YouTube videos were very helpful in making this!

What about the .WAD files? Or are they included in the BSP? 
 
Here is a link to the final map if anyone is interested in playtesting.

https://drive.google.com/open?id=14HcCX9XRv6p1KIUrx1s1IRIVxj5UCG5I 
DooM_RO 
Seems like a good first effort. Though unfortunately it's pretty much unplayable currently. The map is unsealed (leaks) and unvised - this is something you must address before the final release. In addition, there are many issues concerning entity placement: nine items (including a grenade launcher) fall out of the level, and a large number of monsters are being reported as partially stuck in geometry. Check the map with developer 1 and you'll see all the warning messages in the console:

walkmonster 'monster_ogre' in wall at '768.0 -80.0 265.0'
walkmonster 'monster_zombie' in wall at '-784.0 -704.0 41.0'
walkmonster 'monster_zombie' in wall at '-352.0 -400.0 41.0'
walkmonster 'monster_ogre' in wall at '528.0 -1008.0 489.0'
walkmonster 'monster_ogre' in wall at '296.0 -1072.0 488.0'
walkmonster 'monster_ogre' in wall at '368.0 -976.0 489.0'
walkmonster 'monster_ogre' in wall at '296.0 -1240.0 489.0'
walkmonster 'monster_enforcer' in wall at '632.0 -952.0 296.0'
walkmonster 'monster_ogre' in wall at '224.0 -1288.0 184.0'
walkmonster 'monster_ogre' in wall at '-2400.0 -1472.0 -424.0'
walkmonster 'monster_ogre' in wall at '-1704.0 -1880.0 -72.0'
walkmonster 'monster_ogre' in wall at '-2224.0 -2288.0 -72.0'
walkmonster 'monster_ogre' in wall at '-2528.0 -2032.0 -72.0'
walkmonster 'monster_knight' in wall at ' 32.0 -1808.0 25.0'
walkmonster 'monster_knight' in wall at ' 96.0 -1808.0 25.0'
walkmonster 'monster_knight' in wall at '-32.0 -1808.0 25.0'
walkmonster 'monster_knight' in wall at '192.0 -1840.0 25.0'
walkmonster 'monster_knight' in wall at '128.0 -1840.0 25.0'
walkmonster 'monster_knight' in wall at ' 64.0 -1840.0 25.0'
walkmonster 'monster_knight' in wall at ' -0.0 -1840.0 25.0'
walkmonster 'monster_knight' in wall at '-64.0 -1840.0 25.0'
walkmonster 'monster_knight' in wall at '-128.0 -1840.0 25.0'
walkmonster 'monster_knight' in wall at '-160.0 -1872.0 25.0'
walkmonster 'monster_knight' in wall at '-96.0 -1872.0 25.0'
walkmonster 'monster_knight' in wall at '-32.0 -1872.0 25.0'
walkmonster 'monster_knight' in wall at ' 32.0 -1872.0 25.0'
walkmonster 'monster_knight' in wall at ' 96.0 -1872.0 25.0'
walkmonster 'monster_knight' in wall at '160.0 -1872.0 25.0'


bonus item 'item_shells' fell out of level at '624.0 -48.0 22.0'
bonus item 'item_health' fell out of level at '216.0 -1312.0 166.0'
bonus item 'item_spikes' fell out of level at '-2240.0 -576.0 -410.0'
bonus item 'item_spikes' fell out of level at '-2016.0 -576.0 -410.0'
bonus item 'weapon_grenadelauncher' fell out of level at '-1760.0 -992.0 -378.0'
bonus item 'item_shells' fell out of level at '-1632.0 -1280.0 -658.0'
bonus item 'item_shells' fell out of level at '-2544.0 -1648.0 -202.0'
bonus item 'item_rockets' fell out of level at '-1296.0 80.0 38.0'
bonus item 'item_rockets' fell out of level at '-1264.0 80.0 38.0'


The monster in wall warnings may not be critical in most cases (usually if placed too close to a wall or ceiling - have at least 4 units space between), but it's still a good idea to try to fix it.

Apart from that, it seems there are no difficulty settings whatsoever and a very large enemy count to the point where at least the entire upper (outside) part feels extremely overcrowded and unfair - and especially since most of them seem to wake up all at once.

I didn't play the map properly in light of the aforementioned issues, but my initial thought: I don't really like it when enemies spot you and attack the very moment the map starts, at least if it's without warning and they spawn close by. I would remove all monsters from the start room; maybe put them in the room to the left (partrolling maybe?). This would have the benefit of keeping them from opening the door to the right and making even more enemies wake up right away.
The population in the outside area should be thinned out somewhat, or made to wake up in waves (e.g. "ambush" spawnflag), or the ones on the battlements only appearing at a later point when the player has cleared the majority of enemies in the area (e.g. by having them move up from holes on top of the wall or teleporting in). As it stands, it's pretty messy and bullethell on top of being low on health and ammo at the start. 
Btw 
Wasn't supposed to come across as bashing the map, just highlighting some things to improve for the next beta. 
I'm Having Problems With My Map (compiling). 
At first my map compiled with no lights at all and in the end it didn't compile at all.

I'm making it in JACK (I'm too used to Hammer and it's like Jackhammer) and compiling in TrenchBroom or Quark (because JACK fails to create .bsp file). TB can't launch the map and Quark gives me the error: «SubdivideFace: didn't split the polygon».

Could anyone, please, take a look at the map and say what's wrong with it?

Link to the .map file: https://drive.google.com/open?id=1gAltEvDB1hDXnsgvg5IJsQZlt9qFvp2P

P.S. It's obviously not finished. BTW, placing buttons made it crash for some reason and triggers don't seem to work. Golden key changes position for some reason and other weird shit only here, only now.

P.P.S. Quark log:

5227 leaffaces 4806 nodefaces ************ ERROR ************ SubdivideFace: didn't split the polygon

!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-! Build failed, because it did not create the (+BSP) file: D:\Steam\SteamApps\comm on\Quake\tmpQuArK.\maps\pipe_dream.BSP Build failed, because it did not create the (+PRT) file: D:\Steam\SteamApps\comm on\Quake\tmpQuArK.\maps\pipe_dream.PRT

_________________________ GO ! (textures+build+Quake) _________________________

D:\Steam\SteamApps\common\Quake\tmpQuArK> "E:\Закуток Разраба\GoldSrc Games\J.A. C.K\quake\qbsp.exe" maps\pipe_dream.map

Quake BSP Compiler (build Oct 8 2015) ----------- qbsp ------------ qdir: D:\Steam\SteamApps\common\Quake\ gamedir: D:\Steam\SteamApps\common\Quake\tmpQuArK\ outputfile: maps\pipe_dream.bsp --- LoadMapFile --- maps\pipe_dream.map 465 brushes 41 entities 48 miptex 233 texinfo building hulls sequentially... --- Brush_LoadEntity --- 445 brushes read ---- CSGFaces ---- 2845 brushfaces 7194 csgfaces 2277 mergedfaces ----- SolidBSP ----- 3247 split nodes 1546 solid leafs 1702 empty leafs 0 water leafs 6231 leaffaces 5777 nodefaces ----- portalize ---- ----- FillOutside ---- 806 outleafs ----- SolidBSP ----- 2480 split nodes 1309 solid leafs 1172 empty leafs 0 water leafs 5227 leaffaces 4806 nodefaces ************ ERROR ************ SubdivideFace: didn't split the polygon

!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-!!-! Build failed, because it did not create the (+BSP) file: D:\Steam\SteamApps\comm on\Quake\tmpQuArK.\maps\pipe_dream.BSP Build failed, because it did not create the (+PRT) file: D:\Steam\SteamApps\comm on\Quake\tmpQuArK.\maps\pipe_dream.PRT 
 
SubdivideFace: didn't split the polygon typically means that there's a face somewhere on which the texture is scaled too low for QBSP to handle. For example a small face/brush with a texture scale of less than 0.25, or something along these lines.

It seems you use the compilers that come with Quark. I don't even know what those are, but they're definitely outdated. Try some newer ones, e.g. these, and it should either take care of it right away or at least give you some indication of where the problem originates. 
 
1st thing I did is changed textures to default wall and checked scale, it's 1.0 for everything.

Quark uses the same compilers as JACK and TB. 
 
JACK log

** Executing...
** Command: Change Directory
** Parameters: D:/Steam/steamapps/common/Quake/pipe_dream


** Executing...
** Command: Copy File
** Source: D:\Steam\steamapps\common\Quake\pipe_dream\pipe_dream.map
** Destination: \pipe_dream.map


** Executing...
** Command: E:/Закуток Разраба/GoldSrc Games/J.A.C.K./quake/qbsp.exe
** Parameters: "\pipe_dream"
Quake BSP Compiler (build Oct 8 2015)
----------- qbsp ------------
************ ERROR ************
SetQdirFromPath: no 'maps' in \pipe_dream


** Executing...
** Command: E:/Закуток Разраба/GoldSrc Games/J.A.C.K./quake/vis.exe
** Parameters: "\pipe_dream"
Quake VIS Compiler (build Dec 11 2013)
------------ vis ------------
************ ERROR ************
Error opening \pipe_dream.bsp: No such file or directory


** Executing...
** Command: E:/Закуток Разраба/GoldSrc Games/J.A.C.K./quake/light.exe
** Parameters: "\pipe_dream"
Quake LIGHT Compiler (build Oct 6 2015)
----------- light -----------
************ ERROR ************
Error opening \pipe_dream.bsp: No such file or directory


** Executing...
** Command: Change Directory
** Parameters: D:/Steam/steamapps/common/Quake


** Executing...
** Command: D:/Steam/steamapps/common/Quake/quakespasm.exe
** Parameters: +map pipe_dream


************
for some reason it launches the old version, no lights. 
@mafon2 
I will look at your map this evening after work. I can load it at work but I can't compile it without a lot of trouble. I'd suggest compiling with ericw tools and using Necro's compiling GUI. It will eliminate any issues that may be arising from switching between editors. Here is a PDF I created with step by step setup instructions on page 2.

http://www.quaketastic.com/files/misc/dumptruck_ds_TrenchBroom_2_Tutorial_Setup_Shortcuts.pdf

I'm not sure if you've seen my TrenchBroom 2 tutorials but this pdf if is specific to the Quickstart tutorial. But it's shouldn't matter.

One thing is I am seeing you have wads in 2 locations on your system. I would move them to a common folder and re-link them in your editor of choice. Try to compile with ericw tools and Necro's GUI.

I'd also recommend you watch my Quickstart video as well. In it I recommend setting up a "dev" folder for Quake and show how to do it.

https://youtu.be/gONePWocbqA 
 
it seems that some columns caused "integer" trouble. I deleted 'em. Nothing changed. 
@ Dumptruck_ds 
Oh, thank you for the step by step instruction. I'll try it as soon as possible. 
Common Compiling Errors 
I think if you take Negke's and my suggestion and ensure you use ericw's tools to compile you will be able to supply us with better information overall. Please try that and share the .log files that are generated.

http://web.comhem.se/bjp/tooltips.txt 
 
I found that some portion of errors was tied to the root folder name (сyrillic). After I changed it, EricW made me a .bsp. (Still no lights. And keys dissapear for some reason)

I adjust the archive with logs and .bsp.

https://drive.google.com/open?id=1xg9ctxbBz4gc-0vAWZAueAno3PdBYdCZ

It's a middle of a night here, so I'm signing off. Again, thanks for the quick answers, wasn't expecting this. 
@mafon2 
Hey we're getting somewhere. I'm assuming ericw found some leaks. I loaded up the map in TB2 and the level in Quakespasm.

First off you want to run Quake with the +developer 1 command line option or type developer 1 in the console and then restart. Either way you will now see much more information in the console. You can dump the console to a txt file by typing condump in the console. Here are your missing keys and items:

Bonus item fell out of level at '1920.0 1856.0 230.0'
Bonus item fell out of level at '1700.0 1844.0 6.0'
Bonus item fell out of level at '2272.0 1952.0 222.0'
Bonus item fell out of level at '2132.0 2144.0 -186.0'
Bonus item fell out of level at '1684.0 2144.0 -186.0'


In TrenchBroom in the View menu select Camera > Move Camera to... and type in those coordinates above. You will then be "inside" the entity. In this case your keys and other items are too low to the ground or close to other items so they've fallen out of the level.

There are lights in your level. HOWEVER, you have a light key in the Worldspawn that is making the entire level lit at 200 regardless of your light entities. If you delete that key your lights will work.

The gold key up top I think is being pushed down into the world by the func_plat you are using.

The level is pretty nice. I hope you keep working on it. We're happy to help. 
@mafon2 
Hey we're getting somewhere. I'm assuming ericw found some leaks. I loaded up the map in TB2 and the level in Quakespasm.

First off you want to run Quake with the +developer 1 command line option or type developer 1 in the console and then restart. Either way you will now see much more information in the console. You can dump the console to a txt file by typing condump in the console. Here are your missing keys and items:

Bonus item fell out of level at '1920.0 1856.0 230.0'
Bonus item fell out of level at '1700.0 1844.0 6.0'
Bonus item fell out of level at '2272.0 1952.0 222.0'
Bonus item fell out of level at '2132.0 2144.0 -186.0'
Bonus item fell out of level at '1684.0 2144.0 -186.0'


In TrenchBroom in the View menu select Camera > Move Camera to... and type in those coordinates above. You will then be "inside" the entity. In this case your keys and other items are too low to the ground or close to other items so they've fallen out of the level.

There are lights in your level. HOWEVER, you have a light key in the Worldspawn that is making the entire level lit at 200 regardless of your light entities. If you delete that key your lights will work.

The gold key up top I think is being pushed down into the world by the func_plat you are using.

The level is pretty nice. I hope you keep working on it. We're happy to help. 
@negke 
The map works well on my end but I will keep in mind what you said.

I am still getting used to how Quake feels. I mean AD got me back into it (didn't even know Quake had a mapping community before that!) so I kinda designed my maps like I would design my Doom maps. I am still getting used to tougher individual enemies and the slower speed. 
Mission Accomplished 
Thanks for all your support, it works fine now! Some trouble with the key I so wanted to place under the moving platform, but otherwise – pretty smooth.

I love making levels, but rarely finish them :).

I was so used to leaks and light surfaces overload that I assumed that there's a trouble with the light by the default xD.

P.S. Now the map looks less embarassing : https://drive.google.com/open?id=1J7gSfXqR3umYRURJ6wUOBlLBBFJU7K9k

P.P.S. I must say it's really increadible work you're doing for Quake community. It's hard to belive that the tools are still being made. 
@mafon2 
Glad this is working now. I have faith in this level. You should finish it.

SleepwalkR and ericw are doing a great job developing TrenchBroom and keeping us all mapping after 21 years... amazing. 
Free Space Around Entities 
BTW, how much space should be left around items and monsters for them not to stuck / to appear?

Dogs in my level glued to the walls of their kennels (64x128x64) and some items don't respawn if placed too close to the walls or to the other items, but not always. Like, for example, armor and rockets goes fine together, but rockets and nails don't and niches are apparently very item-unfriendly.

This key, I was speeking about early, finally it got right where I want it, but it's like pure luck. 
 
All monsters are Shambler-sized in their collisions, to the best of my knowledge.

64 width, 64 height 88 tall -- says the engine source code. 
 
That can't be right, this fullbright box compiled just fine and didn't drop the enemy into the void with an enemy's hitbox- listed as 32x32x64 in Trenchbroom- a single unit away from the wall. Making it touch the wall still spawns it but it ends up stuck (an error is shown in the console when using developer 1), but even one unit is enough to leave it free to turn around and run. 
 
It might not be right. I don't work with the qbsp tools. There may be other factors in play than just what the engine says is the monster hull, which is hull->clip_mins: -32, -32, -24 to hull->clip_maxs: 32, 32, 64. 
 
There are two bounding box sizes: 32x32x56 and 64x64x88. There needs to be some space around and above them for the monsters to be able to move and not produce a warning (or for items not to fall out) - they must not touch a wall or ceiling, but they can be placed right on the ground. As Spud pointed out, a space as small as 1 unit can be enough. 
Quake Collisions And Placing Stuff 
Vertical, have at least 1 unit of space above the heights below. 2 is recommended. The origin(center point) can be put exactly on the floor, though for monsters it is best to put 1 or 2 units above the floor at least to avoid potential position rounding errors sticking them through the floor (should be rare in newer editors).

Horizontal have at least 2 units of space beyond the sizes below.

Items are an effective 62 units tall. Items are 32x32x56 tall and get moved 6 units up on level start so that they can be "dropped" straught down to instantly put them on the floor and also check to see if they are below the floor and thus "fell out of level".

Monsters have 2 different collision hulls regardless of the bounding box sizes shown in Hammer/Worldcraft or other which negke mentioned above. The bounding box size for monsters shown in the editor should be close. Most smaller or narrower enemies use 32x32x56 (hull1), the larger enemies such as shamblers and vores use the 64x64x88 (hull2) size.
Dogs are a little wierd in that they have same size collision as shamblers, BUT...

There is a 4th layer of collisions...the qc code can define any bounding size it wants for an enemy. The engine rounds this size to the hull closest to either of the 2 enemy sizes for all collisions except raytracing and bullets. The qc lets, for unstance, giant monsters such as the gug, vermis, or boglord, get shot more easily in a way that is believable rather than only having bullets affect it right in the center 64units. Also tiny monsters such as fish or spiders don't get hurt if you shoot the empty air above or below them even though there could be 20-30 units of collision hull above these smaller enemies, shooting the air doesn't hurt them.

That is why, even though enemies appear to fit in niches in the editor and make sense from where you can shoot them, the tiny enemies still all need 57 units of vertical space. You can cheat it visually by using func_illusionary so long as the player can't reach the niche. 
 
That explains a lot. 
Odd BBOX Sizes 
Also note that entities with bboxes will collide with each other according to their actual size, even though when colliding with BSP entities they snap to the two fixed sizes discussed above. Useful applications of this fact are left as an exercise... 
Possibly A Stupid Question But 
Do I need a different gbsp light and vis for Quake II or do the ones we use for q1 work? 
They're Different For Q2 
I think these are the most commonly used ones:
http://home.insightbb.com/~gryndehl/q2compile/quake2.html 
Falling Through Part Of A Brush 
First up: swear I had the screenshots folder selected but oh well. I have had a quick look through mapping help re: nonsolid brushes but not finding this issue atm.
My brushes look like this in TB2
http://www.quaketastic.com/files/spz1dm1_brush1.jpg (view from above)
If i move past the vertical line here I fall through the brush
http://www.quaketastic.com/files/spz1dm1_brush2.jpg (view from below)
I am using Ericw's latest tools. 
@oGkspAz 
Not sure but you can try downgrading to a different version of the tools first just in case. 
Func_illusionary? 
Are the brushes a func_ of some sort? Or plain bsp. Workarounds: clip to split them up into diferent brushes, make new brushes from scratch, make another brush inside them that is 1 unit smaller all around...or to add a clip brush around them.

Check that they DO NOT have an origin key. 
 
This is an annoying one. Assuming these are worldspawn brushes, it's a qbsp bug, but usually it can be worked around. Try the command in TB to snap the selected selected brushes to integer. Try turning the selected brushes into func_detail (not a direct fix, but it will cause qbsp to chop that area of the map in a different order and might randomly fix the problem) 
22 posts not shown on this page because they were spam
First | Previous | Next | Last
Post A Reply:
Name:
Title:
Body:
message
question
exclamation
idea
flame
noflame
error
skull
beer
moon
pent
rocket
sheep
pacman
pig
cheese
worldcraft
gauntlet
crate
pitfall
pimp
smile
cool
sad
frown
oi
yay
tongue
evil
wink
neutral
q1
q2
q3
ut
hl
cs
doom
dkt
serious
cube
Website copyright © 2002-2017 John Fitzgibbons. All posts are copyright their respective authors.