News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread:
First | Previous | Next | Last
I use GZDoom and F12 is the key to take screenshots, but i don't remember if i had to change it or not... anyway, if you are using GZDoom just go to the "customize controls" menu and you can set any key you want to take screenshots 
I tried printscreen, but it results in a pink-blue gamma error. Then used my old 386 with VGS (dos screencapture) but then Doom shut of because of the Terminate and Stay Resident prog.
Will try it out anyway. 
Sv_startsound: Not Precached 
While I'm modding, I still can't lay my hands on this little error.

I can't help it. Everytime I add a new monster, with its specific alterations, the game stays persistent giving this warning.
Sometimes after a few weeks, or pakking the file to a pak file it disappears.

How does it come? Is it something hard coded or just a flawn in the engine? 
make sure you've called precache_sound() before you call sound() with that name...
some engines allow you to call precache_sound outside of spawn functions while others consider that a fatal error. these permissive engines still expect you to precache, its not fatal to fail to do so but you'll still get warning spam.

secondly, remember that many engines (including quakespasm) are lame and favour files from paks over files outside of them.
(hence why qss and qs display slightly different ordering from the path command).
So yeah, don't put your progs.dat into a pak, at least while still developing your mod. 
but I precached new sound in a soldier.qc, made a new sound folder for it, the script runs fine in fteqc and still these warnings apear. The sounds come through well.
Can't think of another place to store them, world.qc?

I run the game in quakespasm_spike_ad. 
WAD For Original 
Any idea where can one get the gfx/base.wad file that should have come with the example in the original source code of QuakeEd? I’m working on a MacOS port of the app and would like to run some tests with it. 
I jumped into my archive, installed the original QuakeEd. Read me shows This is qED(tm) Version 2.0.0126 (26 Jan'1998)
I couldn't find the, probably a later version.
Maybe you could combine it with the original QUAKE101.WAD.

Here is the original sample file that came with Qed2.
Hope it is of any use. 
qedsamp is another one.
This one is slightly larger (2.48Mb). = 1.752Mb 
Thanks for the help! Alas, the files do not seem to be compatible with what the app needs.
Just to clarify, the app I'm porting is the very, very old QuakeEd written in Objective-C for NeXTstep machines.
Somehow, the app expects a WAD file whose first lump is called precisely PALETTE and contains palette data, followed by many miptextures (and *only* miptextures). I'm not sure that qed, or any of the modern map editors, would have (or generate) files following such a strict sequence and format. 
I only have the light version of qED as it was a commercial programm, but there´s a work around for it.

With adquedit_v13 you can manage to extract the wadfile into specs for *.lmp and *.mip textures. But there's glitch, it will show the texture files in 16bit only and that's really bad.
Solution is to export your texture files to *.bmp 256bit and export them to *.pcx.

From there you can import them in adquedit again and export them to *.lmp. Then import them back again and export them to *.mip files.
I know, it's a bit complicated, but it works. One good thing is that adquedit has the quakepal.lmp stored.

So let's say you've got your directory with quakepal.lmp first, then you start adding the others to it and when you use quake101.wad you'll be able to import them in Wally and compose your own wad file for research.

I know it is quiet a lot of hussle, but as I suspect you're a tester it shouldn'ty be that much work. 
There is a little overvieuw which counts the maximal damage versus ammunition towards monsters.
I'm eagerly searching for it to finish my level.
Does somebody has it close at hand? 
This is probably not what you are looking for but it's helped me in the past. 
it's a close goal to reach.
Missing Textures In Darkplaces 
Hi all. About three years ago, I started on my first ever map and got a long way into it before real life got in the way.

I'm coming back to it now and finding that some of the textures seem to be missing in Darkplaces:
(maps works fine in Quakespasm).

In those three years, I replaced my PC and thought I'd copied the entire Quake directory across so I'm not sure what's gone wrong.

I've tried reinstalling Darkplaces but the textures are still missing.

Any ideas gratefully received. Thanks. 
Re: Missing Textures In Darkplaces 
If only I could delete my previous post.

I found the problem. A .shader file in the ID1/scripts folder. I removed it and bingo! All textures display properly again.

Now to get round to finishing my first ever map ... 
Questions About Csaddon For Quake3 
Questions About Csaddon [EDIT]
Posted by FTE terrain editor, csaddon on 2019/05/15 14:48:19
I was making map with landscape for quake3 and when I decided to make landscape with q3 patches I remembered about the csaddon in fte engine. Yesterday I tried it and it works pretty fine but I have some questions about it.

First of all, which type of heightmap is it using? Is it a kind of format which some terrain-editors like worldmachine can use or it is a format which was made only for csaddon editor? And where is it saved? I cant find any heightmap files in maps or in any other folders.

The second question is can I make a lightmap from the sun (q3 shader light) or can I make lightmap for terrain without using any realtime lights? And if I can do that, what exactly should I do?

Thanks, and sorry for my poor English... 
its some private sparse format, split over multiple files (which allows for some massive terrain).
losslessly exporting it to a raw heightmap would take 16gb.
the texture blends (and granularity) is unlikely to be compatible with other programs, and would be about 16 times bigger, and it would still be missing data.

the sections get written into some 'maps/FOO/block_XX_YY.hms' files, which you'll generally find in some annoying homedir location somewhere that everyone forgets about etc.
use the 'path' command at the engine's console and you'll see lots of paths, files usually get written to the first one listed.
or `dir maps/*/*.hms` should include the system path info too (and can list dupes if you have the same file in multiple places - a red colour shows inactive entries). 
Landscape Works With Csaddon In FTE 
Hello, I copy this question from my thread which was deleted for some reason. I have some questions about terrain editor in FTE.

First of all, where are all those terrain files saved? I checked maps and other mod folders, but nothing is there.

The second question is which format is used for terrain in that editor? Is it some kind of format which can be used in other editors like worldmachine, or is it format which was created only for FTE?

I wonder how can I make light for terrain on my map. I am making map in q3 format and I would like to use only lightmaps without any rtl lights. But if there is no other way than use rtl lights is there any possibilitiy to make directional rtl light? I mean not pointlight but something similar to sun light shader in q3.

P.S. Nice editor. It is pretty convinient to use and in my opinion it is the simpliest way to make landscapes in quake forks. Thanks for that. 
Sorry For Coping This Here 
Sorry, I didnt notice, that Shambler already copied my question here 
What about adding the lightmap. Is it possible to make lightmap "from the sun" for terrain which was created with csaddon? And if it is possible how can I do that? 
Light Sources 
Quick and stupid question: Is there a limit on the amount of light sources one should use in a map? I've kind of gone overboard in my very first room, which has +1000 light sources by now... 
Your light compile times should let you decide what's too much for your map. If the compile becomes intolerably time-consuming, then consider ways of simplifying your lighting. 1000 in one room does sound a bit crazy (how big and complex is the room?)

Light times for 1/x and 1/x^2 lights will be massively influenced by how much vis-blocking you are doing. If your map is very open without much vis-blocking, lighting will be exponentially more time-consuming than in a room-corridor-room type dealio.

In desperate times, for 1/x and 1/x^2 lights, the "gate" variable can be played with - this sets a hard cutoff on the area of influence of your light, but the light will just visibly "cut off" if the value is too high, so use this with care. 
Thanks, much appreciated! Yes, I have six walkways in a room and decided to have small lights on the sides of them, which multiplied the light sources ridiculously. I can probably cut it in hald - every single small light texture doesn't need its on light source I guess.

Nice to know the issue will be compiling time rather than some technical limit. 
So basically six walkways like this, although they weill extend to different rooms:

If nothing else, tinkering around with Trenchbroom makes me look at other Quake maps with different eyes, checking for neat ideas. 
Did you know about surf_light?
It can be helpful with many lights for the same texture. Add one light with the argument surf_light light1 and all light1 textures receive this light without adding one.
Of course this do count as light and goes on for every light1 texture you use. So carefully before you reach the 625 entity count. 
surf lighting is very coarse (1 light every 128 units) and not terrible controllable (if faces are split, more lights are generated)

I would consider a different design for the platforms that doesn't use tiling light textures with huge extents. maybe just have some light fixtures plonked along the walkways at reasonable intervals?

@madfox - what "625 entity count" ? 
"not terribly controllable" I meant. 
I'm still living in the age compilers use this 625 enitty count as limit. That means the total count of entity and lights have this ceiling before the game starts "warning maximum entities reached".
It can be nowadays engines don't have this failure, but I'm like an old dog that can't learn new tricks.
Something like the maximum poly's what is I thought 33768, and then try to build a map with one more to see what happens.

Your declarance though of surf_lights helped me to see why I keep getting those dark spots in my map. 
You do not need anywhere near that amount of overlapping light entities to give a good lit-up effect to that texture. Try 1/4 the amount and play around with the entity values. 

..... non-interactive light entities with no associated sprites or models, are removed as the map loads, so they don't contribute to the in-game entity limit (the "edict" limit)

This was always the case even with old unmodified engines.

of the lights that aren't removed, some e.g. torches, are turned into statics (so again, not contributing to the edict limit, only the static ent limit)

the only light "edicts" should be those that need dynamic interaction in game, e.g. switchables. 
Since those lights in the screenshot above are "light_flouro" they are going to make a sound. Might be a bit loud or cause issues. You may want to use them at certain intervals 512 units or so. 
1000 light fluoros per room HYPE! 
FTE Csaddon Terrain Lighting 
How can I make light “from the sun” for the terrain made with csaddon? Is it possible to make the lightmap (I am working with q3 format)? Or if it is not possible, can I make directional rtl light in fte? 
How can I avoid monsters to start fighting eachother? (like ogres don't). 
Give them all the same classname 
(void) monster_anonymous = explode on it selve
return ; 
From A Discussion Thread. 
Lighting For Graveyard And Flat Ambience [EDIT]
Posted by Featheon on 2019/06/01 23:10:21
Thanks for hosting my question. I'm having trouble of solving light sourcing for a graveyard scene featuring tall mausoleum. In your experience, to get an even low ambience, does one use many point entities or one powerful entity and adjust the penumbra? I cannot use worldspawn light more than 20 for this project. Editor is trechbroom, engine is darkplaces.

Thank you.

#1 posted by anonymous user on 2019/06/01 23:30:26 spam
Try these tools if you aren't using them already:

Some options like -bounce may help. You'll need fewer light entities that way.
.mdl Files 
What is the preferred way to create (or modify, if possible at all) Quake .mdl files? Unless I’m severely wrong (or utterly blind) the Quake-Tools repo in github do not mention a way to create them with any existing tools.

I know the progs are there, so you can alter their behavior (possibly), but what about their appearance? 
Here's the best tutorial on the web I've been able to find on the subject. This details every step and has links to tools etc. 
I'm not familiar with phonetics but maybe it are the format options this that you searching? 
1) Nice way to force lowercase :D
2) Nice specification document! I intended, however, to ask for actual model creation tools, just like dumptruck pointed in the page he posted. 
I'll Stay 
lower case,

but just in case your looking for a way to get your jbase.wad right it would help if you have a compiled jbase.bsp or file.
AdQEdit has a tool for remipping wadfiles. 
Oh. That Particular Issue 
Has been already solved. In fact, I already created two command-line tools that generate the .wad files that QuakeEd needs to open maps - one that generates plain textures (fakewad) and another that reads them from a pakfile (leechwad). They are now in the QuakeEd for MacOS package, starting from v. 1.0.2 . 
I'm trying to use the tessla coil I made in 2013.
When I download the map from quaketastic and play it everything goes right, with a bright lightning bold.
When I use the map to recompile it I end up in a dimm room with a shaded bold I can hardly see.

Could it be the new compile tools that cause this?
The map hasn't changed.

classname info_notnull
use CastLightning
enemy 1
Gate Logic Error: Runaway Loop 
Got a problem that I don't understand.
I created a three button gate logic in my map months ago and everything worked fine. Now I tested it again and it crashes all the time when pushing a button for the logic.
Has someone an idea whats going wrong or how I can figure this out? 
Probably good to see the error. Advice is to get to the spot where this is triggered. Type clear in the console then trigger the event. When it quits to console, type condump which will spit out a log in your id1 or mod directory. Paste that here and it will help. 

Hope I can find the mistake before recreating the whole puzzle. 
Quake 2 Maps Won't Compile 
So I was drafting a Quake 2 map, but upon compiling and running the game I get an error:
CMod_LoadbrushMode: mapbase123.bsp has wrong version number (15972 should be 38).
My Quake 1 maps compile with a few errors but run without any issues, but Quake 2 seems to be throwing fits. Any help would be appreciated. 
Are you using Quake 2 compiling tools specifically. I'm not sure of a suite that does both Quake and Quake 2 maps. 
No, I'm using the baseline set that came with ericw's tools. Do I need something specific then? 
I am pretty sure ericw's tools only work with Quake and Hexen2.

Try these out:

or here (scroll down a bit): 
Kickin, I'll test this out after work and report back any success or failure. Ty man. 
FTE Texture Bug 
Hello, found some bug on md3 models on my q3 map. So I am making map in q3 format and one bug appeared. Look at that:
The part of model is covered with texture and one part is not. It is so weird. The problem is not in model because in darkplaces it works fine. How can I fix that? 
@dumptruck_ds Re: Gate Logic 
So finaly the error report helped nothing.
So I deleted the whole gate logic and rebuild it now.
But now I'm a bit whiser. :)
I think the problem with the infinit loop has something to do with copieng and renaming functions.
It seems, for me, that it's in the program language.
If you copy and rename a bunch of functions it's still a copy of the older one.
So if you trigger the first one the others are also triggerd and this brings the loop.
The only solution for me now is to rename copys one by one to made them separet functions.
It seems that it works now. 
Quake 3 Lightstyle In FTE 
Hello. I am using FTE engine and I have some troubles with lightstyles on my Quake 3 map.

I would like to use some lightstyles on my quake 3 map, so I placed point light with parameter "style 3". After that I compiled the map. Here is the screenshot of light entity settings:

When I launched my map the screen was blinking and the brightness of textures in the room was higher than usual. Check it out:
Here is how the map looks without lightstyles:
And here is how the map looks with lightstyles (also screen is blinking but you cant see that on screenshot):

After that I tried to compile this map for qfusion format but no result. May be I have done something wrong. Here is my compiler settings:

Does anybody know how to fix it? If this bug can not be solved please tell me. There are already 3 my questions on this forum which were ignored. Thanks. (sorry for my English if I made any mistakes) 
Trouble With Fence Texture 
Hi, I'm trying to make the GoldenEye's Dam, I'm having problems with this fence texture:
I did exactly what it says here:
Am I missing some parameters in the compiling tools or something? 
Party Boy 
Is that texture 8bit and inside a wad file or is that an external texture? 
what engine are you using? Not all Quake engines support fence textures...

also the texture name must begin with the { character. 
It has 8 bit per channel

It's inside a .wad, I created it with TexMex 3.4

I tried saving it with Use Full Brites on and off

Quakespasm 0.93.1

Yes, it has a Left Curly Bracket 
I don't know if it's important but the map is not closed yet, it's leaking 
Can You Upload The Image(or Wad)? 
Then we can determine where this is going wrong.

Somehow I suspect the "color", the garish pink, is getting changed om you. 
OK, I fixed, it

I'm working with PS, I was just picking the color from the Quake palette .png from here:

and applying the Paint Bucket over the texture, all of this on RGB Color mode

It didn't work for some reason

I took the texture and on Indexed Color mode, applied the .act palette

Then changed it to RGB Color mode again and exported

It worked

Thanks for the help 
Nice Texture! 
How did you obtain the transparant? 
It's explained here:

I extracted the texture from the GoldenEye .rom 
With Source, there's a lot of detailed information on in-game units, such as player speed, bounding blocks, etc. Check this page:

Where can I find similar info for Quake 3 and Quake 1? 
not sure about Quake 3 but here's some info for Quake 1 
Is that velocity in units per second? 
Looks like it yeah. 
Hi I am trying to make an elevator in my map... the problem I am having is the elevator is triggered by a button... the only problem is when it gets to the bottom it comes back up... how do I make it stop till triggered again at the bottom of the elevator shaft? thanks.

In "vanilla" Quake once a func_plat is triggered it will lower and wait for the player. Once the player steps into the "trigger volume" of the elevator it will rise up.

If you want a elevator that toggles using a button that use a func_door instead. This is covered in my entity tutorial here:

Watch the whole way through as I show how to toggle a door - which is the method you will use to toggle the elevator. 
Two Questions 
1. Hi I am trying to make an elevator in my map... the problem I am having is the elevator is triggered by a button... the only problem is when it gets to the bottom it comes back up... how do I make it stop till triggered again at the bottom of the elevator shaft? thanks.

2. I am trying to make triggerable enemies but when i set them some where and apply a trigger to a dog for example i pass the trigger point and it still sits in the spot i had put it.... 
1. There should be a flag to set the elevator to just toggleable.

2. Double check targetnames etc. Should just be a matter of trouble shooting. 
Often the trick to making an elevator that does what you want is to use the func_door class instead, and vary the lip field to get the height you want. In your case you will want to apply the TOGGLE spawnflag to your "door" so that it never moves without being triggered. 
thank you for your help... but what is the plat function for? 
Specialised Task 
func_plat is designed to be an self contained platform that doesn't need any other triggers to function. So it automatically rises when the player steps on it, and automatically descends again afterwards. It's not useless, but it can't really be customised if you want it to behave differently. 
Door Issues 
how do you get a door to go up and down instead of side to side? thanks. 
Re: Door Issues 
Set the angle to -1 for up, -2 for down 
Hi all... I was wondering... when I make a secret door to hide maybe an item or something... what do I do to make the game display a "you have discovered a secret"
message? I know I would probably have to trigger it... or is it in the secret door function as an option? thanks. 
Hi all... I was wondering... when I make a secret door to hide maybe an item or something... what do I do to make the game display a "you have discovered a secret"
message? I know I would probably have to trigger it... or is it in the secret door function as an option? thanks. 
never mind...found it just wasn't sure how to delete my previous post about the matter thanks. 
I think you missed my post above with the YouTube link that explains plats and doors. Here's the link again:

also here is a long video that explains how secret doors work. 
Where Do Black Ops 3 Mappers Lurk? 
Not really sure if this belongs here or in the General thread.

Since creators of custom maps for Black Ops 3, both multiplayer and zombies mode, do exist, where do these people "hang out"? I went through a few large discords I could find, but they had no mapping/modding channels. Wasn't successful at finding some forum-based community either.

What gives? 
Blops Custom 
3 seconds later and google autocomplete delivers 
Perhaps it's more for general abuse, but I'm not sure.

Was there ever an all-colab jam? I.e. every map was worked on by 2+ people (or exactly 2 people, but that doesn't mean one person couldn't colaborate on multiple maps or with multiple people).

There's Literally One Ending Today 
XD I knew the name was "Tag Team Championship!" but didn't really connect the dots. Thanks! 
So I have a pretty simple map with a circular wall around it and just one light, the sun. Its mangle set to 0 -90 0 (straight down according to ericw's documentation). Yet one side of the wall is completely dark, while the other is bright. As if the sun was at an angle. Why could this be? How do I make the sun light all sides of the map evenly? 
try the sunlight_penumbra worldspawn settings, a value of 8-12 gives good results.
Else, a small sunlight2 value might help.
Your circular structure needs to be centered at 0 0 0 of the world to work correctly if i remember right. 
Thanks for the suggestion. I actually figured out what the issue was. I had bounce lighting enabled and had only filled in architecture on one side of the map so far, so the undeveloped side had nothing for the light to bounce off of. 
i'd still suggest to at least try the penumbra effect. 
What The Hell Do I Do 
---- vis / ericw-tools v0.18.1-32-g6660c5f ----
running with 4 threads
testlevel = 4
LoadBSPFile: 'E:\C to E\New folder (2)\zv\development\quake-tools\ericw-tools-v0.18.1-32-g6660c5f-win64\bin\textic'
************ ERROR ************
Error opening E:\C to E\New folder (2)\zv\development\quake-tools\ericw-tools-v0.18.1-32-g6660c5f-win64\bin\textic: No such file or directory

That was for the vis.

---- light / ericw-tools v0.18.1-32-g6660c5f ----
Raytracing backend: Embree
running with 4 threads
LoadBSPFile: 'E:\C to E\New folder (2)\zv\development\quake-tools\ericw-tools-v0.18'
************ ERROR ************
Error opening E:\C to E\New folder (2)\zv\development\quake-tools\ericw-tools-v0.18: No such file or directory

That was for the light

---- qbsp / ericw-tools v0.18.1-32-g6660c5f ----
Input file: E:\C to E\New folder (2)\zv\development\quake-tools\ericw-tools-v0.18.1-32-g6660c5f-win64\bin\
Output file: E:\C to E\New folder (2)\zv\development\quake-tools\ericw-tools-v0.18.1-32-g6660c5f-win64\bin\textic.bsp

---- LoadMapFile ----
*** WARNING 06: No info_player_deathmatch entities in level
54 faces
9 brushes
5 entities
5 unique texnames
28 texinfo

Opened WAD: E:/C to E/New folder (2)/zv/development/quake-tools/texwads/sewerjam_wad/sewerjam_metal.wad
Processing hull 0...
---- Brush_LoadEntity ----
9 brushes
24 planes
---- CSGFaces ----
54 brushfaces
61 csgfaces
61 mergedfaces
---- SolidBSP ----
103 split nodes
34 solid leafs
70 empty leafs
0 water leafs
0 detail leafs
0 detail illusionary leafs
0 detail fence leafs
0 illusionary visblocker leafs
200 leaffaces
197 nodefaces
---- Portalize ----
70 vis leafs
70 vis clusters
156 vis portals
---- FillOutside ----
55 outleafs
---- MergeAll ----
30 mergefaces
---- SolidBSP ----
20 split nodes
10 solid leafs
11 empty leafs
0 water leafs
0 detail leafs
0 detail illusionary leafs
0 detail fence leafs
0 illusionary visblocker leafs
82 leaffaces
52 nodefaces
---- Portalize ----

qbsp works fine.I see no leaks. 
Put stuff in a shorter directory without spaces and try again. 
seems like the qbsp didn't finish -- unless it has more output than what you pasted.

light/vis seem to be complaining they can't find the bsp. can you confirm that a bsp file exists in that folder?

also, light seems to truncate the bsp name when printing its error, while vis prints the whole name. 
I made a small bat file
light.exe textic.bsp
vis.exe textic.bsp

It worked,for some reason.
Yes,there were both BSP and map in the directory.

The map and bsp is named test1 now.Not textic.

I still don't get that ericw-tools bsp name appearing in the light log. 
Dirt, Stairs (different Height Floors) And Black Models. 
First of all hello.
Second, I hope my English are good enough to achieve communication...

In the topic now.
When I use dirt in a map I get nice results but when the floor height is changed like in stairs, dirt leaves black lines between stairs and this turns the models black when are above it.

The problem gets bigger as the models move over stairs and flash.

One "solution" I thought was to use func group for all floors and set to them dirt -1.

This is the result:

Do you fellow mappers find the "solution" acceptable?

Is there any technique to get better results?

Or I have to discard dirt in closed rooms?

it's far better to have good looking lighting on your world geo than to compromise your art to "solve" issues with quake's ancient rules for mdl lighting.

I'd keep dirt on the stairs personally. 
I Will Keep Dirt. 
Thanks Kinn, I lean towards this too.
Now I got in the task to modify quakespasm to get "better" results.
I found a solution but I get 32 more samples for each moving model. Models are getting darker on stairs but do not flash. 
Always Getting "WARNING: Leaf Portals Saw Into Leaf (#)" 
I'm a new Quake mapper and hoping to submit a map for Yoder's Sewer Mapjam. I'm already getting hung up because every time I'm compiling a map and get to the vis process I get a bunch of "WARNING: Leaf portals saw into leaf" warnings. The compiler doesn't report any leaks and no pts files are made, so I am at a loss with how to fix/approach this. Trying to read through the Trenchbroom manual and searching on Google hasn't helped me figure out how to solve this.

When I pull other maps, be they original id maps or maps from Quaddicted, I notice they don't have the same warnings. For troubleshooting, I have tried putting a few different maps I started through the compiler and closing the maps down until there are no warnings, but even maps that are barely more than a cube room give me the warning.

I am sure I keep doing something dumb that keeps causing this issue since I'm new to Trenchbroom and Quake modding. If anyone is able to point me toward some documentation to explain what I'm doing wrong or is able to help me troubleshoot through the comments, it would be super appreciated!! 
My Bad.. 
I assume this is happening with:

It's a bug I inadvertently added in that version while fixing something else (a cause of HOM's with very thin leafs). As far as I can see the warnings are safe to ignore and the vis quality is still fine. On my list of things to investigate / fix properly, but if you want you can use an older version like or another compiler etc. 
Ericw - That Did It 
Thanks for the heads up on the bug. I see someone else mentioned it on your github page now. I tried things in v0.18.1 and I don't get any warnings. Also nice to know the warnings can be ignored in v0.18.2-rc1 if I want though.

btw, thanks for all the tools ericw! 
Longer Messages 

I want to show a long mission briefing text in a message that has to be shown at least 10 seconds.
Tried this with a brush-trigger with wait and delay but it dissapeard after 3 seconds.
Is there a way to show it longer? 
Here's A Hacky Method 
I've done this in the past by using a chain of trigger_relay entities. It's not perfect but it should work.

Give the same message to 5 trigger relays. Trigger the first in the chain with no wait value. Have this trigger_relay target the next relay and give it a wait of 2. Repeat this with the remaining relays.

It's been a while and I am typing this from memory but I believe this worked. You may need to fiddle with the wait value. Also the text is limited to a certain number of characters. Not sure how many. 
or, trigger_multiple for the text, and a silent counter that kills the trigger after X times 
It Works! 
@dumptruck_ds; @metlslime

Thanks for the hints.

I did the trigger_relay thing and it works.
I only got this nerve killing bing sound endless repeating.
Can I turn this off? 
it should only do it 5x - what might be happening is you are using a trigger_multiple with a short wait time.

increase the wait time to a higher number 
it should only do it 5x - what might be happening is you are using a trigger_multiple with a short wait time.

increase the wait time to a higher number 
Ok. I changed the waittime of the trigger to 10 and the wait=2 of the relays to delay=2. That works better. Less beeps. :)

Re-post From Closed Thread 
Teleportation And Boss Gate Help
Posted by gillandro on 2019/08/23 19:33:24

Hi all,

I am trying to set up a gate to lead to a boss, i created a separate area for the boss to be in and can't figure out how to use a teleport function to send my player to the boss room... there doesn't seem to be many tutorials about boss room teleports... if anyone has any ideas... I basically have a set of stairs with a portal, just not sure how to make it a usable object to send my character to the other room. thanks.

a trigger_teleport pointing to an info_teleport_destination. 
Take a look at this tutorial series, particularly the entity tutorials 1-4. 
I have watched those but i wasnt sure about where in the entity spread sheet to put the target stuff or the target name parts....also in the “boss room” i place the boss entity in the map, but it doesnt show up when i run quake i missing something there too? 
Put an info_teleport_destination in your boss room. Give it a targetname.

Create a trigger_teleport brush and set the target field to the targetname of the info_teleport_destination above. 
I got that part now....only problem now is how do i set a door to open with a specific kill count, or if i choose to reaquire a dropped item to open the door? Thanks 
Re: Boss 
sorry hit submit to quickly

What boss are you referring to? Chthon or Shub Niggurath?

Those bosses require more complex setups so you should refer the original id maps to see how they were done.

Chthon is in and Shub N is in

Sources here:

Video about map sources here: 
You should re-watch my entity tutorial on trigger_counter 
Map Boss 
It was the red genie looking thing with the claws...and thanks for the video referral 
what are yo guys using to compile maps for q1 and q2? 
For Q1 
Stop The Train! 
To get over the time releasing my new map I'm creating a little jumping platform game where trains as platforms are running threw the screen.
I only have one problem.
How can I stop them from running? 
The last point for the func_train could be

"classname" ""path_corner"
"wait" "-1"

if you don't use it in your train path.

Other way would be creating a button that breaks the func_train with kill_target on the moment it needs to stop. Bad thing is it disappears. 
You could also use the progs_dump devkit that has the feature of pausing func_trains. 
@Whistle @Esrael 
@Whistle. Thanks for help but I need the trains as a floor.

@Esrael- I'm using progs_dump and thought to find that in the function. Is it a spawnflag or a trigger_function? 
Found It !!! 
Finaly found it after reading the manual the third time. Ahh
It's the retrigger-spawnflag.
Will test it after the weekend.

Thanks again Whistle and Esrael for your help. 
The pd_lava map has an example of the RETRIGGER spawnflag if you want to see it in action. 
Does anyone know any good set of open source (CC0 or CC-BY) textures? I'm tired of using philipk's. 
Sock Has Some 
Sound Info 
I watched the video on entity properties but what i cant seem to find is a list of properties....i want to use an ambient thunder point entity in my map but not sure how to change the intensity of sound or frequency of its occurence thanks 
that industrial set was awesome. thank you. 
The retrigger works great!
I made an mini episode with seven platform jump & run levels and am now fixing some map problems.
One of them is realy tricky. Sometimes there are two trains rolling in the same position but I can't find the second one in the editor. Do you now a way to find that brush? 
@dumptruck_ds Re:retrigger Double Brush 
So Ichecked out the brushes and theres no second.
It seems that this's a bug.
When the startingpoint of a train and the retriggerpoint of another train are the same, the second train has a ghost on the second position. 
I'm currently helping dumptruck_ds with some stuff for progs_dump. I've taken a look at the train code, and I'm not sure what would be causing that problem. =( Is there any chance I could take a look at the .map file that's exhibiting this bug? If I could, I might be able to work out what's going on. 

I'll check out the map size. Maybe I can mail it.

Hope that error was a failur of mine and not in the code. 
@iw; Mapfiles 
So heres the downloadlink to the map.
Hope all files are included. 
OK, I think I can see what's happening. The "ghost" train that overlaps the big train at the start is the model of the big, final train that appears at the end.

This one isn't a progs bug. I believe what's happening here is that the map is hitting one of the engine limits, which is that the playable area of a map is +/-4096 units on each axis. It looks like the final train starts at a path_corner so far "north" on the Y axis that its model wraps around and gets displayed at the "south" of the map.

In fact, it isn't just the final train whose model gets wrapped around: the models of the last several trains that should be at the far north are visible in the void to the south of the map when the map starts (try noclipping through the wall behind the player start point to see).

If you're using QuakeSpasm or a derivative, you should be able to see the effect vanish if you enter "sv_protocol 999" at the console and load the map again. (QuakeSpasm defaults to Protocol 666; Protocol 999 is the newer, higher-limit protocol which allows larger maps.)

If you want the bug to go away for all players, regardless of protocol, I think you'll need to modify the map so that there's less distance between the entities that are farthest south and farthest north on the Y axis.

P.S. I liked the retro visuals. =) 
Big Thanks!

Glad to hear that the failer isn't in the progs. I thought on everything but not on the map limits. So i will move the party more southward to get it work.

Best wishes. 
Ericw-tool Light "no Backend Available" 
Hello everyone,

I've set up a mapping environment under Arch Linux, using TrenchBroom + ericw-tools + quakespasm.

Everything works well, aside from the lighting. light is throwing a "no backend available" error at me, and my maps are always full-bright.

I made a small box with a single torch for testing. You can read the log here:

Best regards. 
Try the linux build from (in case you got it from somewhere else?)

What kind of cpu do you have? The raytracing library (embree) requires sse2 so mid-2000s ish. 
Hello ericw,

Thank you very much for answering my message.

Downloading the binaries from github fixed my issue. It turned out I only had the light, vis, and qbsp bianries and nothing else.

I thing I probably have downloaded the source and compiled everything myself.

This is fixed now. Thank you very much for your time! 
Zerstorer Textures Copyrighted? 
I'm building a level which is using some textures from Zerstorer, that famous Quake mod. The WAD was available on Quaddicted, but I've noted the following in the text file that came with Zerstorer.

* This product is property and is copyrighted by Nihilism Unlimited.
* If this product appears on any medium/media without the consent of
Nihilism Unlimited, full legal action will be taken.

I note some textures were used in func map jam 3, which was a Zerstorer themed jam.

The question is, is it OK to use these textures? Obviously I want to respect the authors wishes, but this disclaimer is confusing, as it appears to discourage any copying! 
It's fine to use them. It's been 20+ years and everybody from "Nihilism Unlimited", which I doubt was ever any proper legal entity, has since gotten jobs and careers (some of them are still at id). 
seems like they don't want it distributed on a physical medium like CD-ROM 
@Borax Man 
A bit of historical perspective:

That warning came at a time when software publishers were downloading maps and mod archives from They would package them and sell them in retail stores without permission.

Mappers and Modders started adding warning like these back in the Doom days. 
Oh God I Remember That Crap 
Yeah you could literally walk into a high street games retail outlet and buy one of those big cereal-box sized packages with a CD rattling around in it, with "3000 BRUTAL QUAKE LEVELS" written on it in a big red "rubber stamp" font, and 90% of them would be fullbright boxes with a rotfish stuck in the air, big walls tiled with the flashing button texture, and everything more than 10 feet away from you is a great big HOM. 
SM202 Theme Confirmed There. 
I suspected that would be the case. Good.

I played jamx_bloodshot, which was quite excellent, a map in func_mapjam x.

One thing that appeared to happen after passing through the silver key door, was the player being teleported when they turned their back on the door. I have a few ideas for my level, but the only way I can implement them is to have a func_wall disappear when the player gets close to it. That I can do, but is there Quake C code which allows for a trigger to be fired when LOOKED at? 
Triggers can have an “angle” property which requires players to face within a quarter turn of that direction before the trigger will fire. 
Key Values 
is there a list of the key values I can use some where... I wanted to use some ambient sounds but I can't seem to find the key value for volume... i.e. how the ambient light has an intensity key value, I wanted to make the sound of a rumble or something louder... I have typed in things like volume, intensity and what not but not sure how... also I had wanted to put a lightning effect so I wanted to make the lightning have a occurrence so it would happen every five or 10 seconds. thanks. the video on entities tells how to edit and add key values...but not what key values are available and unless i missed it in the manual I can't seem to find it there... 
Not sure but are you asking about progs_dump?

If so the audio settings are well documented in the manual since version 1.1.0

In a nutshell, the audio defaults to the loudest volume. If you need something louder try and "double up" entities next to each other.

Random lightning effects are too complex to explain here but you will want to take a look at func_counter and the random spawnflag.

I have a new pd_lightning map that will be released very soon with pd_ version 1.1.2 
I have implemented a lightning effect in Lords of Chaos. Actually, the effect is a little more complex than what I'm describing here, but I don't want to spoil too much.

I used a func_counter, which has the "looping" spawnflag set. "wait" is set to the delay between each lightning strike. The counter targets three trigger_relays. The first trigger_relay targets the light which is the lightning effect, and turns it on. The second trigger_relay also targets the light which is the lightning effect, but to turn it off. I have 'delay' set on this trigger at 0.3, so you get a pretty quick flash. The third trigger_relay targets 4 different play_sound_triggered entities spaced a few hundred units apart. I have delay set on this relay to '1', so the thunder sound is a little delayed from the lightning, for realism. These entities all play ambience/thunder1.wav. Of course, you can use your own effect here or change the delay values to change the timing of events.

The trick to making it louder is the 'impulse' key on the play_sound_triggered entities. The default value is '0', which is 'automatic', but I found the sound crackled a little and could drop out. What I did is set each play_sound_triggered to use a different impulse value (1,2, 3 and 4) which means all four entities use their own unique channel. The sound comes out nice and loud if you space them apart just right. My sound entities are about 500 - 600 map units apart. Note this doesn't actually really make it louder than other sound effects, but it does allow you to have it loud over a larger area in a reliable way.

You COULD use one play_sound_triggered instead of four, and set speed to '-1' (heard all over the level), but for my purposes I only wanted it heard where the lightning could be seen. 
Key Values 
when you use the point entity ambient_drone for example... and I look at they key/value spread sheet in entities all I see is the classname, origin, and spawnflags keys... the ambient_drone only seems to be audible if I create it near the player start entity. I wanted to put it some where in the middle of the part of the map it was created in and sort of be loud enough that no matter where I was in that part of the map that it would be heard... thanks hopefully this clears up my question better. 
ambient_drone (and the other ambient_* entities from the original game) are unfortunately not very configurable; there's no key the mapper can set to change the volume etc.

If you're using progs_dump, it adds a more configurable entity named ambient_general which has the following keys:

- Set "noise" to the path of the wav file to play (if you want the same sound as ambient_drone, that's "ambience/drone6.wav").

- Set "volume" to the volume (1.0 should be full volume, 0.5 should be half volume, etc.).

- Set "speed" to the attenuation factor. "-1" means no attentuation (i.e. should be audible anywhere in the level). The original game generally uses "2" for monster idle sounds, "3" for ambient sounds, and "1" for most other things.

Disclaimer: I haven't tried using this entity, I'm just looking at the source code. 
@Borax Man 
Funny reading your lightning set up. I've done something very similar in a new sample map called pd_lightning. Yours is a bit more involved and mine is more a trap than an effect for ambiance. I used func_counters to toggle the lights in my setup. The new version of progs_dump will be out soon. (I am hoping to get it wrapped up later tonight. 
Is progs_dumps something i can find in the create menu? 
You mean when you first launch TrenchBroom?

If that is what you mean, the answer is NO.

progs_dump is a mod. You can enable it in the editor at the bottom of the Map Inspector tab. Look for the Mod selection area at the bottom right side of the screen. Then you load the FGD (found in the progs_dump development folder) at the bottom of the Entity Inspector tab. The FGD will allow you to see all of the specific entities like dead monsters, the candle and other entities. 
I must have misread one of the previous posts, I thought you were using progs_dump. As dumptruck_ds said, it's a mod, so if you did want to use it, you'd need to download and install it, and then set up your map editor to use the mod's entity definitions.

BTW, other mods provide similar entities for setting up ambient sounds with specific properties: e.g. Quoth has ambient_generalpurpose, Arcande Dimensions has ambient_custom_loop, and Copper has ambient_sound. 
only issue is... 1 where do I find it? and 2. can players play maps made with it... or do I need to put my maps some where specific? thanks. 
Scroll down here for the new version I just posted last night. Please read the readme and manual. I spent a lot of time and most of your questions are answered there. 
Textures With Incompatible Colors...? 
I have custom textures for a map I'm making but once I convert the texture from an image to a texture and put them in the custom wad and run the map in Quake, I see that the texture's colors are simplified, parts of the texture are simply grey where the colors are I guess incompatible or whatever.
What's going on? Is it a problem with Quake's colormap, a problem or a problem with the WAD? 
Do the colors look correct in texmex? (Or which was editor you’re using?) 
Any Quake 1 Texture Artists Still Around And Active ? 
Somehow, in 2019, I need some Quake 1 inspired textures for my indie project. So I am wondering if there are still any good Quake 1 texture artists around and reachable (like Speedy for example, who I have no contact with, unfortunately). 
Quake uses an 8 bit color palette. More info here: 
is there any engine that allows me to increase the lightmap size for my maps? I was wondering if I could get some nice 2048 or even 4096 lightmaps for cool lighting 
misc_poster, you can see Spike and ericw discussing that, starting at post 19263 here: 
I am very close to finishing my map, but am facing a few issues I need to iron out. The one I'm not sure of, is r_speeds, and what they should be for a modern machine.

After building it with a level 4 vis, I find with the FTE Quake Engine, the sound still stutters, where it doesn't with other maps. By stuttering, I mean that the last second of sound or so repeats multiple times while the game keeps running. The frame rate seems to average 60FPS, with the worst frame rate still over 35.

The "draw indices" value indicated by r_speeds can get over 70,000. Is that too high? How do authors today ensure that the maps aren't too detailed? Is the sound issue an FTE Quake issue only? 
Curves And Grid 
Hi and hello! In my first post I'd like to say hi to QUAKE maniacs and thank to people who made trenchbroom (@kristianduske), compiliations tools (@ericw), and @dumptruck_ds for great tutorials and all others people thanks to them I could back to QUAKE maps - thank you very much!
I got two question:
1. Is possible to use on some Q-port patches/curves like in Q3.
2. Is this a big problem to not keep the grid (I know it is very important, but maybe new compilators can handle it without any problems). Here I show my little altars: as for sure you see they can't handle the grid. Of course I can make altars in the grid but they don't look as good as this style. Is this a real bad idea in building map or I should always handle the grid? Thanks! 
Is this a real bad idea in building map or I should always handle the grid?

"Always stay on grid" is like a func_msgboard/terrafusion mantra.

In this particular case it won't really matter, since it's a loose object and not part of anything structural*. But otherwise, yes, you should always try to stay on grid when building in Quake, 2 at the very least.

It is possible to use smooth on-grid curves to achieve your desired result, though.

* - I hope you're going to mark this altar as a func_detail_wall
Quake, 2 at the very least.

Grid 2, not Quake 2. I wouldn't inflict that on you! 
@onetruepurple - thanks for advice, I always keep in grid in DOOM3/QUAKE4/QUAKE1 but I thought there could be some new feature I didn't know about. I look at my altar once again and it was just easy to see rectangles in triangles chaos. I love brush style mapping! Back to QUAKE mapping thanks new compilers and trenchbroom is like holidays for me. I had to loose work on maps 10 years ago cause compilation time :(
Now is good grid 2 units. 
Looks great in map, for now without func_detail and _phong 1 
Grid 0.125 For Life Yeah \m/ 
"I Wouldn't Inflict That On You!" 
So is Q2 mapping not really a thing now? Genuine question, since I've been out of the game for a long time and have just started resurrecting a project that I started about 20 years ago.

As far as I have heard there are still MP and "jump" maps being created. We have a small group of Quake 2 enthusiast on the Quake Mapping Discord with a dedicated #q2-mapping-etc channel.

I know a few of the regulars there are interested in giving Quake 2 SP mapping a spin. Including myself. Most likely in the new year for me as I am finishing up a project.

Come say hi: 
Why Thank You! :D 
Have done, thanks! 
Someone created a TrenchBroom importer for Godot: 
Cool find, I was recently wondering if there's any sort of support for Quake content in Godot. Too bad that most implementations that aren't derived from Quake support the simplest subset of data formats (either .map or .bsp) and are not concerned with gameplay portion of Quake at all (progs, client-server, etc.). But I guess people work on what they find the most interesting, typically rendering. ;) 

You guys have any idea where I can get a hold of a Wrath ent def file? It's kinda tedious to write your own, trying to figure out all that stuff =) 
AD Item Offset/rotation 
How do I disable it? I'm using jackhammer 1.1.1064 (latest freebie version available) and AD 1.70 P1 with included fgd.

There are a couple of parameters in worldspawn properties that regulate offset and rotation but they have no effect. I tried both Ericw and TyrUtils qbsps, with the same result - items are still rotated/offseted randomly, and will not spawn at all if they dont have more than 64x64 space around them.

There is "Floating" flag that solves the not spawning issue, but it makes items clip through world geometry because they are still offset randomly, but this time with no regard for surroundings. 
Yeah the worldspawn keys don't apply anymore in latest AD I think.

You can set an explicit nonzero angle on the item to stop the random rotation. If you really want explicit angle zero, then use 360 instead. 
Works For Me, Thanks! 
But what about position offset? 
I think that particular worldspawn key DOES still work. I.e. try setting no_item_offset to 1 for worldspawn. 
Yea, apparently "enabled" is actually "disabled". Worked, thanks! 
No Spawn Function For: Func_detail_illusionary 
Console spits this error for every func_detail_illusionary in the map. Am I doing something wrong or this entity just broken? No errors during compilation, playing with quakespasm. 
You need to use ericw's compilers.

That ent is just used by his compilers. It will be stripped out of the bsp.

In general, ericw's compilers are the only compilers anyone should even be thinking about using, at this stage. 
no q2 though :( 
Argh! Hunk_Alloc 

One year of work and now I got this message after compiling: "Hunk_Alloc: failed on 67108896 bytes".
if I read the crashreport right, "ERROR: SymGetLineFromAddr64" it means stack overflow.

Does someone know what this means and how to repair it? 
Gotta Alloc More Hunks, Bro 
Try your local gym.

Errrr, could mean needing to allocate more RAM, IIRC? try -heapsize 256000 or similar in your Quake exe shortcut. 
used heapsize. Same failure.
Is there any other way? 
What Is Your Current Heapsize? Try Doubling It 
Where can I find the heapsize setting? 
Not Sure But 

I think you type com_hunkmegs into the console to see what your current settings are. 
Thanks @Shambler, Metlslime, Dumptruck_ds 
Finaly it works with -heapsize 512000. 
Just found out about a strange thing with my Xmas map. The player falls into a trigger_push at the start, and in QSS this causes the camera to get tilted by 4 degrees.

Raising the player start by 4 units solves the issue, but copying the unmodified playerstart+trigger to a fresh map does not isolate it.

The trigger has "angles 335 35 0", the player has "angle 30". Messing with these leads to all sorts of weird results (zeroing the player makes the tilt go up to 8 degrees).

So, is it an issue with my map, QSS or AD?

I also had some other issues that were either AD bugs or me being dense:
- Widowmaker doesn't work in deathmatch: can't be picked up again after dying
- "Delayed" monsters seem to activate all monster-sensitive triggers on spawn
- "Non-solid" flag on a func_bob seems to have no effect
- The distance that a func_bob moves seems unreliable and/or goes out of sync over time
- trigger_monsterjump doesn't affect flying enemies despite the specific spawnflag
- It's impossible to trigger-set fog density/color to 0, have to use 0.0001 etc instead
- Brushes with sky texture on one side will behave as pass-through for projectiles on all other sides too(?). Possibly even make the enemies pass-through(?) 
non-solid func_bob becomes solid when you walk over a corpse 
Overwriting Default Backpack Values? 
I have a monster_ogre, and when I add a key value pair of
ammo_shells: 20
I gain 20 shells when I kill him and touch the dropped backpack.

This does not work with ammo_rockets however, because in ogre.qc it sets self.ammo_rockets = 2. Is there a way so it respects my values in the entity settings? 
Trenchbroom Q2 Map Leaks 
Hey everyone,

I'm a newbie working on mapping with Quake 2 in Trenchbroom (loving the editor so far!)

Unfortunately I can't seem to generate a map with proper lighting due to a leak while running QBSP3.

I can still launch the map, however after compiling with QVIS3 it will be dark.

In order to troubleshoot I started a new file which is a simple closed off room, ensured my "Snap to Grid" option is on, and that the room is indeed closed off.

Here's what the compiler is doing:

#### Executing 'E:\Games\quake2\baseq2\qbsp3.exe q24'
----------- qbsp3 -----------
original code by id Software
Modified by Geoffrey DeWan
Revision 1.09
gamedir set to E:\Games\quake2\baseq2\
entering E:\Games\quake2\baseq2\maps\
0...2...5...7... (0)
**** leaked ****
Writing E:\Games\quake2\baseq2\maps\q24.bsp
0 seconds elapsed
#### Finished with exit status 0

#### Executing 'E:\Games\quake2\baseq2\qvis3.exe q24'
----------- qvis3 -----------
original code by id Software
Modified by Geoffrey DeWan
Revision 1.03
reading E:\Games\quake2\baseq2\maps\q24.bsp
reading E:\Games\quake2\baseq2\maps\q24.prt

************ ERROR ************
LoadPortals: couldn't read E:\Games\quake2\baseq2\maps\q24.prt

#### Finished with exit status 1

#### Executing 'E:\Games\quake2\baseq2\qrad3.exe q24'
----------- qrad3 ----------
original code by id Software
Modified by Geoffrey DeWan
Revision 1.04
Compiled for Pentium processors
gamedir set to E:\Games\quake2\baseq2\
reading E:\Games\quake2\baseq2\maps\q24.bsp
Couldn't load E:\Games\quake2\baseq2\textures/__tb_empty.wal
No vis information, direct lighting only.
0...1...2...3...4...5...6...7...8...9... (0)
0...1...2...3...4...5...6...7...8...9... (0)
writing E:\Games\quake2\baseq2\maps\q24.bsp
0 seconds elapsed
#### Finished with exit status 0

Here's the map:

Any help would be greatly appreciated! 
Have you tried 'File > Load Point File'? It should tell you where the leak is.
Have you tried different textures? The compiler complaining about __tb_empty means you have untextured brushes. Not all textures seal against the void.

I can see that the geometry shouldn't be leaking, but I don't have Q2 or its compilers installed. 
Default Backpack Values 
Hi nathnolt. Afraid that can't be done without modifying the QC. Map hacks involve getting interesting effects from setting values in fields which the QC has assumed are set to default. If the QC explicitly changes a field, you can't tell it not to do that.

Sometimes you can work around things the QC does, either by:
- using a hack earlier on to prevent the offending QC running
- running another hack after the offending QC to overwrite the value
Neither of these work for the ogre ammo, because the ammo value is set in the same function which drops the backpack. If you found a way to skip that, you'd skip the backpack spawning as well. If you rewrote the ammo value later (which might not be possible anyway...) you've missed the change for it to count. 
Map Hacks 
Thanks @Preach, both for your reply and your website. Is there a list with the combined knowledge of map hacks and/or entity knowledge? 
Trigger_cdtrack Transfering From AD To Progs_dump? 
Now that I'm getting closer to finish alpha-stage of my map, I'm wondering if I could implement the trigger_cdtrack from Arcan Dimensions to my progs_dump.
I have the fteqcc but absolutly no idear where to start.
Is there someone into QC who can tell me how to do this?

best wishes 
It's pretty involved. AD is a near re-write of the QuakeC logic so lifting anything from AD is a pretty advanced IMO.

That said I have not looked at that code so maybe it's a straight port?

QuakeWiki Modding Tutorial:

QuakeC tutorial:

QuakeC Reference Manual in PDF:

QuakeC Manual website version (with nice text formating):

FTEQCC compiler:

FTEQCC documentation:

Progs v1.01 source code:

Progs v1.01 source code: (cleaned):

Progs v1.06 source code:

Hipnotic SDK: 
Wow! Thanks!

A lot to read.

Thought of a free weekend. Haha :)

best wishes 
I will take a look at this qc for you as well but no promises on any real code unless it's something simple! 
Map Hacks 
Hi nathnolt, bit of self promotion but you could start with the map hacks posts on my blog. The earlier ones tend to be the simpler ones... 
More Hacks 
@ZungryWare has compiled an exhaustive list of hacks here: 
Thanks everyone for the help & support. 
also if you haven't seen it yet, there is a whole long-running thread about map hacks:

Teaching Old Progs.dat New Tricks 
@dumptruck_ds Re:trigger_cdtrack 
I think I've found all necessary functions in the progs and definitions.
I will try to copy and paste after the weekend and tell if it works. 
@dumptruck_ds Re:trigger_cdtrack 
I tried and failed.
Seems I've got to read more into detail. 
I will take a look this evening. (I said that before but forgot.)

I will report back here. Adding a reminder on my phone for after work. 
I was able to get a CD track to play using the built-in command SVC_CDTRACK

I have a killable Chthon and added this to the end of the function where he gibs.

WriteByte (MSG_ALL, 3);
WriteByte (MSG_ALL, 3);

Track 3 played perfectly from my music directory.

You need to repeat the 2nd command for it to work. In Quakespasm I got developer errors about not finding the CD track but that is only in dev mode and the music still plays. If you need further help I would need to see what you are coding.

As far as using the AD functions, that's a bit too much work for me and I am not sure I could get it to work properly. Try the built-in id function first. 
Thank a lot!

i was able to find the code for cdtrack in the targets.qc and built it in the progs.dat but finaly struggled, from my point of view, with the definition of the functions.

I*m looking forward to check the SVC_cdtrack this week and tell you if it works.

best wishes. 
Fun Fact Time! 

WriteByte (MSG_ALL, 3);
WriteByte (MSG_ALL, 3);

Track 3 played perfectly from my music directory.

You need to repeat the 2nd command for it to work.

The second writebyte is setting a variable called cl.looptrack - which on first glance you would expect would control whether the track loops or not. Surprise! It's not actually implemented in the engine, so the track always loops. You are free to send any number in the second WriteByte, it doesn't need to be the same as the track number.

If you'd like to play a CD track without it looping, the alternative is to use stuffcmd with the console command "cd play 3". You can also replicate the looping cd track from the SVC_ command with "cd loop 3". 
Ok, I thought the whole thing over and came to the conclusion that whatever I will do, I have to make it a trigger_cdtrack. Otherwise it will not work with the mod.
That means getting into the whole qc-thing and read a lot.
So at this point I will finish mapping first before doing anything else.
Thanks to dumptruck_ds and preach for the assistance!
Hope I can ask you again when the job is done.

best wishes 
One last thought: If the mod you're using has the equivalent of
trigger_command then you can use the console command to achieve what you're after without modifying it. 
I looked at the code again and wondered why my attemp doesn't work.
I copied the trigger_cdtrack function (is equal to the code dumptruck_ds showed with a -change and -use procedure) from AD's target.qc to my progs_dump/triggers.qc next to the trigger_relay function and compiled the progs.dat.
Then I copied the trigger_cdtrack definition from AD's .fgd to my progs_dump.fgd with the windows editor.
When I entered Trenchbroom and changed to the new fgd (in new progs_dump folder with the changed progs.dat) I got this message: "progs_dump_112.fgd': At line 1, column 1: Unknown entity definition class '//'".
I think I'm not to far from a solution.
Have I missed to change or add something in the progs or done a failur in the fgd? 
looks like invalid characters in the fgd 
Byte Order Mark 
Yeah, if you encode the sequence "" in the default windows codeset and decode that as UTF8 you get character FEFF (a byte order mark). Working backwards I guess the program you used to edit the fgd saved the file as UTF-8 and added a byte order mark. Trenchbroom is then opening the file as 8-bit windows codeset text and seeing garbage at the top. Suggest you reopen the cfg file and save it in ascii format, which should get rid of the garbage. 
It should have been saved in ANSI.
I will try to save in Unicode and use notepad if it doesn't work. 
Got It! 
So. This challange is masterd.
For no reasons, the widows editor saves automaticly in UTF-8. So I changed that in ANSI and now theres a trigger_cdtrack in trenchbroom.:)
That's the good news.
The other is that I was wrong about the compiling.

Whatever progs.dat I decompile and recompile ,with fteqccgui64, I get messages like this:"defs.qc:328: error: "ev_field" is not a type in function SUB_CalcMove (line 61), subs.qc:66: error: Unknown value "tspeed"Errors have occured Error in defs.qc on line 328."
The funny thing is that fteqcc shows erros, but
the progs work.

I have absolutly no idea what happens here. 
Job's Done 
Built from the source. Now it works. 
how check max entities limin in trenchbroom? 
Urban Mercenary Level 
Please can someone help me I tried to convert a .bsp2 map to .bsp1 for a game that uses the Quake 1 Engine, but it gives me error ModLoadBrushModel has wrong version number .... should be 29, how can I solve? 
A Mystery In Quakespasm 
Yesterday I got a fascinating problem.
Got the message Alloc Block: full and started to solve the problem like usual.

replaced every bad texture. -nothing
deleted or repaired every unclean brush. - nothing
deleted over 60 lights. -nothing
deleted all trenchbroom autosaves. -nothing
deleted all the maps .bsp, .lit, config,... and recompiled the map. -nothing

Deleted Quakespasm and reinstalled. No Error anymore.

Has anyone an idea what happend?
I think this would be usefull to everyone.

best wishes 
Deleted Quakespasm and reinstalled. No Error anymore.

I'm wondering whether you may have replaced an older version of QuakeSpasm with a newer version? The newest is 0.93.2, released November 2019.

From the thread dumptruck_ds linked:

metlslime: This is caused by lightmaps.

From the README for QuakeSpasm 0.93.2:

Lightmaps are now dynamically allocated (from QSS), and BLOCK_WIDTH/HEIGHT raised from 128 to 256.

So if you replaced an older version with 0.93.2, I guess this would be why that error went away? 
Ahhh, enlightened!

I installed the newest version.
So it is a change in Quakespam.

Thank you very much.

best wishes. 
As Random As Always 
Who said trisouping can only be used for terrain? 
Textures With Permissive Licenses 
where to find them? CC0, CC-BY, etc. i love evillair stuff 
Lazarus Misc_actor / Target_anger 
Hi guys, nearly got my new Q2 map ready for playtesting but struggling with a particular issue.

I'm using the Lazarus misc_actor to have a friendly marine attack some Strogg enemies but I want the friendly guy to stand still in one place while he shoots the bad guys.

I'm using the "Hold" spawnflag on the target_anger to achieve this:

HOLD Spawnflag (=16)
The target_anger will cause the misc_actor/monster_* to stand in place and not run around.

...but it seems to have no effect. The actor runs around trying to get close to the Strogg and, while he will occasionally shoot them, when he happens to find himself with a suitable angle to do so, he's largely useless and stupid.

Has anyone here used this feature in Lazarus and managed to get the actor to stand still when he's told to? 
Elevator Multi Level And Combining Mods? Help Lease. 
New and signed up just for this! Really enjoying my first foray in mapping for quake.
As per title, I know you can make multi direction elevators with progs_dump mod (dowloaded from Dumptruck DS)
However I'm enjoying using AD mods for all the excellent extras it includes. - I cant figure out how to do it (multi level elevator) with AD!
Is there a way to combine mods? I can't find a way to do this anywhere either! ...or maybe a tutorial on how to customize my own mods and features / combine mods?
(on a side note, I spent 4 hours trying to raise/lower water into an electrified basement room!!! Urgh...failed)

Apologies if this has been asked before, please link to post if that's the case. Much appreciated.

Thanks in advance and I'll upload my maps in time! hopefully! 
1)NO combining MODS.

2)Load AD and type "map test_2floorplat"
in the console.

Map is in the AD maps folder. 
Elevator Multi Level And Combining Mods? Help Lease. 
@damage_inc thanks for that will reverse engineer, This is a blast. 
Compiled Map No Longer Feels Like Running 

So I started mapping a few days ago and I've recently hit a brick wall. I've been working on a Quake map in Trenchbroom, compiling it with ericw-tools, and now suddenly, upon compiling, my map is just refusing to run and I have no idea why.

^ That is all I see upon compiling and attempting to run the map. I have a .BSP of my map, it IS in the correct location, I can run an older version of my map and the default maps, but for no apparent reason Quake has just decided to not let me run my map anymore. Using the console and typing "map mymapname" leads to the same result as the image posted above.

I have no idea what the solution is and would appreciate some help because I can't test my map anymore until this is resolved. 
Running any mod or is this vanilla id1? 
Some Googling says:

This is also the error given when giving a func_plat a negative "height" value. 
Yeah got it now, thank you. I wasn't aware that you couldn't reverse the direction of a func_plat with a negative integer, that's why the game was freaking out. 
Platform Tip 
Very often if you want a platform, you should use a func_door. Moving downwards is certainly one of those cases. 
WTF Brush Entities Turning Non Solid ?! :°°-( 
Dear all,

I experience a very annoying bug. I'm afraid it's a well-known issue. Sorry in advance for maybe being the 1000th one to ask about it but I didn't figured out the right keywords in the search engine to find how to fix it.

For some unknown (to me) reason, some of the brush entities in my map turn non solid. They are still drawn but don't block the player movements anymore and can't be touched either, just like illusionary walls: doors looking closed but being wide open, button not triggerable anymore unless they have a health value, breakable brushes needless to break...

Trenchbroom doesn't give me a clue about the problem. There is no leak... What the hell is going on???

Shall I precise that curiously SOME of the brush entities in the same map react the right way and can be normally interacted with. o_O;

Thank you in avdance for enlighting my mind, I'm going mad! 
Are you building things near the origin coordinates in the space, or are you building far away from the origin? If things get more than 4096 units away from the origin then weird stuff can happen in most Quake engines. 
I Am Already 
so, what it feels to me is like a vis problem.
Some brushes may overlap eachother on a 0.01 unit which causes the compiler choose between both of them.

Isn't there a command "force all brushes on grid" in Trenchboom? 
In TrenchBroom, under the Edit menu you will find Snap Vertices to grid and snap to integer. 
Are there any maps with identical versions for both Quake 1, UT99 and/or UT2K4?

I've been reading about Q3A to UT map converters, but I'm not sure if that would work well for Q1 maps: 
Angled Brushwork 
For long time now i ask myself how you guys to angled brushwork in Radiant, like arches that lie on 45°, 33° or any other weird angles on the grid.

A great example for what i mean would be the huge chains in czg's q1 map Honey.

I try avoiding building stuff on grid 90° on grid an then rotaing it, as this brings the vertices off grid.
Some stuff i manage to do via a mix of csg_subtract and clipping, but for more complex constructs my brains 3D projecting algorithms fail ^^'

Are there any "cleaner" methods to do it? 
i did a post here once about "magic" (aka on-grid) rotation, but fuck knows where that's gone - same technique czg did for those angled bridge ruins in saint.bsp

These days though, misc_external_map is your friend for a lot of this stuff... 
In That Case 
i could do it with .ase geometry, as i am using Darkplaces with q3map2.
It's for a total conversion and use advanced features of both.

In some cases using .ase or a model instead of brushwork are not practical, at least that is what it seem to me.
And i guess the main problem in what i am trying to do is not the brushwork and it's limits, but my geometric understanding of things.

Here some screenshots of things i try to do:

Maybe i asked even the wrong question, so i rather ask: how would you guys do that stuff depicted in the screenies? 
I'll Be Honest 
If you are doing stuff for the q3bsp format then it's a pretty good idea to use meshmodels/ase to work around the times when brushes just won't cut it.

For "seamless" joins of arbitrarily rotated meshmodels to surrounding brush geo, you'll want to use some artistic license and design the model in such a way so you have some "wiggle room" to be able to butt things into each other a bit and not look ugly - e.g. hide the joins with some raised trim or raised brick quoins or something 
I will for sure use that approach for more complicated geometry.

Just saw that screenshot of Wrath: Aeon of ruins in another thread:

Would be interesting to know how that hall, especialy its in multiple directions facing door arches, where made.
At least that domed ceiling would be no problem with a trisoup.

Is Sock still around? 
Another Wacky Experiment 
Built this ship for someones map and I wanted it to be a rotate train. I got it all working fairly well despite some tuning I can do later. But for now I have this movewall that doesn't rotate. So if you ride the thing straight or fairly straight everything is fine. Once the boat turns the func_movewall doesn't. Is there a way to make the rotate_object solid so I can remove the movewall entirely?

A video showing it does work on my server.

A link to the bsp. It meant to run on teamfortress with hipnotic ents added. So that means megatf and custom. I haven't tried other mods to see how it works. 
bsp collision can't rotate without an engine feature. (this does exist for some engines, can't remember which, but Baker had it in MarkV I think?)

The movewalls are basically a hack to get around this -- you actually need many small movewalls, each one will not rotate, but the positions of them all will orbit the origin of the object to sort of make it work. For example if you put a movewall for just the mast of the ship, it would correctly move with the mast. Warning: You will need a lot of movewalls. 
Bsp Collision 
Yes, I read through preaches site on all this. The server I intend it to run on will be FTE. I wont do the many funcwall thing, but I appreciate you suggesting. It would take way to many to simulate what i need here. I am pretty sure it can work, a non solid into a solid, but setting movetypes and avelocites blows my mind. 
WTF Too Few = Too Many ?! 
Dear skilled mappers,

As a beginner in mapping, I'm facing an unexpected (but probably well known?) issue.
The number of monsters and entities in my map is quite low, and anyway far below the standard number in the original editor's maps.
The original game's maps display without any problem, whereas my map doesn't: it seems a threshold is reached concerning the number of monsters/entities and the most recently added ones are not displayed (as a player I am attacked by an invisible opponent, an invisible brush entity blocks my way, etc.) The entities beyond the threshold index behave normally except they are not drawn by the engine.
This occurs very soon in the mapping process, even before I really start to populate my map with monsters, as if all the available slots for entities would already be taken by doors, lifts, lights, artefacts or whatever. Yet the number of those is, once again, really low. Especially compared to how many entities are found in the game's original maps.

Any help would save not only my day but weeks of work, actually.
Thanks a lot in advance!!! 
First Things First 
This could still be any number of problems afaik, so lets narrow it down:

Which engine do you use?
Even "standard" Quake could mean three different ones: DOSQuake, WinQuake or GLQuake.

What mapeditor and compiler are you using

Have you tried loading your map in another engine and see if the problem persists?

How many entities are there actualy in your map?

Are your sure your map does not leak? 
Make sure your map does not extend past + or - 4096 units on any axis.

If it does and you can't shrink it without negatively impacting your map, compile it with the "-bsp2" command line parameter (for bsp.exe) and run it in a modern engine.

Also, if your map has lots of entities it's probably a good idea to make sure you're running protocol 666, not protocol 15. 
I Thought.., 
A usual Q1 map can have 37678 brushes and 640 entities. If you have less, than another error has faulted. 
Check Your Functions 
Are you sure there are no "empty functions" in your map, like a func_door without arguments? It is easy to add a func and forget to add arguments. You would hardly notice.
Most times these cause a "too many edicts" error. 
Good Guess! 
Thank you for your quick answers :-)

I actually map for Hexen II. The only engines supporting it that I know are Ultimate Quake Engine 1.13 and Hammer of Thyrion. I have the problem with both of them.

My map editor is Trenchbroom 2019.6
My compiler is ericw-tools-v0.18.1-win32\bin\qbsp.exe

Without counting the world, there are currently about 220 entities in my map which is probably far below the limit (although I don't know what that limit in Hexen II is compared to Quake's 640).

My map IS actually leaking. Good guess Wakey! I would have never thought about that because it seemed to me that leaking problems were far behind for a while... and I must confess I still can't understand what the problem is. I open the pts file and carefully follow the "leak line" in TB but at the places it goes from inside to outside, it simply goes through solid world brushes and not between them through unnoticeable interstices as usual leaks do.
So now I know it's about leaking, but I can't figure out what the leak is.

Shall I very humbly and respectfully submit my map to one of you to get their insight and improve my understanding please? I would be most grateful for that!

@Shamblernaut: the actual count of entities doesn't seem to be the direct responsible but as a side note, what are protocol 666 and protocol 15??? 
your map does not gave to be open anywhere to leak.
An entity by mistake placed into the void can cause a leak too.
At least thats true for q3bsp, so i asume that is a valid statement for q1 maps as well.

What shamblernaut was talking about are different network protocols.
15 is the original, 666 is an enhanced one, by Fitzquake methinks.
It's important because Quake works with a client-server protocol, so even offline in sp the gamecode communicates internally over this. 
if you're mapping for Hexen II then the protocol 15/666 question isn't relevant. 
Leaks can be very tricky. Following the pts file will lead to the initial brush, but it always starts at one corner fading on a irragular vector into the void.
Very useful to set the sky brush dark and look with a 3d viewer along the pts line. 
About the protocols, got it, thank you for the precisions.

The pts line didn't show clearly the leaking point but went from inside to outside in an irregularly shaped part of the map (a cave). Certainly not a coincidence (thank you so much Wakey for having put me on the leak's track!)

I never understood where exactly was the leak but I found a workaround.

I encompassed the whole area into a giant square box. By chance the cave was a dead end and was connected to the rest of the map only through a rectangular tunnel. I just opened a square hole in the giant box wall to let the tunnel go through, et voilà!

Hop this trick could help someone in a similar situation in the future.

As a side note, strangely enough brush entities or water brushes partially in the void don't seem to cause a leak. I have the impression that the only "entities in the void" counting for leaks are model/point entities...

Thank you again to all of you for your help. 
the "put a big box around a leaky area" is an old trick, and it does work, but you'll have longer compile times and a larger BSP than if you actually plugged the leak. Depending on the cost/benefit analysis, might be worth finding the actual leak, or not. 
Planning Routes 
is something i want to learn more in-depth.
Just can't properly wrap my around yet.

How did you guys learn it and do it now?
Learning by playing doesn't seem to do the trick for me.
My guess is that most of you will already have a rough idea of the routes in a map in your head when starting to block out a rough layout - is that right?

To you take notes and sketches beforehand?
Like "I want this traps in that map, that many arenas..."?

Especialy interleaved routes with some backtracking and opening paths give me a headache, but my guess is that im thinking about them the wrong way. 
Sketch layouts first - including approx player routes, likely combats etc. 
My Nitwitz 
32768 brushes - 620 entities standard quake

I often asked myself what happens on the edge of the 33768 brushes. Having a map that big gets weary adding one brush or deleting one entity.

Still the knowhow behind it isn'nt clear to me.

Let's say I have map with that account. It is widly surrounded in the editor with all kind of edges. I assume the compiler uses all that outer brushedges to come to that 32768.

Then, would it be of any use to pull all outer edges to one line so the outside would be a cube with only 8 sides. It should make a difference, or am I just short sighted as these outer brushes get deleted after compiling? 
Brushes Are Not Faces(sides) 
a brush can have up to 255 faces in q1,
what matters is therefor the facecount.
outside faces seeing the void (if your map is sealed, no leaks...) aren't considered when creating the bsp. 
To Add To This 
brushes are made out of faces of course. 
Host_Error: Mod_LoadModel: 9 Not Found 

Got this error message on my map: Host_Error: Mod_LoadModel: 9 not found.
Seams I've wrote a wronge value somwhere.
Is there a way to find the entity/brush in trenchbroom, via notepad,.. or another way to fix this? 
Entities Come Up With Nr In Map File 
Trenchboom>View>Switch to Entity Inspector
or when it won't come up, I would search with Texpath in the *.map file all entities. A bit meak. 
Still Cant Think Up 
a map layout.
Does anyone of you have some general tips when it comes to layouting your map? 
Steal It Off Something Completely Different. 
Like, I dunno, a HL Alyx cutscene.... 
Oh Cmon 
That would be way to obvious xD
Then rather some Boom Eternal cutscene.
But i'm not so keen on learning how to steal at all, i just don't want to come up with
some linear hallway-room-hallway-room kinda thing.
You get the idea. 
Sweet Inspiration 
Forget your intention of completing a finished map. Just imagine you are in a corner of a room. Start sculpting a corner without the intention to finish something off. Make a small ledge on the floor. Try to compare on the moment what your intuition is telling you.

I am working on three maps now, and stop immediately when I feel I want to finish them. That's why I am no speed mapper. It can take years and I don't care. 
Was Kind Of My Workflow Too 
But it hasnt yielded any release in years.
The last one was a WoP map in 2015.
Most of the time i experiment around with brushwork, but that doesnt help in upping my skills to create a map interesting to play. 
Make your method more structured.

When you just do random stuff finishing can get near to impossible. You don't know when to stop or where it's going so it just becomes an unending slog.

When you set yourself limitations and challenges, it becomes more satisfying to complete and you have to be creative to make something interesting.

Build the entire layout in simple form, without detail or gameplay. The layout itself is up to you - I like to make things loop as much as possible and expand any dead ends into self-contained segments with unique challenges - button hunts, locked in a room with a shambler, whatever. Loops mean the player enters the same area from different directions along the critical path; try and avoid forcing backtracking unless you're going to change the structure of the level on the return or drastically change the gameplay (repopulate). You should be thinking analytically and planning what you want to do with these areas later on. If a particular area gets visited a lot, be sure to make it bigger.

Make yourself a handful of object to decorate the level with. Ideally these should be from an external bsp to let you make big changes with minimum effort further down the line. Does take a bit more work at the start, but it's worth it. Sprinkle the deco all over the place. Areas that deserve something special, make it. This is the more artistic part, so you'll be making your ugly blockout nice looking, modifying or expanding it where needs be.

Fill it with monsters. You should have planned ambushes and set ups in your head already during the blockout and deco phases - now you get to fill in the blanks. you should be playtesting constantly, on hard skill (nobody is better at your map than you). You shouldn't have to make any structural changes to the level now, but if you do or you have a cool idea, go for it.

Get a few people together and test it - demos are ideal. This is where the assumptions you've made on how the level with function with a rel player are tested. Listen to each complaint and understand what it's about.

Wait for a month or so without working on it. Then replay the level and make any changes that you deem necessary. Once those are done and playtested, upload the zip.

There's probably some bugs. Be prepared to patch the release after it's done. This should be limited to fixes only, no new stuff. 
Kill Your Deadline 
I understand your intention, but from where the urge to deliver an outstanding map?
My last map is from 2014 and was one of my hardest cases. It can bring you on the edge of tranquility, as the map starts leaking or lightning gets abused.

From the moment I stopped wanting to make something good I made all these small maps with no pretention that fitted in together.

Looking at I'd maps it comes to me that they are not that hard to make. The challenge is to give it something unexpecTed. A moebius ring or a part with moving walls that gives several options for leadways.

If I'm on the point to produce something wild I just start playing AD. 
Everyone's Got Their Own Method And Driver 
My driver is the sooner I finish one project, the sooner I can start another.

Each project has new and interesting stuff to learn.

But, to each their own. 
one easy idea is to start by building a "hub room" which has multiple entrances and exits, so the player has a familiar space they return to multiple times.

The hub room could contain locked doors (so you have to go find a key and come back) or multiple elevations (so the second time you visit, you are on a higher level you couldn't get to before.)

Some good examples of hub rooms are: the central room in e1m5, the starting room in e1m6, the room with 3 wind tunnels in e3m5.

Once you have a hub room, then you are mainly just building out the looping paths that branch off from it and loop back into it from a different angle. 
That's More Practical And Less Esoteric :) 
Yes I Just Watched Unabomber On Netflix 
Thanks Guys 
Already making progress.
The explanation of loops, how to deal with dead and ends and the explanation of the hub room helped a lot!

@madfox: It doesn't necessarily need to be outstanding map, but at least it should be worth beeing played.
I think i should at least try to make the best out of it, nobody wants his time wasted by a boring map.
Had my fair share of ugly releases already, like that messed up monstrosity Chili Quake XXL.
Gosh, i have to do a remake of that, to save at least some of my dignity xD

@metlslime: yeah, e1m5 and e1m6 are very good examples for learning purposes.
They use both a hub room and loops, but are not overly complicated or long.
So for examining and studying them both are ideal.
Cool about e1m6 is that the goldkey is visible from the beginning.
On the other hand it's one of those maps you can cheat through by just grenadejumping there.

@ijed: Thank you for your very detailed post!
Lot's of useful information in there.
Never thought about letting a map rest a month or so before the final releas, but it seems very wise.
You might start to see stuff that you overlooked while still working on it. 
On the other hand it's one of those maps you can cheat through by just grenadejumping there.

These things used to bother me too, but with the DM4 jam I decided to just embrace the potential for breaking progression. It made for a much better map in the end. 
I'm trying to make some new sprites, but Fimg saved my results without alpha's. So I used *.tif files. Same result.

Is there another prog to obtain sprites? 
Worked fine for me - I just had to copy the dirty pink colour Quake uses for .spr transparency. 
Without that colour it seems to leave the alphas out. Now I've got ome bit it's still invincible as I used no fullbright's. 
Sprites ignore light, they're never black or invisible. 
Dark Cloud 
I tried to make a sprite look like an ink cloud,
but the disadvantage is they fade too fast.

Anyway, this one I don't see appear in game.
It will be my lack of coding. 
Make sense now, somehow 
Black Textures With Fresh Trenchbroom Setup 
I set up Trenchbroom on a new laptop. When I open it up I get this in the console:

"Could not load palette file 'gfx\palette.lmp': File not found: 'gfx\palette.lmp'"

When I add a WAD file all textures appear black.
This is the entire console log when I start Trenchbroom:

"Creating new document
Loaded entity definition file Quake.fgd
Loading palette file gfx\palette.lmp
Could not load palette file 'gfx\palette.lmp': File not found: 'gfx\palette.lmp'
Renderer info: GeForce RTX 2070 with Max-Q Design/PCIe/SSE2 version 4.6.0 NVIDIA 445.75 from NVIDIA Corporation
Depth buffer bits: 24
Multisampling enabled "

Does anyone know what is happening?
It can't find the id1 .pak files. Either copy those over or reconfigure your paths in TB. 
Thank you! I deleted my .pak files and copied them in again. It all works now. 
Any Good 'cutscene' Tutorial For Quake 1 Or Hexen II? 
Hello, I've been playing around with Worldcraft/JACK for a while now and I'd like make a small map pack for Hexen II, but I'd like to have an opening cutscene to setup the story and world. However, I can't figure it out.

So does anyone know of a tutorial which shows how to setup a cutscene in Quake 1 or Hexen II?

Any help would be appreciated, thank you. 
There is a small map "visions of hatred" of Reign MacNeil, that has a "Capture Camera Kit".
It works a bit slow but it has a tut that will make you cutscenes. 
Thank You Madfox! 
This is just what I was looking for! Now I just have to get this to work in Hexen II... hmmm, well, time to carpe those diems! :D 
More About Cutscenes.., 
The same question came up a month ago in coding help.
There are some more answers and possibilties there.
hexen2 #2768 
Light Splotches 
So i am currently working on a map with lots of skylight, and i get this ugly bright splotches, due to bounce most propably:

I am using ericw-tools v0.18.1, phong, -bounce, a sunlight + sun2 for direct & indirect lighting.
My guess is this occures because the light stage stage creates pointlights for the bounce, is that about right?

How are you guys working around this? 
No Clues At All? 
The light process reports solid faces and lights created, seems consistent with your idea, though I don't know what exactly happens under the hood.
The docs are good, not much to recommend beyond that. Try extra4, try soft, try sunsamples. If that fails, try hiding it with ao (dirtmap).
Generally, if you avoid flat uniform colors it wouldn't be noticeable in the first place. 
Thanks for your answer chedap.
extra4, soft, sunsamples and dirt are already enabled on that screenshot.
Using that flat uniform coloured textures TO pronounce the lightmaps features is my intention all along, of course i could have guessed that that will pronounce any flaws as well.

I could try setting _bounce to "-1" as entity key to prevent light from bouncing off the nearby brushes, just found that feature, isn't in the documentation yet.

I will also try to play around with _anglescale, altough i dont fully understand what exactly what this keys effect is, yet. 
Is there a way to link two trigger_secret brushes so that if one is triggered, the other is removed, and they count as one secret? It's for a secret area that can be entered from more than one location. Obviously I can place the brush where the two paths link up but I'm curious. 
Each trigger secret counts as a secret.

You can killtarget one trigger from another, so you should be able to have two trigger_once which point at a trigger_secret to activate it.

Which might actually work without killtargeting anything.

id1 progs is kinda rough though and I haven't used it in years so this might all be wrong :L

I'm working from a Copper base now, which allows lots of entity manipulation without having to hack the level. I have coded up similar entities in the past, but didn't want to do it again and Lunaran's are better made than the legacy stuff I was going to resuscitate yet again. 
Anyone Remember My PyramidGav Map? 
Like ijed says. One trigger_secret somewhere (set spawnflags 1 for make it not touchable) and two trigger_once in each area. The trigger_secret can killtarget both triggers, but be sure to set a slight delay on it to avoid trouble. 
The trigger_secret removes itself after being triggered so there's no need to kill the other trigger_once. It'll be swinging at nothing if it ever goes off. 
I was thinking about cases where each area gives an individual message which would then be printed by the trigger_onces instead of the trigger_secret itself. 
Thanks Guys. 
Also does anyone know what map has a "bloodfall" texture? I think I recall playing a map that had one but I can't remember what map. 
Also does anyone know what map has a "bloodfall" texture? I think I recall playing a map that had one but I can't remember what map. 
Insomnia map3, end of Travail ep1, probably some Zerstorer/Zer.jam maps 
Ah sweet. Reminds me I need to replay Insomnia and Travail. I don't think Zerstorer has one because I'm already using zerstorer.wad. (Love those "viscera" water textures.)

Same Isue 
Hey mate, any luck with this one?
I have the same issue, trying to find a way to increase, I assume the hunk allocation of memory... so far no luck. Let me know how ya go / went... 
Hi, please ignore previous post :O
I’m well into my first level now, after following dump truck tutorials. Using AD current version. However, I’ve hit a snag re hunk_alloc when compiling completes. I’m using quakespasm and upon launch, Quake crashes with ‘hunk_alloc at #######’ - I’m fairly certain my level is far from optimised...And it’s quite large. (I will attempt to cut it down and split into multiple maps eventually) but for aesthetic reasons I can’t yet... as it’s a ‘hub’ city / difficulty select / start map and relies on line of site to buildings etc. outside of the play area.
Thanks in advance. I’m new to all this, so I’d also love to share some pics etc. - some of the maps here are AMAZING! I’ve a long way to go!!
Small Field Of Vision 

I have a very large room full of entities. When the player stands in the corridor leading to that room, the walls, floor and ceiling of it restrain considerably the field of vision: just a very small portion of the room is visible and 99% of the many entities are out of sight.

Here is a picture of the setting:
(the red thing is the cone of vision, and the red rectangle its projection onto the room's front face).

Yet there is one brush entity which should be seen because partly in the red and partly out of it, but it's invisible until it suddenly appears when the player approaches very close to it. As if until the very last moment out of sight entities were still taken into account and were to many to calculate, thus exceeding the rendering limits.

Does that make sense?
Is there a way to prevent the engine from calculating out of sight entities over supposedly visible ones?

Any clue will be very welcome...
I precise that I can't move to a more powerful game engine because I'm mapping for Hexen II, so there are so few compatible engines already that if I deliberately exclude some of them, almost nobody will be able to play my map! ^_^; 
How To Make A Conveyor Belt? 
Is there a way to make a conveyor belt? In newer doom source ports you can make a brush with a scrolling texture and it will carry entities. I want something similiar.

I tried making a brush with an animated texture and have a trigger push carry entities but with trigger push affects player's movement in a negative way. Another idea I had was to make lots of small platforms that move but that seems like a really hacky way to do it. 
Convoyer Pets 
It's been a hardbreaker from the moment I tried to lay hold on it. Conveyor belts and quake func_trains don't like eachother, that is what timing concerns.
When you're really as mad as me you might try a static like this.

On ther other hand I spend a few moments to get a solution for it. It isn't that hard, you can do with two func_trains. That is.., when you fine tweak it to the right moment.
Here is an example, although it still has a wig in it. I went really domino after a few houres, but I think it can be done.

"Four feather" has a fine way of doing it, but it are all statics. So no.., I don't have a real solution than tweaking two func_lifts. Size, distance, time. 
Hexen 2 Water 
Hey guys, I'm working on my map using trenchbroom and erics tools; I've got a body of water and I assign it to func_detail but this means the water is not transparent, despite any settings.
If I set it to func_wall, I can provide the spawnflag for translucency, but then it's not water any longer.
Any suggestions on what I do here? 
what if you don't assign it to func_detail? I don't see a good reason to make water "detail" 
Just like metlslime I wonder the reason why. Could you be more precise about what you're trying to do please? 
49 posts not shown on this page because they were spam
First | Previous | Next | Last
Post A Reply:
Website copyright © 2002-2020 John Fitzgibbons. All posts are copyright their respective authors.