News | Forum | People | FAQ | Links | Search | Register | Log in
CMC Q1SP Released
Hello guys,

I'm back with a brand new Quake Single Player base-based map called CMC (CMC for "Cheyenne Mountain Complex").
I would like to specially thank aguirRe, who helped me to reduce vis running time from 10 hours to less than 2 hours, and as well for his global feedback about the map design: you rock man !!

Download on

So now go play it, enjoy or hate it, as you want... All feedback and comments are welcomed...
First | Previous | Next | Last
I wouldn't take a lot of work to make this map look excellent.

Should have been:

It wouldn't take a lot of work to make this map look excellent.
Aye Sir 
I definitely thought it was an improvement over Hellchepsout. I think the main problem here is the lack of overall detail work; Someone already said some parts are uberdetailed while the rest of the map suffers. Scampie told me once that it's not one or two set centerpieces that people notice, it's the entire feel of the map. If you have a couple great eye candy spots, then the rest of the map probably suffers because of it, and I think that's the case here.

You had some great areas, lots of great fighting arenas after the initial tunnel area. Some of the monsters were used ineffectively compared to the rooms they were in. Vores for example were used almost exclusively in areas where you could easily just duck behind a corner. Shamblers were put in long corriders, where you could back up and they couldn't even attack you, etc.

I found 4/4 secrets, only the megahealth and red armor I noticed. I take that back, there was a Quad Damage I found after I cleared out an entire room of guys. :(

It was a pretty big map, with lots of hoard combat. I prefer smaller, more focused battles, but overall the gameplay was pretty good. The map itself is nice, it just needs a lot of overall polish and cohesion. There were lots of random-seeming architecture, that, while pretty neat, didn't contribute well to the level.

I think everyone pretty much said the same stuff, so I'll just say what they said again. You've got a lot of potential, you just need to refine and polish. Good work sir. 
Excellent Review 
now I'll have to play the map! 
Well, after the firsts 2 comments, I was afraid to be really flamed this time.... But, now I'm really glad to hear that even if the map is not perfect (due to this funcking bug i hard skill.. which I will try to solve quickly), the major part of you guys have a good impression about it.
So I would like to thank everybody for your consructive feddback (I learn from bad and good comment), and all the encouragements you gave me..... I think _Func place is definitively the best Quake mapping forum... 
Great Work... 
man is a realy peace of art...i love the map very much keep making good things like that! 
gonna dload now :> 
I've just updated the map in order to be able to play it on hard skill. It seems not ot crash any more on FitzQuake, so I hope it's OK now... Let me now if you reach any problem.. 
Had Fun 
Well, I disliked the lift that moved on its own. It's boring to wait for those. And you sealed the shortcuts with invisible brushes, so it's not really speedrunnable. I'll concentrate on the small, others have covered the rest already :P 
Well, I disliked the lift that moved on its own.

...not being funny, but wtf. Since when has this been a mapping crime?

*sigh* ...I just can't wait to bring out a map myself. I'm just gonna sooo love reading your reviews. 
About The Lift 
Well, I was asking here in the mapping help thread how to solve this problem using triggers or some some other stuffs. Many mappers answered me that it is easily possible with a "2 levels" lift, but if there are more, the better way is to let the lift run free, and just wait for it.
BTW, I agree, it's sometimes boring to wait for it... Anyway, it works fine, and it's the most important isn't it ?? 
It is possible, just fairly slow. There's a big shortcut in the GK Door room - slope jump onto the suspended platform thing, then sneak in through a little gap at the top of the stairs on the right. Then get gold key, return to that room, and exit, blah.

Megazoid, don't be stupid. The lift moving on it's own accord is a poor idea because it means you have to wait around a lot to use it (and you have to use it quite a lot in this map). 
... it seems you find a hole in a clip brush.. grrr... 
Played It ,Liked It. 
Very nice map. Liked the wide, open areas. But agreed with Hanz about the lift. BTW, does the lift activate on the shootbuttons, or does it go from the start? Cause it seemed to me that it didnt matter how fast I did the first section, the lift was always at the same place (almost at the top) when I reached. Maybe I'm wrong here...

Also agree that clipbrushes is a no-no, unless it's used in areas that you wouldnt fit through, to "smooth out" a floor where you've carved some decorations for example. Or to control monster behaviour. Used simply to block off the possibility of taking a short-cut, is a major turn off for me anyway. If that was your goal, you'd first of all need to clipbrush that silverkey. And about a dusin other places, so I dont really see the point behind it.

This is from a speedrunning viewpoint of course, so most players probably don't care. That's fine with me =)

Anyway, great map. Really enjoyed it, and hope to see more!

You are right, the lift is activated by the 2 first shootbuttons.. perhaps I should started it on a lower level in order to let more time to the player here.. I added clip brushes in order to force the player to fight monsters, regardless of speedrunning contest... I will takemuch more care about speedrunning next time for sure.
Well, I' glad you globaly enjoyed the map.
BTW, I thank everybody for the encouragements I found here... 
Have you solved the edicts problem? It is not so easy to reduce the number of edicts. I also have this problem, but it appears already on normal skill. I see no chance to go down with the edicts and will have to recommend playing the map with custom engines.
I have 570 active edicts in the beginning of the level on both normal and hard skill. And I always get a crash with standard winquake. I don't have this problems with joequake.
I guess I have to get rid of 30 edicts :(

Oh yes, and I liked playing your level. The middle part was most entertaining for me. 
Yes, and not... The edict crash occurs if you try the game (with console cheats..) in hard skill, god mode, quad damage, and rocket launcher, and try to speed as far as possible during the game... edictcount is about 604 (aguirRe's value feedback, and against 620 more or less before the changes..) Nevertheless, if you try to play the game in a normal way (without cheats), you can close the map without crash... BTW, I also recommend to use FitzQuake, instead of Winquake which is powerless, to play my map(s)... I noticed that Winquake have problems into the map "rendering" (some "grey zones" in the backward appear sometimes..)
As you said, edict count is difficult to reduce. I do the job removing lights, and monsters / health in hard skill... It's a quick turnaround, but at least it worked here..
Oh... and I forgot to thank you for your feedback: I'm glad you enjoy the map... ;) 
Grey Zones. 
that is to say grayflash.

this is easily fixable via console (or command line?) variables. so don't worry about that. :) 
yes that's it... ;p 
You Don't Believe Me? 
r_maxsurfs 3000
r_maxedges 8500

try that.
you can even set maxsurfs and maxedges to huge numbers like 10000 and 40000 to make sure there is no gray flash. 
I Played - And Liked 
I just finished the first issue of this map on hard (wish I had grabbed the fixed version.) Here are my comments:

- Overall, I liked this map and thought it was well built and offered may interesting areas to go through. I especially liked that bridge supported by the two oblique arches. I like bridges in general and this one was sweet. There were lots of interesting structures, walkways and machines.
- Textures and lighting gave this complex an Austen Powers' feel. This suited the over-the-top hop and blast gameplay. Gameplay was like Painkiller without the kill-gates. I played just as Shambler described. Kind of fun but frustrating sometimes. Overall, this was fun and demonstrates one of Quake's possible gameplay styles.
- I used FitzQuake 0.75 and that button dumped me every time. I noclipped through the door that it opened and finished the game before noclipping back though the exit bars and going back to the bad button, hitting it, and then killing the enemies that spawned. I ended up with 100% kills using this workaround on your first release.
- I agree with Kay about clip brushes. They should not be obvious and used only for the purposes of good. If you don't want a player to take a certain path, put in visible barriers or change geometry to seal off pathways. I tried RJing over the rails to deal with the button crash only to encounter glaring and un-needed clips. Most SP players like to clean out levels anyways so losing the clips would not hurt your map and would offer some interest to speedrunners.
- I tended not to wait for that lift and often willingly paid the 5% penalty to just jump down.
- Good secrets. I got all 4.
- Overall, great map and I hope to see more. I think this forum has offered some useful tips and you do have what it takes. Let's hope SP keeps going as I have maps on the go too. 
Necros; Scragbait 
necros:.. I was just saying I agree with you !! I believe you when you said it can be solved by console commands, because it was the first time I see this kind of "grey flashes" in the backward with WinQuake... I meant: "yes, that's the problem I've seen", and I didn't want to be ironical with your explanations, sorry if I hurted you.. Anyway, I will test your soluce: thanx for the info!

Scragbait: Thank for your feedback, I'm glad you globally enjoyed the map. 
.. I've just tested your console commands in order to avoid "grey flashes", but even if the problem is reduced, it remains some huge zone where it is visible... anyway, thanks for the infos.. 
I think you'll need to issue a restart command as well to make it work. You can also try my WinQuake, which has these limits initially set to 100000. 
like i said, just put in HUGE assmoloid numbers and you won't have to worry about it. :) remember, like aguiRe said, you need to restart the map via the restart command, or better yet, load those commands up via the commandline with +r_maxsurf etc... 
AguirRe, Necros.. 
OK, thanks, I missed the restart command, thousands apologizes for my lack of knowledge.. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.