News | Forum | People | FAQ | Links | Search | Register | Log in
Mapping Help
This is the place to ask about mapping problems, techniques, and bug fixing, and pretty much anything else you want to do in the level editor.

For questions about coding, check out the Coding Help thread:
First | Previous | Next | Last
With "wait" "-1" on the path_corner you want it to stop at. Train will start again when triggered (again) 
Compiling Gui Not Working >:( 
I'm trying to compile my quake map and its not working so here's the error.

Copying Files...
1 file(s) copied.
Converting map...
---- qbsp / ericw-tools v0.18.1-32-g6660c5f ----
Input file:
Output file: gamermap.bsp

---- LoadMapFile ----
*** WARNING 06: No info_player_deathmatch entities in level
4808 faces
783 brushes
341 entities
36 unique texnames
1075 texinfo

Opened WAD: D:/quakedev/wads/QUAKE101.WAD
Processing hull 0...
---- Brush_LoadEntity ----
0 brushes
0 planes
---- CSGFaces ----
0 brushfaces
0 csgfaces
0 mergedfaces
---- Portalize ----
---- vis / ericw-tools v0.18.1-32-g6660c5f ----
running with 16 threads
testlevel = 4
LoadBSPFile: 'gamermap.bsp'
************ ERROR ************
Error opening gamermap.bsp: No such file or directory
---- light / ericw-tools v0.18.1-32-g6660c5f ----
Raytracing backend: Embree
running with 16 threads
LoadBSPFile: 'gamermap.bsp'
************ ERROR ************
Error opening gamermap.bsp: No such file or directory
The system cannot find the file specified.
The system cannot find the file specified.
The system cannot find the file specified.
Press any key to continue . . .

It used to compile fine but now it doesn't. I'm new to this message board so I might not be posting in the right place. please help I wanna finish my map >:( 
Something is probably wrong in your setup, like directories or perhaps the paths have spaces in them (they shouldn't). Maybe something changed?

For some reason the QBSP log looks cut off and then immediately VIS log starts. Either way the BSP file either can't be created (maybe some user rights issue like you can't write to that folder or whatever) or is not created due to some other error. 
Yeah you'd probably need to show us how your compile GUI is set up, paths/arguments/whatever. 
Try Running The Tools Using A Command Prompt. 
Put your tools (qbsp.exe, vis.exe and light.exe) in a directory such as c:\compile\, along with your map file.

Then click start, type CMD, press enter.

You should see a command prompt.

Type cd c:\compile

Then type qbsp gamermap

Then, assuming it finishes, type light gamermap

If that runs, type vis gamermap

then you can copy your map file to quake\id1\maps or wherever your maps directory is.

Then you can run Quake, press the tilde key (`), and type map gamermap.

The old fashioned way. You will probably find out what the problem is along the way. If not, post your experience here :) 
Quake Rerelease Crashes 
My map crashes the Quake Rerelease with this weird error:

kexTaggedMemory::Malloc: failed on allocation of 18446744073709453648 bytes (c:\jenkins-agen\workspace\_ii_silver_athena_quake_i_master\kex3_bastet\source\renderer\r_model.cpp:1145)

It's vis'd properly with no warnings or errors and works in quakespasm and qss. 
Solved It.. 
Selected everything and moved the map so it's at the center of the grid and now it runs fine. 
Cant Select Touching 
whenever i use Ctrl-T or click "select touching" in the menu, instead of selecting touching, it deletes the object i originally pressed. What am i doing wrong? 
Are you using Radiant? If so, that is expected behavior. The four options -- "select partial tall," "select complete tall," "select touching," and "select inside" -- all assume that you will first draw out a temporary brush that you intend to use only to select "real" brushes. The temp brush then gets deleted as part of the operation. 
^ Yes. 
In Worldcraft and other editors, you can drag a selection box to select brushes and entities. But in Trenchbroom there is no selection tool. So you make a temporary brush then Ctrl+T. 
Button Works Off Proximity? 
i've been trying to design some elevator shennanigans and the last blocker i am experiencing is a button i have that triggers several targets sharing the same name is also triggering an func_door that itself has no targetname. I don't understand how this button is doing is causing the func_door elevator to move once pressed despite seeming have no direct connection to the elevator. I think I've even recreated the brush at this point, deleted and drawn a new one, and structuralized the old one... it seems like it's a proximity thing, like the button is triggering it just by proximity!?? 
Door Linking Could Be The Issue 
If doors touch, quake will automatically link them to animate together (so that a two-part door will animate in sync.) Could that be your issue? If so, there is a spawnflag on doors for "don't link", see if that helps. 
Doors Aren't Linked, And Yet... 
Thanks for the suggestion, testing this out inevitably lead me to fixing the problem which I think had more to do with some nearby doors. I don't know what about them was the problem exactly... but I had three brushes rising up out of the ground to form a wall, and two of those brushes were grouped as one func_door with the other working as a func_door on its own. Ungrouping these and turning them into one func_door seemed to fix it. Why I had it any other way in the first place I cannot say. But that's another blocker overcome, wooh! 
Falling Through Floor Brush All The Sudden 
after compiling my map properly (using ericw's tools, i've been doing the fast mode for a bit), a brush that is part of the walkable section of a floating platform bridge I have built it suddenly not solid, causing the player to fall through it. i've tried switching the brush to an entity and back to structural, replacing it with a duplicate, adjusting the geometry. the only thing that makes it solid seems to be placing a duplicate of it directly underneath it - and it does work, the player does not stand on the duplicate's geometry, it's like the brush's geometry is suddenly solid again.

i don't know what's up with this! 
Is The Brush On-grid? 
Ctrl+Alt+Shift+V in Trenchbroom snaps all the vertexes to grid AFAIK.

Sounds weird, I've had weird bugs in the geometry before. If you download the Worldcraft Quakeadapter, you can load your mapfile, then click Map-> Check for problems. It has nice mapfile error reporting. (Well it's better than nothing I guess). But I don't think the auto-fix tool will do you much good. Might yield some info though. Trenchbroom has a console too, if you click Ctrl+4, that might show something up. 
You Can Also Check Any Brushes That The Brush Intersects 
for errors too. 
And Check The Texture Scalings On The Brush. 
Func_button Linked To A Func_plat Or Func_door Or Func_train 
Hi all.
I'm trying to make a simple elevator, imagine it's a small cabin. I want it to be triggered by a button. So far it's simple, the problem is that I want that button to be a part of the elevator (cabin), so it moves when the elevator moves.

I tried with func_plat, func_door and func_train, without success, the button will not move.

Any idea?

I don’t think you can do that with vanilla progs. But with most of the big mega mods like AD, alkaline, copper, and progs_dump, I think you can. 
progs_dump has a great elevator system that was taken from one of the mission packs and then enhanced but sadly I don't think you can use the button as you describe. The button needs to be a static entity - so ours live at each stop the elevator can make.

Our system is nice because you can call an elevator back if it's on the wrong floor for any reason. We have a good sample map in the release that shows how it all works.

progs_dump info, links and videos can be found here:

I am only aware of one other mod that might have this functionality but I am not 100% sure on that. It's called extras_r4. There's an updated version called extras_r5 too that added some new stuff.

r4 is here: from

In mid 2002 nostalgia and boredom drove me to write some interesting QuakeC hacks. The result is this "Extras" mod, which aims to provide extra stuff for Quake mappers. It features honest to goodness func_water, and func_ladder entities, as well as an insanely customizable emitter/effector based particle system, and advanced trains and switches. So if you ever wanted to dynamically flood a level, or attach water volumes and/or switches to trains, this is the mod for you! Example maps and some snazzy new animated sprites and sound effects are also included.

r5 is here but not a lot of documentation: 
Thanks both of you for the reply. Right now I want to finish a map that I've started in 2000 (long story). And I want to be as close as vanilla Quake as possible, so I'm using only standard Quake textures, monsters, etc. 
Map Loading Forever 
This is my first 3D map I am ever making so getting errors isnt surprising at all. Before when map had less objects I could load it but now it gets to number 9 and then nothing happens... I really cant believe that a map with few floating islands, rocks and some other objects is too big.
Heres cmd:
Copying Files...
1 file(s) copied.
Converting map...
---- qbsp / ericw-tools v0.18.1-32-g6660c5f ----
Input file:
Output file: infernalislands.bsp

---- LoadMapFile ----
*** WARNING 06: No info_player_deathmatch entities in level
921 faces
181 brushes
5 entities
9 unique texnames
102 texinfo

Opened WAD: D:/QuakeDev/wads/Doom3_hell.wad
Opened WAD: D:/QuakeDev/wads/Doom3_rock.wad
Opened WAD: D:/QuakeDev/wads/Doom3_outside.wad
Opened WAD: D:/QuakeDev/wads/e4m8.wad
Processing hull 0...
---- Brush_LoadEntity ----
181 brushes
539 planes
---- CSGFaces ----
921 brushfaces
1104 csgfaces
973 mergedfaces
---- SolidBSP ----
1219 split nodes
338 solid leafs
814 empty leafs
68 water leafs
0 detail leafs
0 detail illusionary leafs
0 detail fence leafs
0 illusionary visblocker leafs
1982 leaffaces
1731 nodefaces
---- Portalize ----
882 vis leafs
882 vis clusters
3427 vis portals
---- FillOutside ----
89 outleafs
---- MergeAll ----
950 mergefaces
---- SolidBSP ----
1023 split nodes
334 solid leafs
624 empty leafs
66 water leafs
0 detail leafs
0 detail illusionary leafs
0 detail fence leafs
0 illusionary visblocker leafs
1579 leaffaces
1336 nodefaces
---- Portalize ----
690 vis leafs
690 vis clusters
2836 vis portals
---- Tjunc ----
1398 world edges
3928 edge points
657 edges added by tjunctions
0 faces added by tjunctions
---- MakeFaceEdges ----
---- GrowRegions ----
Processing hull 1...
Processing hull 2...
*** WARNING 19: No entities in empty space -- no filling performed (hull 2)
---- WriteBSPFile ----
Wrote infernalislands.bsp
1983 planes 39660
1242 vertexes 14904
1023 nodes 24552
102 texinfo 4080
1336 faces 26720
6183 clipnodes 49464
691 leafs 19348
1579 marksurfaces 3158
5400 surfedges 21600
2701 edges 10804
9 textures 250640
lightdata 0
visdata 0
entdata 463

0.547 seconds elapsed
Peak memory usage: 38475782 (36.7M)
---- vis / ericw-tools v0.18.1-32-g6660c5f ----
running with 4 threads
testlevel = 4
LoadBSPFile: 'infernalislands.bsp'
BSP is version 29
690 leafs
2836 portals
State file is out of date, will be overwritten
Calculating Base Vis:
Calculating Full Vis:
I'm surprised that it never finishes, but, not surprised it takes a long time.

Vis is the process that calculates visibility between different parts of a level, and it does really poorly with wide-open levels where you can see almost everything from everywhere. It's optimized for more rooms & hallways type levels.

Some ideas to try:
1. Make a lot of your smaller brushes "detail"
2. Just run "fast vis" instead of "full vis" since you won't get much improvement either way. 
I didnt find anything related to detail however I used fast vis in necros compiling gui and made the skybox smaller. Now it works perfectly, thanks! 
1 post not shown on this page because it was spam
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.