News | Forum | People | FAQ | Links | Search | Register | Log in
TyrUtils V0.11
TyrUtils v0.11 has been released:

*Support BSP2 format (qbsp requires the "-bsp2" command line option)
*qbsp: Fix animating texture bug when brushes are textured with alt-animations
* qbsp: Fix a crash in tjunc calculations
* qbsp: Exit with error if verticies exceed 65535 (BSP29 limit)
* qbsp: Add experimental "-forcegoodtree" command line option (thanks Rebb)
* vis: reduce "leaf recursion" error to a warning and continue processing

Download from the utils page as usual (Win32 / OSX / source).
First | Previous | Next | Last
I'm using tyr-glquake.exe or tyr-quake.exe, with the DP 'BSP2' format from the new compiler. Version of the engine is .61 1175. qbsp is 0.13.

The engine throws a 'not version 29' error when I try to load the map.

Think I'm gonna download tyrutils 0.12.....

Shame because the map took 520 seconds to compile (just qbsp) :P

I still cannot believe it doesn't throw warnings. Or do I need -verbose for that..... 
Or Do I Just Need To Use -2psb? 
Gonna check..... 
Doesn't work with -2psb. How do I force RMQBSP2? 
Sorry, the compiler doesn't do 2PSB format anymore - I'll upload a new TyrQuake snapshot for you that will load the BSP2 format.

Might look at supporting a -2psb command line option for qbsp also, but probably better to use the -bsp2 and I'll fix the engine. 
TyrQuake With (DP Style) BSP2 Support 
Snapshot version 0.61-1221 uploaded here:

Win32 and Mac OS X.

One of these days I'll have to do a proper release! 
I haven't actually tested that Windows build, but it should be okay. 
OK Cool 
Here goes nothin.... 

I understand that feature-bloat is a bad thing and all, but ATM RMQe is the only Fitz-branch engine with any kind of BSP2 going on. I can only speak for myself here, but I would really love the feature right now. The main reason being that I want to us MHAguireLight to do the light, and it won't work on V29 maps. I just love AguireLight, and now we have lit support with it, I was so made up when we hit that milestone.

Having said that, I'm still keen on using Tyrquake. And I'm really impressed with the QBSP. It seems really stable to me. I'm so used to having trouble compiling huge maps, but this compiler has blown me away. And I haven't tried your light tool for ages either, but I guess the entities are set up differently to Aguires.....?

One quuestion - does it support the -extra4 level of resolution? And the really cheeky question - does it do dynamic (flickering etc) coloured lights? I seem to remember that RMQe + MHAguireLight would actually do that stuff. But I'm not and engine or tools guy, other that using them heh.

Now, where was I.... 
That Snapshot Works 
Changing the resolution and applying full screen from the menu caused no textures to be drawn, I could only see the shading on the gun. everything else (including the menu) was flat grey.

Launching from command line with the resolution and fullscreen applied worked fine. I cant remember the cvars to apply texture filtering. I prefer the blurry bilinear type texture effect. Lit files not working (were they supposed to be?), no aspect-ratio correction stuff (especially on the weapon).

I decided that what I'm going to do (for now) is use TyrQBSP v0.11 to compile my map, and hopefully I can use MHAguireLight to light it, and run it in RMQe. To me that is going to be the most Fitz-like experience. Baker? 
Maybe Someone Could Hack DPstyle BSP2 Support Into 
MHAguireLight. Maybe MH would do it? Que Sera Sera.

Then that can be a standard and FitzQuake MkV will also support it and all will be perfect and centered in the universe again 
Well I Can Confirm That The Following Combo Works 
TyrQBSPv0.11 + MHAguireLight + RMQe

And I LOVE it! 
Yeah, lots of unfinished stuff in TyrQuake. Resolution changing is only partly done - I really need to finish that off.

I'll get another build of qbsp up with -2psb support. 
TyrUtils V0.14 
Qbsp can now parse Quake 2 map format - you still need your textures in WAD format, but qbsp will automatically strip the leading path from the texture name and ignore the extra surface attributes that are not used by Quake. And by popular demand, we can now output RMQ style BSP2 ("2PSB") format bsp files again with the -2psb command line.

TyrUtils v0.14 changes:

* qbsp: Added Quake 2 map compatibility
* qbsp: Add -2psb option to output in RMQ compatible BSP2 format

Download from the utils page as usual (Win32 / OSX / source). 
@RickyT23: my light util has most things that are provided by the bjp tools - give it a try and see if it does what you need. Check the docs to see which options and keys are available. 
I'll try the light tool too :) 
Fantasic Stuff, But A Small Problem 
This is great news that you have added RMQ BSP2 support for Tyrqbsp. However, there is one crucial feature that crashes v14 of tyrqbsp before it even begins, fence textures, or alpha masked textures.

If tyrqbsp finds any texture in the map that starts with the { character, is stops operation and results in an error of:

************ ERROR ************
Internal error: didn't allocate enough entities?


************ ERROR ************
Internal error: didn't allocate enough brushes?

depending upon the map. I've done various tests and concluded the result of this error is in fact the cause of having just one texture starting with the { character, which any alpha masked texture must start with to be rendered properly by RMQ etc.

Surely this is an easy fix? 
Doesn't support these yet either.

I haven't investigated any code or anything - what was the reason for using opening brace? This seems to be the cause of most of the problems.

Lame question, seeing as how close I was to the development of the format, but why not use a neutral / unused symbol, like @ or something... 
TrenchBroom Does Allow Them 
but only if you enclose the texture name in quotes. 
Double Quotes 
to be precise: " 
Return Of The { 
seriously... that curly brace is causing more trouble than it's worth! 
Good To Know :) 
Damn, Missed That Opportunity :{ 
Yeah, { Not Difficult 
@Orl: Does this snapshot work for you? If not, can you email me a test map + wad?

Snapshot tyrutils-0.14-1-ge8d1f59: Win32 and Mac OS X
Yes Sir 
Indeed it does Tyrann, works perfect. :) 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.