News | Forum | People | FAQ | Links | Search | Register | Log in
Updated Q1SP MOD - Arcane Dimensions 1.7.1 *PATCHED*
Sock has been beavering away behind the scenes to get a fully updated tweaked fixed and finalised version of AD. So here it is. One point SEVEN.

Download (220mb):

V1.7.1 Patch (see recent post below):


Recommended Quakespasm 0.93:

Past versions etc:

In his own words:
"The AD zip file is getting a bit big and inconvenient to download and I think its time to start splitting stuff off into separate files. The AD map source files are not needed or viewed much and if anyone wants to see them, just drop me an email request.

This download contains all the previous maps, some new extra code and features, lots of bug fixes, some new mapper features (check documentation) and as a final bonus, a couple of extra maps hidden away in the main map hubs, good hunting!"

First | Previous | Next | Last
By the way, there's a more elegant way to fix that, without adding an extra entity. 
I'm finally finishing up the second hub with only Sepulcher left after just beating ad_azad. I don't know what else to say aside from that it was brilliant. I loved the theme and the level of detail was mind blowing. Even something as simple as accumulated snow on the some of the steps outdoors added so much to the map.

The breakables helped the world feel alive and I really enjoyed the way that they were employed this time. Instead of just having breakable walls and pieces of wood, some major set pieces were destructible. I was pleasantly surprised when the bridge in front of the silver key lock collapsed under me after being attacked by a death knight. Pillars breaking during the four stoneman ambush and during the final boss made the fights more intense with nothing to hide behind.

I also liked how the destructibles were part of the progression like the iron wood that needed to be smashed with the mine cart. The combat was really enjoyable although the tiny room with the four stone death knights that ambush you got me several times. I didn't exactly save scum but it still felt scummy saving the game beforehand and attempting that fight a few times when I already knew what to expect.

I finished with 6/10 secrets but just like every other AD map, I'm going to attempt the 100% clear. The bruskwork was incredible and it seems like an insane amount of time must have gone into the details. I loved some of the amorphous architecture as well like the wooden platforms haphazardly arranged and supported in the room with the mine carts. Stuff like this is inspiring and I'm always curious as to how much of this was implemented or how certain ideas were conceived. My only complaint was that the map wasn't longer since I enjoyed it so much but hopefully I will squeeze a lot more time out of it as I search for the rust key and the remaining secrets. 
I'm trying to use ad_1_7p1_gtk.def for GtkRadiant, but in the properties of the entities I see basically only the angle, the model and the noise. Maybe someone has a normal ENT file? 
Is there any chance that we can get access to the wads used for these maps? I know that many were custom and/or modified by sock and others but I'm interested in some of these themes and I'm having trouble matching them. 
You can just open up the BSP's with Texmex and then save to .wad. 
Thx again.

„although the tiny room with the four stone death knights that ambush you got me several times. I didn't exactly save scum but it still felt scummy saving the game beforehand and attempting that fight a few times when I already knew what to expect.“

This is the Tronyn moment. It is doable, but very random and hard.
I toned this encounter down a lot with AD 1.7, previous setup was just mad and cruel. 
Leptis Magna 
Leptis Magna is one of my favorite maps in AD and I'm playing through it a third time atm, partly to find more of those pesky little secrets.

Anyway, playing through it on Nightmare for the first time and either I suck or there is way too little ammo in it on this difficulty level. For instance, my char has 3 rockets left and nothing else when the next fight is all those statues in the gold lock area. But I've been out of ammo for most the other half of the map. Once or twice it is a bit exciting as I have to rush past a bunch of monsters in order to get ammo to actually kill them, but in the long run it is frustrating rather than fun really. Perhaps Nightmare is balanced around the player always trying to get monsters to infight? Not sure what I could have done differently, but I think I'll play it on Hard after this playthrough.

Looking forward to the upcoming update of AD btw. I'm sure it will be epic. 
Leptis Is Hard On Hard. 
But it is doable. 
It's Hard 
Yes, pretty sure I played it on hard the last time and I had no issues with ammo or anything else then. The last fight was rather tough, but you can thankfully cheese it. 
We didn’t test AD_magna on nightmare. I’m sure it’s woefully unfair. 
Leptis On Nightmare 
I'm not a Quake master by any mean, but...


I already knew the map quite well, obviously, but did not even come close to be without ammo... 
As I said, I might very well suck. Can it be secrets? I have a hard time finding secrets i Leptis Magna - think I have 7/25. Perhaps missing out on a lot of ammo that way. 
Ammo Is Tight But Not Unreasonable 
I last played it in Nightmare a while ago and I remember tight situations but not desperate ones. Although you might be right about secrets, I found 24/25 and they probably helped as they include some valuable weapons and power-ups. 
Wow! Now This Is Strange... 
...after having completed my NM run yesterday, I fired up Leptis Magna again to go hunting for the last 2 secrets I had missed (I had previously found all of them several times over). My last quicksave was just before the last 5 or so enemies, I loaded that, killed the boys and got back upstairs to see what I had missed.
I retracked exactly the intended route and I came to the red key room, and naturally that was empty (I already found the secret of LM during the main run, doing the whole routine until teh collapse). I proceeded to the red door expecting to find the boulder blocking the path, but found the closed red door instead and the room intact, praying knights an' all! How come? Has anybody experienced the same before? 
Hmmm... No. 
I'm almost certain I misremembred my first run. I probably picked up the red key, saved, went to the red room and got killed afterwards. When I reloaded I must have forgot to go to the red room. Problem solved(an edit function would be great). 
Nightmare Revisited 
OK, so I replayed Leptis Magna from the start on nightmare and this time I had no issues with ammo, which is a bit weird as I basically played it the same way. So it seems rather well balanced when it comes to ammo and I must have messed it up somehow the previous play.

It's such a wonderful map. I love how it comes up with surprises almost throughout the entire level and the secrets are just amazing as well.

@the silent, I'd love to see a 100% demo of the map. 
Faster Than Recording One... 
Ah, thanks! I thought I had searched on YouTube, but apparently not. 
One Last Secret 
The video was of course very helpful and it was nice to finally find all three tomes so I could access the keys. I really like how dynamic the map is, with sections opening up, previously walled alcoves being accessible etc.

But I still have one secret left and hope someone can help me with that. In the very last room there is an alcove you can jump into and shoot a red star on the wall, but there's still one red star remaining and I can't locate it. Annoying to have a single secret left... 
Same Thing, Different Corner 
The setup is symmetric with respect to the center of the room :) 
WTF, I had already looked there. Guess it would be easier if I upped the brightness a bit when looking for secrets. Anyway, thanks, now I can rest in peace. 
Runes Glitch 
Perhaps reported earlier, but I have a glitch with the runes. After finishing the four maps with the runes, there are only two showing up in the antechamber with the portal to ad_end, so I can't proceed.

Guess I can use the console to add them, but I just wanted to report it.

BTW, Foggy Bogbottom was even more epic than usual with the help of watching a 100% play through, as I had missed lots of secrets and the entire roof top section previously. 
Runes Worked 
So I started over and redid the four maps with runes and this time it worked fine. 
Isn't there a longstanding bug with runes and savegames? Does someone remember? Maybe it was that. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.