News | Forum | People | FAQ | Links | Search | Register | Log in
New Q1SP (AD) Forgotten Sepulcher

The next big release for Arcane Dimensions is finally here! This a technical masterpiece and a monster of a map with roughly 60k brushes. All beautifully realized by Simon, and made possible through the engine updates by Eric. Please take note that you need AD 1.5 and the new engine provided in this thread to play the map. I would also recommend reading the ad_sepulcher readme for further information.

** this map requires a new engine and AD 1.5 **

New Quakespasm / Quakespasm-spike Engine

Map file:


First | Previous | Next | Last
Would it be simpler to just put this in its own unique folder? All you need to run Quake is an ID1 subfolder with PAK0.PAK and PAK1.PAK in there. Only a little over 50 MB of drive space is needed, which is a drop in the bucket these days. I have 4 or 5 different Quake folders just to keep things neat and cleanly separated. 
MacOS Tips 
@Barnak unfortunately the macSO Finder can't patch the AD1.5 install with ad_sepulcher.

The way to do it is on the command line. Open and enter:
ditto ~/Desktop/ad_sepulcher ~/Desktop/quake/ad

This assumes you have already extracted on your desktop,and your AD1.5 install is in Desktop/quake/ad.

This will copy everything in ad_sepulcher over the ad directory properly overwriting things.
You can use tab completion when typing the two directories.

btw you'll see the rain in ad_sepulcher.

@icaro might be macOS's "gatekeeper path randomization" security feature. To defeat it you need to extract the engine zip in your Downloads folder, then drag the .app's out of the Downloads folder (e.g. to the desktop). If you don't do this the OS runs the application with a current directory of some hidden directory, so the engine is unable to find any pak files. Need to make QS detect this and explain the problem.. 
If I do the second way I described, would it do the same as what you described ?

I already overwritten all the files from one sepulcher sub-folder to the same name sub-folder of AD1.5, by hand, and done the same for all the other sub-folders.

Do I now have some useless files in my AD1.5 after done that ?

Maybe the AD mode needs a full update, including sepulcher. 
Yep, you should be fine. The "ditto" command would do the same thing as copying files from every subfolder by hand. 
Thanks A Lot, Eric 
But really, AD1.5 should be updated.

I can't wait to see the new rain effect.

Is there also new effects on water ? 
But Really, AD1.5 Should Be Updated. 
did you read the readme file by any chance? 
That Read Me Is Too Long To Read All ! 
What are you refering to, in that file ? It's 1000 pages of text ! 
* Extract the contents of the zip file (overwrite all files)
This zip file contains the latest AD Quake Code (v1.6) 
I Mean... 
That the AD download link should be updated with 1.6.

Or is it already ? 
I appreciate ... but it still doesn't work! :-(

both the engines (admod and spike-admod) give the error message "You must have the registered version to use modified games". No error message with Quakespasm 92.1, but obviously it crashes when I enter the Forgotten Sepulchre's gate. 
Do I need other original files other than PAK0.PAK and PAK1.PAK in ID1? 
..It works now! sorry for the mess!
I've just copied and pasted the engines!

I had the same problem as Icaro. Regular QS works fine. I had to supply -basedir /Applications/Quake to make it work. 
"Do I need other original files other than PAK0.PAK and PAK1.PAK in ID1?"

I have a clean copy of Quake I use as a starting point. It contains 5 files and one folder. Fitzquake085.exe is in the root folder and in the ID1 folder there is only pak0.pak, pak1.pak, autoexec.cfg and config.cfg

autoexec.cfg is a custom file and not needed. config.cfg is created the first time the game is run if not already present. 
Note that I use Windows 7, I have no idea if it works the same on other operating systems. 
Going To Be Playing Through The Rest Of This 
Starts in an hour. Played two hours, and I'm about halfway through. To the finish! 
When I go to your Twitch page, select the videos tab and click the Forgotten Sepulcher video, it plays the Jam 9 mapping video instead. WTF? 
I map for about five minutes before I start playing. 
Oh, OK. Thanks. 
Can I Drink Beer While I Watch Your TV Show, Ionous ? 
... and I'll play some CyberGoth music at the same time, babe ! 
Eric (or Others ?) 
Two things :

1. While I can launch the sepulcher map from the console, I'm unable to find its portal from the start map. Where is it ?

2. Just at the start of sepulcher (that part is soooo amazing, by the way), I'm getting several sound not loading warning in the opper-left corner :

"sound/ambience/windgust1, 2, 3, ..."

What is happening here ? 
1. In the Chapters start map, first portal to the right. 
And Where Is The Entrance To The Chapters Start Map ? 
hmm, I'm lost here. 
And What About The Sounds Not Found ? 
I don't have any files called windgust in my ambience folder... something's fishy here. 
To the right of the entrance to ad_crucial. 
First | Previous | Next | Last
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.