News | Forum | People | FAQ | Links | Search | Register | Log in
QuakeEd For MacOS 1.0.1 (Updated)

There is a new release of QuakeEd for MacOS, available here:

Quite a few things have changed:

- QuakeEd now targets MacOS 10.7 (Lion), instead of the latest available.
- The qbsp, light and vis command-line tools are now included in the package, and ready to use.
- A bug related to scrolling in the top-down (XY) view and the Z view has been fixed; both views now scroll as expected.
- Another bug related to pop up menus not appearing next to the selectors in the XY and Z views at their bottom right corner has also been fixed.
- Quake_OSX (the game engine) is now included for the user to test maps generated by the tool. NOTE: Quake_OSX targets 10.11 (El Capitan), due to it being a Swift application.

Instructions for setup, BSP generation and some other stuff are now included in the package in a file.

Let me know what do you find with this new iteration of the tool. Have fun mapping!


Here is an early preview of the QuakeEd mapping tool as ported to MacOS:

This is my first time creating a MacOS app to be directly distributed to "customers", so it is quite possible that - if the app even starts at all - your Mac will deny / ask for your permission to open it. That can only be solved the very moment I get enough money to enroll on the Apple Developer program.

Most UI stuff should be working. This package does not yet include the qbsp, light and vis command-line tools to actually generate a map - work on them is currently underway.

Included in the package is a test_maps folder containing the example quake.qpr and files that came originally with the tool, as well as the progs directory with the .qc files also from the original package.

This application requires the presence of a /qcache folder in your system; since (because of security considerations) the app cannot create it directly, please open a Terminal and run:

cd /
sudo mkdir /qcache
sudo chmod 777 /qcache

before opening the app.

Also, once you set up the location of the quake.qpr project file after opening the app, be sure to go to Preferences, press the [current] button to set the path of the project file, *close the app* and *open it again*. Only then you will be able to open in the list of maps displayed in the Maps tool.

Have fun, and let me know how that worked for you!
This requires OS X 10.14 I am stuck on 10.13.6 at work! 
Same Here. 
Yeah I'd like to test this but using 10.12. 
I Beat You All! 
I'm still on good'old 10.6.8. Snow Leopard is the best Mac OS ever, period. Fuck you Apple! 
Me Too! 
Snow Leopard FTW! >:3 
Screw Snow Leopard 
I got Cheetah. 
Some Stuff Working, Some Not 
This is a cool project.

I gave it a try on a MacBook Pro running 10.14.4. Dump of stats from the About This Mac dialog:

MacBook Pro (Retina, 15-inch, Mid 2015)
Processor 2.2 GHz Intel Core i7
Memory 16 GB 1600 MHz DDR3
Graphics Intel Iris Pro 1536 MB

After downloading/unzipping the archive, I created a new QuakeEd folder on my desktop and used the Finder UI to drag the QuakeEd app over to there, just in case this is an app that might be affected by Gatekeeper Path Randomization (security shenanigans on new macOS releases, google for details).

For first launch I had to use the right-click menu and select Open, so that it would ask me if I was sure I wanted to open an app from an unidentified developer.

Then I followed your directions about the project-file stuff. So far so good!

After opening it with the quake.qpr project set up, I use the upper-right dropdown to pick “Maps” and then choose It loads it up ok, and I can poke around with the various buttons. But if I try to interact with the overhead-view pane — e.g. drag the view or move the slider — I just get a spinning beachball.

Let me know if there’s anything you want me to try, or info I could gather for you.

Some very Radiant-ish look to parts of this. I guess that's not surprising :-) but still neat to see. Kind of mind-boggling though to think about some of the original campaign maps that were created just working in a single 2D view. 
I tried it on another (newer) 10.14.4 MacBook Pro just to make sure it's not that old one being cantankerous. Same behaviors. 
Yes, I’m aware that the scrolling panes for the XYView and ZView are performing badly. I’m working on a solution for it. As a workaround, dragging the mouse by pressing the right/secondary button should do the trick - it is even mentioned in the Help file.

Which makes me wonder: could that be an actual bug in the original application? 
FWIW it's not bad performance, in this case. It's app lockup that requires force-quit. 
No more freezing! 
Good To Hear. 
While working on this, I learned that in Objective-C your constructor does NOT need to return self - that is, you can return an entirely different object than the one you're creating. And that's legal even in today's iteration of the language.

HOWEVER, if you do that trick with a NSView returning a NSScrollView, in today's OSes, your system will become thoroughly confused, and things will go awry with your app: calls to [lockFocus] failing miserably, scroll bars hanging for no reason, pop up menus appearing at the bottom corner *of the screen*, and so on. :( 
Update - 1.0.2 
Get it here:

Highlights of the update:
- QuakeEd can now remember the most recent maps you´ve opened - they will be accessible in the "Open Recent" option in the menu, starting from this update.
- A new command-line tool, leechwad, allows you to gather miptex entries referenced by a .map file directly from a pakfile, and create the required .wad file for QuakeEd to use.
- The file was updated to reference the new tool, and to describe two recently found issues (bugs?) in the original tools, and how can you work around them.

Just as a reminder, the source code for this project can be accessed from:

If the command-line tools in the package cannot be run as-is in your system, you might need to recompile them - the Xcode project in that repository can be used to do that.

Happy mapping! 
You must be logged in to post in this thread.
Website copyright © 2002-2024 John Fitzgibbons. All posts are copyright their respective authors.